Jump to content
Froxlor Forum

Leaderboard

Popular Content

Showing content with the highest reputation since 01/31/10 in all areas

  1. Du musst in den Optionen folgendes aktivieren: Welcher Webserver wird benutzt? habe dieses Shop System oh. Probleme mit LE SSL getestet und ging ohne Probleme. Und wie d00p, schon angemerkt hat, wurde deine Shop Seite per IP anstatt mit einer Domain installiert. Daher kannst du probieren in der DB, Manuel die Einträge zu ändern oder installiert den Shop noch mal richtig mit einer Domain. *Nachtrag* Du kannst die die Domain auch per DB ändern. In folgenden Tabellen findet du die Einträge: - ps_configuration - ps_connections_source
    1 point
  2. root@con1:~# a2dismod php7.0 && a2enmod php7.4 Module php7.0 disabled. To activate the new configuration, you need to run: systemctl restart apache2 Considering dependency mpm_prefork for php7.4: Considering conflict mpm_event for mpm_prefork: Considering conflict mpm_worker for mpm_prefork: Module mpm_prefork already enabled Considering conflict php5 for php7.4: Enabling module php7.4. To activate the new configuration, you need to run: systemctl restart apache2 root@con1:~# systemctl restart apache2 root@con1:~# GEILomat das war die Lösung,
    1 point
  3. Ich hatte mich nicht getraut, weil ich nicht den Server lahmlegen wollte unwissend, ob das überhaupt der richtige Ansatz wäre. Jetzt habe ich es gemacht, stellte sich heraus, daß Apache es nicht mochte, weil man die folgenden Apache-Module braucht: proxy proxy_http proxy_balancer lbmethod_byrequests Also: a2enmod proxy a2enmod proxy_http a2enmod proxy_balancer a2enmod lbmethod_byrequests Jetzt geht es! Ich bin begeistert, herzlichen Dank für die schnelle Hilfe und das großartige Programm!
    1 point
  4. Yes, it does. I have another server with froxlor running and I tested and it worked perfectly, so I am assuming theres some mismatch settings that maybe I manually made on Apache's config while learning/understanding/testing froxlor. So, thank you very much. I will post the solution when i find it so maybe it can help someone else. Bye
    1 point
  5. Super, hat funktioniert. Danke Dir vielmals für die super Unterstützung.
    1 point
  6. Danke für die Rückmeldung. Also um erstmal einfach zu machen, kann ich doch den Hostnamen als Mailserver konfigurieren, sprich das Zertifikat davon einbinden. Und auch die Mailadressen von allen konnektierten Domains in externen Clients verwenden, muss dann eben als Servername für Ein-und Augangsserver den Haupt Hostnamen verwenden, ist das so einfach machbar. Danke
    1 point
  7. Habe es heute getestet und das Erstellen von Domains als Sub-Admin war erfolgreich. Vielen Dank für die Hilfe!
    1 point
  8. Nur zur Info: Ich hatte gerade das gleiche Problem mit "Permission denied: AH02454: FCGI: attempt to connect to Unix domain socket" nach einem Update auf 0.10.23.1 (absofort PHP 7.3 required). Als ersten Workaround half chmod 777 /var/lib/apache2/fastcgi/* Als ich dann nachgeschaut habe, sind die vermutlich fehlenden extra-Gruppen in /var/lib/extrausers/groups drin, denn jetzt funktioniert es auch ohne chmod 777 und den normalen Rechten srw-rw---- Ich kann mir auch nicht wirklich erklären, warum es plötzlich nicht funktionierte, wobei es mit der Umstellung der CLI default
    1 point
  9. Ah, Danke! /root/.acme.sh hatte ich gar nicht auf dem Schirm. Ja, manuell gelöscht und zack, hat froxlor ein neues Zertifikat generiert, Problem solved! 👍 Das mit der falschen Adresse, ich nehme an zum Zeitpunkt des Generierens hatte ich wohl die alte Adresse noch in der Config übersehen bei den vielen hin und her *shrugs*
    1 point
  10. Das ist doch schonmal eine Aussage, die mich weiterbringt - ich muss außerhalb von Froxlor suchen. Danke.
    1 point
  11. Ich habe testweise falsches Passwort in /etc/libnss-mysql.cfg eingegeben... funktioniert immernoch :-) Ich vermute, dass nun libnss-extrausers wieder funktioniert.
    1 point
  12. I saw the Github notification. I didn't have the opportunity to test. Anyway, that fix worked.
    1 point
  13. Hi zusammen, in Froxlor habe ich SSL aktiviert, ein Zertifikat zu einer Domain erstellt und der Domain den Port 443 zugewiesen. Jetzt startet der apache Server nicht mehr mit dem Fehler: apachectl[852]: (98)Address already in use: AH00072: make_sock: could not bind to address IP:443 Ich hab schon im Forum gesucht, einen Hinweis gefunden, dass ein "listing" Setting gesetzt sein könnte. Bewusst habe ich das nicht aktiviert. Ist jemand hier, der helfen kann? Kann natürlich gern mit Logfiles unterstützen Danke Euch und beste
    1 point
  14. Thanks @d00p it is working now 😀👍
    1 point
  15. Really appreciate your feedback. a2enmod ssl, yes. root@server6:/home/ubuntu# a2enmod ssl Considering dependency setenvif for ssl: Module setenvif already enabled Considering dependency mime for ssl: Module mime already enabled Considering dependency socache_shmcb for ssl: Module socache_shmcb already enabled Module ssl already enabled root@server6:/home/ubuntu# I am pretty certain it has something to do with the Oracle Cloud server setup. Something with the Virtual Nentwork adapter, the proxies in between etc. Not an expert on this and only a novice froxlor user so a bit over my head
    1 point
  16. Sound great! Good luck + best wishes for your new project!
    1 point
  17. Hallo d00p. Das war ein sehr wertvoller Hinweis - irgendwie war der name server aktiviert. Ich habe ihn abgeschaltet und nun klappt es auch wieder mit dem Cronjob. Danke.
    1 point
  18. So I started over, patiently following all of the instructions. It's working brilliantly. Thank you so much for Froxlor. Great product.
    1 point
  19. Hallo, Postfix ist ein MTA und nicht über eine URL erreichbar. Gruss cardman
    1 point
  20. Hi @d00p, sry das ich mich so spät melde. Du bist ein Traum, hat natürlich direkt geklappt. Mit Ondemand dürften dann auch durch die idle time andere Fehler bei mir verschwinden. Vielen Dank für deine Antwort 🙂
    1 point
  21. Ja, das habe ich alles im Kopf und sammle gerade die Punkte zusammen die mir noch einfallen. Wollte mich nur in den Code einarbeiten und schauen wie schnell ich da zum Ergebnis komme. Gute Besserung!
    1 point
  22. Moin, der OP hier. Sorry, dass ich mich die ganze Zeit nicht gemeldet habe - gab/ gibt leider schwerwiegende Gründe. Hat mit Krhs und Koma zu tun. Ist sonst nicht meine Art, mich nicht zu melden. Zur Sache: Ich hatte mir für's Erste mit dem viel weiter oben beschriebenen Workaround (www-data an Gruppen in /etc/groups) beholfen. Den von mir selbst reingesetzten Link auf einen älteren Post hatte ich angesehen, geprüft, brachte mich aber nicht weiter. Inzwischen wurden 2 Froxlor-Updates reingedrückt und siehe da, beim heutigen Prüfen stand auf einmal "www-data" mit hinter jedem Ein
    1 point
  23. Hi there, I finally could update to the latest Froxlor version with the testing repository. Thanks!
    1 point
  24. Das war DER Tipp! Jetzt funktioniert alles, wie gewollt. Vielen Dank!
    1 point
  25. Thanks you very mucht for your work! I've already updates 4 hours ago witout any issue. BR Christian
    1 point
  26. Danke, hat so funktioniert! Falls jemand noch Warnungsmails bei Quotaüberschreitung benötigt, hier mein Setup: vi /etc/dovecot/conf.d/90-quota.conf plugin { quota_warning = storage=95%% quota-warning 95 %u } service quota-warning { executable = script /usr/local/bin/quota-warning.sh user = vmail unix_listener quota-warning { user = vmail } } plugin { quota = maildir:User quota } Das eigentliche Mail wird über dieses Script versandt (chmod 755): vi /usr/local/bin/quota-warning.sh #!/bin/sh PERCENT=$1 USER=$2 cat << EOF | /usr/lib/dovecot/dovecot-
    1 point
  27. I've struggled with this issue myself now for a couple of days. My goal was to activate Apache + mpm_event + php7.3-fpm. For now, i playing around with a WordPress installation and it runs fast as hell (considering WordPress with OPCache and RedisCache-Server, without any WordPress caching plugin). TTFB is around 170ms, I am satisfied. Finally I solved it ? (thankfully without fiddling in conf-Files) by disabling the Apache-conf for php7.3-fpm (in my case php7.3): a2disconf php7.3-fpm (removes /etc/apache2/conf-enabled/php7.3-fpm.conf) I searched for the string "php7.3
    1 point
  28. Einen neuen Kunden extra für phpmyadmin zu erstellen brauchst du schon mal nicht, aber was du erstellen musst, wenn du andere confs für php-fpm benutzen willst, ist halt ne eigene conf, das dauert keine 5min und ist im Panel ruck zuck gemacht. Und zwar unter PHP-Konfigurationen > Neue Konfiguration erstellen so mache ich dies auch bei vers. CMS die ich am laufen habe. Du musst dann nur nach dem erstellen der conf im Panel, einem oder dem einen Kunden die rechte für die php-conf geben. Kunden > Kunden bearbeiten > PHP-Konfiguration und fast ganz unten, dann die conf mit einem hacken ak
    1 point
  29. An PHP wirds mit Sicherheit nicht liegen. Deine Aussagen sind allerdings zu dünn und konfus um jetzt konkret zu helfen. Erst schreibst Du POP3/IMAP tun und dann zeigst Du uns Fehler aus deren Log. SMTP geht nicht aber Du bleibst uns Logs schuldig. Soweit ich mich erinnere, sehen die Configtemplates von Froxlor keine eigene TLS/SSL Zertifikate für postfix?/dovecot vor. Was hindert Dich die Konfig von Debian 8 zu übernehmen? Im Zweifel mit Intelligenz und "diff". Ich habe vor einer Woche erst ein Upgrade von Debain 8 auf 9 mit installiertem Froxlor gemacht, da war nur bisschen im Dovecot anzup
    1 point
  30. Ich hab auch die Mail bekommen. In meinem Fall war es aber so, dass ich bei mir zu Hause noch einen Rechner stehen habe, bei dem ich nicht froxlor nutze und stattdessen certbot per cron anwerfe. Hier war die Config falsch und es wurde noch als Authenticator "apache" benutzt - laut Doku kann dieser nur TLS-SNI-01. Ich habe dann auf "webroot" umgestellt und hoffe jetzt, dass alles weiter läuft Vielleicht prüfst du auch mal, ob du noch irgendwo certbot manuell nutzt - vielleicht noch von früher, als froxlor noch kein letsencrypt konnte oder so?
    1 point
  31. At this point I would like to say thank you to all people involved in the development. ?
    1 point
  32. Subdomains für die du keinen seperaten Record eingerichtet hast, lösen nur auf die IP auf wenn ein entsprechender Wildcard Record existiert.
    1 point
  33. Doch bei Debian / Ubuntu gibt's das. Repository ist unter https://deb.sury.org zu finden. Anleitung: https://ansas-meyer.de/programmierung/php/rip-dotdeb-hello-deb-sury-org/amp/
    1 point
  34. Hi, Prinzipiell kannst du ohne Probleme einfach neue Zertifikate via lets encrypt anfordern, es gibt zwar rate limits, ich denke aber nicht, dass du entsprechend viele Domains hast. Hier genauer nachzulesen: https://letsencrypt.org/docs/rate-limits/ Die im/export Funktion übernimmt keine zertifikate, hier werden lediglich Einstellungen gespeichert.
    1 point
  35. 1 point
  36. 1 point
  37. Hmm.... irgendwie habe ich den Eindruck, dass Du hier völlig falsch bist.
    1 point
  38. Hallo, ich würde auch gerne noch meine Senf dazu geben Zum einen die Frage, wenn die Software in deinen Augen, soviele Defizite aufweist, warum benutzt du sie dann? Niemand zwingt dich Froxlor zu benutzen. Ich kenne einige Serveranbieter die bieten dir zu ihren Servern auch eine Plesk-Lizenz an. Da hast du dann ein "Rundum-Sorglos-Paket" und keine Probleme mehr. Ich von meiner Seite aus kann nur sagen, das Froxlor eine gute Software ist. Auf meinen Servern läuft die Software schon seit 10Jahren (anfangs noch unter SysCP). In meinen augen hält es eine gute die Waage zwischen Funkt
    1 point
  39. Reseller Accounts gehen über verschiedene Admin-Accounts Backups über die Benutzeroberfläche sind Augenwischerei und nur für temporäre Backups zu gebrauchen. Richtige Backup liegen auf externer Hardware und diese wird nicht einheitlich angesprochen. Mal ist es rsync, dann ftp und wieder andere machen NFS. Wie soll das eine verwaltungssoftware können? Auch Confixx konnte das nicht. 1&1 empfahl vor 10 Jahren Backups von Rootservern mit FTP auf deren Backupserver zu machen und auch das mußte händisch konfiguriert werden. Die meisten Benutzer sind mit den Einstellmöglichkeiten für
    1 point
  40. Hallo, Es ist zwar deine erstellte Domain SSL verschlüsselt, doch die Adresse auf die du diese weiterleitest "IP/phpmyadmin" nicht, daher auch die Fehlermeldung. Die einfachste Möglichkeit ist es, einen neuen Kunden zu erstellen, ihm die Subdomain phpmyadmin.domain.de zuzuordnen und in den Webroot packst du phpmyadmin manuell. https://files.phpmyadmin.net/phpMyAdmin/4.7.4/phpMyAdmin-4.7.4-all-languages.zip
    1 point
  41. Du weißt aber schon wie Google funktioniert oder? Das sind alles Kompatibilitätsprobleme der verschiedenen Postfix-Versionen und den Distributionen und kein Froxlor-Problem Such halt mal mit find nach postfix-script und wenn es das gibt, dann hinterlegst du den kompletten Pfad in main.cf Ganz ehrlich: Wer einen Server betreibt und administriert sollte wenigstens soviel Ahnung haben wie er zu Lösungen kommt um sowas zu fixen oder es lassen mit einem eigenen Server im Internet.
    1 point
  42. Hi, @ninopi d00p war doch ganz korrekt. Nur glaube ich hast du leider nicht ganz verstanden wie es funktioniert und daher hat er mehrmals versucht zu helfen aber du hast darauf nicht richtig reagiert. Versuche doch einfach mal bitte im Verzeichnis /var/www/froxlor/.well-known/acme-challenge/ eine test.html Datei anzulegen und diese dann über deine Subdomain http://SUBDOMAIN/.well-known/acme-challenge/test.html aufzurufen. Weißt du was ein Apache Alias ist? Den hast da da oben geposted. Der sagt, dass wenn man http://SUBDOMAIN/.well-known/acme-challenge/ aufruft im Verzeic
    1 point
  43. Zeigt die SubDomain denn auf deinen Server? Ist die denn ohne SSL auch richtig erreichbar? Du kannst den Cronjob auch mal manuell aufrufen: /usr/bin/php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug durch den Debug Parameter kriegt man da ne menge mit.
    1 point
  44. Poor, retarded and isolated kid... I wish you all the best for your mental health dude...
    1 point
  45. ja weil Froxlor und dein Server keine automatische Konfiguration unterstützt. Du mußt das manuell konfigurieren.
    1 point
  46. Froxlor presupposes strong user experience with your server system.... If you can't handle simple server configs without reading a how-to, it's better for you to use Plesk or something else like this... ...Same Shit Different Day...
    1 point
×
×
  • Create New...