Jump to content
Froxlor Forum

d00p

Administrators
  • Content count

    6106
  • Joined

  • Last visited

  • Days Won

    41

Everything posted by d00p

  1. as said, the initial setup should've filled that already. Port is of course 80 or 443 (ssl). The other settings are self-explaining
  2. lighttpd mod_openssl warnung

    ist gefixt: https://git.io/vFSmA
  3. lighttpd mod_openssl warnung

    ich nehme an, da hat wohl lighttpd sein verhalten geändert. Versuch mal folgenden Patch und sag mir obs damit klappt: diff --git a/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php b/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php index d1ba5d0..a2d5258 100644 --- a/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php +++ b/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php @@ -535,7 +535,8 @@ class lighttpd extends HttpConfigBase if ($domain['ssl_cert_file'] != '') { - $ssl_settings .= 'ssl.engine = "enable"' . "\n"; + // ssl.engine only necessary once in the ip/port vhost (SERVER['socket'] condition) + //$ssl_settings .= 'ssl.engine = "enable"' . "\n"; $ssl_settings .= 'ssl.use-compression = "disable"' . "\n"; $ssl_settings .= 'ssl.use-sslv2 = "disable"' . "\n"; $ssl_settings .= 'ssl.use-sslv3 = "disable"' . "\n";
  4. Mailsettings autodiscover

    Alias "/.well-known/autoconfig/mail/" "/var/www/autoconfig/" Alias "/.mz-autoconf/" "/var/www/autoconfig/" Alias "/autodiscover/" "/var/www/autoconfig/" und dann neben der config-v1.1.xml noch eine autodiscover.xml: <?xml version="1.0" encoding="UTF-8"?> <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006"> <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a"> <Account> <AccountType>email</AccountType> <Action>settings</Action> <Protocol> <Type>POP3</Type> <Server>dein.mail.fqdn</Server> <Port>995</Port> <DomainRequired>on</DomainRequired> <SPA>off</SPA> <SSL>on</SSL> <AuthRequired>on</AuthRequired> </Protocol> <Protocol> <Type>IMAP</Type> <Server>dein.mail.fqdn</Server> <Port>993</Port> <DomainRequired>on</DomainRequired> <SPA>off</SPA> <SSL>on</SSL> <AuthRequired>on</AuthRequired> </Protocol> <Protocol> <Type>SMTP</Type> <Server>dein.mail.fqdn</Server> <Port>587</Port> <DomainRequired>on</DomainRequired> <SPA>off</SPA> <SSL>on</SSL> <AuthRequired>on</AuthRequired> <UsePOPAuth>off</UsePOPAuth> <SMTPLast>off</SMTPLast> </Protocol> </Account> </Response> </Autodiscover>
  5. Mailsettings autodiscover

    erstell doch einfach nen globalen alias (wie für let's encrypt). Für thunderbird z.B. und in /var/www/autconfig/ dann die config-v1.1.xml mit entsprechendem inhalt, z.B.
  6. Mal die Fehlermeldung/Nummer gegooglet? Das ist eine andere als der Thread-Ersteller nennt...siehe: https://askubuntu.com/questions/763336/cannot-enter-phpmyadmin-as-root-mysql-5-7/763359#763359
  7. proftpd -> debug -> logs, sonst kann man schwer was sagen
  8. https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-from-tarball Da erstellt froxlor auch nix...du hinterlegst da nur die URL zu der App die DU selbst irgendwo installiert/konfiguriert hast Permissions sind korrekt so. FTP Dienst korrekt konfiguriert (mysql verbindung!)? Wüsste da von keinem Problem das Kunden ihre Daten nicht per FTP bearbeiten können...
  9. Probleme mit Let's Encrypt

    Bitte zunächst mit der aktullen git-version testen
  10. Debian Stretch und libnss-extrausers

    Dann solltest du für das Froxlor panel selbst auch fpm aktivieren, ein mischmasch mit fpm und anderer integration ist nich zu empfehlen. Einstellungen -> Froxlor Vhost Einstellungen
  11. Debian Stretch und libnss-extrausers

    joa, nsswitch ist falsch, nach Änderungen in den Einstellungen musst du die Konfigurationsschritte dafür auch noch mal durchgehen, für libnss-extrausers gibt es welche die nsswitch.conf muss doch wissen das sie extrausers nutzen soll und nicht mehr mysql joa das wird nich passen, wirf mal nen blick in deine php-fpm.conf welcher ordner da inkludiert wird, bei debian meist eher sowas wie /etc/php/7.0/fpm/pool.d/
  12. Debian Stretch und libnss-extrausers

    /etc/nsswitch.conf vergessen anzupassen? Und die PHP-Sockets stimmen schon so, hast du vllt den pfad zu den fpm-pool-configs nicht korrekt gesetzt in den Einstellungen? Bitte nicht davon ausgehen, dass die Defaults 100% passen!!!
  13. hä? Wie wie muss ich das einrichten? Du aktivierst Let's Encrypt in den Einstellungen (global), du musst natürlich die acme.conf einrichten (konfiguration -> webserver) damit der globale Alias existiert und Ende. das wars. Entsprechend musst du natürlich auch einer SSL-enabled domain noch sagen, sie soll let's encrypt nutzen (domain -> bearbeiten)
  14. 1) na URL aufrufen??? Domain.tld/.well-known/acme-challenge/Test (oder wie sie auch heisst) 2) wie du kannst da nix ändern wenn du aufs schloss klickst? Da sind Textfelder wo entsprechend der Beschreibung die Inhalte eingefügt werden.
  15. 1) du bist doch der sysadmin, du hast das eingerichtet, du solltest es wissen. Default wäre /var/www/froxlor/.well-known/acme-challenge 2) Kunde -> Domain Übersicht -> rechts das Schloss-icon neben dem bearbeiten Link
  16. 1) schau dir die Meldung doch einfach mal genau an, dafür ist die da: 404 Not Found Teste also am besten mit einer Testdatei im . well-known/acme-challenge Ordner ob der alias funktioniert. Gab es hier nun schon in diversen Threads. 2) wie schon gesagt, du kannst grundsätzlich alle certificates manuell hinterlegen, auch ein Let's encrypt Zertifikat. Es wird so hinterlegt aber halt nicht automatisch erneuert.
  17. Wie lang du da warten musst entnimmst du bitte der Let's encrypt Doku. Du kannst natürlich (als Kunde) die SSL Zertifikate manuell hinterlegen. Wenn das allerdings Let's encrypt Zertifikate sind, weiss froxlor das nicht und wird sie nicht automatisch erneuern
  18. IP ändern

    Der 5. Thread innerhalb 24 Stunden...hätte es vllt nicht auch einer getan? Wieso willst du Änderungen an der IP vornehmen wenn du doch die IP übernimmst? Ich verstehe dein Szenario nicht so ganz, beschreibe doch das was du tun möchtest und was du erreichen möchtest etwas genauer
  19. Steht doch da: zuviele registrierungen auf diese IP
  20. Aktualisierung geht nicht

    Nach der Installation kommt normal keine Aktualisierung, erläutere bitte was du genau gemacht hast, sonst wird helfen schwer.
  21. Einstellungen in der datenbank

    panel_settings - macht Sinn ne?
  22. neuste version

    Git Clone, wenn du die aktuelle Entwicklerversion willst, gibt eine Anleitung dazu hier: https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-from-git-sources
  23. neuste version

    Gibt es noch nicht.
  24. Du musst alle Schritte in Admin Panel => System => Konfiguration für alle genutzten Dienste NACH Anpassung der Einstellungen (WICHTIG!!!) durchgehen und ausführen. Das "example-script.sh" am Anfang der Seite ist ein BEISPIEL. Bitte einfach aufmerksam lesen: "You are about to configure a service/daemon. The following legend explains the nomenclature." - danach geht es erst mit den ECHTEN Befehlen los
×