Jump to content
Froxlor Forum

franks

Members
  • Posts

    49
  • Joined

  • Last visited

  • Days Won

    1

franks last won the day on October 18

franks had the most liked content!

franks's Achievements

Contributor

Contributor (5/14)

  • Conversation Starter
  • Week One Done
  • One Month Later
  • One Year In
  • First Post

Recent Badges

1

Reputation

1

Community Answers

  1. joo, das wars. ich habe immer nur die vhost einträge geändert. Lösung: Eintrag in SSL Vhost und "Nicht-SSL vHost-Einstellungen in SSL-vHost inkludieren:" auswählen.
  2. <VirtualHost xx.xx.xx.20:443> ServerName stream.xxx.info ServerAdmin xxx SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLSessionTickets on SSLHonorCipherOrder off SSLCipherSuite ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA$ SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/froxlor-custom/stream.xxx.info.crt SSLCertificateKeyFile /etc/ssl/froxlor-custom/stream.xxx.info.key SSLCACertificateFile /etc/ssl/froxlor-custom/stream.xxx.info_CA.pem SSLCertificateChainFile /etc/ssl/froxlor-custom/stream.xxx.info_chain.pem <IfModule mod_headers.c> Header always set Strict-Transport-Security "max-age=0" </IfModule> DocumentRoot "/var/customers/webs/franks/xxx.com" FcgidIdleTimeout 30 SuexecUserGroup "franks" "franks" <Directory "/var/customers/webs/franks/xxx.com/"> <FilesMatch "\.(php|html)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/franks/stream.xxx.info/php-fcgi-starter .php FcgidWrapper /var/www/php-fcgi-scripts/franks/stream.xxx.info/php-fcgi-starter .html Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> Alias /webalizer "/var/customers/webs/franks/webalizer" LogLevel warn ErrorLog "/var/customers/logs/franks-error.log" CustomLog "/var/customers/logs/franks-access.log" combined </VirtualHost> Müssten die Einstellungen hier mit drinnen stehen?
  3. müsste die vhost nicht in /etc/apache2/sites-enabled liegen?
  4. Funktioniert leider nicht. Der Proxy leitet nicht um. Ich werde ins DocumentRoot root geleitet (404)
  5. ProxyPass /service1 http://localhost:8080/service1 ProxyPassReverse /service1 http://localhost:8080/service1 <Proxy http://localhost:8080/service1> Require all granted Options none </Proxy> ich habe den von dir oben beschriebenen eintrag in die vhost gemacht und nun erhalte ich wenn ich auf www.domain.com funktioniert das SSL Zerifikat aber lande im Verzeichnis von einer Website www.domain.com:8080/service1 dann geht Restreamer mit ungültigem SSL Zerifikat www.domain.com/service1 gehe Restreamer mit ungültigem SSL Zerifikat (Restreamer antwortet {"code":404,"message":"File not found","details":["/service1/ui"]}) Beim versuch ProxyPass / http://localhost:8080/ ProxyPassReverse / http://localhost:8080/ <Proxy http://localhost:8080/> Require all granted Options none </Proxy> www.domain.com funktioniert das SSL Zerifikat aber Lande im Verzeichnis von einer Website www.domain.com:8080/ dann geht Restreamer mit ungültigem SSL Zerifikat
  6. ja, oder dass der dienst unter https://public-domain.tld:8181 abrufbar ist. Mir ist noch aufgefallen dass der Docker auf den Ports 8080 und 8181 hört jedoch wenn ich einen Open Port Check mache dann scheint nur 8080 offen zu sein. Kann das sein?
  7. kann ich hierfür ein ticket unter froxlor.support erstellen?
  8. In den Einstellungen von Restreamer kann man Zertifikate erstellen lassen. http://stream.xxx.com:8080 funktioniert auch https://stream.xxx.com:8181 funktioniert nicht (ERR_CONNECTION_REFUSED) http://stream.xxx.com wird auf die Loging Seite von Froxlor umgeleitet
  9. unter stream.xxx.com:8080 ist docker continer erreichbar. unter stream.xxx.com:8181 kommt die Fehlermeldung 502 Proxy Error Im Apache log habe ich keine Fehler gefunden.
  10. ProxyPass / http://localhost:8181/ ProxyPassReverse / http://localhost:8181/ <Proxy http://localhost:8181/> Require all granted Options none </Proxy> Ich möchte dass die Domain https://deine-domain.tld/ unter dem port 8181 erreichbar ist. Was mache ich hier falsch? mod_proxy_http ist aktiviert.
  11. Hallo, ich habe Restream (Open Source Streaming Server ⇒ Selfhosting Video Server / datarhei ⇒ Open Source Video Streaming Server Software) installiert. Nun kann ich per ip:8080 den Streamingserver erreichen. In der Anleitung steht: Vergessen Sie nicht die Portweiterleitung des öffentlichen Ports für HTTPS: 443 auf Ihren internen Restreamer IP Standardport: 8181 wie kann ich das machen?
  12. Ich habe nun den Fehler gefunden. Die IP 6 hat auf einen falschen Host gezeigt. Danke für die Unterstützung.
  13. die einstellungen haben so inkl. letsencrypt immer funktioniert. jetzt (zum glück) noch die hauptdomain.
  14. --> log gelöscht das ist alles was ich in putty noch sehe.
  15. ja, habe ich gerade nochmals gemacht. ich bin nur ein laie, aber sollten die dateien die laut der error message fehlen nicht vorhanden sein?
×
×
  • Create New...