Jump to content
Froxlor Forum

froxlorforum@pilsgenuss.de

Members
  • Content Count

    18
  • Joined

  • Last visited

  • Days Won

    1

froxlorforum@pilsgenuss.de last won the day on November 1 2019

froxlorforum@pilsgenuss.de had the most liked content!

Community Reputation

1 Neutral

About froxlorforum@pilsgenuss.de

  • Rank
    Froxie

Contact Methods

  • Website URL
    bloombox.de

Profile Information

  • Location
    Steinbach
  1. Ja, Du hast nat├╝rlich recht: Wenn die IPs eingetragen (sind sie), konfiguriert und auch durch die Firewall gelassen werden, sollte das alles funktionieren. Hat es leider nicht. ­čÖé Ich habe die Domain nun auch auf die .71 umgestellt, sie hatte f├╝r sich ein Zertifikat gezogen. Das habe ich ihr nun "weggenommen" (war quatsch - habe es danach wieder gesetzt), sie wieder als Alias f├╝r die andere Domain konfiguriert. Dazwischen immer brav das Skript ablaufen lassen. Wo ich mir nun nicht mehr sicher bin: Muss die Domain ein "eigenes" H├Ąkchen bei "Let's Encrypt" haben (davon gehe ich aus) oder wird das dann ├╝ber die Hauptdomain gesteuert, auf die die Aliases zeigen? Hat auf jeden Fall geklappt ... ­čśë Ergebnis stimmt, funktioniert wieder. Die IP .74 sehe ich mir noch mal genau an mit einer Testdomain. Die anderen waren wichtiger. Danke!
  2. konnt' es doch nicht lassen: Ganz einfache Sache, denke ich: ich-bin-auch-verschnupft.de hat auf die IP .74 gezeigt, der Rest auf die .71. Ist zwar alles auf demselben Server, mag aber LE wohl nicht ... Na denn.
  3. Habe es hinbekommen: Eine der Alias-Domains ich-bin-auch-verschnupft.de hat vermutlich nicht mehr richtig aufgel├Âst (muss ich noch pr├╝fen). Jedenfalls stand etwas derart in der LE-Verification. Domain als Alias entfernt, neu gestartet und gl├╝cklicherweise war ich bei meinen Versuchen unter der Max-Anzahl Versuche, die man pro Stunde machen darf. Zertifikat erstellt f├╝r die verschnupft.de, die anderen Domains mit im Zert enthalten. Nur eben die eine Alias-Domain nicht. Schaue ich mir Morgen an, dann schreibe ich den Grund. Muss f├╝r heute Schluss machen. Hab M├Ąnnerschnupfen. Nacht und Danke! Jens
  4. OK, ich probier es so wie Du sagst! Ansonsten bestell ich ein Kauf-Jahreszertifikat und gut. ­čśĽ Danke f├╝r die schnelle Hilfe! ­čÖé
  5. Verflixt, habe im Debug-Modus des Cron-Jobs eine Fehlermeldung gefunden: [Mo 17. Feb 17:58:04 CET 2020] _post_url='https://acme-v02.api.letsencrypt.org/acme/new-nonce' [Mo 17. Feb 17:58:04 CET 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header -g -I ' [Mo 17. Feb 17:58:05 CET 2020] _ret='0' [Mo 17. Feb 17:58:05 CET 2020] POST [Mo 17. Feb 17:58:05 CET 2020] _post_url='https://acme-v02.api.letsencrypt.org/acme/new-order' [Mo 17. Feb 17:58:05 CET 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header -g ' [Mo 17. Feb 17:58:06 CET 2020] _ret='0' [Mo 17. Feb 17:58:06 CET 2020] code='429' [Mo 17. Feb 17:58:06 CET 2020] Le_LinkOrder [Mo 17. Feb 17:58:06 CET 2020] Le_OrderFinalize [Mo 17. Feb 17:58:06 CET 2020] Create new order error. Le_OrderFinalize not found. { "type": "urn:ietf:params:acme:error:rateLimited", "detail": "Error creating new order :: too many failed authorizations recently: see https://letsencrypt.org/docs/rate-limits/", "status": 429 } [Mo 17. Feb 17:58:06 CET 2020] pid [Mo 17. Feb 17:58:06 CET 2020] No need to restore nginx, skip. [Mo 17. Feb 17:58:06 CET 2020] _clearupdns [Mo 17. Feb 17:58:06 CET 2020] dns_entries [Mo 17. Feb 17:58:06 CET 2020] skip dns. [Mo 17. Feb 17:58:06 CET 2020] _on_issue_err [Mo 17. Feb 17:58:06 CET 2020] Please add '--debug' or '--log' to check more details. [Mo 17. Feb 17:58:06 CET 2020] See: https://github.com/acmesh-official/acme.sh/wiki/How-to-debug-acme.sh [Mo 17. Feb 17:58:06 CET 2020] Diagnosis versions: openssl:openssl OpenSSL 1.1.1d 10 Sep 2019 apache: apache doesn't exists. nginx: nginx doesn't exists. socat: socat by Gerhard Rieger - see www.dest-unreach.org Usage: socat [options] <bi-address> <bi-address> options: -V print version and feature information to stdout, and exit -h|-? print a help text describing command line options and addresses -hh like -h, plus a list of all common address option names -hhh like -hh, plus a list of all available address option names -d increase verbosity (use up to 4 times; 2 are recommended) Tja, "too many failed ...". Jetzt sehe ich auch, dass das Zertifikat schon etwas ├Ąlter ist - am 13.12.2019 zum letzten Mal erneuert wurde und nur noch bis zum 12.3. g├╝ltig ist. Komisch trotzdem. OK, ich l├Âsche wie von Dir beschrieben, warte etwas und probiere wieder (zwischenzeitlich schaue ich mir die Rate-Limits an - ich habe das Gef├╝hl, dass ich so schnell an kein Zert. komme ... ) Danke, Jens
  6. Hallo allerseits, ich habe einen Froxlor-Server (aktuelle Version), der auf einer IP .71 ein Wildcard-Zertifikat f├╝r eine Domain *.irgendwas.de laufen hat. Auf dieser IP gibt es au├čer Domains, die eben auf *.irgendwas.de lauten auch noch Domains, die bspw. auf wasanderes.com lauten. Daf├╝r habe ich jeweils Let's Encrypt Zertifikate aktiviert, was auch die letzte Zeit (Monate) soweit funktioniert hat und teilweise auch noch funktioniert. Bei einer Domain allerdings, als Bsp. ichbinverschnupft.de sieht man in Froxlor, dass Let's Encrypt aktiviert ist, Froxlor zieht sich auch brav ein Zertifikat f├╝r die verschnupfte Domain, das wird aber nicht in der Apache-Conf eingetragen. Stattdessen steht dort das besagte Wildcard der IP-Nummer. Eine andere unverschnupfte Domain verwendet dagegen wie konfiguriert ihr Let's Encrypt Zertifikat. Das Let's Encrypt sehe ich auch im Men├╝punkt "SSL Zertifikate", es handelt sich dabei um eine Version mit mehreren Domains dahinter. Das ist f├╝r mein Gef├╝hl die einzige Unterscheidung zu den ├╝brigen unverschnupften Domains. Gerade sehe ich in den Systemlogs immer wieder diesen Fehler: Cronjob 17.02.20 17:31:05 error system Given SSL private key for verschnupft.de does not seem to match the certificate. Cannot create ssl-directives Hmm, Schluckauf, vermute ich. Die Config wurde seit einigen Tagen nicht angepasst. Ich deaktivere mal LE und aktiviere es dann nach dem Cron-Lauf neu ... Viele Gr├╝├če, Jens
  7. Moin, der OP hier. Sorry, dass ich mich die ganze Zeit nicht gemeldet habe - gab/ gibt leider schwerwiegende Gr├╝nde. Hat mit Krhs und Koma zu tun. Ist sonst nicht meine Art, mich nicht zu melden. Zur Sache: Ich hatte mir f├╝r's Erste mit dem viel weiter oben beschriebenen Workaround (www-data an Gruppen in /etc/groups) beholfen. Den von mir selbst reingesetzten Link auf einen ├Ąlteren Post hatte ich angesehen, gepr├╝ft, brachte mich aber nicht weiter. Inzwischen wurden 2 Froxlor-Updates reingedr├╝ckt und siehe da, beim heutigen Pr├╝fen stand auf einmal "www-data" mit hinter jedem Eintrag in /var/lib/extrausers/groups : jens:x:10002:jens,froxlorlocal,froxlorlocal,www-data Da ich nun wegen der privaten Schwierigkeiten tats├Ąchlich sonst in der Zwischenzeit nichts ge├Ąndert hatte, bin ich ein wenig irritiert, freue mich aber nat├╝rlich, dass es nun l├Ąuft. Ich versuche trotzdem, das Ganze noch nachzuvollziehen. Inzwischen ist in der Konfiguration auch der anfangs fehlende Eintrag drin: "system.httpuser": "www-data", "system.httpgroup": "www-data", Vermutlich macht der das aus. Nur, wie gesagt, k.A., wo der herkommt ... ­čśĽ Gr├╝├če, Jens
  8. Kann es sein, dass mein Problem mit diesem hier identisch ist: Ich lese mir das in Ruhe durch und schaue, ob das passt. Da ging es auch um die ftp_groups
  9. ok. ? aber sonst gibt es definitiv kein "froxlorlocal". Bzw. schon, in ftp_groups: Suchergebnisse f├╝r "froxlorlocal" mindestens eines der W├Ârter: 0 Treffer in cronjobs_run 0 Treffer in domain_dns_entries 0 Treffer in domain_redirect_codes 0 Treffer in domain_ssl_settings 4 Treffer in ftp_groups Anzeigen L├Âschen 0 Treffer in ftp_quotalimits 0 Treffer in ftp_quotatallies 0 Treffer in ftp_users 0 Treffer in mail_users 0 Treffer in mail_virtual 0 Treffer in panel_activation 0 Treffer in panel_admins 0 Treffer in panel_customers 0 Treffer in panel_databases 0 Treffer in panel_diskspace 0 Treffer in panel_diskspace_admins 0 Treffer in panel_domains 0 Treffer in panel_domaintoip 0 Treffer in panel_fpmdaemons 0 Treffer in panel_htaccess 0 Treffer in panel_htpasswds 0 Treffer in panel_ipsandports 0 Treffer in panel_languages 0 Treffer in panel_phpconfigs 0 Treffer in panel_plans 0 Treffer in panel_sessions 4 Treffer in panel_settings Anzeigen L├Âschen 0 Treffer in panel_syslog 0 Treffer in panel_tasks 0 Treffer in panel_templates 0 Treffer in panel_ticket_categories 0 Treffer in panel_tickets 0 Treffer in panel_traffic 0 Treffer in panel_traffic_admins 0 Treffer in redirect_codes Insgesamt 8 Treffer
  10. Anders rum: Kann ich ├╝ber die Datenbank die beiden Eintr├Ąge korrigieren - auf www-data? "system.mod_fcgid_httpuser": "froxlorlocal", "system.mod_fcgid_httpgroup": "froxlorlocal", Ich trau mich mal. Moment.
  11. OK, verstehe. Aber was doch schon bei mir falsch ist: Der "varname" ist nicht httpuser, sondern mod_fcgid_httpuser! Das bedeutet doch vermutlich, dass ich irgendwo eine Checkbox falsch gesetzt habe .. Grunds├Ątzlich habe ich ja genau den httpuser richtig: "system.httpuser": "www-data", "system.httpgroup": "www-data", Kann es sein, dass hier f├Ąlschlich "froxlorlocal" aus dem fcgid gezogen wird? Editieren kann ich das Feld ja nicht ...
  12. ok ... aber: Das hatte ich doch schon gemacht, oder? Das waren vorher genau die drei Zeilen, die ich aus dem Men├╝punkt "Einstellungen" "Import/Export" heruntergeladen habe. Da erzeugt Froxlor eine Datei Froxlor_settings-0.9.40.1-201809280_26.09.2019.json und in der habe ich nach "froxlorlocal" gesucht. Aktuell sind es diese Zeilen hier, nachdem ich das wieder zur├╝ck korrigiert habe: "phpfpm.vhost_httpuser": "froxlorlocal", "phpfpm.vhost_httpgroup": "froxlorlocal", "system.mod_fcgid_httpuser": "froxlorlocal", "system.mod_fcgid_httpgroup": "froxlorlocal", Das entspricht exakt dem, was auch in der panel_settings steht: settingid settinggroup varname value Bearbeiten Kopieren L├Âschen 67 phpfpm vhost_httpuser froxlorlocal Bearbeiten Kopieren L├Âschen 68 phpfpm vhost_httpgroup froxlorlocal Bearbeiten Kopieren L├Âschen 146 system mod_fcgid_httpuser froxlorlocal Bearbeiten Kopieren L├Âschen 147 system mod_fcgid_httpgroup froxlorlocal Oder stehe ich nun v├Âllig auf dem Schlauch/ verstehe Deine Hinweise nicht? Danke!
  13. hmm. Verflixt. Ich verstehe - zumindest jetzt. Da stand zun├Ąchst in beiden Feldern "froxlorlocal" drin. Damit lief es nicht (klar). Also dachte ich, ich bin schlau und schreibe den www-data in die Gruppe. Aber: ich habe das alles unter dieser ├ťberschrift verstanden: Verwende PHP-FPM im Froxlor-Vhost Wenn verwendet, wird Froxlor selbst unter einem lokalen Benutzer ausgef├╝hrt Lokaler Benutzer f├╝r PHP-FPM (Froxlor-Vhost) Lokale Gruppe f├╝r PHP-FPM (Froxlor-Vhost) Ich dachte, damit steuere ich ausschlie├člich den Froxlor-Vhost. Nicht funktioniert haben aber alle anderen VHosts ... Deswegen kam ich nicht drauf. ? Nun kassiere ich allerdings im Froxlor-Panel mehrere Fehler: PHP warning/error #2 Unknown: open(/var/customers/tmp/froxlor.panel//sess_5721bcf8d802872cb9fd52789b0eb54a, O_RDWR) failed: Permission denied (13) Unknown:0 Muss ich mir ansehen ...
  14. K├Ânnte es sein, dass "mein Froxlor" schon zu alt ist oder anders: H├Ątte ich die Einstellungen jedes Mal nach einem Upgrade neu machen m├╝ssen (habe schon grob kontrolliert, ob sich da was ge├Ąndert hat)? Sicher bin ich mir nicht, aber ich hatte Debian irgendwann hochgezogen von 8 auf 9 und dadurch (oder war es schon vorher von 7 auf 8 - m├╝sste ich nachsehen) wurde auch der Apache umgestellt. Die Einstellungen hatte ich mir angesehen. Die Umstellung auf php-fpm hatte ich erst vor kurzem vorgenommen, was bedingt gut geklappt hat. Und in diesem Zusammenhang kam auch erst libnss-extrausers dazu ...
  15. OK. Dann suche ich mal. ? Bei den Froxlor-VHost-Einstellungen steht es drin. Aber das sollte ja nicht zusammenh├Ąngen: "phpfpm.vhost_httpuser": "froxlorlocal", "phpfpm.vhost_httpgroup": "www-data", Das hier sollte nicht relevant sein: "system.mod_fcgid_httpuser": "froxlorlocal", "system.mod_fcgid_httpgroup": "froxlorlocal", Das sind alle Vorkommen von "froxlorlocal" im Download des JSON-Modells der Einstellungen.
×
×
  • Create New...