Jump to content
Froxlor Forum

d00p

Administrators
  • Content count

    6106
  • Joined

  • Last visited

  • Days Won

    41

d00p last won the day on September 8 2016

d00p had the most liked content!

Community Reputation

131 Excellent

6 Followers

About d00p

  • Rank
    Lead developer
  • Birthday 07/15/85

Profile Information

  • Gender
    Not Telling
  • Location
    Frankfurt/Main

Recent Profile Visitors

108700 profile views
  1. as said, the initial setup should've filled that already. Port is of course 80 or 443 (ssl). The other settings are self-explaining
  2. lighttpd mod_openssl warnung

    ist gefixt: https://git.io/vFSmA
  3. lighttpd mod_openssl warnung

    ich nehme an, da hat wohl lighttpd sein verhalten geändert. Versuch mal folgenden Patch und sag mir obs damit klappt: diff --git a/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php b/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php index d1ba5d0..a2d5258 100644 --- a/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php +++ b/scripts/jobs/cron_tasks.inc.http.20.lighttpd.php @@ -535,7 +535,8 @@ class lighttpd extends HttpConfigBase if ($domain['ssl_cert_file'] != '') { - $ssl_settings .= 'ssl.engine = "enable"' . "\n"; + // ssl.engine only necessary once in the ip/port vhost (SERVER['socket'] condition) + //$ssl_settings .= 'ssl.engine = "enable"' . "\n"; $ssl_settings .= 'ssl.use-compression = "disable"' . "\n"; $ssl_settings .= 'ssl.use-sslv2 = "disable"' . "\n"; $ssl_settings .= 'ssl.use-sslv3 = "disable"' . "\n";
  4. Mailsettings autodiscover

    Alias "/.well-known/autoconfig/mail/" "/var/www/autoconfig/" Alias "/.mz-autoconf/" "/var/www/autoconfig/" Alias "/autodiscover/" "/var/www/autoconfig/" und dann neben der config-v1.1.xml noch eine autodiscover.xml: <?xml version="1.0" encoding="UTF-8"?> <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006"> <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a"> <Account> <AccountType>email</AccountType> <Action>settings</Action> <Protocol> <Type>POP3</Type> <Server>dein.mail.fqdn</Server> <Port>995</Port> <DomainRequired>on</DomainRequired> <SPA>off</SPA> <SSL>on</SSL> <AuthRequired>on</AuthRequired> </Protocol> <Protocol> <Type>IMAP</Type> <Server>dein.mail.fqdn</Server> <Port>993</Port> <DomainRequired>on</DomainRequired> <SPA>off</SPA> <SSL>on</SSL> <AuthRequired>on</AuthRequired> </Protocol> <Protocol> <Type>SMTP</Type> <Server>dein.mail.fqdn</Server> <Port>587</Port> <DomainRequired>on</DomainRequired> <SPA>off</SPA> <SSL>on</SSL> <AuthRequired>on</AuthRequired> <UsePOPAuth>off</UsePOPAuth> <SMTPLast>off</SMTPLast> </Protocol> </Account> </Response> </Autodiscover>
  5. Mailsettings autodiscover

    erstell doch einfach nen globalen alias (wie für let's encrypt). Für thunderbird z.B. und in /var/www/autconfig/ dann die config-v1.1.xml mit entsprechendem inhalt, z.B.
  6. Mal die Fehlermeldung/Nummer gegooglet? Das ist eine andere als der Thread-Ersteller nennt...siehe: https://askubuntu.com/questions/763336/cannot-enter-phpmyadmin-as-root-mysql-5-7/763359#763359
  7. proftpd -> debug -> logs, sonst kann man schwer was sagen
  8. https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-from-tarball Da erstellt froxlor auch nix...du hinterlegst da nur die URL zu der App die DU selbst irgendwo installiert/konfiguriert hast Permissions sind korrekt so. FTP Dienst korrekt konfiguriert (mysql verbindung!)? Wüsste da von keinem Problem das Kunden ihre Daten nicht per FTP bearbeiten können...
  9. Probleme mit Let's Encrypt

    Bitte zunächst mit der aktullen git-version testen
  10. Debian Stretch und libnss-extrausers

    Dann solltest du für das Froxlor panel selbst auch fpm aktivieren, ein mischmasch mit fpm und anderer integration ist nich zu empfehlen. Einstellungen -> Froxlor Vhost Einstellungen
  11. Debian Stretch und libnss-extrausers

    joa, nsswitch ist falsch, nach Änderungen in den Einstellungen musst du die Konfigurationsschritte dafür auch noch mal durchgehen, für libnss-extrausers gibt es welche die nsswitch.conf muss doch wissen das sie extrausers nutzen soll und nicht mehr mysql joa das wird nich passen, wirf mal nen blick in deine php-fpm.conf welcher ordner da inkludiert wird, bei debian meist eher sowas wie /etc/php/7.0/fpm/pool.d/
  12. Debian Stretch und libnss-extrausers

    /etc/nsswitch.conf vergessen anzupassen? Und die PHP-Sockets stimmen schon so, hast du vllt den pfad zu den fpm-pool-configs nicht korrekt gesetzt in den Einstellungen? Bitte nicht davon ausgehen, dass die Defaults 100% passen!!!
  13. hä? Wie wie muss ich das einrichten? Du aktivierst Let's Encrypt in den Einstellungen (global), du musst natürlich die acme.conf einrichten (konfiguration -> webserver) damit der globale Alias existiert und Ende. das wars. Entsprechend musst du natürlich auch einer SSL-enabled domain noch sagen, sie soll let's encrypt nutzen (domain -> bearbeiten)
  14. 1) na URL aufrufen??? Domain.tld/.well-known/acme-challenge/Test (oder wie sie auch heisst) 2) wie du kannst da nix ändern wenn du aufs schloss klickst? Da sind Textfelder wo entsprechend der Beschreibung die Inhalte eingefügt werden.
×