Jump to content
Froxlor Forum

BigWhoop

Members
  • Posts

    22
  • Joined

  • Last visited

  • Days Won

    1

BigWhoop last won the day on April 7

BigWhoop had the most liked content!

Recent Profile Visitors

1686 profile views

BigWhoop's Achievements

Apprentice

Apprentice (3/14)

  • Conversation Starter
  • Week One Done
  • One Month Later
  • One Year In
  • First Post

Recent Badges

1

Reputation

1

Community Answers

  1. Es war php8.1-fpm enabled in der apache2 conf. Ein a2disconf php8.1-fpm und der Spuk war vorbei! Danke d00p
  2. Danke und Erledigt. Da es in meinen Augen auch keinen Sinn macht frage ich ja hier nach.
  3. # 35_froxlor_ssl_vhost_XXX.de.conf # Created 07.04.2022 00:50 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 (SSL) - CustomerID: 2 - CustomerLogin: user <VirtualHost XXX:443> ServerName XXX.de ServerAlias www.XXX.de ServerAdmin xxx@XXX.de SSLEngine On SSLProtocol -ALL +TLSv1.2 Protocols h2 http/1.1 SSLCompression Off SSLSessionTickets on SSLHonorCipherOrder off SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/froxlor-custom/XXX.de.crt SSLCertificateKeyFile /etc/ssl/froxlor-custom/XXX.de.key SSLCACertificateFile /etc/ssl/froxlor-custom/XXX.de_CA.pem SSLCertificateChainFile /etc/ssl/froxlor-custom/XXX.de_chain.pem <IfModule mod_headers.c> Header always set Strict-Transport-Security "max-age=15768000; includeSubDomains" </IfModule> DocumentRoot "/var/customers/webs/user" <FilesMatch \.(php)$> SetHandler proxy:unix:/var/lib/apache2/fastcgi/2-user-XXX.de-php-fpm.socket|fcgi://localhost </FilesMatch> <Directory "/var/customers/webs/user/"> Require all granted AllowOverride All </Directory> Alias /awstats "/var/customers/webs/user/awstats/XXX.de" Alias /awstats-icon "/usr/share/awstats/icon/" LogLevel warn ErrorLog "/var/customers/logs/user-error.log" CustomLog "/var/customers/logs/user-access.log" combined </VirtualHost> Der grep bringt kein Ergebnis. Das mit der htaccess war nochmal ne gute Idee. Aber finden tu ich da nichts. RewriteEngine on und dann nur RewriteRules (die ich nicht öffentlich posten mag) und noch ein RewriteCond %{HTTP_REFERER} !XXX\.(de|com|net) In die von froxlor erstellte vhost muss man sich noch das "<If "-f %{SCRIPT_FILENAME}">" denken
  4. Hallo ihr lieben. Damit ich nicht den Thread hier übernehme mit Offtopic kram, mache ich nen neuen auf. Es läuft die komplette Internetseite. Aber wenn jemand eine PHP Datei aufruft die nicht vorhanden ist kommt kein 404 sondern ein 503 Fehler. Und in der Log steht: [proxy:error] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/php8.1-fpm.sock (*) failed [proxy_fcgi:error] [client xxx:50996] AH01079: failed to make connection to backend: httpd-UDS Allerdings ist das ja auch gar nicht der richtige socket. Eigentlich wird der von froxlor generierte Socket benutzt vom Rest der Page. Und somit gibt es die Standard php8.1-fpm.sock ja nicht weil die www.conf gelöscht wird wenn froxlor die config per cron schreibt. Nehme ich aus der vhost das <If "-f %{SCRIPT_FILENAME}"> raus..rennt der Prozess in nen "File not found." und in der log taucht [proxy_fcgi:error] [client xxx:45838] AH01071: Got error 'Primary script unknown' auf. Was zumindest eine log Zeile weniger ist Aber dennoch frage ich mich warum er den standard socket sucht, den es ja gar nicht gibt. Vielen Dank für eure Antworten, BigWhoop
  5. Kann es sein das diese Anpassung dafür jetzt andere Fehler wirft? Falls jemand jetzt nicht vorhandene Datein aufruft wirft der Server einen 503 zurück weil er auf nen sock will der garnicht eingerichtet ist. No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/php8.1-fpm.sock (*) failedb denn er nutzt ja jetzt durch das IF nicht mehr den passenden Pfad zum konfigurieren Socket. Also wenn die Datei nicht da ist generiert er mir nen Primary script unknown Aber durch das hier jetzt einmal das nicht vorhandene Socket und dann noch AH01079: failed to make connection to backend: httpd-UDS hinterher. Also eigentlich sogar eine Errorlog zeile mehr. Welche verwirrend sein kann für Leute die sich fragen wieso in der Domain nach nem fpm Socket gefragt wird, der garnicht zugeteilt wurde.
  6. Kann sein das in der DB da irgendwas drin steht was im das "vorgaugelt". Die Froxlor install hat schon einige Jahre auf dem Buckel. Ich habe dein workaround von oben als beste antwort markiert. Vielen Dank für deine Zeit.
  7. Naja aber er macht ja per default diesen eintrag eben nicht. Darum geht es doch die ganze Zeit Und die php-fpm sind wie oben beschrieben auch überall an. Das mit "damit wird php-fpm genutzt" bezieht sich darauf das es durch die mod_proxy implementiert ist dann. Laut froxlorpanel MUSS der haken bei stretch ja auch gesetzt werden.
  8. Genau dieses /var/www/froxlor ist ja eben nicht da gewesen wie man sehen konnte. In der 05_frox.... auch nicht. Da ist nur der cusomters/webs pfad drin. Außerdem wundert mich gerade das du oben doch noch gesagt hast: Wenn das froxlor toll alleine schaffen würde, wäre das doch nicht nötig? Was ich nutze stand ja auch oben. Da Stretch rennt ist Verwende mod_proxy / mod_proxy_fcgi aktiviert. Damit wird php-fpm genutzt.
  9. Das Resultat wäre doch aber auch wieder das es bei allen nicht eingetragen werden würde. Und er macht es ja bei allen vhosts bis auf den angelegten von froxlor selbst. Ich meine...es funktioniert jetzt ja. Aber wäre doch schön wenn froxlor das selbst in den griff bekommt. Warum an ner server config noch extra rumschrauben. ODER es muss mit in die copy&past configs. Dann macht man das für froxlor quasi bei der installation mit.
  10. Hallo @cardman das würde dann aber alle vhosts betreffen. Danke @d00p nochmals für die antwort. Es ist aber nichts unter Webserver-Einstellungen => Standard vHost-Einstellungen eingetragen. und auch nicht in Kunden-Prefix Ordner-Optionen ist das mit dem automatischen nicht nur für die costumer? weil da klappt das ja auch.
  11. Danke für die Antwort, aber das schreibt froxlor bei den anderen vhosts auch mit rein oder nicht? warum nicht bei sich selbst? und viel interessanter...warum geht das auf dem einen server und auf dem anderen nicht? Werde mir mal die apache config der beiden server anschauen. Vielen Dank schonmal für die Hinweise. Edit: Tatsächlich steht in der apache.conf von dem funktionierenden Server das hier: <Directory /var/www/froxlor/> Options FollowSymLinks AllowOverride None Require all granted </Directory> verrückt. Aber trotzdem die Frage warum froxlor das nicht selbst macht, wenn er es für die anderen doch auch tut. Danke
  12. Hallo d00p. Eine schönen guten morgen wünsche ich. Stimmt die vhosts wären noch interessant gewesen. sorry. Hier sind sie: # 10_froxlor_ipandport_xxx.conf # Created 22.09.2018 20:16 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. <VirtualHost xxx:80> DocumentRoot "/var/www/" ServerName sub.domain.de <IfModule mod_rewrite.c> RewriteEngine On RewriteCond %{HTTPS} off RewriteCond %{REQUEST_URI} !^/\.well-known/acme-challenge RewriteRule ^/(.*) https://sub.domain.de/$1 [R=301;L,NE] </IfModule> <IfModule !mod_rewrite.c> Redirect 301 / https://sub.domain.de/ </IfModule> </VirtualHost> sowie # 10_froxlor_ipandport_xxx.conf # Created 22.09.2018 20:16 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. <VirtualHost xxx:443> DocumentRoot "/var/www/" ServerName sub.domain.de <FilesMatch \.(php)$> SetHandler proxy:unix:/var/lib/apache2/fastcgi/1-froxlor.panel-sub.domain.de-php-fpm.socket|fcgi://localhost </FilesMatch> <Directory "/var/www/"> Require all granted AllowOverride All </Directory> SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 Protocols h2 http/1.1 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/froxlor-custom/sub.domain.de.crt SSLCertificateKeyFile /etc/ssl/froxlor-custom/sub.domain.de.key SSLCACertificateFile /etc/ssl/froxlor-custom/sub.domain.de_CA.pem SSLCertificateChainFile /etc/ssl/froxlor-custom/sub.domain.de_chain.pem </VirtualHost> wie gesagt ist das <Directory "/var/www/"> Require all granted AllowOverride All </Directory> von mir damit ich rein komme manuell. Danke und schönen Sonntag, BigWhoop PS: Ich habe noch eine Grundsatzfrage...ist es richtig das bei dem setup die Ordner und Dateien alle ein "read" für groups brauchen? eigentlich sollte die doch vom eigenen nutzer aufgerufen werden?
  13. Hallo liebe Leute, ich weiß gar nicht wo ich Anfangen soll weil ich seit gestern Abend daran sitze und immer noch keine Lust habe das System neu zu machen. Es war in den vielen Jahren als Admin keine Option und soll es auch jetzt nicht werden. Also fange ich mal an zu Erzählen: Ich bin wegen http2 mit allen Servern auf Debian Stretch gewechselt. Was auch überraschend gut funktioniert hat (Backups sind natürlich vorhanden). Einige Anleitungen später und etwas eigenes Wissen habe ich Froxlor 0.9.39.5-1+jessie1 mit PHP-Version 7.0.30-0+deb9u1 und MySQL-Server-Version:5.5.5-10.1.26-MariaDB-0+deb9u1 laufen. Das ganze mit libnss-extrausers, dem dazu passenden php-fpm und Apache 2.4. Achso letsencrypt für SSL natürlich nicht zu vergessen. Das alles läuft auch bei den Kunden. Aber wenn ich nicht die directive ein all grand per Hand in die vhost vom froxlorpanel schmeiße bekomme ich einen 403 Fehler. d.h. sobald etwas im panel die configs neu schreibt komme ich wieder nicht mehr in den adminbereich. Ich finde einfach das Problem nicht. Die Fehlermeldung der Log ohne grand all ist: Verwende PHP-FPM im Froxlor-Vhost ist aktiviert und froxlorlocal ist der Benutzer davon. Weitere Froxlor VirtualHost Einstellungen sind LetsEncrypt + SSL Weiterleitung und eben http2. Der Inhalt der fpm pool conf ist wie folgt: ;PHP-FPM configuration for "sub.domain.de" created on 2018.09.22 20:16:52 [sub.domain.de] listen = /var/lib/apache2/fastcgi/1-froxlor.panel-sub.domain.de-php-fpm.socket listen.owner = froxlorlocal listen.group = froxlorlocal listen.mode = 0660 user = froxlorlocal group = froxlorlocal pm = dynamic pm.max_children = 6 pm.start_servers = 2 pm.min_spare_servers = 2 pm.max_spare_servers = 4 pm.max_requests = 50 ;chroot = /var/www/froxlor/ security.limit_extensions = .php env[PATH] = /usr/local/bin:/usr/bin:/bin env[TMP] = /var/customers/tmp/froxlor.panel/ env[TMPDIR] = /var/customers/tmp/froxlor.panel/ env[TEMP] = /var/customers/tmp/froxlor.panel/ php_admin_value[session.save_path] = /var/customers/tmp/froxlor.panel/ php_admin_value[upload_tmp_dir] = /var/customers/tmp/froxlor.panel/ php_value[date.timezone] = "Europe/Berlin" php_admin_value[date.timezone] = "Europe/Berlin" php_admin_flag[allow_call_time_pass_reference] = Off php_admin_flag[allow_url_fopen] = On php_flag[asp_tags] = Off php_admin_value[disable_classes] = php_admin_value[disable_functions] = curl_multi_exec,exec,parse_ini_file,passthru,popen,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate,shell_exec,show_source,system php_flag[display_errors] = Off php_flag[display_startup_errors] = Off php_admin_flag[enable_dl] = Off php_value[error_reporting] = E_ALL & ~E_NOTICE php_admin_flag[expose_php] = Off php_admin_flag[file_uploads] = On php_admin_flag[cgi.force_redirect] = 1 php_admin_value[gpc_order] = "GPC" php_flag[html_errors] = Off php_admin_flag[ignore_repeated_errors] = Off php_admin_flag[ignore_repeated_source] = Off php_value[include_path] = ".:/usr/share/php/:/usr/share/php5/" php_flag[log_errors] = On php_admin_flag[log_errors] = On php_value[log_errors_max_len] = 1024 php_flag[magic_quotes_gpc] = Off php_flag[magic_quotes_runtime] = Off php_flag[magic_quotes_sybase] = Off php_value[max_execution_time] = 60 php_admin_value[max_input_time] = 60 php_admin_value[memory_limit] = 128M php_admin_value[post_max_size] = 16M php_admin_value[precision] = 14 php_admin_flag[register_argc_argv] = Off php_admin_flag[report_memleaks] = On php_admin_value[sendmail_path] = "/usr/sbin/sendmail -t -i -f xxx@xxx.de" php_value[session.auto_start] = 0 php_value[session.cookie_domain] = php_value[session.cookie_lifetime] = 0 php_value[session.cookie_path] = / php_admin_value[session.gc_divisor] = 1000 php_admin_value[session.gc_probability] = 1 php_value[session.name] = PHPSESSID php_value[session.serialize_handler] = php php_flag[session.use_cookies] = 1 php_flag[short_open_tag] = On php_flag[suhosin.simulation] = Off php_flag[track_errors] = Off php_value[upload_max_filesize] = 32M php_admin_value[variables_order] = "GPCS" php_admin_value[opcache.restrict_api] = "/var/www/froxlor/" Ich hoffe einer von euch Froxlor Profis hat noch eine Idee. Auf einem anderen Server lief das alles durch ohne so ein Problem. Kann aber keine Unterschiede in der froxlor config finden. Da gab es dann nur Ärger mit PHP7 aber das ist eher ein Problem der Kunden :D Grüße und ein schönes Wochenende, BigWhoop
  14. Danke Leute kann zu. Wie im Edit beschrieben...nach dem zweiten durchlauf hat er das Zertifikat eingerichtet. Komisch aber das es nicht ging. Vielleicht hat das komplett ein und ausschalten des SSL Parts geholfen. Ich weiß es nicht. Aber wie gesagt: GET /.well-known/acme-challenge/5titBgD1ChBE46B22n1xVNuENiO8xxWIVRTOsnqhCsY HTTP/1.1" 404 527 "-" "Mozilla/5.0 kam vom letsencrypt server. was ja bedeuten sollte die auflösung klappt schon. Aber ihr seid mega schnell! Vielen Dank!
×
×
  • Create New...