Jump to content
Froxlor Forum

chrisiwien

Members
  • Content Count

    13
  • Joined

  • Last visited

  • Days Won

    1

chrisiwien last won the day on July 25 2019

chrisiwien had the most liked content!

Community Reputation

1 Neutral

About chrisiwien

  • Rank
    Froxie
  1. Ha, das weiß ich garantiert dass das username:username ist... da ich keine stabile FTP-Verbindung mit proFTP zusammenbekomme gehe ich immer über SFTP mit root rein und chmode dann den gesamten Ordner in der Shell händisch auf den username... *rotwerd* - was soll ich tun, wieder zig Stunden in das Thema FTP investieren...uff... Gack: Hab folgendes entdeckt: der Temp-Ordner (var/customers/tmp/username) hat die User/Gruppenzuweisung (in WinSCP angezeigt) 10006 [10006], währenddessen die anderen - funktionierenden - haben username2 [10006]. Wird auch mit ls -l so angezeigt. Hab den Temp-Ordner jetzt manuell mit chown -R auf username:username gesetzt und ... ... es läuft! 😀 Danke Dir für den Zuspruch! Da ja alles mit Froxlor von Haus aus gehen sollte hab ich hier gefragt. War keine schlechte Idee, wieder was gelernt!
  2. Hab im Zuge des Problems auch entdeckt, dass ich nach einem apt-update den Server nicht rebootet habe...hehe...äh...zuerst kam ich mit unsername.domain.com überhaupt nicht in das Verzeichnis...403 und dann 503, nachdem ich die Verzeichnisberechtigungen geändert habe. Nach dem Reboot hat es dann funktioniert - bis auf die Berechtigungen vom Temp-Ordner halt...
  3. Habs versucht mit open_basedir wegnehmen. Auch die php-Konfig vom funktionierenden Host genommen, auch alle von mir gedachten problematischen Werte sind wie vom funktionierenden Host. Nope. Geht nicht. Ich bin mir da nicht ganz sicher, aber: wenn ich einen Kunden lösche, verschwinden nicht die Ordner im Verzeichnis "customers", richtig? Die müsste ich manuell entfernen. Kann es sein - da ich den Kunden gelöscht und wieder unter dem gleichen Username angelegt habe - dass die noch existierenden Ordner da eine korrekte Verbindung verhindern?
  4. Noch etwas: ich fliege immer auch nach kurzer Zeit aus Froxlor raus und muss mich neu anmelden. Könnte sein, dass im Zuge dessen einige Werte nicht korrekt in die Froxlor-Datenbank geschrieben wurden. Gibt es in Bezug auf mein Problem irgendeinen Wert den ich in der Froxlor-Datenbank überprüfen könnte?
  5. Hallo d00p! Danke für die wie immer prompte Antwort! 770 hat leider auch nicht geholfen. Ich habe die Berechtigungen wieder auf 750 gesetzt, im Error-Log username-error.log - als WordPress greift unter dem angelegten Kunden-Username zu (scheint so) - steht folgendes: proxy_fcgi:error] [pid 28270:tid 140380049725184] [client xxx.xxx.xxx.xxx:61211] AH01071: Got error 'PHP message: PHP Warning: Unknown: Unable to create temporary file, Check permissions in temporary files directory. in Unknown on line 0PHP message: PHP Warning: Unknown: POST data can't be buffered; all data discarded in Unknown on line 0PHP message: PHP Warning: array_key_exists() expects parameter 2 to be array, null given in /var/customers/webs/username/wp-includes/rest-api/class-wp-rest-request.php on line 412PHP message: PHP Warning: array_key_exists() expects parameter 2 to be array, null given in /var/customers/webs/username/wp-includes/rest-api/class-wp-rest-request.php on line 412', referer: http://username.domain.com/wp-admin/post.php?post=5&action=edit vHost-Datei vom nicht funktionierenden Host: # 35_froxlor_normal_vhost_username.domain.com.conf # Created 09.06.2020 16:28 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 16 - CustomerID: 8 - CustomerLogin: username <VirtualHost [Server-IP]:80> ServerName username.domain.com ServerAlias *.username.domain.com ServerAdmin chrisiwien@domain.com DocumentRoot "/var/customers/webs/username/" <FilesMatch \.(php)$> SetHandler proxy:unix:/var/lib/apache2/fastcgi/1-username-username.domain.com-php-fpm.socket|fcgi://localhost </FilesMatch> <Directory "/var/customers/webs/username/"> CGIPassAuth On Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/username-error.log" CustomLog "/var/customers/logs/username-access.log" combined </VirtualHost> vHost-Datei von einem anderen, mit Temp-Ordner auf 750, funktionierenden Host: # 35_froxlor_normal_vhost_username2.domain.com.conf # Created 09.06.2020 16:28 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 - CustomerID: 2 - CustomerLogin: username2 <VirtualHost [Server-IP]:80> ServerName username2.domain.com ServerAlias *.username2.domain.com ServerAdmin chrisiwien@domain.com DocumentRoot "/var/customers/webs/username2/" <FilesMatch \.(php)$> SetHandler proxy:unix:/var/lib/apache2/fastcgi/1-username2-username2.domain.com-php-fpm.socket|fcgi://localhost </FilesMatch> <Directory "/var/customers/webs/username2/"> Require all granted AllowOverride All </Directory> Alias /webalizer "/var/customers/webs/username2/webalizer/username2.domain.com" LogLevel warn ErrorLog "/var/customers/logs/username2-username2.domain.com-error.log" CustomLog "/var/customers/logs/username2-username2.domain.com-access.log" combined LogLevel debug </VirtualHost> In der Folge die php-fpm pool-Dateien, einmal vom funktionierenden, einmal vom nicht funktionierenden vHost. Um das ganze ev. abzukürzen, die Unterschiede die mir beim nicht funktionierenden Host aufgefallen sind: php_admin_flag[allow_url_fopen] = Off php_admin_value[open_basedir] = "/var/customers/webs/dcamp:/var/customers/tmp/dcamp:/usr/share/php:/usr/share/php5:/tmp" (open_basdir Wert ist definiert, bei der funktionierenden pool-Konfiguration nicht) php_admin_value[post_max_size] = 16M (im Vergleich 256M bei der funktionierenden pool-Konfiguration. Mir ist auch aufgefallen, dass NUR bei sehr komplexen Gutenberg-Posts, also mit vielen Blöcken, Änderungen nicht gespeichert werden. Wie selbst die großen Gutenberg-Posts 16M haben sollen ist mir aber ein Rätsel. Sollte ja nur Text sein.) php-fpm pool-Datei, nicht funktionierender Host: ;PHP-FPM configuration for "username.domain.com" created on 2020.06.09 16:28:44 [username.domain.com] listen = /var/lib/apache2/fastcgi/1-username-username.domain.com-php-fpm.socket listen.owner = username listen.group = username listen.mode = 0660 user = username group = username pm = dynamic pm.max_children = 5 pm.start_servers = 2 pm.min_spare_servers = 1 pm.max_spare_servers = 3 pm.max_requests = 0 ;chroot = /var/customers/webs/username/ security.limit_extensions = .php env[PATH] = /usr/local/bin:/usr/bin:/bin env[TMP] = /var/customers/tmp/username/ env[TMPDIR] = /var/customers/tmp/username/ env[TEMP] = /var/customers/tmp/username/ php_admin_value[session.save_path] = /var/customers/tmp/username/ php_admin_value[upload_tmp_dir] = /var/customers/tmp/username/ php_admin_flag[allow_call_time_pass_reference] = Off php_admin_flag[allow_url_fopen] = Off php_flag[asp_tags] = Off php_admin_value[disable_classes] = php_admin_value[disable_functions] = curl_multi_exec,exec,parse_ini_file,passthru,popen,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate,show_source,system php_flag[display_errors] = On php_flag[display_startup_errors] = Off php_admin_flag[enable_dl] = Off php_value[error_reporting] = E_ALL & ~E_NOTICE php_admin_flag[expose_php] = Off php_admin_flag[file_uploads] = On php_admin_flag[cgi.force_redirect] = 1 php_admin_value[gpc_order] = "GPC" php_flag[html_errors] = Off php_admin_flag[ignore_repeated_errors] = Off php_admin_flag[ignore_repeated_source] = Off php_value[include_path] = ".:/usr/share/php/:/usr/share/php5/" php_flag[log_errors] = On php_admin_flag[log_errors] = On php_value[log_errors_max_len] = 1024 php_flag[magic_quotes_gpc] = Off php_flag[magic_quotes_runtime] = Off php_flag[magic_quotes_sybase] = Off php_value[max_execution_time] = 300 php_admin_value[max_input_time] = 1000 php_admin_value[memory_limit] = 256M php_admin_value[open_basedir] = "/var/customers/webs/username:/var/customers/tmp/username:/usr/share/php:/usr/share/php5:/tmp" php_admin_value[output_buffering] = 4096 php_admin_value[post_max_size] = 16M php_admin_value[precision] = 14 php_admin_flag[register_argc_argv] = Off php_admin_flag[report_memleaks] = On php_admin_value[sendmail_path] = "/usr/sbin/sendmail -t -i -f chrisiwien@domain.com" php_value[session.auto_start] = 0 php_value[session.cookie_domain] = php_value[session.cookie_lifetime] = 0 php_value[session.cookie_path] = / php_admin_value[session.gc_divisor] = 1000 php_admin_value[session.gc_probability] = 1 php_value[session.name] = PHPSESSID php_value[session.serialize_handler] = php php_flag[session.use_cookies] = 1 php_flag[short_open_tag] = On php_flag[suhosin.simulation] = Off php_flag[track_errors] = Off php_value[upload_max_filesize] = 32M php_admin_value[variables_order] = "GPCS" php_admin_value[opcache.restrict_api] = "/var/customers/webs/username/" php-fpm pool-Datei, funktionierender Host: ;PHP-FPM configuration for "username2.domain.com" created on 2020.06.09 16:28:44 [username2.domain.com] listen = /var/lib/apache2/fastcgi/1-username2-username2.domain.com-php-fpm.socket listen.owner = username2 listen.group = username2 listen.mode = 0660 user = username2 group = username2 pm = dynamic pm.max_children = 5 pm.start_servers = 2 pm.min_spare_servers = 1 pm.max_spare_servers = 3 pm.max_requests = 0 ;chroot = /var/customers/webs/username2/ security.limit_extensions = .php env[PATH] = /usr/local/bin:/usr/bin:/bin env[TMP] = /var/customers/tmp/username2/ env[TMPDIR] = /var/customers/tmp/username2/ env[TEMP] = /var/customers/tmp/username2/ php_admin_value[session.save_path] = /var/customers/tmp/username2/ php_admin_value[upload_tmp_dir] = /var/customers/tmp/username2/ php_admin_flag[allow_call_time_pass_reference] = Off php_admin_flag[allow_url_fopen] = On php_flag[asp_tags] = Off php_admin_value[disable_classes] = php_admin_value[disable_functions] = curl_multi_exec,exec,parse_ini_file,passthru,popen,proc_close,proc_get_status,proc_nice,proc_open,proc_terminate,shell_exec,show_source,system php_flag[display_errors] = Off php_flag[display_startup_errors] = Off php_admin_flag[enable_dl] = Off php_value[error_reporting] = E_ALL & ~E_NOTICE php_admin_flag[expose_php] = Off php_admin_flag[file_uploads] = On php_admin_flag[cgi.force_redirect] = 1 php_admin_value[gpc_order] = "GPC" php_flag[html_errors] = Off php_admin_flag[ignore_repeated_errors] = Off php_admin_flag[ignore_repeated_source] = Off php_value[include_path] = ".:/usr/share/php/:/usr/share/php5/" php_flag[log_errors] = On php_admin_flag[log_errors] = On php_value[log_errors_max_len] = 1024 php_flag[magic_quotes_gpc] = Off php_flag[magic_quotes_runtime] = Off php_flag[magic_quotes_sybase] = Off php_value[max_execution_time] = 60 php_admin_value[max_input_time] = 60 php_admin_value[memory_limit] = 256M php_admin_value[output_buffering] = 4096 php_admin_value[post_max_size] = 256M php_admin_value[precision] = 14 php_admin_flag[register_argc_argv] = Off php_admin_flag[report_memleaks] = On php_admin_value[sendmail_path] = "/usr/sbin/sendmail -t -i -f chrisiwien@domain.com" php_value[session.auto_start] = 0 php_value[session.cookie_domain] = php_value[session.cookie_lifetime] = 0 php_value[session.cookie_path] = / php_admin_value[session.gc_divisor] = 1000 php_admin_value[session.gc_probability] = 1 php_value[session.name] = PHPSESSID php_value[session.serialize_handler] = php php_flag[session.use_cookies] = 1 php_flag[short_open_tag] = On php_flag[suhosin.simulation] = Off php_flag[track_errors] = Off php_value[upload_max_filesize] = 256M php_admin_value[variables_order] = "GPCS" php_admin_value[opcache.restrict_api] = ""
  6. Hallo! Meine Server/Froxlor-Installation unter Debian 9 mit Apache 2.4 und PHP-FPM 7.3 läuft grundsätzlich sehr gut, wenn ich einen neuen Kunden einrichte, dazu eine Domain und eine Datenbank klappt bisher alles prima. Ich stehe nun bei einer neuen WordPress-Installation vor dem Problem, dass der System-Temp Ordner (var/customers/tmp/username) nur mit chmod 777 funktioniert, das ist natürlich suboptimal... bei den anderen funktionierenden Installationen hat der jeweilige Temp-Ordner die Berechtigung 750 und alles klappt. Bisher habe ich eine neue Website strikt nach dieser Abfolge angelegt: Kunde/Benutzername einrichten Datenbank einrichten Domain einrichten und dem Benutzer zuweisen Beim letzten Mal habe ich unter Zeitdruck die Schritte vertauscht, und nach Nicht-Funktionieren den Kunden und die Domain wieder gelöscht und nochmals angelegt. Scheint so dass sich Froxlor "verschluckt" hat... Woran kann das liegen dass der System-Temp Ordner nur mehr mit chmod 777 funktioniert? Wie kann ich das ändern? Die vHost-Settings und die php-fpm pool Konfiguration entsprechen den anderen Installationen. Der System-Temp Ordner ist für die Funktionalität von WordPress entscheidend, z.B. Mediaupload, Speichern von Gutenberg-Posts... Froxlor-Version ist 0.10.15-1 (DB: 202002290) Grüße aus Wien
  7. Ok! Danke für Deine Antworten! Super Hilfestellung! Zusatz: nach enablen der php7.3-fpm.conf rennen die beiden Webseiten gefühlt schneller? (Noch vor der FPM-Werteumstellung) Hat ev. doch einen Einfluss?? Die Gaudi fängt erst an, da ich auf nginx umstellen werden. Keine Panik, habe ich gestern bei einem anderen RootServer gemacht. Und ich liebe nginx bisher - die strukturierten Config-Dateien haben im Vergleich zu Apache auf alle Fälle die Nase vorn!
  8. Ah ok, danke für die Einstellungen. Werde das umstellen und weiter beobachten. I Kipfl hab übrigens die php7.3-fpm.conf nicht enabled (a2enconf). 😁
  9. Was? 7.3 war gestern doch noch neu! 😀 Hast Du eine Idee mit der Fehlermeldung? Übrigens danke für die rasche Rückmeldung. Ich weiß schon, das Thema ist etwas offtopic-froxlor, allerdings muss ich Verbesserungen wenn dann genau dort vornehmen...
  10. Ok. Ich hab mich mal danach gerichtet: https://haydenjames.io/php-fpm-tuning-using-pm-static-max-performance/ Eine Idee welche Werte ich nehmen soll? Du hast recht mit dem spawnen....wenn ich die Anzahl der php7.3-fpm Prozesse ansehe wird mir schlecht....
  11. Liebe Leute! Meine Installation: Debian 9 mit Apache/mpm_event und php7.3-fpm. Auf dem Server laufen gerade zwei Wordpress-Seiten produktiv. Aus für mich nicht ersichtlichen Gründen liefert der Aufruf der Webseiten von Zeit zu Zeit einen 503 Service Unavailable Error. Im dazu passenden vHost-error-log steht: [Tue Feb 04 13:52:52.651498 2020] [proxy:error] [pid 2510:tid 139659873113856] (13)Permission denied: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-vHost-Name-php-fpm.socket (*) failed [Tue Feb 04 13:52:52.651552 2020] [proxy_fcgi:error] [pid 2510:tid 139659873113856] [client xxx.xxx.xxx.xxx:56984] AH01079: failed to make connection to backend: httpd-UDS, referer: https://www.vHost-Domain.at/ Ein Restart von Apache und php7.3-fpm löst das Problem zeitweilig. Ich hab jetzt den LogWarn-Level auf debug hochgedreht, vielleicht ist da mehr ersichtlich. Der Error deutet auf ein Rechteproblem hin, das kann ich allerdings nicht nachvollziehen. Alle Sockets in dem Directory haben die korrekten User-Rechte lr. froxlor-Einstellungen. Die PHP-FPM Einstellung lauten: pm = static pm.max_children = 100 pm.max_requests = 1000 Fragen: Ist das Socket-Verzeichnis /var/lib/apache2/fastcgi/ bei der Verwendung von php-fpm überhaupt korrekt? In meinen Logwatch-Meldung ist gelegentlich zu sehen, dass versucht wurde meinen FPM-Proxy zu missbrauchen, könnten daher die Rechte-Fehler kommen? Wie kann ich den Proxy-Missbrauch verhindern? PHP 7.3 FPM dürfte noch ein paar Bugs haben. Könnte ev. ein Downgrade auf PHP 7.2 oder 7.1 helfen? Soll ich mal auf PHP-FPM pfeifen und auf mod_php zurückstellen? Ev. von mpm_event auf mpm_worker umstellen? Wo und wie kann ich da weiter nachforschen? Hilfe!
  12. I've struggled with this issue myself now for a couple of days. My goal was to activate Apache + mpm_event + php7.3-fpm. For now, i playing around with a WordPress installation and it runs fast as hell (considering WordPress with OPCache and RedisCache-Server, without any WordPress caching plugin). TTFB is around 170ms, I am satisfied. Finally I solved it ? (thankfully without fiddling in conf-Files) by disabling the Apache-conf for php7.3-fpm (in my case php7.3): a2disconf php7.3-fpm (removes /etc/apache2/conf-enabled/php7.3-fpm.conf) I searched for the string "php7.3-fpm.sock" in files like this: grep -iRl [text-string-to-search] [search-in-this-folder] grep -iRl 'php7.3-fpm.sock' /etc/ I found out this string is in /etc/apache2/conf-enabled/php7.3-fpm.conf. The file (or a symlink) php7.3-fpm.config MUST NOT be in the directory /etc/apache2/conf-enabled!! Other steps I made to get Apache + mpm_event + php7.3-fpm to work: a2dismod php7.3: the Apache php-module is not needed and anyway incompatible with mpm_event a2dismod php7.3 a2dismod mpm_prefork a2enmod mpm_event service apache2 restart Now check if mpm_event is running: apachectl -V The output should contain "Server MPM: event". Also check via phpinfo() if under "Server API" the value "FPM/FastCGI" is written. Other things I found out, it is not directly related to php-fpm, but I've struggled with issues at the same time: /var/customers/tmp/froxlor.panel/ has do be owned by froxlorlocal: chown froxlorlocal:froxlorlocal /var/customers/tmp/froxlor.panel /var/www/php-fpm/froxlor.panel/ has do be owned by froxlorlocal: chown froxlorlocal:froxlorlocal /var/www/php-fpm/froxlor.panel Check your Webserver-Settings: Settings -> Webserver-Settings: The username webserver and the groupname webserver has to be "www-data". Hope this helps someone. If I wrote anything wrong, please just leave a reply, i'm also grateful for other hints on this topic.
×
×
  • Create New...