Jump to content
Froxlor Forum
  • 2
irisdina

[Howto] Debian 9 | Ubuntu Cosmic + PHP 7.3 / MariaDB / NGINX / PHP-FPM / SSL

Question

Warning, this is not an official guide!!!

1.

sudo mv /etc/apt/source.list /etc/apt/source.list.bak

1a. Create new Source.list

sudo nano /etc/apt/source.list

1b.  insert (for Debian Stretch)

Spoiler

###### Debian Main Repos
deb http://ftp.de.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.de.debian.org/debian/ stable main contrib non-free
deb http://ftp.de.debian.org/debian/ stable-updates main contrib non-free
deb-src http://ftp.de.debian.org/debian/ stable-updates main contrib non-free
deb http://security.debian.org/ stable/updates main
deb-src http://security.debian.org/ stable/updates main
deb http://ftp.debian.org/debian stretch-backports main
deb-src http://ftp.debian.org/debian stretch-backports main

###### Extra Repos

###Debian Multimedia
deb [arch=i386,amd64] http://www.deb-multimedia.org stretch main non-free

###nginx
deb [arch=amd64,i386] http://nginx.org/packages/debian/ stretch nginx
deb-src [arch=amd64,i386] http://nginx.org/packages/debian/ stretch nginx

###php7.X | curl https://packages.sury.org/php/apt.gpg | apt-key add -
deb https://packages.sury.org/php/ $(lsb_release -sc) main

### MariaDB 10.3
### http://downloads.mariadb.org/mariadb/repositories/
deb [arch=amd64,i386,ppc64el] http://ftp.hosteurope.de/mirror/mariadb.org/repo/10.3/debian stretch main
deb-src http://ftp.hosteurope.de/mirror/mariadb.org/repo/10.3/debian stretch main

1.2B (for Ubuntu Cosmic)

Spoiler

###### Ubuntu Main Repos
deb http://de.archive.ubuntu.com/ubuntu/ cosmic main restricted universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ cosmic main restricted universe multiverse

###### Ubuntu Update Repos
deb http://de.archive.ubuntu.com/ubuntu/ cosmic-security main restricted universe multiverse
deb http://de.archive.ubuntu.com/ubuntu/ cosmic-updates main restricted universe multiverse
deb http://de.archive.ubuntu.com/ubuntu/ cosmic-proposed main restricted universe multiverse
deb http://de.archive.ubuntu.com/ubuntu/ cosmic-backports main restricted universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ cosmic-security main restricted universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ cosmic-updates main restricted universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ cosmic-proposed main restricted universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ cosmic-backports main restricted universe multiverse

###### MariaDB 10.3 repository list - created 2019-01-25 21:01 UTC
###### http://downloads.mariadb.org/mariadb/repositories/
deb [arch=amd64] http://ftp.hosteurope.de/mirror/mariadb.org/repo/10.3/ubuntu cosmic main
deb-src http://ftp.hosteurope.de/mirror/mariadb.org/repo/10.3/ubuntu cosmic main

###### Nginx Mainline
###### https://launchpad.net/~nginx/+archive/ubuntu/development
deb http://ppa.launchpad.net/nginx/development/ubuntu cosmic main 
deb-src http://ppa.launchpad.net/nginx/development/ubuntu cosmic main

###### PHP7.X
###### https://launchpad.net/~ondrej/+archive/ubuntu/php
deb http://ppa.launchpad.net/ondrej/php/ubuntu cosmic main 
deb-src http://ppa.launchpad.net/ondrej/php/ubuntu cosmic main
 

 

1c

sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove

1d

sudo apt install curl wget apt-transport-https dirmngr git software-properties-common

Now you can start setting up your server

2. MariaDB install
Warning use sudo command für this install!

sudo apt install mariadb-server mariadb-client

2a. MariaDB 10.3 Workround (Optional)

Spoiler

when you MariaDB install with not sudo command, have you Problems with your Froxlor install. 
you can use this workround: (Thanks J-BBB for this Note :) )


mysql -u root
MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root';
MariaDB [(none)]> update mysql.user set plugin='' where user='root';
MariaDB [(none)]> flush privileges;

 

3. nginx install

sudo apt install nginx

3a

mkdir /etc/nginx/sites-available
mkdir /etc/nginx/sites-enabled

3b. nano /etc/nginx/nginx.conf

Spoiler

user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
    worker_connections 768;
    multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
        #include /etc/nginx/naxsi.rules;
        #include /etc/nginx/naxsi-wp.rules;
    default_type application/octet-stream;

    ##
    # SSL Settings
    ##

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip_vary on;
    gzip_proxied any;

    gzip_comp_level 6;
    gzip_buffers 16 8k;
    gzip_http_version 1.1;
    gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
}


#mail {
#    # See sample authentication script at:
#    # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript

#    # auth_http localhost/auth.php;
#    # pop3_capabilities "TOP" "USER";
#    # imap_capabilities "IMAP4rev1" "UIDPLUS";

#    server {
#        listen     localhost:110;
#        protocol   pop3;
#        proxy      on;
#    }

#    server {
#        listen     localhost:143;
#        protocol   imap;
#        proxy      on;
#    }
#}

4. PHP install

sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip

4a

sudo service nginx restart
sudo service php7.3-fpm restart

Froxlor install
There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)

Stable Version

1

cd /var/www/html/

1a

sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz

or

Git Version (Beta Version)

sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/
sudo apt install composer 
su - www-data -s /bin/bash
cd /var/www/html/Froxlor/

1a(2). Composer install in your Froxlor directory

composer install --no-dev
Spoiler

composer install --no-dev
Loading composer repositories with package information
Updating dependencies
Package operations: 5 installs, 0 updates, 0 removals
  - Installing psr/log (1.1.0): Loading from cache
  - Installing monolog/monolog (1.24.0): Downloading (100%)         
  - Installing mso/idna-convert (v1.1.0): Downloading (100%)         
  - Installing phpmailer/phpmailer (v6.0.7): Downloading (100%)         
  - Installing robthree/twofactorauth (1.6.5): Downloading (100%)         
Writing lock file
Generating autoload files
> if [ -f ./vendor/bin/phpcs ]; then "vendor/bin/phpcs" --config-set installed_paths vendor/phpcompatibility/php-compatibility ; fi
 

1b. 

sudo chown -R www-data:www-data Froxlor/

Set up Froxlor

2. Open Your Browser

2a.

http://your IP or Hostname/Froxlor

262874432_froxlor1.JPG.de1b8879ed2a836192848f408702e622.JPG

 

1c4092bcfa.jpg.d00787c866a2075facd1e5a07a19311e.jpg

Install Froxlor finish

 3d. Move userdata (Optional

sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/

2c. 

sudo rm /etc/nginx/site-enable/default

don't restart nginx!

Froxlor Settings

1. Cronjob

sudo nano /etc/cron.d/froxlor

insert 

#
# Set PATH, otherwise restart-scripts won't find start-stop-daemon
#
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
#
# Regular cron jobs for the froxlor package
#
# Please check that all following paths are correct
#
*/5 * * * *    root    /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php
sudo chmod 0640 "/etc/cron.d/froxlor"
sudo chown root:0 "/etc/cron.d/froxlor"
sudo service cron restart

2. Nginx PHP Backend
Settings > Webserver settings > Nginx PHP backend

from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock

3. 

sudo mkdir -p /var/customers/webs/
sudo mkdir -p /var/customers/logs/
sudo mkdir -p /var/customers/tmp
sudo chmod 1777 /var/customers/tmp
sudo service nginx restart

4IPs and Ports > Add IP/Port

5a0abb2913e96_2port80.jpg.5de52e0487f1e64183bc623a6be546c1.thumb.jpg.3a05a38a43a4172cd4c1d7d01d66fd3c.jpg

2a(1), SSL Port

ssl.jpg.dfd261bca0c36bd2082ef209dae1899e.thumb.jpg.9513d8374c420e3331502aed2dd45b45.jpg

5a0abbfa454e0_sslport.thumb.JPG.984db8ea483048659d89b5b92884d19b.JPG.51efe8bd99067b361f56af2986d3098e.JPG

e0da66b243.thumb.jpg.956b94b1262115a358704d3a595cf209.jpg

Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually

sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug

Optional

PHP-FPM activate

1. User/Group add

sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal

2. libnss-extrausers install 

sudo apt install nscd libnss-extrausers
sudo mkdir -p /var/lib/extrausers
sudo touch /var/lib/extrausers/{passwd,group,shadow}
sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak"
sudo nano /etc/nsswitch.conf
# Make sure that `passwd`, `group` and `shadow` have mysql in their lines
# You should place mysql at the end, so that it is queried after the other mechanisams
#
passwd:         compat extrausers
group:          compat extrausers
shadow:         compat extrausers

hosts:       files dns
networks:    files dns

services:    db files
protocols:   db files
rpc:         db files
ethers:      db files
netmasks:    files
netgroup:    files
bootparams:  files

automount:   files
aliases:     files
sudo service nscd restart
sudo nscd --invalidate=group

2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

5a0ab9076514b_mysqllibnss.JPG.12412b89cfb570aacbb9ba20cc018632.JPG.20574ef70c9e0d8671e6f7e40cf90a32.JPG

3. Settings > PHP-FPM > Activated:
Change from NO to YES

3a. PHP-FPM versions
Change > php-fpm restart command:

service php7.3-fpm restart

and

Configuration directory of php-fpm: > to 

/etc/php/7.3/fpm/pool.d/

3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

5a0ab9ad113be_froxlorfpm.JPG.f9851e4e1b4a69e51c530866f342a3be.JPG.39fa67062ec1055f32555c0f0e298f71.JPG

3c

sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor

SSL / Let's Encrypt activate

1.

sudo apt install certbot

1a

sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl

1bCreate SSL File

sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt

1c

sudo nano /etc/nginx/acme.conf

insert

location /.well-known/acme-challenge {
    alias /var/www/html/Froxlor/.well-known/acme-challenge;

    location ~ /.well-known/acme-challenge/(.*) {
        default_type text/plain;
    }
}

 

2. Open your  Froxlor Panel
Settings> SSL > Activated:
Change from NO to YES

2a. Settings > SSL > Settings
Change your path from your certificate / Keyfile

Path to the SSL certificate
insert

/etc/nginx/ssl/nginx.crt

Path to the SSL Keyfile
insert

/etc/nginx/ssl/nginx.key

2b. Settings > SSL > Settings
Activate > Enable Let's Encrypt

f1f454e31b.jpg.e41728d94b6001edbc66ee089192c8be.jpg

Change Path to the acme.conf snippet to > 

/etc/nginx/acme.conf

2c. Activate on Settings > Froxlor VirtualHost settings
- Enable Let's Encrypt for the froxlor vhost
- Enable SSL-redirect for the froxlor vhost
- HTTP Strict Transport Security (HSTS)
- Include HSTS for any subdomain

8bc097eda1.thumb.jpg.56a411c412ad233b0fd15f95ad159606.jpg

mysql libnss.JPG

froxlor fpm.JPG

2port 80.jpg

ssl.jpg

ssl port.JPG

2d. Activated HTTP2 Support on > Settings > Nginx

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 1

@irisdina: Danke für deine TOP Anleitung. Ich habe das Howto unter Ubuntu 17.10 (Artful) installiert.

Ich habe noch folgende Anmerkungen:

2a. MariaDB 10.1 Workround (Optional)  sollte nicht nur Debian, sondern auch Ubuntu 17.10 stehen, da ich dies auch brauchte.

PHP-FPM activate

2. libnss-extrausers install (hier fehlt apt)

sudo install nscd libnss-extrausers

Nach der Konfiguration von PHP-FPM nach der Anleitung kam immer der Gateway Fehler 502.

Das konnte ich mit folgendem Befehl lösen:

usermod -a -G www-data froxlorlocal

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, J-B said:

Was spricht denn gegen die MariaDB von Debian Stretch?

seitens froxlor selbst nix :)

Share this post


Link to post
Share on other sites
  • 0
12 hours ago, J-B said:

Was spricht denn gegen die MariaDB von Debian Stretch?

In den Alten Versionen gab es ein Problem/Bug/Feature, dass man kein PW ändern konnte bzw. bei dem Install setzen konnte und später erst nervig ein PW einstellen konnte.

 

2 hours ago, d00p said:

seitens froxlor selbst nix :)

will man doch hoffen, das Froxlor nichts dagegen hat :P

Share this post


Link to post
Share on other sites
  • 0

Wenn man den Standard MariaDB Server benutzen will von Debian 9, muss man das unix_socket Plugin deaktivieren.

 

Wie das geht wird hier beschrieben.

Share this post


Link to post
Share on other sites
  • 0

Du benutzt in deiner Anleitung ja PHP-FPM.

Dies braucht aber doch (laut alter Anleitung) das Paket "libnss-mysql", welches es unter Debian 9 Stretch nicht mehr gibt.

Wird dieses nicht mehr benötigt, oder warum wird es hier nicht erwähnt? 

Share this post


Link to post
Share on other sites
  • 0
21 hours ago, Infected said:

Dies braucht aber doch (laut alter Anleitung) das Paket "libnss-mysql", welches es unter Debian 9 Stretch nicht mehr gibt.

Wird dieses nicht mehr benötigt, oder warum wird es hier nicht erwähnt? 

Das ist seit debian 8 nicht mehr bei debian dabei. Nutze am besten für debian 8 und 9 libnss-extrausers, dafür auch in froxlor den support aktivieren in den einstellungen

Share this post


Link to post
Share on other sites
  • 0

Guten Tag,

 

Ich habe es nach der Anleitung oben durch geführt.

Bis zum letzten schritt bis auf die Sache mit acme.con das wollte ich erst danach machen.

Doch eine neue vhost datei hat mir Froxlor nicht angelegt.

oder dauert das einen Moment bis das durch läuft?

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, htmljucky said:

oder dauert das einen Moment bis das durch läuft?

Standardmäßig läuft der cronjob alle 5 Minuten

Share this post


Link to post
Share on other sites
  • 0

Okay und wie muss ich das mit lets crypt einrichten?
Finde dazu leider auch nichts

 


Edit:

Habe nun gewartet aber keine Änderung das er einen nginx Eintrag selbst schreibt.

Share this post


Link to post
Share on other sites
  • 0

hä? Wie wie muss ich das einrichten? Du aktivierst Let's Encrypt in den Einstellungen (global), du musst natürlich die acme.conf einrichten (konfiguration -> webserver) damit der globale Alias existiert und Ende. das wars. Entsprechend musst du natürlich auch einer SSL-enabled domain noch sagen, sie soll let's encrypt nutzen (domain -> bearbeiten)

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, lino16 said:

@irisdina: Danke für deine TOP Anleitung. Ich habe das Howto unter Ubuntu 17.10 (Artful) installiert.

Ich habe noch folgende Anmerkungen:

2a. MariaDB 10.1 Workround (Optional)  sollte nicht nur Debian, sondern auch Ubuntu 17.10 stehen, da ich dies auch brauchte.

PHP-FPM activate

2. libnss-extrausers install (hier fehlt apt)


sudo install nscd libnss-extrausers

Nach der Konfiguration von PHP-FPM nach der Anleitung kam immer der Gateway Fehler 502.

Das konnte ich mit folgendem Befehl lösen:

usermod -a -G www-data froxlorlocal

Wenn du es zu 100% nach dem Howto gemacht hast, sollte dies nicht auftreten mit MariaDB, da bei der Ubu Anleitung die 10.2 drin ist.
Das mit dem error 502 passiert eigentlich nur, wenn man vergisst den Froxlor ordner die rechte vorher von www-data zu geben, dann passiert dies.

Habe die zwei anmerkungen ins Howto aufgenommen, danke.

Share this post


Link to post
Share on other sites
  • 0

Danke für das Klasse Tutorial !!!

Bei mir hat alles geklappt.

Eine Anmerkung, ich musste nach der Installation noch folgenden Eintrag bei den Froxlor EInstellungen machen, sonst gingen meine vHost Container nicht (siehe Bild).

Ich habe auch den 502 Fehler bekommen, das lag bei mir daran das im Verzeichnis

/etc/php/7.1/fpm/pool.d/

keine Datei angelegt war, deshalb kam mein php-fpm nicht hoch. Ich habe dann die Konfig so geändert das der php-fpm kurz starten konnte, dann es wieder umgestellt wie im Tutorial und dann erst konnte Froxlor die Datei anlegen ( also php Datei für den Froxlor vHost ) und dann kam der php-fpm wieder hoch.

Bei Ubuntu 17.10 musste ich nginx und php-fpm noch in den Autostart reinnehmen, die kamen nach Installation nicht automatisch hoch.

 

Und bei

2a(1), SSL Port

wäre noch zu sagen, dass man vorher in den Einstellungen "SSL Aktivieren" anklicken muss, sonst kann man den SSL Port nicht anlegen.

 

Ansonsten geiles Tutorial, bitte in die aktuelle Froxlor Installation mit aufnehmen. Die unterscheidet sich ja doch etwas von der im Backend.

vhost.PNG

Share this post


Link to post
Share on other sites
  • 0

One more thing.

I had the Problem that I had to disable the mysql Strict Mode.

Otherwise I had the error

SQLSTATE[HY000]: General error: 1364 Field 'mail_virtual' doesn't have a default value

Everytime I wanted to delete a Domain.

I did it with the following Instruction:

https://serverpilot.io/community/articles/how-to-disable-strict-mode-in-mysql-5-7.html

After that I created the table with:

ysql> CREATE TABLE `mail_virtual` (
    ->   `id` int(11) NOT NULL auto_increment,
    ->   `email` varchar(255) NOT NULL default '',
    ->   `email_full` varchar(255) NOT NULL default '',
    ->   `destination` text NOT NULL default '',
    ->   `domainid` int(11) NOT NULL default '0',
    ->   `customerid` int(11) NOT NULL default '0',
    ->   `popaccountid` int(11) NOT NULL default '0',
    ->   `iscatchall` tinyint(1) unsigned NOT NULL default '0',
    ->   PRIMARY KEY  (`id`),
    ->   KEY `email` (`email`)
    -> ) ENGINE=MyISAM CHARSET=utf8 COLLATE=utf8_general_ci;

 

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, j4mb4l4j4 said:

I had to disable the mysql Strict Mode

Try current git Version

Share this post


Link to post
Share on other sites
  • 0

Hi Danke dir für die Antwort,

die habe ich allerdings am Sonntag benutzt bei der Installation.
Und nach der Installation war die TABLE nicht da.

Hattest du jüngst ein Update gemacht ?

Nutze Ubuntu 17.10 und die neueste mysql-server dazu.

 

Ich habe auch nach der Installation das Problem mit Letsencrypt, das ich nicht auf die Datei ( zum testen wie du in vielen Beiträgen hier empfohlen hast ) ( oder neuen Forumsbeitrag dazu aufmachen ? )

Suche mich da seit 14 Stunden wund :-) :

/var/www/cust01.DOMAIN.com/.well-known/acme-challenge/test.html

Zugreifen kann, damit Letsencrypt geht.

Wenn ich darauf zugreife schreibt der nginx laut error.log immer:

2017/12/12 15:21:34 [error] 12563#12563: *27 open() "/var/www.cust01.DOMAIN.com/.well-known/acme-challenge/test.html" failed (2: No such file or directory), client: 31.16.227.7, server: cust01.DOMAIN.com, request: "GET /.well-known/acme-challenge/test.html HTTP/2.0", host: "cust01.DOMAIN.com"

Weißt du woran das liegt das es so komisch umgeschrieben wird , also der "/" statt des "." geschrieben wird ?

Meine /etc/nginx/acme.conf ist gemäß Tutorial:

location /.well-known/acme-challenge {
        alias /var/www/cust01.DOMAIN.com/.well-known/acme-challenge;

        location ~ /.well-known/acme-challenge/(.*) {
                default_type text/plain;
        }
}

Wenn ich test.html in das Verzeichnis

/var/www/cust01.DOMAIN.com/.well-known/test.html

lege, funktioniert der Aufruf der Datei.

Das ist das einzige was mich nach der Installationsanleitung grade noch am Betrieb hindert.

Die SSL Zerts sind laut Doku von oben auch nur bei folgendem hinterlegt ( siehe Bild ).
Mit IP/Ports kam aber trotzdem der Umschreibefehler wenn ich das Zertifikat dort angegeben habe.

PS: Vhost von 80 und 443 sind:

        listen    93.104.212.200:80 default_server;
        # Froxlor default vhost
        server_name    cust01.DOMAIN.com;
        access_log      /var/log/nginx/access.log;
        include /etc/nginx/acme.conf;
# temp. disabled ssl-redirect due to Let's Encrypt certificate generation.
        root     /var/www/cust01.DOMAIN.com/;
        index    index.php index.html index.htm;

        location / {
        }
return 301 https://$host$request_uri;
        location ~ \.php {
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                include /etc/nginx/fastcgi_params;
                fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                fastcgi_param PATH_INFO $fastcgi_path_info;
                try_files $fastcgi_script_name =404;
                fastcgi_pass unix:/var/run/froxlor.panel-cust01.DOMAIN.com-php-fpm.socket;
                fastcgi_index index.php;
        }
}
# Created 12.12.2017 15:15
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

server {
        listen    93.104.212.200:443 default_server ssl http2;
        # Froxlor default vhost
        server_name    cust01.DOMAIN.com;
        access_log      /var/log/nginx/access.log;
        include /etc/nginx/acme.conf;
        root     /var/www/cust01.DOMAIN.com/;
        index    index.php index.html index.htm;

        location / {
        }
        ssl_protocols TLSv1 TLSv1.2;
        ssl_ciphers ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128;
        ssl_ecdh_curve secp384r1;
        ssl_prefer_server_ciphers on;
        ssl_certificate /etc/letsencrypt/live/cust01.DOMAIN.com/fullchain.pem;
        ssl_certificate_key /etc/letsencrypt/live/cust01.DOMAIN.com/privkey.pem;
        location ~ \.php {
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                include /etc/nginx/fastcgi_params;
                fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                fastcgi_param PATH_INFO $fastcgi_path_info;
                try_files $fastcgi_script_name =404;
                fastcgi_param HTTPS on;
                fastcgi_pass unix:/var/run/froxlor.panel-cust01.DOMAIN.com-php-fpm.socket;
                fastcgi_index index.php;
        }
}


 

ssl-cert.PNG

ssl-cert-2.PNG

Share this post


Link to post
Share on other sites
  • 0

UPDATE:
Hab den Fehler gefunden, das Verzeichnis

/var/www/cust01.DOMAIN.com/.well-known/acme-challenge

Hatte die Rechte

drwxr-xr-x  2 froxlorlocal froxlorlocal 4096 Dec 12 16:08 acme-challenge

Ich habe dann die Rechte

drwxr-xr-x  2 www-data www-data 4096 Dec 12 16:08 acme-challenge

gesetzt und konnte die Datei aufrufen.

Jetzt hat Froxlor es wieder zu

drwxr-xr-x  2 froxlorlocal froxlorlocal 4096 Dec 12 16:08 acme-challenge

gemacht, aber ich kann es jetzt ohne Probleme aufrufen.

Jetzt klappts auch wieder mit dem nachbarn.

 

Einziges letztes Problem ist, das Letsencrypt sich gerade nicht automatisch Cronjobed. Muss es noch manuell anstoßen, vllt liegts daran das ich das Zertifikat nicht bei IP/Ports habe

 

UPDATE 2:

Der Cron war nicht eingetragen, vieleicht weil Letsencrypt nicht funktioniert hatte zuvor.
Jetzt funktioniert es. Das mit dem Verzeichnisrecht ist mir allerdings immernoch ein Rätsel.

Share this post


Link to post
Share on other sites
  • 0

@irisdina

DANKE ! perfektes Howto - sieht man selten :) 
Habe alles mal mit Debian 9.3, PHP 7.2.1 aufgesetzt - bis jetzt läuft es fast ohne den kleinsten Fehler, im Grund System - nur wenn ich den vhost frox lösche, ladet das Admin Panel nicht mehr mit not found - wo könnte ich da was falsch gesetzt haben ?
Ich glaube ich habe irgendwas übersehen - nur der Wald hat irgendwie zuviel Bäume ;) 

kleine Frage - bring die "PHP-FPM activate" noch merkliche Vorteile oder wäre sonst irgendwie vorteilhaft ?

@d00p

Ich bin mit Froxlor ganz neu, komme von iMSCP - maybe eine Froxlor-Newbie Frage - gibt es für Pphmyadmin, FTP, WebMail ein paar HowTo bzw. Vorschläge, was mit Froxlor am besten funktioniert 

Bzw. muss noch irgendwas nach dem Grund-Setup hinzugefügt werden, was zu empfehlen wäre 

Share this post


Link to post
Share on other sites
  • 0
9 minutes ago, MaT said:

nur wenn ich den vhost frox lösche, ladet das Admin Panel nicht mehr mit not found - wo könnte ich da was falsch gesetzt haben ?

manuell was löschen ist schonmal ein falscher ansatz

10 minutes ago, MaT said:

kleine Frage - bring die "PHP-FPM activate" noch merkliche Vorteile oder wäre sonst irgendwie vorteilhaft ?

die Frage verstehe ich nicht...du als admin entscheidest doch was du nutzen möchtest. fcgid/php-fpm hat den simplen aber schönen vorteil, dass die php prozesse unter dem kunden-benutzer ausgeführt werden (security++)

11 minutes ago, MaT said:

Ich bin mit Froxlor ganz neu, komme von iMSCP - maybe eine Froxlor-Newbie Frage - gibt es für Pphmyadmin, FTP, WebMail ein paar HowTo bzw. Vorschläge, was mit Froxlor am besten funktioniert 

phpmyadmin würd ich via archiv entweder unterhalb eines kunden (dich selbst, wenn du dich da auch angelegt hast) oder in den froxlor ordner installieren. Wenn du das auch per apt und paket machen willst UND fcgid/php-fpm nutzt kommst du sonst um einen manuellen vhost nicht herum.

Bei "FTP" weiss ich nicht was du meinst, es sei denn du meinst WebFTP - davon rate ich so oder so in jedem fall ab...

Webmail -> siehe phpmyadmin; bei roundcube kannst du mit dieser config (https://github.com/Froxlor/Froxlor/tree/extras/roundcube_plugins/password) das "passwort ändern" in roundcube realisieren

Offizielle Howtos oder so gibt es dazu nicht

Share this post


Link to post
Share on other sites
  • 0

@d00p

"vhost frox löschen", meine ich in Bezug auf das HowTO oben - da ist das ja ein Schritt im Ablauf - ich habe den vhost jetzt wieder erstellt derzeit, um das Froxlor Panel zu haben 

Share this post


Link to post
Share on other sites
  • 0
On 8.1.2018 at 10:48 AM, MaT said:

@d00p

"vhost frox löschen", meine ich in Bezug auf das HowTO oben - da ist das ja ein Schritt im Ablauf - ich habe den vhost jetzt wieder erstellt derzeit, um das Froxlor Panel zu haben 

Der Manuelle Frox vhost ist nur dazu da, weil ich froxlor ausserhalb des html verz. betreibe, sonst kann nginx nicht darauf zugreifen. Normal ist es so, wenn du Froxlor installiert hast und danach den angelegten Vhost wieder löscht, weil Froxlor selbst einen Vhost ja anlegt, sobald der Cron neu startet.

Schau mal in den ordner von nginx /etc/nginx/site-enable/ ob da Froxlor datein vorhanden sind, wenn nicht checke mal deinen cronjob.

Share this post


Link to post
Share on other sites
  • 0
Am 17.11.2017 um 21:21 schrieb lino16:

 

Nach der Konfiguration von PHP-FPM nach der Anleitung kam immer der Gateway Fehler 502.

Das konnte ich mit folgendem Befehl lösen:

usermod -a -G www-data froxlorlocal

Guten Abend zusammen,

ich freue mich eine so gute Anleitung gefunden zu haben. Ich bin noch recht neu auf dem Gebiet Froxlor, komme aus der ISPConfig Ecke. Allgemein bin ich noch ein Rookie in Sachen Ubuntu/Debian. 

Leider bin ich auch auf den 502 Gateway Fehler gestoßen und leider hilft auch usermod -a -G www-data froxlorlocal nicht. 

Vielleicht habt Ihr eine Idee woran es liegen könnte. 

Vielen Dank für Eure Hilfe.

MFG Johannes

Hier der Auszug der Fehlermeldung:

 php7.1-fpm.service - The PHP 7.1 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.1-fpm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2018-02-07 19:40:02 CET; 40min ago
     Docs: man:php-fpm7.1(8)
  Process: 941 ExecStart=/usr/sbin/php-fpm7.1 --nodaemonize --fpm-config /etc/php/7.1/fpm/php-fpm.conf (code=exited, status=
 Main PID: 941 (code=exited, status=78)

Feb 07 19:40:02 v22018024008360949 systemd[1]: Starting The PHP 7.1 FastCGI Process Manager...
Feb 07 19:40:02 v22018024008360949 php-fpm7.1[941]: [07-Feb-2018 19:40:02] WARNING: Nothing matches the include pattern '/et
Feb 07 19:40:02 v22018024008360949 php-fpm7.1[941]: [07-Feb-2018 19:40:02] ERROR: No pool defined. at least one pool section
Feb 07 19:40:02 v22018024008360949 php-fpm7.1[941]: [07-Feb-2018 19:40:02] ERROR: failed to post process the configuration
Feb 07 19:40:02 v22018024008360949 php-fpm7.1[941]: [07-Feb-2018 19:40:02] ERROR: FPM initialization failed
Feb 07 19:40:02 v22018024008360949 systemd[1]: php7.1-fpm.service: Main process exited, code=exited, status=78/n/a
Feb 07 19:40:02 v22018024008360949 systemd[1]: Failed to start The PHP 7.1 FastCGI Process Manager.
Feb 07 19:40:02 v22018024008360949 systemd[1]: php7.1-fpm.service: Unit entered failed state.
Feb 07 19:40:02 v22018024008360949 systemd[1]: php7.1-fpm.service: Failed with result 'exit-code'.

 

Share this post


Link to post
Share on other sites
  • 0

Dein Pfad zu den fpm Pool Configs ist nicht korrekt, prüfe deine fpm Einstellungen

Share this post


Link to post
Share on other sites
  • 0
vor 11 Stunden schrieb d00p:

Dein Pfad zu den fpm Pool Configs ist nicht korrekt, prüfe deine fpm Einstellungen

Guten Morgen,

vielen Dank für Deine Antwort. Leider stehe ich gerade total auf dem Schlauch :(. In dem Verzeichnis 

/etc/php/7.1/fpm/pool.d#

liegen keine .conf-Dateien? lediglich in 

/etc/php/7.0/fpm/pool.d#

liegt eine .conf Datei.

Vielen Dank.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Michael Groß
      Hallo,
      nachdem ich meinen Froxlor-Server neu aufgesetzt habe, habe ich nun ein anderes komisches Problem.
      Ich habe die Konfigurationsschritte vollständig durchgeführt - sicherheitshalber auch zuerst "automatisch" durchführen lassen und danach noch einmal verifiziert.
      Lege ich nun einen Kunden an (http://test.computer-stube.com), verweist dies auf den Root des Servers.
      Schaue ich in die vHost-Datei, steht dort folgendes:
      # 29_froxlor_normal_vhost_test.computer-stube.com.conf # Created 07.02.2020 16:55 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:80> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> # 29_froxlor_ssl_vhost_test.computer-stube.com.conf # Created 07.02.2020 17:26 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 (SSL) - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:443> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder off SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/certs/apache.crt SSLCertificateKeyFile /etc/ssl/private/apache.key <IfModule mod_headers.c> Header always set Strict-Transport-Security "max-age=0" </IfModule> DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> Also an sich ist die richtige Konfiguration hinterlegt.
      Im Cron ist folgendes konfiguriert:

      # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null 5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null 0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null 10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --backup 1> /dev/null Auch das manuelle Ausführen mittels "
      php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force bringt bei mir leider keinen Erfolg.
      Die Ausgabe vom debug ist wie folgt:
      root@lx001:/etc/apache2/sites-enabled# php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Requesting/renewing Let's Encrypt certificates [information] No new certificates or certificates due for renewal found [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:80 [notice] 178.63.105.174:80 :: namevirtualhost-statement no longer needed for apache-2.4 [debug] 178.63.105.174:80 :: inserted vhostcontainer [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:443 [debug] 178.63.105.174:443 :: inserted vhostcontainer [information] apache::createVirtualHosts: creating vhost container for domain 3, customer test [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/ [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi [notice] Creating passwd file [notice] Writing 1 entries to passwd file [notice] Succesfully wrote passwd file [notice] Creating group file [notice] Writing 1 entries to group file [notice] Succesfully wrote group file [notice] Creating shadow file [notice] Writing 1 entries to shadow file [notice] Succesfully wrote shadow file [notice] Checking system's last guid  
      Ich fühle mich gerade echt dämlich, kann ja eigentlich nicht so schwer sein, da es eigentlich ja alles nur "Copy+Paste" ist
      Das Endverzeichnis wurde jedoch korrekt angelegt:
      root@lx001:/var/customers/webs# ls test root@lx001:/var/customers/webs# cd test root@lx001:/var/customers/webs/test# ls index.html webalizer Ich habe zusätzlich zur "Standardkonfiguration" noch libnss-extrausers und FCGID  eingerichtet, da ich ältere PHP Versionen benötige.
      Grüße
      Michael
    • By j4mb4l4j4
      Hallo, ich habe eine Frage zum idle-timeout bei PHP-FPM.
      Ich habe gem. Froxlor howto-debian-9-ubuntu-cosmic-php-73  die Installation vorgenommen mit PHP-FPM mit Apache das FPM Basic.
      Wollte mal mit idle-timout in den Settings das Timeout hochschhrauben was ich auch getan habe (siehe Screen).
       
      Bei meinem alten Server wurde mir in den Apache Configs diese Option geschrieben (siehe Screen), das fehlt aber in den Configs beim neuen Server (siehe Screen).
      Wird das woanders hingeschrieben ?
      Überlege nur grade wie ich verifiziere, dass das was ich eingestellt habe auch so übernommen wurde oder ob mir noch ein Setting oder Modul fehlt.



    • By Pro-Webs
      Hallo,
      ich bin gerade dabei einen Shopware Shop v.5 unter nginx mit froxlor einzurichten.
      Das ist jedoch relativ problematisch.
      Aktuell habe ich im Froxlor folgende vHost Einstellung zur Domain:
      location @php { fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location / { index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } location ~ \.php$ { try_files $uri =404; include /etc/nginx/fastcgi_params; fastcgi_pass 127.0.0.1:9000; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param HTTPS $fastcgi_https; fastcgi_param HTTP_AUTHORIZATION $http_authorization; } Diese Einstellung führt zu einem 500 error.
      Meine 35_froxlor_ssl_vhost_studio-ausruestung.de.conf sieht damit leider wie folgt aus:
      # 35_froxlor_ssl_vhost_studio-ausruestung.de.conf # Created 02.01.2020 14:30 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 91.250.82.51:443 ssl; server_name studio-ausruestung.de www.studio-ausruestung.de xn--studio-ausrstung-tzb.de *.xn--studio-ausrstung-tzb.de studioausruestung.de *.studioausruestung.de priolite-shop.com www.priolite-shop.com sirui-shop.de www.sirui-shop.de shooting-gutschein.de *.shooting-gutschein.de shooting-gutscheine.de *.shooting-gutscheine.de; ssl_protocols TLSv1 TLSv1.2; ssl_ciphers ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH; ssl_ecdh_curve secp384r1; ssl_prefer_server_ciphers on; ssl_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; ssl_certificate_key /etc/ssl/froxlor-custom/studio-ausruestung.de.key; add_header Strict-Transport-Security "max-age=0"; ssl_stapling on; ssl_stapling_verify on; ssl_trusted_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; include /etc/apache2/conf-enabled/acme.conf; access_log /var/customers/logs/klimek-studio-ausruestung.de-access.log combined; error_log /var/customers/logs/klimek-studio-ausruestung.de-error.log error; root /var/customers/webs/klimek/studio-ausruestung.de/shopware/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/klimek/webalizer/studio-ausruestung.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/htpasswd/1-c3d3ffdab2b8342809d19524c21b98c1.htpasswd; } location ~ \.php { try_files /333c3697df6a41bcc37bccd05271f644.htm @php; } location @php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_index index.php; fastcgi_param HTTPS on; fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } } Man bemerkt u.a. das einige Konfigurationen doppelt vorhanden sind, da floxlor diese auch selbst generiert. Das könnte natürlich schon die Ursache des Fehler sein. Ich weiß nur leider nicht, wie ich es "besser" lösen kann.
      Die original .htaccess für den appache sieht folgende Konfiguration vor:
      php_value memory_limit 1024M php_value max_execution_time 600 php_value upload_max_filesize 20M php_value post_max_size 20M <IfModule mod_rewrite.c> RewriteEngine on #RewriteBase /shopware/ # Https config for the backend #RewriteCond %{HTTPS} !=on #RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] RewriteRule shopware.dll shopware.php RewriteRule files/documents/.* engine [NC,L] RewriteRule backend/media/(.*) media/$1 [NC,L] RewriteRule custom/.*(config|menu|services|plugin)\.xml$ ./shopware.php?controller=Error&action=pageNotFoundError [NC,L] RewriteCond %{REQUEST_URI} !(\/(engine|files|templates|themes|web)\/) RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/) RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ shopware.php [PT,L,QSA] # Fix missing authorization-header on fast_cgi installations RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] </IfModule> <IfModule mod_alias.c> # Restrict access to VCS directories RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$) # Restrict access to root folder files RedirectMatch 404 /(autoload\.php|composer\.(json|lock|phar)|README\.md|UPGRADE-(.*)\.md|CONTRIBUTING\.md|eula.*\.txt|\.gitignore|.*\.dist|\.env.*)$ # Restrict access to shop configs files RedirectMatch 404 /(web\/cache\/(config_\d+\.json|all.less))$ # Restrict access to theme configurations RedirectMatch 404 /themes/(.*)(.*\.lock|package\.json|\.gitignore|Gruntfile\.js|all\.less|node_modules\/.*)$ </IfModule> # Staging environment #SetEnvIf Host "staging.test.shopware.in" SHOPWARE_ENV=staging # Development environment #SetEnvIf Host "dev.shopware.in" SHOPWARE_ENV=dev #SetEnv SHOPWARE_ENV dev DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration <Files ~ "\.(tpl|yml|ini)$"> # Deny all requests from Apache 2.4+. <IfModule mod_authz_core.c> Require all denied </IfModule> # Deny all requests from Apache 2.0-2.2. <IfModule !mod_authz_core.c> Deny from all </IfModule> </Files> # Enable gzip compression <IfModule mod_deflate.c> AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json application/font-woff application/font-woff2 image/svg+xml </IfModule> <Files ~ "\.(jpe?g|png|gif|css|js|woff|woff2|ttf|svg|webp|eot|ico)$"> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 month" </IfModule> <IfModule mod_headers.c> Header append Cache-Control "public" Header unset ETag </IfModule> FileETag None </Files> # Match generated files like: # 1429684458_t22_s1.css # 1429684458_t22_s1.js <FilesMatch "([0-9]{10})_(.+)\.(js|css)$"> <ifModule mod_headers.c> Header set Cache-Control "max-age=31536000, public" </ifModule> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 year" </IfModule> </FilesMatch> # Disables auto directory index <IfModule mod_autoindex.c> Options -Indexes </IfModule> <IfModule mod_negotiation.c> Options -MultiViews </IfModule> <IfModule mod_php5.c> # php_value memory_limit 256M # php_value max_execution_time 120 # php_value upload_max_filesize 20M php_flag phar.readonly off php_flag magic_quotes_gpc off php_flag session.auto_start off php_flag suhosin.session.cryptua off php_flag zend.ze1_compatibility_mode off php_value always_populate_raw_post_data -1 </IfModule> # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php <IfModule mod_headers.c> Header append X-Frame-Options SAMEORIGIN </IfModule>  
      Für Ideen und Vorschläge wäre ich wie immer sehr dankbar
    • By nisamudeen97
      Hi,
      Our froxlor server is behiend NAT and it uses the local IP  192.168.73.40.  We have enabled letsencrypt module in froxlor and tried validating SSL for a domain in the server.  SSL generation is getting failed with 403 error.  See the debug log information.      Replaced domain name and main IP.    Can any one help me regarding the issue.
       
      [information] Updating Let's Encrypt certificates [information] Updating domain-name.com [information] Adding SAN entry: domain-name.com [information] Adding SAN entry: www.domain-name.com [information] letsencrypt-v2 Using 'https://acme-v02.api.letsencrypt.org' to generate certificate [information] letsencrypt-v2 Using existing account key [information] letsencrypt-v2 Starting certificate generation process for domains [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/new-order [information] letsencrypt-v2 Requesting challenge for domain-name.com [information] letsencrypt-v2 Got challenge token for domain-name.com [information] letsencrypt-v2 Token for domain-name.com saved at /var/www/froxlor/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k and should be available at http://domain-name.com/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [information] letsencrypt-v2 Sending request to challenge [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/chall-v3/803008408/k46kFQ [information] letsencrypt-v2 Verification pending, sleeping 1s [information] letsencrypt-v2 Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for domain-name.com: Verification ended with error: {"type":"http-01","status":"invalid","error":{"type":"urn:ietf:params:acme:error:unauthorized","detail":"Invalid response from http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [212.224.xxx.xxx]: \"<!DOCTYPE html>\\n<html lang=\\\"en-CA\\\" class=\\\"html_stretched responsive av-preloader-active av-preloader-enabled av-default-lightbox\"","status":403},"url":"https:\/\/acme-v02.api.letsencrypt.org\/acme\/chall-v3\/803008408\/k46kFQ","token":"vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","validationRecord":[{"url":"http:\/\/www.domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"www.domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"},{"url":"http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"}]} [information] Let's Encrypt certificates have been updated  
×
×
  • Create New...