Jump to content
Froxlor Forum

Infected

Members
  • Content count

    52
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Infected

  • Rank
    Advanced Froxie
  1. [Howto] Froxlor + MariaDB + NGINX + PHP7.0

    Du benutzt in deiner Anleitung ja PHP-FPM. Dies braucht aber doch (laut alter Anleitung) das Paket "libnss-mysql", welches es unter Debian 9 Stretch nicht mehr gibt. Wird dieses nicht mehr benötigt, oder warum wird es hier nicht erwähnt?
  2. Cannot get uid for user

    Hallo, ich bin gerade dabei mir Froxlor auf mein Ubuntu 16.04 zu installieren. Soweit funktioniert das auch gut. Nur habe ich jetzt Probleme mit PHP-FPM. Ich bekomme bei neu angelegten Benutzern die Meldung "cannot get uid for user". Ich habe die Anleitung und die Configs zu "libnss-mysql" mehrmals geprüft, alles stimmt. Woran kann das liegen? Braucht ihr irgendwelche Configs?
  3. Froxlor VHost Custom Settings

    Schönen guten Abend, ich habe eine Froxlor Instanz, welche auf einem Debian, Nginx und PHP-FPM läuft. Froxlor selbst läuft jetzt selbst über ein VHost. Jetzt möchte ich gerne eigene Einstellungen in diesem VHost eintragen. Wenn ich diese jedoch in der Datei direkt vornehme, sind diese bei der nächsten Neuerstellung der Configs weg. Gibt es eine Möglichkeit, eigene Einstellungen für die Froxlor VHost Instanz vorzunehmen? Mit besten Grüßen
  4. acme.conf not found

    Schönen guten Tag, Froxlor wird bei jedem Update besser und besser. Jedoch bin ich auf ein kleines Problem gestoßen. Ich habe etwas ausprobiert, weshalb ich (entgegen dem Hinweis) direkt an den VHosts der Nginx Config rumgespielt habe. Nachdem ich Änderungen gemacht hatte, wollte ich Nginx von Hand neu starten. Doch aufgrund eines Fehlers war dies nicht möglich. Also habe ich mir den Fehler angesehen und habe folgende Zeile in sämtlichen VHosts ausfindig machen können: include /etc/nginx/acme.conf; Diese Datei ist nicht vorhanden. Als ich diese Zeile überall auskommentierte, konnte ich Nginx endlich neustarten. Meine Frage ist nun, ist das so richtig? Wenn ich über das Froxlor Panel die Webconfigs neu erstelle, kann Nginx ohne Probleme neu gestartet werden, obwohl der Eintrag dann wieder vorhanden ist.
  5. FastCGI_Params duplicate

    Na immer wenn man den Fehler beschreibt, findet man ihn. Die fastcgi_params war in einer vhost datei zwei mal includiert. EDIT: Ok, ganz behoben ist der Fehler noch nicht. Der dopplte Include Eintrag wird bei jeden neuen erstellen der Configs wieder mit erstellt. Kann ich das irgendwo einstellen, oder liegt evtl ein Fehler im Template vor?
  6. FastCGI_Params duplicate

    Schönen guten Abend, ich habe mir Froxlor installiert. System: Debian Jessie Nginx Php5-FPM Nun habe ich alle Konfigurationsschritte durchgeführt wie angegeben. Doch leider stoße ich jetzt auf das Problem, dass Nginx nicht mehr starten will, weil die in der Config angegebenen Parameter schon irgendwo vorhanden sind. Und zwar genau die drei: fastcgi_connect_timeout 65; fastcgi_send_timeout 180; fastcgi_read_timeout 180; Wenn ich diese aus der Datei nehme, startet nginx wunderbar. Jetzt stellt sich mir nur die Frage, wo genau diese Einträge schon vorhanden sind. Ich konnte diese nirgends finden.
  7. Nginx 1.6.2 + PHP5-FPM = 502 Bad Gateway

    Das ist soweit richtig. Ich entnehme deiner Antwort, dass Probleme bei Froxlor und PHP 5.6 bekannt sind. Daher werde ich ganz einfach wieder zum Debian standard springen
  8. Hall?chen zusammen, leider habe ich gerade einen weiteren Fehler entdeckt, den ich mir nicht erkl?ren kann. Ich habe einen neuen kunden angelegt. ?ber diesen Kunden habe ich mir eine Forensoftware installiert. Soweit alles ok. Ich sehe das Forum auch. Doch wenn ich mich nun versuche, im ACP anzumelden, bekomme ich einen 502 Bad Gateway Error. Jetzt frage ich mich, wie so etwas sein kann, wenn das Forum an sich ja wunderbar l?uft. Log: 2014/10/26 15:07:04 [error] 3609#0: *305 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: XX.XX.XX.XX, server: meineseite.de, request: "GET /admincp/index.php?adsess=a849e802283436a013858985c929bf35 HTTP/1.1", upstream: "fastcgi://unix:/var/run/nginx/kunde-php-fpm.socket:", host: "meineseite.de", referrer: "http://meineseite.de/admincp/index.php" Forum funktioniert und auch den Login vom ACP sehe ich. Soch sobald ich auf Login dr?cke, bekomme ich den Fehler. Informationen Betriebssystem: Debian 7 x64 Webserver: Nginx 1.6.2 PHP5-FPM Benutze Source: deb http://packages.dotdeb.org wheezy all deb-src http://packages.dotdeb.org wheezy all deb http://packages.dotdeb.org wheezy-php56 all deb-src http://packages.dotdeb.org wheezy-php56 all Ich habe die gleiche Forensoftware schoneinmal installiert, allerdings habe ich damals noch nicht die neuere Nginx und PHP Version von DotDeb benutzt. Kann das daran liegen?
  9. Hauptdomain leitet auf Panel statt auf Seite

    Kein Ding, h?tte ich ja auch gleich dabei schreiben k?nnen Hier meine nginx.conf: user www-data; worker_processes 4; pid /var/run/nginx.pid; events { worker_connections 768; # multi_accept on; } http { ## # Basic Settings ## sendfile on; tcp_nopush on; tcp_nodelay on; keepalive_timeout 65; types_hash_max_size 2048; # server_tokens off; # server_names_hash_bucket_size 64; # server_name_in_redirect off; include /etc/nginx/mime.types; default_type application/octet-stream; ## # Logging Settings ## access_log /var/log/nginx/access.log; error_log /var/log/nginx/error.log; ## # Gzip Settings ## gzip on; gzip_disable "msie6"; # gzip_vary on; # gzip_proxied any; # gzip_comp_level 6; # gzip_buffers 16 8k; # gzip_http_version 1.1; # gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript; ## # nginx-naxsi config ## # Uncomment it if you installed nginx-naxsi ## #include /etc/nginx/naxsi_core.rules; ## # nginx-passenger config ## # Uncomment it if you installed nginx-passenger ## #passenger_root /usr; #passenger_ruby /usr/bin/ruby; ## # Virtual Host Configs ## include /etc/nginx/conf.d/*.conf; include /etc/nginx/sites-enabled/*; } #mail { # # See sample authentication script at: # # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript # # # auth_http localhost/auth.php; # # pop3_capabilities "TOP" "USER"; # # imap_capabilities "IMAP4rev1" "UIDPLUS"; # # server { # listen localhost:110; # protocol pop3; # proxy on; # } # # server { # listen localhost:143; # protocol imap; # proxy on; # } #} Ich habe gerade einfach mal alle VHosts bis auf die, die nicht funktioniert hat gel?scht. Dann habe ich Nginx neugestartet Und pl?tzlich ging die Seite. Daraufhin habe ich die anderen nach und nach wieder eingef?gt und auch jedesmal Nginx neugestartet. Jetzt sind alle VHosts wieder drin, also so, wie es davor auch war, aber jetzt geht alles. Normalerweise sollte nginx doch beim erstellen der neuen VHosts einen reload machen. Kann es sein, dass da evtl. was fehlschl?gt? Edit: Ich habe auf meinem System "sudo" installiert. Fehlt vielleicht dem Froxlor Benutzer ein Recht?
  10. Hauptdomain leitet auf Panel statt auf Seite

    Genau, ist Nginx mit PHP-FPM. H?tte ich vielleicht auch mal erw?hnen sollen, sry ^^ Es sind keine weiteren VHosts vorhanden. Auch nicht der Default. Ich bin echt rahtlos.
  11. Guten Morgen zusammen, seit l?ngerem arbeite ich jetzt mit Froxlor und bin super zufrieden. Leider sto?e ich gerade auf ein Problem, welches ich nicht l?sen kann. Daher hoffe ich, dass ihr mir helfen k?nnt. Folgende Situation: Ich habe auf meinem Server Froxlor installiert. Nun wolle ich Forxlor ?ber den Hostnamen direkt erreichbar machen (froxlor.meinedomain.de). Soweit so gut, funktioniert auch. Zudem wolte ich, wie ich es auch schon immer gemacht habe, ?ber meine Domain eine normale Seite anzeigen lassen. Dazu habe ich also eine neue Domain in Froxlor angelegt und ihr den Alias (www.) zugeordnet. Die VHosts wurden erstellt und die passende Verzeichissstruktur angelegt. Doch statt meiner Seite, bzw der Froxlor Wellcome Page werde ich trotzdem auf das Froxlor Panel weitergeleitet. Ich habe darauf die VHosts gepr?ft, aber die scheinen OK zu sein. Nun verstehe ich nicht, wieso Froxlor die Domain nicht zum passenden Verzeichiss leitet. Vielleicht noch zu erw?hnen ist, dass ich 2 IPs konfiguriert habe. Auszug VHost Froxlor Hostname mit IP 1: listen 1.1.1.1:80 default; # Froxlor default vhost server_name froxlor.meinedomain.de; access_log /var/log/nginx/access.log; root /var/www/froxlor/; Auszug VHost Froxlor Hostame mit IP 2: listen 2.2.2.2:80 default; # Froxlor default vhost server_name froxlor.meinedomain.de; access_log /var/log/nginx/access.log; root /var/www/froxlor/; Auszug VHost MeineDomain ?ber IP 2: listen 2.2.2.2:80; server_name meinedomain.de www.meinedomain.de; access_log /var/customers/logs/admin-access.log combined; error_log /var/customers/logs/admin-error.log error; root /var/customers/webs/kunde/meinedomain.de/; Wie man sieht, stimmen die Rootverzeichnisse sowie die Servernamen. Daher verstehe ich nicht, wieso ich wenn ich meinedomain.de oder www.meinedomain.de aufrufe, das Froxlor Panel zu Gesicht bekomme. Ich hoffe, ihr k?nnt mir helfen. PS: Nur um das klar zu stellen, die IPs sind nat?rlich nicht meine
  12. nginx php5-fpm Path_Info

    Hmmmm,a lso ich habe das genannte gerade auch mal ganz oben eingetragen. PATH_TRANSLATED wird tats?chlich richtig angezeigt. Aber PATH_INFO bleibt leer. Sehr merkw?rdig
  13. nginx php5-fpm Path_Info

    Sch?nen guten Abend, leider muss ich mich bez?glich dieses themas nocheinmal melden. Ich habe mich jetzt wieder ein paar Stunden mit dem Thema besch?ftigt, bekomme es aber einfach nicht hin. Was habe ich im Moment gemacht: Ich habe in "/etc/nginx/fastcgi:params" den Eintrag hinzugef?gt und nginx neugestartet. fastcgi_param PATH_INFO $fastcgi_path_info; Ich bekomme zwar keinen Fehler, allerdings ist der Eintrag PATH_INFO leer, wenn ich diesen ?ber folgende Anweisung aufrufe: <pre><?php var_export($_SERVER)?></pre> Ich habe keine Ahnung, wieso ich PATH_INFO nicht zum laufen bekomme. PS: Wenn ich in oben genannter Datei folgenden Eintrag hinzuf?ge, bekomme ich bei jeder .php Datei die Meldung "Access Denied": fastcgi_param PATH_TRANSLATED $document_root$fastcgi_path_info; Warum das so ist, kann ich mir nicht erkl?ren.
  14. Hallo zusammen, seit etwas l?ngerem bekomme ich jeden Tag eine EMail vom Cron Daemon mit folgender Nachricht: Title: Message: Im besagter sql-error.log findet man unz?hlige Eintrage mit immer der selben Nachricht: Nur leider kann ich damit ?berhaupt nichts anfangen. Froxlor ist auf der aktuellen Version 0.9.31.2-1.
  15. [solved] PHP Warning: exec():

    So hab ich gemacht. Bisher scheint alles wunderbar zu laufen. Ich sehe das Problem vorerst als gel?st an. Danke ^^
×