Jump to content
Froxlor Forum

Infected

Members
  • Content Count

    59
  • Joined

  • Last visited

Everything posted by Infected

  1. php7.3-fpm wurde aktualisiert. Er scheint so, als wenn die Config Datei einen Lock verursacht hat. Meine Lösung: Ich habe den "mysql" Eintrag aus der init Datei raus genommen, das Paket neu konfigurieren lassen, dabei die alte Datei behalten und dann den mysql Eintrag wieder hinzugefügt. Scheint jetzt sauber zu laufen.
  2. me@vps:/# systemctl enable mysql Failed to enable unit: Refusing to operate on linked unit file mysql.service
  3. Guten Morgen, ich habe eben ein Update meiner Software Pakete auf meinem System gemacht. Danach wollte ich einen Mailserver einrichten. Doch jetzt bekomme ich bei der Installation folgenden Fehler: Service mysql has to be enabled to start service php7.3-fpm Froxlor selbst läuft normal, jedoch würde ich die Meldung dennoch gerne loswerden. Mein System: Debian Stratch Nginx php-fpm MariaDB Ich habe folgende Stelle in Verdacht: https://github.com/Froxlor/Froxlor/wiki/nginx-with-php-fpm#4-enable-php-fpm-in-froxl
  4. Hallo zusammen, ich wollte mir heute PowerDNS installieren, um Nameserver bereit zu stellen. Leider scheint die Installation nicht vollständig beschrieben zu sein. Sobald ich die Installation von PowerDNS ausführe werde ich gefragt, ob ich die Config via common-irgendwas durchführen will und soll irgendwelche Passwörter eingeben. Dort habe ich erst einmal nein ausgewählt und es wurde nur PowerDNS installiert. Dann habe ich die Config Dateien wie beschrieben angelegt. Leider wird mir jetzt in der Konsole angegeben, dass keine Verbindung zur Datenbank hergestellt werden kann. D
  5. Guten Abend, ich habe mich mal wieder dazu entschlossen Froxlor als Software einzusetzen und bin mal wieder mehr als zufrieden. Leider bin ich jetzt an einem Punkt angekommen, wo ich mir nicht mehr helfen kann. Ich möchte einen Wordpress Blog anlegen. Für ein bestimmtes URL Schema wird jedoch in Worpdress ein rewrite benötigt, welcher so aussieht: location / { # This is cool because no php is touched for static content. # include the "?$args" part so non-default permalinks doesn't break when using query string try_files $uri $uri/ /index.php?$args; } We
  6. Also Wordpress braucht eine spezielle Config, wenn du URLs rewriten möchtest. Sprich statt der URL www.domain.de/wordpress/index.php=id=123 lieber www.domain.de/wordpress/mein-beitrag Und hier musst du in Froxlor ein paar Einstellungen ändern.
  7. Hallo zusammen, ich habe aktuell immer das Problem, dass ich einen 503 Bad Gateway Error bekomme, wenn ich meinen Server neustarte. Dann muss ich per Hand php-fpm neustarten und dann geht es. Im Log steht, dass nginx die .socket Dateien nicht finden kann. Wisst ihr, woran das liegen kann?
  8. Du benutzt in deiner Anleitung ja PHP-FPM. Dies braucht aber doch (laut alter Anleitung) das Paket "libnss-mysql", welches es unter Debian 9 Stretch nicht mehr gibt. Wird dieses nicht mehr benötigt, oder warum wird es hier nicht erwähnt?
  9. Hallo, ich bin gerade dabei mir Froxlor auf mein Ubuntu 16.04 zu installieren. Soweit funktioniert das auch gut. Nur habe ich jetzt Probleme mit PHP-FPM. Ich bekomme bei neu angelegten Benutzern die Meldung "cannot get uid for user". Ich habe die Anleitung und die Configs zu "libnss-mysql" mehrmals geprüft, alles stimmt. Woran kann das liegen? Braucht ihr irgendwelche Configs?
  10. Schönen guten Abend, ich habe eine Froxlor Instanz, welche auf einem Debian, Nginx und PHP-FPM läuft. Froxlor selbst läuft jetzt selbst über ein VHost. Jetzt möchte ich gerne eigene Einstellungen in diesem VHost eintragen. Wenn ich diese jedoch in der Datei direkt vornehme, sind diese bei der nächsten Neuerstellung der Configs weg. Gibt es eine Möglichkeit, eigene Einstellungen für die Froxlor VHost Instanz vorzunehmen? Mit besten Grüßen
  11. Schönen guten Tag, Froxlor wird bei jedem Update besser und besser. Jedoch bin ich auf ein kleines Problem gestoßen. Ich habe etwas ausprobiert, weshalb ich (entgegen dem Hinweis) direkt an den VHosts der Nginx Config rumgespielt habe. Nachdem ich Änderungen gemacht hatte, wollte ich Nginx von Hand neu starten. Doch aufgrund eines Fehlers war dies nicht möglich. Also habe ich mir den Fehler angesehen und habe folgende Zeile in sämtlichen VHosts ausfindig machen können: include /etc/nginx/acme.conf; Diese Datei ist nicht vorhanden. Als ich diese Zeile überall auskommenti
  12. Na immer wenn man den Fehler beschreibt, findet man ihn. Die fastcgi_params war in einer vhost datei zwei mal includiert. EDIT: Ok, ganz behoben ist der Fehler noch nicht. Der dopplte Include Eintrag wird bei jeden neuen erstellen der Configs wieder mit erstellt. Kann ich das irgendwo einstellen, oder liegt evtl ein Fehler im Template vor?
  13. Schönen guten Abend, ich habe mir Froxlor installiert. System: Debian Jessie Nginx Php5-FPM Nun habe ich alle Konfigurationsschritte durchgeführt wie angegeben. Doch leider stoße ich jetzt auf das Problem, dass Nginx nicht mehr starten will, weil die in der Config angegebenen Parameter schon irgendwo vorhanden sind. Und zwar genau die drei: fastcgi_connect_timeout 65; fastcgi_send_timeout 180; fastcgi_read_timeout 180; Wenn ich diese aus der Datei nehme, startet nginx wunderbar. Jetzt stellt sich mir nur die Frage, wo genau diese Einträge schon vorhanden sind.
×
×
  • Create New...