Jump to content
Froxlor Forum

d00p

Administrators
  • Posts

    9652
  • Joined

  • Last visited

  • Days Won

    41

Community Answers

  1. d00p's post in einzelne von den automatisch angelegten A-records deaktivieren was marked as the answer   
    Kommt drauf an ob "mail" record automatisch erstellt wurde (aufgrund von settings) oder nicht, wenn ja wirds schwer, wenn nein hast du es ja selbst in der hand
  2. d00p's post in proftpd login with long usernames not possible [solved] was marked as the answer   
    Thanks, we'll make these changes to the next release
  3. d00p's post in apt remove php8.1-opcache räumte ganze froxlor installation weg - client applicationen laufen noch was marked as the answer   
    sichere einfach deine lib/userdata.inc.php - bin gerade nicht sicher ob die beim entfernen des pakets gelöscht wird. Ansonsten klar, es geht keine Datenbank verloren usw. du kannst das Paket einfach wieder installieren
     
  4. d00p's post in Let's encrypt Fehler bei neu eingerichtetem Server was marked as the answer   
    pcamsee.net:Verify error:217.79.180.217: Invalid response from http://pcamsee.net/.well-known/acme-challenge/UC00jYbr5csw048QE7fnH8fGjb7lX-U4c3WQ7msZDYI: 404 Hast  du nach der Aktivierung von Let's Encrypt auch die Webserver Configuration-templates durchgeführt? Du solltest eine acme.conf in /etc/apache2/conf-enabled/ haben
  5. d00p's post in Let´s Encrypte für Restream was marked as the answer   
    Müsstest du via "Eigene vhost einstellungen" machen, je nach anforderungen des dienstes z.B. so:

     
    ProxyPass /service1 http://localhost:8181/service1 ProxyPassReverse /service1 http://localhost:8181/service1 <Proxy http://localhost:8181/service1> Require all granted Options none </Proxy> Damit würdest du dann via "https://deine-domain.tld/service1" den streaming server auf port 8181 erreichen (oder 8080, je nach dem was du eingerichtet hast, einfach überall korrekt angeben)
    Nicht vergessen das du ggfls mod_proxy_http aktivieren musst
  6. d00p's post in CatchAll Email deaktivieren? was marked as the answer   
    Einstellungen -> mailserver -> catchall verwenden: ja/nein 
  7. d00p's post in PHP 8.1 installieren was marked as the answer   
    du hast ja auch php-fpm installiert und nicht php-cgi....
  8. d00p's post in Fehler bei Updatecheck und Newsfeed was marked as the answer   
    OS? Version? ca-certificates version? scheint mir einfach veraltete pakete zu sein, habe hier auf einigen servern absolut kein problem mit den certificates
  9. d00p's post in Fresh Install Debian 11 was marked as the answer   
    Noch ungetestet, aber probiers mal mit folgendem Patch in der install/lib/class.FroxlorInstall.php
     
    diff --git a/install/lib/class.FroxlorInstall.php b/install/lib/class.FroxlorInstall.php index 30855bfa..b30f9ed0 100644 --- a/install/lib/class.FroxlorInstall.php +++ b/install/lib/class.FroxlorInstall.php @@ -734,8 +734,26 @@ class FroxlorInstall private function _grantDbPrivilegesTo(&$db_root, $database, $username, $password, $access_host) { + // mariadb + if (version_compare($db_root->getAttribute(\PDO::ATTR_SERVER_VERSION), '10.0.0', '>=')) { + // create user + $stmt = $db_root->prepare(" + CREATE USER '" . $username . "'@'" . $access_host . "' IDENTIFIED BY :password + "); + $stmt->execute(array( + "password" => $password + )); + // grant privileges + $stmt = $db_root->prepare(" + GRANT ALL ON `" . $database . "`.* TO :username@:host + "); + $stmt->execute(array( + "username" => $username, + "host" => $access_host + )); + } // mysql8 compatibility - if (version_compare($db_root->getAttribute(\PDO::ATTR_SERVER_VERSION), '8.0.11', '>=')) { + elseif (version_compare($db_root->getAttribute(\PDO::ATTR_SERVER_VERSION), '8.0.11', '>=')) { // create user $stmt = $db_root->prepare(" CREATE USER '" . $username . "'@'" . $access_host . "' IDENTIFIED WITH mysql_native_password BY :password  
  10. d00p's post in Fresh Install Debian 11 was marked as the answer   
    Okay, hier herrschen wohl doch größere Unterschiede zwischen MariaDB und MySQL - muss ich fürs nächste release fixen. 
    MariaDB:
    | IDENTIFIED {VIA|WITH} authentication_rule [OR authentication_rule ...] authentication_rule: authentication_plugin | authentication_plugin {USING|AS} 'authentication_string' | authentication_plugin {USING|AS} PASSWORD('password') MySQL:
    | IDENTIFIED WITH auth_plugin BY 'auth_string' [AND 2fa_auth_option] | IDENTIFIED WITH auth_plugin BY RANDOM PASSWORD [AND 2fa_auth_option] | IDENTIFIED WITH auth_plugin AS 'auth_string' [AND 2fa_auth_option] > For syntax that uses BY 'auth_string', the string is cleartext and is passed to the authentication plugin for possible hashing. > For syntax that uses AS 'auth_string', the string is assumed to be already in the format the authentication plugin requires das "BY" war mal das was bei beiden funktioniert hatte...offenbar nicht mehr
  11. d00p's post in Fresh Install Debian 11 was marked as the answer   
    ja ich denke da wird man einfach verfolgen müssen wie sich die versionierung von mysql ergibt. Aktuell sollte das so kein problem sein. Ausgabe von "mysql --version" ist natürlich eine Möglichkeit setzt aber wieder voraus, dass ich das im installer (web!) überhaupt ausführen darf! + parsing
  12. d00p's post in DKIM record for Domains was marked as the answer   
    No you don't have to. At this time, there are sadly no configuration templates for any dkim service. But with the given setting-opportunities, it should be fairly easy to get this running with opendkim or even rspamd, see the original issue from the underscore in selectors, there are some hints: https://github.com/Froxlor/Froxlor/issues/619
  13. d00p's post in DKIM record for Domains was marked as the answer   
    so which service are you using that signes the emails? this does not happen automatically by enabling dkim in froxlor
  14. d00p's post in DKIM record for Domains was marked as the answer   
    No you don't have to. At this time, there are sadly no configuration templates for any dkim service. But with the given setting-opportunities, it should be fairly easy to get this running with opendkim or even rspamd, see the original issue from the underscore in selectors, there are some hints: https://github.com/Froxlor/Froxlor/issues/619
  15. d00p's post in Email accounts not showing after re-enabling mailboxs was marked as the answer   
    Try running "Recalculate resource usage" in the admin left-side menu
  16. d00p's post in Adding multiple domain names to a single site was marked as the answer   
    Just assign the same documentroot?
  17. d00p's post in Konsolidierung der Github Doku und der Froxlor Konfiguration was marked as the answer   
    https://froxlor.github.io/configuration/nginx/php-fpm
    Der lokale user wird beim Konfigurieren der Dienste mit angelegt sofern er nicht existiert. Folge einfach den Konfigurations-Vorgaben für php-fpm, da sollte das dabei sein.
    Sofern du libnss-extrausers nutzt statt libnss-mysql (und das solltest du! libnss-mysql ist ziemlich alt) brauchst du keinen nscd mehr - auch hier: die konfigurations-vorgaben beinhalten eigentlich alles was du brauchst
  18. d00p's post in Email accounts not showing after re-enabling mailboxs was marked as the answer   
    Try running "Recalculate resource usage" in the admin left-side menu
  19. d00p's post in Installationsschwierigkeiten von PHP-FPM mit Apache was marked as the answer   
    wenn du es über das config-services script gemacht hast brauchst du da eigentlich nix mehr installieren - voraussetzung ist natürlich das du vorher - so wie die anleitung es sagt - die Einstellungen alle entsprechend korrekt gesetzt hast!
    libnss-extrausers ist was anderes als libnss-mysql !!! ich rate dringend libnss-extrausers zu nutzen, beachte das dafür die Option in den entsprechenden Einstellungen aktiviert sein muss.
    Also:
    1) Einstellungen komplett kontrollieren, alle gewünschten Dienste aktivieren (wie z.B. php-fpm, libnss-extrausers, etc.).
    2) config-services ausführen oder ggfls manuell als admin -> Configuration -> distro wählen -> dienst wählen -> etc. -> befehle anschauen, kopieren und auf der shell ausführen
     
  20. d00p's post in How do I enable allow_url_fopen? was marked as the answer   
    admin -> PHP-configurations -> edit the php config you want to enable this for in field php.ini settings -> save and wait for cron
  21. d00p's post in nscd invalidiert nicht die Gruppen was marked as the answer   
    Mit libnss-extrausers brauchst du kein nscd...kannst du einfach löschen, er liest die User und Gruppen ja über Textfiles genau wie das System.
  22. d00p's post in vHost PHP disabled in apache configuration was marked as the answer   
    Log in as admin -> edit customer -> check "PHP enabled?" flag AND/OR
    Log in as admin -> edit domain -> check "PHP enabled" flag 
  23. d00p's post in [HELP] After switching to PHP-FPM I cannot upload images to WordPress via Admin interface 🤯 was marked as the answer   
    Well, just take a look at the owner, chown it to user/group editor1
  24. d00p's post in [HELP] Reconfiguring running froxlor was marked as the answer   
    Settings -> System -> Use libnss-extrausers instead of libnss-mysql
  25. d00p's post in [HELP] Reconfiguring running froxlor was marked as the answer   
    Settings -> System -> Use libnss-extrausers instead of libnss-mysql
×
×
  • Create New...