Jump to content
Froxlor Forum

nisamudeen97

Members
  • Content Count

    31
  • Joined

  • Last visited

Community Reputation

0 Neutral

About nisamudeen97

  • Rank
    Advanced Froxie

Recent Profile Visitors

1555 profile views
  1. Hi, Thx for the update. I have configured the following. ErrorLog "/var/log/apache2/error.log" CustomLog "/var/log/apache2/access.log" combined
  2. Hi, I need to enable access log for froxlor. In froxlor vhost config I cannot see access log enabled. If I edit manually it is getting overwritten. Below is my vhost config for froxlor. let me know how to enable access log and error log for foxlor. <VirtualHost 192.168.73.40:443> DocumentRoot "/var/www/froxlor/" ServerName hostname.cm SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/apache2/ssl/*********.crt SSLCertificateKeyFile /etc/apache2/ssl/******.key SSLCACertificateFile /etc/apache2/ssl/*******CA.crt SSLCertificateChainFile /etc/apache2/ssl/******.crt </VirtualHost>
  3. Hi, I am aware emails have nothing to do with froxlor, I just wanted to know if email and attachments are saved differently or both in single file ? Do you think if there is some work around to copy the attachments and make it working ?
  4. Hi, My email was previously with gmail and it is configured in my Thunderbird mail client with mac. I have now moved my domain and its mx to froxlor mx. I have tired migrating old email to froxlor via thundirbird. I could see it getting failed for some reason. All emails are also not getting copied. Finally I have managed to copy old emails manually to my server via scp. I copied emails from local system location "/Users/nisa/Library/Mail/V4/5214C655-C856-4C64-A5B2-45B4FD5B11D4/INBOX.mbox/B07A31E1-A91B-4F22-9F5D-6DBBB760A094/Data/2/8/1/Messages/*" to "/var/customers/mail/nisa/domain.com/nisa/Maildir/.Sent/cur/" copied sent folder likewise. I could see emails good meanwhile I am unable to find the attachments. Thunderbird stores attachments as files in different folder and I am unable to find the location where froxlor store its email attachments. My question is how froxlor manages the email attachments? Is it treating each attachment as file names ? I have froxlor + dovecot. Let me know the location to which I have to copy my attachments ?
  5. Hi, I have met with two issues on it. 1. FCGI users not getting configured as needed. 2. FCGi user error on newly created vhosts Can you please let me know if there is some docs for the same.
  6. Hi, Is Ubuntu16 compatible with froxlor. I have tried the same. FCGI getting failed. I am unable to find documentation for the same in "Configuration" inside froxlor.
  7. Hi, I have also rebooted the server to make sure updated things loads good. Still it is not working. What you think is the cause ? Bugs ?? root@:~# uname -a Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u5 (2017-09-19) x86_64 GNU/Linux root@:~# cat /etc/issue Debian GNU/Linux 9 \n \l
  8. updated Open ssl version to latest. Still it is like the same openssl version OpenSSL 1.1.0f 25 May 2017
  9. openssl version OpenSSL 1.0.1t 3 May 2016 (Library: OpenSSL 1.0.2l 25 May 2017)
  10. apache2ctl -M | grep "http2" http2_module (shared)
  11. root@w03:/etc/apache2/sites-enabled# cat 35_froxlor_ssl_vhost_nisa.kaikaito.de.conf # 35_froxlor_ssl_vhost_nisa.kaikaito.de.conf # Created 06.11.2017 11:46 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 45 (SSL) - CustomerID: 13 - CustomerLogin: kaikaito <VirtualHost 192.168.73.56:443> ServerName nisa.kaikaito.de ServerAlias *.nisa.kaikaito.de ServerAdmin np@kaikaito.it SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 Protocols h2 http/1.1 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/froxlor-custom/nisa.kaikaito.de.crt SSLCertificateKeyFile /etc/ssl/froxlor-custom/nisa.kaikaito.de.key SSLCertificateChainFile /etc/ssl/froxlor-custom/nisa.kaikaito.de_chain.pem <IfModule mod_headers.c> Header always set Strict-Transport-Security "max-age=31535995" </IfModule> DocumentRoot "/var/customers/webs/kaikaito/nisa/" FcgidIdleTimeout 30 SuexecUserGroup "kaikaito" "kaikaito" <Directory "/var/customers/webs/kaikaito/nisa/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/kaikaito/nisa.kaikaito.de/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> Alias /webalizer "/var/customers/webs/kaikaito/webalizer" ErrorLog "/var/customers/logs/kaikaito-error.log" CustomLog "/var/customers/logs/kaikaito-access.log" combined </VirtualHost>
  12. Hi, I have tested it and it is showing not supported result
  13. Hi, Thx for the update. I have enabled http2 in forxlor as updated in the above steps. See the screen shots. I can also see "OCSP stapling" and "HSTS" . Cool. But upon testing I could see the below error in apache. AH00526: Syntax error on line 12 of /etc/apache2/sites-enabled/35_froxlor_ssl_vhost_dumdum.conf: Invalid command 'Protocols', perhaps misspelled or defined by a module not included in the server configuration Action 'configtest' failed. https://www.shivering-isles.com/http-2-getting-ready-on-debian-with-apache2/ I have then followed the above doc and enabled http2 in apache. As i was using "Apache 2.4.10", I have to update it to "Apache/2.4.29" which is still in latest test release of Debian.. But unfortunately I cannot still see http2 enabled On header testing. curl --http2 -I domain.com HTTP/1.1 200 OK Date: Thu, 02 Nov 2017 04:44:53 GMT Server: Apache/2.4.29 (Debian) Last-Modified: Thu, 02 Nov 2017 03:32:23 GMT ETag: "e-55cf7a2e85d40" Accept-Ranges: bytes Content-Length: 14 Content-Type: text/html Can you please help me to fix this ?
  14. Hi, Does it mean we have to update the current froxlor version ? it will automatically get updated? What is the procedure to get updated ?
  15. Hi, We wish to enable HTTP/2 support in our forxlor server which is currently running apache server version "Server version: Apache/2.4.10 (Debian)". Debian GNU/Linux 8 \n \l https://http2.pro/doc/Apache Has any one tried to enable the same in forxlor ? We are running shared hosting. Look forward to have detailed update.
×
×
  • Create New...