Jump to content
Froxlor Forum

j4mb4l4j4

Members
  • Content count

    19
  • Joined

  • Last visited

Community Reputation

-1 Poor

About j4mb4l4j4

  • Rank
    Froxie
  1. PATH und HOSTNAME in php5-fpm configs eintragen

    Ich habe es jetzt so gepatcht und bekomme im Nextcloud/Owncloud Backend auch keinen Fehler mehr: /Froxlor-Document-Root/lib/classes/phpinterface/class.phpinterface_fpm.php 242 # NEXTCLOUD CUSTOM for PATH by Carsten Sievers 243 $fpm_config.= 'env[PATH] = /usr/local/bin:/usr/bin:/bin'."\n"; 244 $fpm_config.= 'env[TMP] = '.$tmpdir."\n"; 245 $fpm_config.= 'env[TMPDIR] = '.$tmpdir."\n"; 246 $fpm_config.= 'env[TEMP] = '.$tmpdir."\n";
  2. UPDATE: Hab den Fehler gefunden, das Verzeichnis /var/www/cust01.DOMAIN.com/.well-known/acme-challenge Hatte die Rechte drwxr-xr-x 2 froxlorlocal froxlorlocal 4096 Dec 12 16:08 acme-challenge Ich habe dann die Rechte drwxr-xr-x 2 www-data www-data 4096 Dec 12 16:08 acme-challenge gesetzt und konnte die Datei aufrufen. Jetzt hat Froxlor es wieder zu drwxr-xr-x 2 froxlorlocal froxlorlocal 4096 Dec 12 16:08 acme-challenge gemacht, aber ich kann es jetzt ohne Probleme aufrufen. Jetzt klappts auch wieder mit dem nachbarn. Einziges letztes Problem ist, das Letsencrypt sich gerade nicht automatisch Cronjobed. Muss es noch manuell anstoßen, vllt liegts daran das ich das Zertifikat nicht bei IP/Ports habe UPDATE 2: Der Cron war nicht eingetragen, vieleicht weil Letsencrypt nicht funktioniert hatte zuvor. Jetzt funktioniert es. Das mit dem Verzeichnisrecht ist mir allerdings immernoch ein Rätsel.
  3. Hi Danke dir für die Antwort, die habe ich allerdings am Sonntag benutzt bei der Installation. Und nach der Installation war die TABLE nicht da. Hattest du jüngst ein Update gemacht ? Nutze Ubuntu 17.10 und die neueste mysql-server dazu. Ich habe auch nach der Installation das Problem mit Letsencrypt, das ich nicht auf die Datei ( zum testen wie du in vielen Beiträgen hier empfohlen hast ) ( oder neuen Forumsbeitrag dazu aufmachen ? ) Suche mich da seit 14 Stunden wund :-) : /var/www/cust01.DOMAIN.com/.well-known/acme-challenge/test.html Zugreifen kann, damit Letsencrypt geht. Wenn ich darauf zugreife schreibt der nginx laut error.log immer: 2017/12/12 15:21:34 [error] 12563#12563: *27 open() "/var/www.cust01.DOMAIN.com/.well-known/acme-challenge/test.html" failed (2: No such file or directory), client: 31.16.227.7, server: cust01.DOMAIN.com, request: "GET /.well-known/acme-challenge/test.html HTTP/2.0", host: "cust01.DOMAIN.com" Weißt du woran das liegt das es so komisch umgeschrieben wird , also der "/" statt des "." geschrieben wird ? Meine /etc/nginx/acme.conf ist gemäß Tutorial: location /.well-known/acme-challenge { alias /var/www/cust01.DOMAIN.com/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } } Wenn ich test.html in das Verzeichnis /var/www/cust01.DOMAIN.com/.well-known/test.html lege, funktioniert der Aufruf der Datei. Das ist das einzige was mich nach der Installationsanleitung grade noch am Betrieb hindert. Die SSL Zerts sind laut Doku von oben auch nur bei folgendem hinterlegt ( siehe Bild ). Mit IP/Ports kam aber trotzdem der Umschreibefehler wenn ich das Zertifikat dort angegeben habe. PS: Vhost von 80 und 443 sind: listen 93.104.212.200:80 default_server; # Froxlor default vhost server_name cust01.DOMAIN.com; access_log /var/log/nginx/access.log; include /etc/nginx/acme.conf; # temp. disabled ssl-redirect due to Let's Encrypt certificate generation. root /var/www/cust01.DOMAIN.com/; index index.php index.html index.htm; location / { } return 301 https://$host$request_uri; location ~ \.php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_pass unix:/var/run/froxlor.panel-cust01.DOMAIN.com-php-fpm.socket; fastcgi_index index.php; } } # Created 12.12.2017 15:15 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 93.104.212.200:443 default_server ssl http2; # Froxlor default vhost server_name cust01.DOMAIN.com; access_log /var/log/nginx/access.log; include /etc/nginx/acme.conf; root /var/www/cust01.DOMAIN.com/; index index.php index.html index.htm; location / { } ssl_protocols TLSv1 TLSv1.2; ssl_ciphers ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128; ssl_ecdh_curve secp384r1; ssl_prefer_server_ciphers on; ssl_certificate /etc/letsencrypt/live/cust01.DOMAIN.com/fullchain.pem; ssl_certificate_key /etc/letsencrypt/live/cust01.DOMAIN.com/privkey.pem; location ~ \.php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_param HTTPS on; fastcgi_pass unix:/var/run/froxlor.panel-cust01.DOMAIN.com-php-fpm.socket; fastcgi_index index.php; } }
  4. One more thing. I had the Problem that I had to disable the mysql Strict Mode. Otherwise I had the error SQLSTATE[HY000]: General error: 1364 Field 'mail_virtual' doesn't have a default value Everytime I wanted to delete a Domain. I did it with the following Instruction: https://serverpilot.io/community/articles/how-to-disable-strict-mode-in-mysql-5-7.html After that I created the table with: ysql> CREATE TABLE `mail_virtual` ( -> `id` int(11) NOT NULL auto_increment, -> `email` varchar(255) NOT NULL default '', -> `email_full` varchar(255) NOT NULL default '', -> `destination` text NOT NULL default '', -> `domainid` int(11) NOT NULL default '0', -> `customerid` int(11) NOT NULL default '0', -> `popaccountid` int(11) NOT NULL default '0', -> `iscatchall` tinyint(1) unsigned NOT NULL default '0', -> PRIMARY KEY (`id`), -> KEY `email` (`email`) -> ) ENGINE=MyISAM CHARSET=utf8 COLLATE=utf8_general_ci;
  5. Danke für das Klasse Tutorial !!! Bei mir hat alles geklappt. Eine Anmerkung, ich musste nach der Installation noch folgenden Eintrag bei den Froxlor EInstellungen machen, sonst gingen meine vHost Container nicht (siehe Bild). Ich habe auch den 502 Fehler bekommen, das lag bei mir daran das im Verzeichnis /etc/php/7.1/fpm/pool.d/ keine Datei angelegt war, deshalb kam mein php-fpm nicht hoch. Ich habe dann die Konfig so geändert das der php-fpm kurz starten konnte, dann es wieder umgestellt wie im Tutorial und dann erst konnte Froxlor die Datei anlegen ( also php Datei für den Froxlor vHost ) und dann kam der php-fpm wieder hoch. Bei Ubuntu 17.10 musste ich nginx und php-fpm noch in den Autostart reinnehmen, die kamen nach Installation nicht automatisch hoch. Und bei 2a(1), SSL Port wäre noch zu sagen, dass man vorher in den Einstellungen "SSL Aktivieren" anklicken muss, sonst kann man den SSL Port nicht anlegen. Ansonsten geiles Tutorial, bitte in die aktuelle Froxlor Installation mit aufnehmen. Die unterscheidet sich ja doch etwas von der im Backend.
  6. Hi, vielen dank für die Info. Ich habe es jetzt mit der .htaccess gemacht, nicht so schön aber es funktioniert. Danke für die schnelle Rückmeldung. Gelöst mit: # SEO REDIRECT # <IfModule mod_rewrite.c> RewriteEngine On RewriteCond %{HTTP_HOST} ^www.domain.com$ RewriteRule (.*) https://domain.com/$1 [R=301,L] </IfModule> Close
  7. Hi, ich hätte mal eine simple Frage zum Thema Redirects. Wir möchten gerne folgende Redirects für eine Domain einrichten (siehe Screenshot für korrektest Beispiel aus dem Internet): http://www.domain.de (301) -> https://domain.de https://www.domain.de (301) -> https://domain.de http://domain.de (301) -> https://domain.de https://domain.de (301) -> kein redirect Könnten wir dies im Froxlor Panel einstellen oder ist es hierzu erforderlich das wir die vHosts Configs der einzelnen Domains/Subdomains mit einer manuellen Config erweitern die die gewünschten Redirects aufweist ? Manuell würde ja bedeuten, dass Froxlor die Config nach 15min überschreibt. Können wir dies permanent hinzufügen oder gar im Panel ? Ich denke im worse Case dann über .htaccess oder ? Gerne würde ich natürlich im vHost anfangen statt in der unteren Ebene (.htaccess). Vielen Dank schon mal im Voraus.
  8. WOW, that did it for me. you're awesome, I forgot that without installing via apt-get it's getting a little bit tricky ;-) Thanks a lot.
  9. Hi, I just installed Froxlor and it works like a charm. But one question, I've got left. When I create a customer or a domain ( even if it's just a customer without domain), after the cronjob, my virtual host changes the doument root from: NameVirtualHost 12.34.56.78:80 <VirtualHost 12.34.56.78:80> DocumentRoot "/var/www" ServerName myfroxlordomain.de </VirtualHost> to NameVirtualHost 12.34.56.78:80 <VirtualHost 12.34.56.78:80> DocumentRoot "/var/" ServerName myfroxlordomain.de </VirtualHost> This is making it unable for me to connect to the myfroxlordomain.de web login. I just the the Directory Index and if I add myfroxlordomain.de/www I'm back in my dashboard. Anyone an idea why I got this error ? I controlled my cronjob settings and that looks just fine. It like everytime I do a change, the Documentroot of the virtual host gets editet to /var instead of /var/www. But why ???
  10. Admin Login funktioniert nicht mehr

    Erledigt ... Man muss es neu als MD5 speichern und den Apache neustarten ... Komische Nummer.
  11. Hallo liebes Forum, ich habe seid heute ein Problem und weiss nicht mehr so recht weiter... Ich wollte mich wie gewohnt mit meinem Admin Daten einloggen und bekomme immer die Meldung das der Benutzername oder das Passwort falsch ist. Dabei sind sie 1000% richtig. Daraufhin habe ich das Passwort in der Froxlor Datenbank noch mal selber gesetzt unter panel_admins. Allerdings funktioniert es trotzdem nicht. Woran kann das liegen ? Kann ich das Passwort auch wieder als md5 in der DB speichern ?
  12. [solved] Why are the configs not complete

    Ok, this was the master.cf after doing the froxlor configuration steps: # Add this lines to be able to use dovecot as delivery agent # Dovecot LDA dovecot unix - n n - - pipe flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -d ${recipient} And i added smtp inet n - - - - smtpd #submission inet n - - - - smtpd # -o smtpd_enforce_tls=yes # -o smtpd_sasl_auth_enable=yes # -o smtpd_client_restrictions=permit_sasl_authenticated,reject #smtps inet n - - - - smtpd # -o smtpd_tls_wrappermode=yes # -o smtpd_sasl_auth_enable=yes # -o smtpd_client_restrictions=permit_sasl_authenticated,reject #628 inet n - - - - qmqpd pickup fifo n - - 60 1 pickup cleanup unix n - - - 0 cleanup qmgr fifo n - n 300 1 qmgr #qmgr fifo n - - 300 1 oqmgr tlsmgr unix - - - 1000? 1 tlsmgr rewrite unix - - - - - trivial-rewrite bounce unix - - - - 0 bounce defer unix - - - - 0 bounce trace unix - - - - 0 bounce verify unix - - - - 1 verify flush unix n - - 1000? 0 flush proxymap unix - - n - - proxymap smtp unix - - - - - smtp # When relaying mail as backup MX, disable fallback_relay to avoid MX loops relay unix - - - - - smtp -o fallback_relay= # -o smtp_helo_timeout=5 -o smtp_connect_timeout=5 showq unix n - - - - showq error unix - - - - - error discard unix - - - - - discard local unix - n n - - local virtual unix - n n - - virtual lmtp unix - - - - - lmtp anvil unix - - - - 1 anvil scache unix - - - - 1 scache I think the most important line here was: smtp inet n - - - - smtpd After this line, my postfix listened on port 25. Before that he was only running but not listening.
  13. [solved] Why are the configs not complete

    i am using Froxlor with - Debian Lenny 5 - Apache 2 - Postfix - Dovecot - Mysql I had the same problem with exim4 for a half year where the smtp server didnt start. Only with this Code i could run my smtp server ( Didnt know if everything is ok in this configuration but with this my smtp port 25 is shown in netstat -tapn : # Add this lines to be able to use dovecot as delivery agent # Dovecot LDA dovecot unix - n n - - pipe flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -d ${recipient} smtp inet n - - - - smtpd #submission inet n - - - - smtpd # -o smtpd_enforce_tls=yes # -o smtpd_sasl_auth_enable=yes # -o smtpd_client_restrictions=permit_sasl_authenticated,reject #smtps inet n - - - - smtpd # -o smtpd_tls_wrappermode=yes # -o smtpd_sasl_auth_enable=yes # -o smtpd_client_restrictions=permit_sasl_authenticated,reject #628 inet n - - - - qmqpd pickup fifo n - - 60 1 pickup cleanup unix n - - - 0 cleanup qmgr fifo n - n 300 1 qmgr #qmgr fifo n - - 300 1 oqmgr tlsmgr unix - - - 1000? 1 tlsmgr rewrite unix - - - - - trivial-rewrite bounce unix - - - - 0 bounce defer unix - - - - 0 bounce trace unix - - - - 0 bounce verify unix - - - - 1 verify flush unix n - - 1000? 0 flush proxymap unix - - n - - proxymap smtp unix - - - - - smtp # When relaying mail as backup MX, disable fallback_relay to avoid MX loops relay unix - - - - - smtp -o fallback_relay= # -o smtp_helo_timeout=5 -o smtp_connect_timeout=5 showq unix n - - - - showq error unix - - - - - error discard unix - - - - - discard local unix - n n - - local virtual unix - n n - - virtual lmtp unix - - - - - lmtp anvil unix - - - - 1 anvil scache unix - - - - 1 scache
  14. Hi, after 4 Days i could solve my Mailserverproblem. The Problem was, that my smtp server didnt work ( postfix with dovecot ), so i searched with google for the solution and find out, that the /etc/init.d/master.cf file was incomplete ( i followed the froxlor configuration steps ). And there was no hint , that i have to edit the master.cf in postfix for getting the smtp server listening on port 25. It would be really n1 if you could change this problem or could tell me why the default config is without the smtp settings. Sorry for my bad englisch ;-)
  15. Hi i installed Froxlor as my Server Control Panel with Postfix and Dovecot. Now i installed roundcube but i cant connect to dovecot, everytime it failes ... here is my dovecot log ( the username and password are defently right .. ) Sep 19 11:13:44 euve10672 dovecot: auth-worker(default): pam(myusername@mydomain.org,127.0.0.1): lookup service=dovecot Sep 19 11:13:44 euve10672 dovecot: auth-worker(default): pam(myusername@mydomain.org,127.0.0.1): #1/1 style=1 msg=Password: Sep 19 11:13:44 euve10672 dovecot: auth(default): client in: AUTH^I1^IPLAIN^Iservice=imap^Isecured^Ilip=127.0.0.1^Irip=127.0.0.1^Ilport=143^Irport=36160^Iresp=dHVyYm9Ad2hpdGVyYWJiaXRob2xlLm9yZwB0dXJib0B3aGl0ZXJhYmJpdGhvbGUub3JnAGM0czVpMDIz Sep 19 11:13:45 euve10672 dovecot: auth(default): new auth connection: pid=7770 Sep 19 11:13:46 euve10672 dovecot: auth-worker(default): pam(myusername@mydomain.org,127.0.0.1): pam_authenticate() failed: Authentication failure (password mismatch?) (given password: mypasswort) Sep 19 11:13:48 euve10672 dovecot: auth(default): client out: FAIL^I1^Iuser=myusername@mydomain.org Sep 19 11:13:53 euve10672 dovecot: imap-login: Aborted login (auth failed, 1 attempts): user=<myusername@mydomain.org>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured Can anyone help me, i cant figure it out :-(
×