Jump to content
Froxlor Forum

irisdina

Members
  • Content count

    22
  • Joined

  • Last visited

  • Days Won

    10

irisdina last won the day on August 13

irisdina had the most liked content!

Community Reputation

1 Neutral

About irisdina

  • Rank
    Froxie

Recent Profile Visitors

1157 profile views
  1. Redirect Schleife

    Zeig mal pls deine vhost conf und liste mal auf wie du deine certs erstellt hast.
  2. Wenn du es zu 100% nach dem Howto gemacht hast, sollte dies nicht auftreten mit MariaDB, da bei der Ubu Anleitung die 10.2 drin ist. Das mit dem error 502 passiert eigentlich nur, wenn man vergisst den Froxlor ordner die rechte vorher von www-data zu geben, dann passiert dies. Habe die zwei anmerkungen ins Howto aufgenommen, danke.
  3. Howto komplett überarbeitet. hinzugekommen: - Ubuntu Artful - PHP-FPM - SSL
  4. Email mit eigener Domain einrichten

    Dein Domain muss in Frox eingetragen sein von einem Admin, dann kannst du erst die Domain in deinem Kunden Account sehen/Benutzen. Laut dem Hinweis in deinem Ersten Post, deutet alles darauf hin, das du nur eine Mail Domain + Mail Space gekauft hast, sprich du kannst keine MX-Einstellungen vor nehmen. Und seit wann ist auf einem Mail Space Frox installiert, wäre mir neu... lasse mich aber gerne überraschen
  5. Install stretch/debian9

    Steht doch in der Meldung, er kann nicht auf die DBs zugreifen, weil die PW's nicht stimmen oder nicht gesetzt wurden während dem install.
  6. Mehrere VHOSTs mit einer IP Adresse

    Verstehe irgendwie dein Problem nicht genau... Machst du die Certs über Letscrypt oder einen anderen Anbieter? Habe selbst x Domains auf einer IP laufen und alle haben keine Probleme mit den Certs.
  7. Froxlor benötigt php5?

    Geh zu IPs und Ports >> IP/Port hinzufügen und setze im ersten Feld deine IP vom Server und im zweiten bei Port: 80 rein. Wenn du SSL benutzen willst, machst du dass gleiche wie oben, nur anstatt Port 80 trägst du 443 ein und unten bei Webserver-SSL-Konfiguration den hacken bei Ist dies ein SSL-Port?: rein
  8. In den Alten Versionen gab es ein Problem/Bug/Feature, dass man kein PW ändern konnte bzw. bei dem Install setzen konnte und später erst nervig ein PW einstellen konnte. will man doch hoffen, das Froxlor nichts dagegen hat
  9. Debian (9) Stretch 1. sudo apt install curl wget apt-transport-https dirmngr git 1a. Keys install wget http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/deb-multimedia-keyring_2016.8.1_all.deb && dpkg -i deb-multimedia-keyring_2016.8.1_all.deb && wget https://nginx.org/keys/nginx_signing.key && apt-key add nginx_signing.key && curl https://packages.sury.org/php/apt.gpg | apt-key add - 1b. Source List ( nano /etc/apt/source.list ) 1c. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 2. MariaDB Install use sudo command for install MariaDB! sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.1 Workround (Optional) when you MariaDB install with not sudo command, have you Problems with your Froxlor install. you can use this workround: (Thanks J-BBB for this Note ) mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 3. nginx Install sudo apt install nginx 3a. mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf 3c. service nginx restart 4. PHP install sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 4a. service nginx restart service php7.1-fpm restart Ubuntu 17.10 (Artful) 1. sudo apt install curl wget apt-transport-https dirmngr git software-properties-common python-software-properties 1b. Source List ( nano /etc/apt/source.list ) 1c. Key Install sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xF1656F24C74CD1D8 1d. PPA (https://askubuntu.com/questions/4983/what-are-ppas-and-how-do-i-use-them/4987#4987) sudo add-apt-repository ppa:ondrej/nginx-mainline sudo add-apt-repository ppa:ondrej/php 2. sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 3. MariaDB Install sudo apt install mariadb-server mariadb-client 3a. MariaDB 10.1 Workround (Optional) when you MariaDB install with not sudo command, have you Problems with your Froxlor install. you can use this workround: (Thanks J-BBB for this Note ) mysql -u root MariaDB [(none)]> update mysql.user set password=password('your PASS') where user='root'; MariaDB [(none)]> update mysql.user set plugin='' where user='root'; MariaDB [(none)]> flush privileges; 4. nginx Install sudo apt install nginx 4a. nano /etc/nginx/nginx.conf 4b. service nginx restart 5. PHP install sudo apt update && sudo apt install php7.1-mysql php7.1-curl php7.1-gd php7.1-intl php-pear php-imagick php7.1-imap php7.1-mcrypt php-memcache php7.1-memcached php7.1-pspell php7.1-recode php7.1-sqlite3 php7.1-tidy php7.1-xmlrpc php7.1-xsl php7.1-mbstring php-gettext php7.1-fpm php7.1-cli php7.1-cgi php-bcmath php-zip 5a. service nginx restart service php7.1-fpm restart Froxlor Install Git version 1. vhost nano /etc/nginx/sites-enabled/frox 1a. service nginx restart 2. Change dir cd /usr/share/nginx/ 2a. Froxlor git Load sudo git clone https://github.com/Froxlor/Froxlor.git 2a. Folder Rename mv /usr/share/nginx/Froxlor /usr/share/nginx/your Folder Name 2b. User/Group Change for Froxlor Folder sudo chown -HR www-data:www-data Your Froxlor Folder 3. Browser Open http://your-SubDomain/your-Frolxor-Folder 3c. Change Your DB/User Name for Froxlor Install Froxlor finish 3d. Move userdata (Optional) mv /tmp/userdata.inc.php /usr/share/nginx/Your Froxlor Folder/lib/ 4. vhost delete rm /etc/nginx/site-enable/frox don't restart nginx! Froxlor Settings 1. cronjob nano /etc/cron.d/froxlor # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /usr/share/nginx/your Froxlor Folder/scripts/froxlor_master_cronjob.php chmod 0640 "/etc/cron.d/froxlor" chown root:0 "/etc/cron.d/froxlor" service cron restart Froxlor Panel 1. Change your PHP-Backend Settings Settings > Webserver settings > Nginx PHP backend from 127.0.0.1:8888 to unix:/run/php/php7.1-fpm.sock 2. Make Folder and Change chmod mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /etc/nginx/sites-enabled/ chown root:0 /etc/nginx/sites-enabled/ chmod 0600 /etc/nginx/sites-enabled/ mkdir -p /home/customers/webs/ mkdir -p /var/customers/logs/ mkdir -p /var/customers/tmp chmod 1777 /var/customers/tmp service nginx restart 2a. IPs and Ports > Add IP/Port 2a(1), SSL Port Wait 5min for Autimatic Start Froxlor's cronjob Optional PHP-FPM activate 1. User/Group add sudo adduser froxlorlocal --disabled-password --no-create-home 2. libnss-extrausers install sudo apt install install nscd libnss-extrausers mkdir -p /var/lib/extrausers touch /var/lib/extrausers/{passwd,group,shadow} mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql 3. Settings > PHP-FPM > Activated: Change from NO to YES 3a. Settings > PHP-FPM > Settings Change > Configuration directory of php-fpm to /etc/php/7.1/fpm/pool.d/ Change > php-fpm restart command to /etc/init.d/php7.1-fpm restart or service php7.1-fpm restart 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost 3c. When you 502 error on Nginx have, use this command (Optional) (Thanks lino16 for this Note) sudo usermod -a -G www-data froxlorlocal SSL / Let's Encrypt activate 1. Create Folder on nginx mkdir /etc/nginx/ssl cd /etc/nginx/ssl 1a. Create SSL File sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1b. create acme.conf nano /etc/nginx/acme.conf location /.well-known/acme-challenge { alias /usr/share/nginx/Your Froxlor Folder/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } } 2. Open your Froxlor Panel Settings> SSL > Activated: Change from NO to YES 2a. Settings > SSL > Settings Change your path from your certificate / Keyfile Path to the SSL certificate insert /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile insert /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings Activate > Enable Let's Encrypt 2c. Activate on Settings > Froxlor VirtualHost settings - Enable Let's Encrypt for the froxlor vhost - Enable SSL-redirect for the froxlor vhost - HTTP Strict Transport Security (HSTS) - Include HSTS for any subdomain
  10. keine auto certs

    Für die letzte Domain wurde dass Cert nun auch erstellt, kA ob es jetzt an den Nameservern lag oder nicht. Aber jetzt geht alles wieder.
  11. Froxlor benötigt php5?

    Bei älteren versionen gab es ein problem, dass man kein Root PW für SQL setzen konnte. Weiß jetzt auch nicht welche vers. Stretch benutzt, aber er könnte mal: Und dann: Wichtig aber, bei einem neu install, vorher die DB's per dump/phpmyadmin etc. sichern. Den benutzer für Frox kann man manuell wieder anlegen, Daten sind ja in dem /lib/ ordner drin. in die source.list eintragen und diese vers. installieren, da kommt die abfrage nach dem PW oder probieren sein jetziges PW zu ändern, https://www.digitalocean.com/community/tutorials/how-to-reset-your-mysql-or-mariadb-root-password *edit* Sehe gerade, dass stretch 10.1 benutzt, daher entweder die source.list ändern und reconfig/neu-install machen oder dass pw ändern/festlegen
  12. Froxlor benötigt php5?

    Ist dass zufällig MariaDB?
  13. keine auto certs

    Ja, lösen alle auf die IP auf. Hab jetzt bei der DE Domain die Nameserver erneuert, vllt hilft dies.
  14. keine auto certs

    Ja, die Test Datei kann ich aufrufen. Heute Nacht, hat er auch zwei weitere Certs erstellt, fehlt aktuell nur noch eine DE Domain, wo dass fehlt.
  15. keine auto certs

    Hab es jetzt noch mal probier, bei 3 von 6 erstellt er mir die certs, bei den anderen 3 nicht, kA why er dies nicht macht. Hab auch die neuste git vers. gezogen. Angefangen hatte es vor einigen Tagen mit der .eu Domain, mittlerweile sind eine .com und eine .de betroffen davon. Manuell kann ich die certs erstellen, nur über frox macht er dies nicht.
×