Jump to content
Froxlor Forum

mrmanuel

Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About mrmanuel

  • Rank
    Newbie
  1. Dann probier ich das mal. Bei Interesse kann ich es dann auch gerne hier posten, könnte nur etwas dauern 😀
  2. Ok, danke. Werden die Passwörter für die Datenbanken von Froxlor auch irgendwo gespeichert oder werden diese nur direkt in die mysql Datenbank mit Benutzer geschrieben?
  3. Hallo liebe Community, ist es möglich die Datenbanken, welche über die Froxlor GUI angelegt wurden und in der Froxlor Datenbank "panel_databases" sind über einen Befehl erneut anlegen zu lassen, wenn diese z.B. nicht vorhanden oder gelöscht sind? Hintergrund ist, dass ich einen von dritten gemanagten vServer mit einer Froxlor Installation habe. Dort habe ich mit einem Benutzer Lesezugriff auf alle Datenbanken sowie alle Ordner unter /var/customers/webs. Nun würde ich gerne einen Failover Server haben (Loadbalancer im Failover Modus schaltet dann automatisch um), falls der gemanagte Server Probleme hat, was ich schon öfters hatte. Hierfür sind mir nur die Websites mit Datenbanken wichtig. Die Froxlor Datenbank wird vom gemanagten Server zum failover Server synchronisiert. Dadurch werden auch alle vHosts und Ordner unter /var/customers/webs korrekt angelegt. Für die Daten unter /var/customers/ habe ich bereits einen Synchronisationstask auf dem Failoverserver eingerichtet. Nun habe ich eben das Problem, dass sich die Datenbanken nicht automatisch mit den zugewiesenen Benutzern und identischen Passwörtern anlegen. Habt ihr eventuell einen komplett anderen Ansatz? Den gemanagten Server würde ich gerne behalten, da ich kein Webhosting Profi bin und auf das Thema Sicherheit nicht verzichten möchte. Liebe Grüße, Mr. Manuel
  4. Bei der Kontrolle, ob fcgid mit dem richtigen Benutzer ausgeführt wird, hatte ich fälschlicherweise kein PHP Script ausgeführt, wodurch der richtige Prozess nicht gestartet wurde. Ich bin davon ausgegangen, dass mindestens ein Prozess pro Kunde standardmäßig läuft, dem ist jedoch nicht so. Somit passt alles, vielen Dank für deine Hilfe
  5. Ja genau. Ansonsten probier ich mal den Server neu zu installieren, vielleicht habe ich was falsch gemacht.
  6. Beim Durchlaufen des Konfigurators habe ich am Ende die Konfiguration ausgeführt. Habe es gerade auch nochmal gemacht (wizard-log.txt). Die Kunden Error Logs unter "/var/customers/logs" sind leer. wizard-log.txt
  7. Ja genau. Ich habe die Konfiguration mittels php /var/www/html/froxlor//install/scripts/config-services.php --froxlor-dir=/var/www/html/froxlor/ --create durchgeführt und bin nach Abschluss und Neustart des Servers die Konfiguration für Webserver und fcgid durchgegangen. Die Einstellungen unter Froxlor -> System -> Settings -> FCGID wurden auf den Standardeinstellungen belassen. Apache startet neu mit folgenden Hinweisen im Apache Error Log: # /etc/init.d/apache2 restart [ ok ] Restarting apache2 (via systemctl): apache2.service. Apache Error Log [Sat Dec 28 12:04:16.956910 2019] [suexec:notice] [pid 12002] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec) [Sat Dec 28 12:04:17.044622 2019] [http2:warn] [pid 12003] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive. [Sat Dec 28 12:04:17.070262 2019] [mpm_prefork:notice] [pid 12003] AH00163: Apache/2.4.38 (Debian) mod_fcgid/2.3.9 OpenSSL/1.1.1d configured -- resuming normal operations [Sat Dec 28 12:04:17.070338 2019] [core:notice] [pid 12003] AH00094: Command line: '/usr/sbin/apache2' Geladene Apache Module (modules.txt). Eine generierte vHost config sieht so aus (vhost.txt) Leider konnte ich es nicht direkt einfügen, da es mir den Fehler gab, dass es Spam sei... Vielen Dank! vhost.txt modules.txt
  8. Hallo, ich habe mir gerade einen neuen Server mit Debian 10 (Buster) aufgesetzt und Froxlor nach der Anleitung Install froxlor on debian installiert. Nachdem ich nun die Anleitung (apache2 with fcgid) abgearbeitet habe und das PHP Modul abschalte (a2dismodphp7.3), wird kein PHP Code mehr verarbeitet. Zudem sehe ich auch keine apache2 Prozesse pro Kunden sondern nur mit www-data. Bei der Konfiguration habe ich folgendes ausgewählt: Distribution: Debian Buster (10.x) Service: Webserver (HTTP) --> Daemon: Apache 2.4 (default) Service: Mailserver (SMTP) --> Daemon: Postfix with dovecot (default) Service: Mailserver (IMAP/POP3) --> Daemon: Dovecot with postfix (default) Service: FTP-server --> Daemon: ProFTPd (default) Service: Other (System) --> Daemon: Cronjob for Froxlor; libnss-extrausers; Logrotate; FCGID libnss-extrausers habe ich erst im Nachinein installiert, da ich es nicht geschafft habe die Installation von libnss-mysql anhand der Anleitung apache2 with fcgid zu installieren. Nach dem aktivieren von libnss-extrausers und einem Neustart wurden die Benutzer unter /var/customers/web korrekt angezeigt. Da ich euch nicht mit Logs überhäufen wollte sagt bitte einfach was ihr braucht, dann stell ich es rein. Vielen Dank im Voraus! Liebe Grüße, Mr. Manuel
×
×
  • Create New...