Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
Pagefreak

[solved] Froxlor E-Mail konfiguration - Roundcube

Question

Hallo liebe Community,

 

Ich habe seit ein paar Tagen Froxlor auf meinem Debian7 vServer laufen. Bisher klappte die Einrichung ganz gut, bis ich zu den E-Mails kam. Ich habe mir Roundcube installiert und als Mail Server mail.meinedomain.de und smtp.meinedomain.de ausprobiert keines der beiden klappt. Wenn ich mich bei Roundcube einloggen will kommt: "Verbindung zum Speicherserver fehlgeschlagen!". Kann mir jemand sagen was ich flasch mache/gemacht habe oder mir vllt. sogar Roundcube einrichten?

 

Ich habe die Nameserver der Domain auf Cloudflare geleitet und bei Cloudflare meine Serverdaten eingetragen. Hier ein kleines Bild:

post-8314-0-11427100-1416238056_thumb.png

 

Roundcube Log:

[17-Nov-2014 14:45:48 +0100]: IMAP Error: Login failed for mail@meinedomain.de from 12.123.12.123.. LOGIN: Fatal error: No such file or directory: No such file or directory in /var/www/webmail/program/lib/Roundcube/rcube_imap.php on line 184 (POST /webmail/?_task=login?_task=login&_action=login)

Ich hoffe ihr k?nnt mir helfen! Vielen Dank im Vorraus! LG Jakob

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

Wenn roundcube auf dem Server ist wo auch froxlor installiert ist (sollte) dann nimm in der roundcube config doch einfach "localhost". Ansonsten hilft nur: mail-logs und config pr?fen

Share this post


Link to post
Share on other sites

Wenn roundcube auf dem Server ist wo auch froxlor installiert ist (sollte) dann nimm in der roundcube config doch einfach "localhost". Ansonsten hilft nur: mail-logs und config pr?fen

Ohh, was ich vergessen habe, es kommen auch bei Thunderbird unter den Standardeinstellungen keine Mails an! Ich werde deinem Tipp aber erstmal folgen und dann mal gucken

Share this post


Link to post
Share on other sites

Warum nicht dovecot was froxlor als default empfiehlt? Courier ist alt und scheisse...

Share this post


Link to post
Share on other sites

Warum nicht dovecot was froxlor als default empfiehlt? Courier ist alt und scheisse...

OK. werde ich mal versuchen! Schonmal Vielen Dank!

Share this post


Link to post
Share on other sites

Moin,

 

ich habe jetzt Dovecot installiert was allerdings nichts gen?tzt hat! Habe auch alle noch mal neugestartet. Doch beim erstellen einer neuen E-Mail kam: Es konnte keine E-Mail an "....." gesendet werden. Und bei roundcube kommt immer noch die selbe Meldung ;(. F?llt euch noch iwas ein oder mache ich vllt. etwas Falsch!?

 

Sch?nen Abend allerseits   Jakob

Share this post


Link to post
Share on other sites

Dovecot hat nichts mit dem Versenden von Mails zu tun. Daf?r ist Postfix z. B. zust?ndig.

Da steht bei der Auswahl auch: Postfix Dovecot.... HILFE!

Share this post


Link to post
Share on other sites

Na weil die postfix config davon abh?ngt ob du Courier oder Dovecot nutzt. Du hast doch vorher die Kategorie SMTP gew?hlt... Das kann nur postfix sein

Share this post


Link to post
Share on other sites

Na weil die postfix config davon abh?ngt ob du Courier oder Dovecot nutzt. Du hast doch vorher die Kategorie SMTP gew?hlt... Das kann nur postfix sein

Die Config scheint die gleiche zu sein! Und ich weis jetzt leider nicht genau was ich machen soll oder tun kann das meine E-Mail adressen wieder gehen. Ich brauche die leider ziemlich dringend! Kann mir vllt. jemand eine Schritt f?r Schritt Anleitung geben :( ? Tut mir echt leid aber ich bin auf dem gebiet ein totaler newbie.

Share this post


Link to post
Share on other sites

Dann kann ich nur wiederholen: configs und settings pr?fen

In dem RoundCube Log steht was neues drin!

 

Log:

[19-Nov-2014 19:30:51 +0100]: IMAP Error: Login failed for mail@domain.de from 89.123.123.123. AUTHENTICATE PLAIN: Authentication failed. in /var/www/webmail/program/lib/Roundcube/rcube_imap.php on line 184 (POST /webmail/?_task=login?_task=login&_action=login)

Share this post


Link to post
Share on other sites

Roundcube ist doch nicht das Mass aller Dinge. Die Logfiles /var/log/mail.* sind die richtige Quelle f?r die Fehleranalyse. Vor allem wenn auch Thunderbird oder Outlook nicht funktionieren.

Share this post


Link to post
Share on other sites

Hallo,

 

vielen Dank f?r euere Tipps! Ich habe jetzt Froxlor nochmal neu installiert und alles neu konfiguriert. Und es kommen jetzt auch Mails an und ich kann Mails senden! Zumindest in Mozilla Thunderbird. Doch in Roundcube kommen zwar Mails an doch wenn ich Mails senden will kommt eine Fehlermeldung! Im Log steht folgendes:

[21-Nov-2014 19:22:31 +0100]: SMTP Error: SMTP error: Failed to add recipient 'hiller_jakob@web.de' in /var/www/webmail/program/lib/Roundcube/rcube.php on line 1505 (POST /webmail/?_task=mail&_unlock=loading1416594181332&_lang=de_DE&_framed=1?_task=mail&_action=send)

Wisst ihr vllt. etwas, was man machen k?nnte?

 

LG und Vielen Dank     Jakob

Share this post


Link to post
Share on other sites

Moin,

 

das Thema hat sich erledigt! Vielen Dank f?r eure Antworten! Ich habe Froxlor jetzt letzdendlich nochmal neu installiert und konfiguriert und jetzt funktioniert alles. Sowohl Mails ?ber Thunderbird als auch Roundcube.

 

LG  Jakob

 

#threadclosed

Share this post


Link to post
Share on other sites

  • Similar Content

    • By AndrewL
      Hello,

      I have installed the latest version of Froxlor (0.10.12) on my Ubuntu 18.04 server and after tweaking the settings and running the configuration, everything is working beautifully.
      However, I noticed that there are options for specifying URLs for PHPMyAdmin, WebMail and WebFTP within the Panel Settings section but I can't seem to figure out how to integrate the three with Froxlor.

      Right now, I want to integrate Roundcube as my server's webmail client and any recommended client for webftp, but I'm not so sure how to go about it? What changes should I make to my server or to my Froxlor settings?

      I have already run the configuration for FTP-Server(Proftpd), Mailserver(SMTP) as well as Mailserver(IMAP/POP3) and have set the "FTP Server" to Proftpd in the FTP Server settings section and the  "Type of the Mail Delivery Server" and "Type of the Mail Transfer Agent" to Dovecot and Postfix respectively in the Mailserver settings section.

      Regards.
    • By Pro-Webs
      Hallo,
      ich bin gerade dabei einen Shopware Shop v.5 unter nginx mit froxlor einzurichten.
      Das ist jedoch relativ problematisch.
      Aktuell habe ich im Froxlor folgende vHost Einstellung zur Domain:
      location @php { fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location / { index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } location ~ \.php$ { try_files $uri =404; include /etc/nginx/fastcgi_params; fastcgi_pass 127.0.0.1:9000; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param HTTPS $fastcgi_https; fastcgi_param HTTP_AUTHORIZATION $http_authorization; } Diese Einstellung führt zu einem 500 error.
      Meine 35_froxlor_ssl_vhost_studio-ausruestung.de.conf sieht damit leider wie folgt aus:
      # 35_froxlor_ssl_vhost_studio-ausruestung.de.conf # Created 02.01.2020 14:30 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 91.250.82.51:443 ssl; server_name studio-ausruestung.de www.studio-ausruestung.de xn--studio-ausrstung-tzb.de *.xn--studio-ausrstung-tzb.de studioausruestung.de *.studioausruestung.de priolite-shop.com www.priolite-shop.com sirui-shop.de www.sirui-shop.de shooting-gutschein.de *.shooting-gutschein.de shooting-gutscheine.de *.shooting-gutscheine.de; ssl_protocols TLSv1 TLSv1.2; ssl_ciphers ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH; ssl_ecdh_curve secp384r1; ssl_prefer_server_ciphers on; ssl_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; ssl_certificate_key /etc/ssl/froxlor-custom/studio-ausruestung.de.key; add_header Strict-Transport-Security "max-age=0"; ssl_stapling on; ssl_stapling_verify on; ssl_trusted_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; include /etc/apache2/conf-enabled/acme.conf; access_log /var/customers/logs/klimek-studio-ausruestung.de-access.log combined; error_log /var/customers/logs/klimek-studio-ausruestung.de-error.log error; root /var/customers/webs/klimek/studio-ausruestung.de/shopware/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/klimek/webalizer/studio-ausruestung.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/htpasswd/1-c3d3ffdab2b8342809d19524c21b98c1.htpasswd; } location ~ \.php { try_files /333c3697df6a41bcc37bccd05271f644.htm @php; } location @php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_index index.php; fastcgi_param HTTPS on; fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } } Man bemerkt u.a. das einige Konfigurationen doppelt vorhanden sind, da floxlor diese auch selbst generiert. Das könnte natürlich schon die Ursache des Fehler sein. Ich weiß nur leider nicht, wie ich es "besser" lösen kann.
      Die original .htaccess für den appache sieht folgende Konfiguration vor:
      php_value memory_limit 1024M php_value max_execution_time 600 php_value upload_max_filesize 20M php_value post_max_size 20M <IfModule mod_rewrite.c> RewriteEngine on #RewriteBase /shopware/ # Https config for the backend #RewriteCond %{HTTPS} !=on #RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] RewriteRule shopware.dll shopware.php RewriteRule files/documents/.* engine [NC,L] RewriteRule backend/media/(.*) media/$1 [NC,L] RewriteRule custom/.*(config|menu|services|plugin)\.xml$ ./shopware.php?controller=Error&action=pageNotFoundError [NC,L] RewriteCond %{REQUEST_URI} !(\/(engine|files|templates|themes|web)\/) RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/) RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ shopware.php [PT,L,QSA] # Fix missing authorization-header on fast_cgi installations RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] </IfModule> <IfModule mod_alias.c> # Restrict access to VCS directories RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$) # Restrict access to root folder files RedirectMatch 404 /(autoload\.php|composer\.(json|lock|phar)|README\.md|UPGRADE-(.*)\.md|CONTRIBUTING\.md|eula.*\.txt|\.gitignore|.*\.dist|\.env.*)$ # Restrict access to shop configs files RedirectMatch 404 /(web\/cache\/(config_\d+\.json|all.less))$ # Restrict access to theme configurations RedirectMatch 404 /themes/(.*)(.*\.lock|package\.json|\.gitignore|Gruntfile\.js|all\.less|node_modules\/.*)$ </IfModule> # Staging environment #SetEnvIf Host "staging.test.shopware.in" SHOPWARE_ENV=staging # Development environment #SetEnvIf Host "dev.shopware.in" SHOPWARE_ENV=dev #SetEnv SHOPWARE_ENV dev DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration <Files ~ "\.(tpl|yml|ini)$"> # Deny all requests from Apache 2.4+. <IfModule mod_authz_core.c> Require all denied </IfModule> # Deny all requests from Apache 2.0-2.2. <IfModule !mod_authz_core.c> Deny from all </IfModule> </Files> # Enable gzip compression <IfModule mod_deflate.c> AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json application/font-woff application/font-woff2 image/svg+xml </IfModule> <Files ~ "\.(jpe?g|png|gif|css|js|woff|woff2|ttf|svg|webp|eot|ico)$"> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 month" </IfModule> <IfModule mod_headers.c> Header append Cache-Control "public" Header unset ETag </IfModule> FileETag None </Files> # Match generated files like: # 1429684458_t22_s1.css # 1429684458_t22_s1.js <FilesMatch "([0-9]{10})_(.+)\.(js|css)$"> <ifModule mod_headers.c> Header set Cache-Control "max-age=31536000, public" </ifModule> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 year" </IfModule> </FilesMatch> # Disables auto directory index <IfModule mod_autoindex.c> Options -Indexes </IfModule> <IfModule mod_negotiation.c> Options -MultiViews </IfModule> <IfModule mod_php5.c> # php_value memory_limit 256M # php_value max_execution_time 120 # php_value upload_max_filesize 20M php_flag phar.readonly off php_flag magic_quotes_gpc off php_flag session.auto_start off php_flag suhosin.session.cryptua off php_flag zend.ze1_compatibility_mode off php_value always_populate_raw_post_data -1 </IfModule> # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php <IfModule mod_headers.c> Header append X-Frame-Options SAMEORIGIN </IfModule>  
      Für Ideen und Vorschläge wäre ich wie immer sehr dankbar
    • By nisamudeen97
      Hi,
      Our froxlor server is behiend NAT and it uses the local IP  192.168.73.40.  We have enabled letsencrypt module in froxlor and tried validating SSL for a domain in the server.  SSL generation is getting failed with 403 error.  See the debug log information.      Replaced domain name and main IP.    Can any one help me regarding the issue.
       
      [information] Updating Let's Encrypt certificates [information] Updating domain-name.com [information] Adding SAN entry: domain-name.com [information] Adding SAN entry: www.domain-name.com [information] letsencrypt-v2 Using 'https://acme-v02.api.letsencrypt.org' to generate certificate [information] letsencrypt-v2 Using existing account key [information] letsencrypt-v2 Starting certificate generation process for domains [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/new-order [information] letsencrypt-v2 Requesting challenge for domain-name.com [information] letsencrypt-v2 Got challenge token for domain-name.com [information] letsencrypt-v2 Token for domain-name.com saved at /var/www/froxlor/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k and should be available at http://domain-name.com/.well-known/acme-challenge/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [information] letsencrypt-v2 Sending request to challenge [information] letsencrypt-v2 Sending signed request to https://acme-v02.api.letsencrypt.org/acme/chall-v3/803008408/k46kFQ [information] letsencrypt-v2 Verification pending, sleeping 1s [information] letsencrypt-v2 Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for domain-name.com: Verification ended with error: {"type":"http-01","status":"invalid","error":{"type":"urn:ietf:params:acme:error:unauthorized","detail":"Invalid response from http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k [212.224.xxx.xxx]: \"<!DOCTYPE html>\\n<html lang=\\\"en-CA\\\" class=\\\"html_stretched responsive av-preloader-active av-preloader-enabled av-default-lightbox\"","status":403},"url":"https:\/\/acme-v02.api.letsencrypt.org\/acme\/chall-v3\/803008408\/k46kFQ","token":"vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","validationRecord":[{"url":"http:\/\/www.domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"www.domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"},{"url":"http:\/\/domain-name.com\/.well-known\/acme-challenge\/vkTyLi2ApfP9O9ou8GyDz6WQmB--HP4ULnU0fhjXI0k","hostname":"domain-name.com","port":"80","addressesResolved":["212.224.xxx.xxx"],"addressUsed":"212.224.xxx.xxx"}]} [information] Let's Encrypt certificates have been updated  
    • By Jason Szymanski
      Hallo,
       
      ich habe leider ein Problem mit Froxlor.
      Zu meiner Situation: Froxlor läuft auf der Subdomain web01.meinedomain.net
      Jetzt möchte ich die Domain aber auch noch weiter Nutzen und habe mich daher als Kunde angelegt und die Domain meineDomain.net als Domain hinzugefügt.
      Dort kann ich auch weitere Subdomains hinzufügen. Das scheint soweit auch zu klappen ich sehe das er VHosts anlegt und auch die Verzeichnisse im FTP anlegt.
      Wenn ich jetzt allerdings versuche auf meinedomain.net oder eine andere Subdomain unter dieser Domain zuzugreifen leitet er mich auf web01.meinedomain.net
      Ich habe mich schon in den Einstellungen umgeschaut konnte aber keine entsprechende Einstellung finden an der das liegen könnte.
      Wie verhindere ich also das er mich auf Froxlor umleitet?
       
      Mit Freundlichen Grüßen
      Jason Szymanski
    • By nisamudeen97
      Hi,
      Wile doing migration of email accounts from one froxlor server to another I have noting some thing.   Expecting some clarification on this.  As we all know emails are normally stored in the location "/var/customers/mail/user/domain.com/user/Maildir/" .   I create email accounts via froxlor panel and copy the email files directly via scp or rsync from old server to new.  The strange thing I have noticed is it is not coping custom folders and its emails like we have in source.  
      The solution I have found for this is to use imapsync between old and new.  imapsync is preserving custom folders like as it is in source.    Does it mean custom folder settings are stored somewhere else?  How we can preserve it and copy emails manually?
×
×
  • Create New...