Jump to content
Froxlor Forum
  • 0
AndrewL

How to integrate a webmail client and a webftp client to Froxlor

Question

Hello,

I have installed the latest version of Froxlor (0.10.12) on my Ubuntu 18.04 server and after tweaking the settings and running the configuration, everything is working beautifully.

However, I noticed that there are options for specifying URLs for PHPMyAdmin, WebMail and WebFTP within the Panel Settings section but I can't seem to figure out how to integrate the three with Froxlor.

Right now, I want to integrate Roundcube as my server's webmail client and any recommended client for webftp, but I'm not so sure how to go about it? What changes should I make to my server or to my Froxlor settings?

I have already run the configuration for FTP-Server(Proftpd), Mailserver(SMTP) as well as Mailserver(IMAP/POP3) and have set the "FTP Server" to Proftpd in the FTP Server settings section and the  "Type of the Mail Delivery Server" and "Type of the Mail Transfer Agent" to Dovecot and Postfix respectively in the Mailserver settings section.

Regards.

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 0

Froxlor does not include any webmail or similar. You can specify the URL to where you installed such software for your customers so they have a link in their customers menu 

Share this post


Link to post
Share on other sites
  • 0

@d00p Oh, so I just download the client software like roundcube or phpmyadmin and link to it rather than integrating it with Froxlor? But how will roundcube integrate with the mailsettings I have set in the Froxlor settings?

Share this post


Link to post
Share on other sites
  • 0

What settings are you referring to? Roundcube uses IMAP....just configure it according to your Mailserver settings (hostname, ports, etc.) Nothing else is needed

Share this post


Link to post
Share on other sites
  • 0

Submission is not enabled by default, you would need to use port 25 or SSL 465 if enabled and configured

Share this post


Link to post
Share on other sites
  • 0

Following the step-by-step guide for integrating roundcube with froxlor (but for debian) shown here: https://myridia.com/dev_posts/view/1876, I have done everything till stage 8 but I'm not sure what I have to do in stage 9 which says:

Quote

in froxlor>stystem>settings>webserversettings>
add the following to the text box:


Alias /roundcube /var/www/html/roundcubemail

<Directory /var/www/html/roundcubemail/>
    Allow from all
    php_admin_value open_basedir none

    <IfModule mod_php5.c>
      php_admin_flag engine on
      php_value memory_limit 64M
      php_value upload_max_filesize 10M
    </IfModule>
</Directory>

 

Which textbox should I add the above? Shouldn't it be in a `.conf` file inside the `sites-available` folder?

Also, I left the default value for the port number in the config file.

Share this post


Link to post
Share on other sites
  • 0

Well a global alias is one way to do it. You can add those for example to the IP/port -> specialsettings or as said in the Webserver settings into default vhost-settings/default SSL vhost-settings

Share this post


Link to post
Share on other sites
  • 0

So I should paste the Alias line and the Directory block into the default vhost-settings and default SSL vhost-settings and then run the installation?

Share this post


Link to post
Share on other sites
  • 0

 Just try it and check the generated vhosts whether this is what you want or not. As said there are many ways of integrating webmail or similar, that's the (mostly preferred) freedom froxlor gives to the sysadmins.

Share this post


Link to post
Share on other sites
  • 0

@d00p I have tried adding the above code to the "Default vHost-settings for every domain container" in IP/ports for port 80 as well as adding it to the "Default vHost-settings" in Webserver settings as well as created a `roundcube.conf` file inside the `sites-available` folder and none of the above are working. By not working I mean, initializing the installer for roundcube and even though I get a green OK for everything, The send mail test keeps failing and returning a "Failed to connect socket" error. I have deleted the roundcube folder as well as remove the database for roundcube and it's user. I have also removed the above code from every place I added it too. I want to re-install it again but I'm not sure what to do first.

Share this post


Link to post
Share on other sites
  • 0
13 hours ago, AndrewL said:

as well as adding it to the "Default vHost-settings" i

not in BOTH...

13 hours ago, AndrewL said:

as well as created a `roundcube.conf` file inside the `sites-available` folder

even TRIPLE....you sure you know what you are doing?

13 hours ago, AndrewL said:

By not working I mean, initializing the installer for roundcube and even though I get a green OK for everything, The send mail test keeps failing and returning a "Failed to connect socket" error.

So, you are saying, the ALIAS you wanted to setup DOES work, just not roundcube itself!?! Sorry, can't really follow your

13 hours ago, AndrewL said:

I want to re-install it again but I'm not sure what to do first.

Why so complicated?

- Add yourself as customer (if not already done)

- Setup a domain/subdomain as that customer, e.g. webmail.hostname.tld

- Extract roudcube to the customers homedir

- Open domain/subdomain in browser - end of story

Even simpler:

- Extract roundcube to e.g. /var/www/froxlor/webmail

- Open [froxlor-url]/webmail - end of story

Share this post


Link to post
Share on other sites
  • 0

I have just extracted roundcube to /var/www/html/webmail as you said and then run the installer.

In the Create Config section, I set the smtp port to 25 and set the smtp_server to localhost and the test for the SMTP config is working now.

For IMAP, I set the default_host to ssl://localhost (added ssl:// for letsencrypt) and the default_port to 25 like in the SMTP section but the test for the IMAP config failed and return the following error:

NOT OK(Login failed for test@abcxyz.com against localhost from 117.214.36.78. Could not connect to ssl://localhost:25: Unknown reason)

What am I doing wrong now?

Share this post


Link to post
Share on other sites
  • 0

If you use SSL you need to specify the fqdn for which the certificate has been issued not localhost

Share this post


Link to post
Share on other sites
  • 0

I changed the default_host from `ssl://localhost` to `ssl://abc.domainname.com` (abc.domainname.com is the FQDN of the server) just now and rerun the test but the same error pops up. Do I need to change the smtp_server to the FQDN with ssl:// too or should the FQDN be specified just for the IMAP host?

 

Also, I have ran `hostname -f` in the terminal to confirm the FQDN before updating the ssl:// with it.

Share this post


Link to post
Share on other sites
  • 0

When I change the smtp_server from localhost to the FQDN (ssl://vps1.shillongserver.com), the test for SMTP fails again and return the following error:

Trying to send email...
SMTP send:  NOT OK(Connection failed: Failed to connect socket: fsockopen(): unable to connect to ssl://vps1.shillongserver.com:25 (Unknown error))

 

And the IMAP test returns the following:

 

Connecting to ssl://vps1.shillongserver.com...
IMAP connect:  NOT OK(Login failed for test@customerdomain.com against vps1.shillongserver.com from 117.214.36.78. Could not connect to ssl://vps1.shillongserver.com:25: Unknown reason)

 

Share this post


Link to post
Share on other sites
  • 0

Well, is your postfix configured correctly for SSL? Roundcube at the end is only a client...

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, AndrewL said:

I have just extracted roundcube to /var/www/html/webmail as you said and then run the installer.

In the Create Config section, I set the smtp port to 25 and set the smtp_server to localhost and the test for the SMTP config is working now.

For IMAP, I set the default_host to ssl://localhost (added ssl:// for letsencrypt) and the default_port to 25 like in the SMTP section but the test for the IMAP config failed and return the following error:


NOT OK(Login failed for test@abcxyz.com against localhost from 117.214.36.78. Could not connect to ssl://localhost:25: Unknown reason)

What am I doing wrong now?

Wrong? You don't have a clue about configuring a server and you shouldn't do it if you dont know the basics. IMAP is port 143 and not 25.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Shortie said:

You don't have a clue about configuring a server and you shouldn't do it if you dont know the basics.

@Shortie I agree with me not having a clue as I am definitely not comfortable with server administration yet which is why I am trying to set up a small vps myself with the help of communities and forums like this one so I can learn it. The server I'm trying to set basic stuff on is just for learning purposes.

However, I don't agree with "shouldn't do it if you don't know the basics." since everyone doesn't just start off knowing everything they touch a-z.

Just from this thread and another one that I started here itself, I have learnt from @d00p about a lot of "basic stuff" on server administration which would have taken me forever to wrap my head around if I just stick to theoretically learning it or as you said, not do it in the first place.

Thanks for telling me that IMAP is port 143 and not 25 btw. That is yet another thing I just found out from this thread which made me google it and understand it further.

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By oedwards0088
      Hello,
      I am hoping someone on here has experienced an odd issue with SSL/HTTPS when using the webmail URL, in my case, https://my.froxlorserver.com/webmail. I can't prove it for sure however, I believe it is working for some in a different country to me but I can't connect to the above URL using https, it will connect with http on port 80. I get the below error.
      Forbidden You don't have permission to access /webmail on this server. I have confirmed this on different devices using different internet connections and I have cleared the cache/browsing data.
      Using Digicert's tool (https://www.digicert.com/help/) the https://Froxlor admin page comes back as a success with zero issues. If I try https://froxlor/webmail I get the below error message
      Error: my.froxlor.com/webmail is not a fully qualified public domain name or public IP address. The above error message does not make sense as using port 80 I can get to the /webmail page, so the above might be a red herring.
      Has anyone seen this issue?
      Thanks in advance.
    • By tt33tt
      Seit ich mit http://redmine.froxlor.org/projects/froxlor/wiki/FCGID_-_Handbuch fcgid und suexex eingerichtet habe, funktioniert phpmyadmin nicht mehr. Das äußert sich darin, dass ich beim Öffnen von der phpmyadmin-Seite die php-Datei angezeigt bekomme und im Quellcode sogar die php-Befehle stehen. Das bedeutet, dass keine Interpretation stattfindet.
      Muss ich dafür nun auch einen vhost, einen User etc. anlegen?
      Wenn ich +ExecCGI unter Options hineinschreibe, dann kommt die Fehlermeldung: Either all Options must start with + or -, or no Option may.
       
      Meine /etc/apache2/conf.d/phpmyadmin.conf sieht so aus:
      # phpMyAdmin default Apache configuration Alias /phpmyadmin /usr/share/phpmyadmin <Directory /usr/share/phpmyadmin>     Options FollowSymLinks     DirectoryIndex index.php     <IfModule mod_php5.c>         AddType application/x-httpd-php .php         php_flag magic_quotes_gpc Off         php_flag track_vars On         php_flag register_globals Off         php_admin_flag allow_url_fopen Off         php_value include_path .         php_admin_value upload_tmp_dir /var/lib/phpmyadmin/tmp         php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/:/usr/share/php/php-gettext/:/usr/share/javascript/     </IfModule> </Directory> # Authorize for setup <Directory /usr/share/phpmyadmin/setup> <IfModule mod_authn_file.c> AuthType Basic AuthName "phpMyAdmin Setup" AuthUserFile /etc/phpmyadmin/htpasswd.setup </IfModule> Require valid-user </Directory> # Disallow web access to directories that don't need it <Directory /usr/share/phpmyadmin/libraries> Order Deny,Allow Deny from All </Directory> <Directory /usr/share/phpmyadmin/setup/lib> Order Deny,Allow Deny from All </Directory>
    • By mircsicz
      Seit dem Update Anfang der Woche kann ich mich nicht mehr an PHPmyAdmin anmelden. Genauer gesagt wird das Passwort schon noch akzeptiert, aber danach bekomm ich nur eine Wei?e Seite.
       
      Google hat mir nur das gezeigt: http://stackoverflow.com/questions/27334512/nginx-phpmyadmin-stuck-after-login-page-all-blank-and-token-in-the-url
       
      Hier die verwendete Nginx Config:
      location /phpmyadmin { root /usr/share/; index index.php; location ~ ^/phpmyadmin/(.+\.php)$ { try_files $uri =404; root /usr/share/; fastcgi_pass 127.0.0.1:9000; fastcgi_param HTTPS on; fastcgi_index index.php; include /etc/nginx/fastcgi_params; } location ~* ^/phpmyadmin/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ { root /usr/share/; } } location /phpMyAdmin { rewrite ^/* /phpmyadmin last; } Die Datei wird in 10_froxlor_ipandport_x.x.x.x:xx:conf included, darin wird logging wie folgt aktiviert:
      access_log /var/log/nginx/froxlor.panel.access.log; error_log /var/log/nginx/froxlor.panel.error.log error; hier ein Ausschnitt aus dem ...access.log
      80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793 HTTP/1.1" 200 1123 "https://websrv.yyy.de/phpmyadmin/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/js/jquery/jquery-1.4.4.js?ts=1344778698 HTTP/1.1" 304 0 "https://websrv.yyy.de/phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/js/update-location.js?ts=1344778698 HTTP/1.1" 304 0 "https://websrv.yyy.de/phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/js/common.js?ts=1344778698 HTTP/1.1" 304 0 "https://websrv.yyy.de/phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/navigation.php?token=1b0aca9e7b0ca79433e7de65db0fe793 HTTP/1.1" 200 1968 "https://websrv.yyy.de/phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:01 +0100] "GET /phpmyadmin/main.php?token=1b0aca9e7b0ca79433e7de65db0fe793 HTTP/1.1" 200 8727 "https://websrv.yyy.de/phpmyadmin/index.php?token=1b0aca9e7b0ca79433e7de65db0fe793" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36" 80.187.110.238 - - [17/Dec/2014:15:39:17 +0100] "-" 400 0 "-" "-" error.log wird erzeugt, bleibt aber leer...
       
      /var/log/php5-fpm/www.access.log
      127.0.0.1 - 17/Dec/2014:15:39:01 +0100 "GET /phpmyadmin/index.php" 200 127.0.0.1 - 17/Dec/2014:15:39:01 +0100 "GET /phpmyadmin/navigation.php" 200 127.0.0.1 - 17/Dec/2014:15:39:01 +0100 "GET /phpmyadmin/main.php" 200 auch hier kein error.log, hier wird es aber noch nicht mal erzeugt, obwohl es hier definiert ist: /etc/php5/fpm/pool.d/www.conf
       
      Hab jetzt gerade noch zus?tzlich in /etc/php5/fpm/php5-fpm.conf 'log_level = debug' gesetzt, aber auch dann ist in /var/log/php5-fpm.log nichts nennenswertes:
      [17-Dec-2014 16:20:22.938365] DEBUG: pid 11568, fpm_children_make(), line 421: [pool test.xxx.de] child 11716 started [17-Dec-2014 16:20:22.939227] DEBUG: pid 11568, fpm_children_make(), line 421: [pool www] child 11717 started [17-Dec-2014 16:20:22.965938] DEBUG: pid 11568, fpm_children_make(), line 421: [pool www] child 11718 started [17-Dec-2014 16:20:22.966023] DEBUG: pid 11568, fpm_event_loop(), line 366: 196056 bytes have been reserved in SHM [17-Dec-2014 16:20:22.966034] NOTICE: pid 11568, fpm_event_loop(), line 367: ready to handle connections [17-Dec-2014 16:20:23.967267] DEBUG: pid 11568, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 2 spare children, 2 running children. Spawning rate 1 [17-Dec-2014 16:20:24.968204] DEBUG: pid 11568, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 2 spare children, 2 running children. Spawning rate 1 Ich bin ratlos!
    • By Pagefreak
      Hallo liebe Community,
       
      Ich habe seit ein paar Tagen Froxlor auf meinem Debian7 vServer laufen. Bisher klappte die Einrichung ganz gut, bis ich zu den E-Mails kam. Ich habe mir Roundcube installiert und als Mail Server mail.meinedomain.de und smtp.meinedomain.de ausprobiert keines der beiden klappt. Wenn ich mich bei Roundcube einloggen will kommt: "Verbindung zum Speicherserver fehlgeschlagen!". Kann mir jemand sagen was ich flasch mache/gemacht habe oder mir vllt. sogar Roundcube einrichten?
       
      Ich habe die Nameserver der Domain auf Cloudflare geleitet und bei Cloudflare meine Serverdaten eingetragen. Hier ein kleines Bild:

       
      Roundcube Log:
      [17-Nov-2014 14:45:48 +0100]: IMAP Error: Login failed for mail@meinedomain.de from 12.123.12.123.. LOGIN: Fatal error: No such file or directory: No such file or directory in /var/www/webmail/program/lib/Roundcube/rcube_imap.php on line 184 (POST /webmail/?_task=login?_task=login&_action=login) Ich hoffe ihr k?nnt mir helfen! Vielen Dank im Vorraus! LG Jakob
×
×
  • Create New...