Jump to content
Froxlor Forum

Pagefreak

Members
  • Content Count

    109
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About Pagefreak

  • Rank
    Advanced Froxie
  • Birthday 02/16/2000

Contact Methods

  • Website URL
    http://bendernetwork.de

Profile Information

  • Gender
    Male
  • Location
    Braunschweig

Recent Profile Visitors

1855 profile views
  1. Kannst du in der account.conf aktivieren.
  2. Den Inhalt des acme.sh.log hatte ich oben schon gepostet. Das Hauptproblem scheint "get to authz error." zu sein. Die Challanges Typ "http-01" stehen auf Status "pending".
  3. Also liegt es daran, dass Froxlor nicht in der default directory liegt? Hat bisher ohne jegliche Probleme geklappt.
  4. Die Pfade für die Crons in /etc/cron.d/froxlor -> Cronjobs werden ja auch ausgeführt. Für die Let's Encrypt Challenges habe ich in den Einstellungen meinen Froxlor-Pfad angegeben (/var/customers/webs/ServerRISE/froxlor.ServerRISE.com). Ebenfalls in der acme.conf als Alias. Dennoch wird der Ordner .well-known nur unter /var/www/froxlor angelegt. Das ist was mir in /root/.acme.sh/acme.sh.log ausgegeben wird. Beim ausführen des Cronjobs kommt folgendes: https://pastebin.com/hbq49A9x
  5. Moin, leider wurden meine Zertifikate nicht mehr aktualisiert. Ich habe auf die 0.10.1 geupdatet und die Konfigurationen durchgeführt. ACME-Version in den SSL-Einstellungen auf v2. Da Froxlor nicht in /var/www/froxlor liegt habe ich die Pfade entsprechend angepasst. An folgenden Orten: in den Crons in den Einstellungen->SSL->Verzeichnis für Let's Encrypt challenges /etc/apache2/conf-enabled/acme.conf Die Zertifikaten werden zwar erstellt allerdings nicht in Froxlor angezeigt bzw. funktionieren nicht. In der acme.sh.log erscheint folgendes: [Fri Oct 11 01:46:05 CEST 2019] pid [Fri Oct 11 01:46:05 CEST 2019] No need to restore nginx, skip. [Fri Oct 11 01:46:05 CEST 2019] _clearupdns [Fri Oct 11 01:46:05 CEST 2019] dns_entries [Fri Oct 11 01:46:05 CEST 2019] skip dns. [Fri Oct 11 01:46:05 CEST 2019] _on_issue_err [Fri Oct 11 01:46:05 CEST 2019] Please check log file for more details: /root/.acme.sh/acme.sh.log [Fri Oct 11 01:46:05 CEST 2019] Running cmd: issue [Fri Oct 11 01:46:05 CEST 2019] _main_domain='BenderNetwork.de' [Fri Oct 11 01:46:05 CEST 2019] _alt_domains='no' [Fri Oct 11 01:46:05 CEST 2019] Using config home:/root/.acme.sh [Fri Oct 11 01:46:05 CEST 2019] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory' [Fri Oct 11 01:46:05 CEST 2019] DOMAIN_PATH='/root/.acme.sh/BenderNetwork.de' [Fri Oct 11 01:46:05 CEST 2019] Using ACME_DIRECTORY: https://acme-v02.api.letsencrypt.org/directory [Fri Oct 11 01:46:05 CEST 2019] _init api for server: https://acme-v02.api.letsencrypt.org/directory [Fri Oct 11 01:46:05 CEST 2019] GET [Fri Oct 11 01:46:05 CEST 2019] url='https://acme-v02.api.letsencrypt.org/directory' [Fri Oct 11 01:46:05 CEST 2019] timeout= [Fri Oct 11 01:46:05 CEST 2019] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header -g ' [Fri Oct 11 01:46:06 CEST 2019] ret='0' [Fri Oct 11 01:46:06 CEST 2019] ACME_KEY_CHANGE='https://acme-v02.api.letsencrypt.org/acme/key-change' [Fri Oct 11 01:46:06 CEST 2019] ACME_NEW_AUTHZ [Fri Oct 11 01:46:06 CEST 2019] ACME_NEW_ORDER='https://acme-v02.api.letsencrypt.org/acme/new-order' [Fri Oct 11 01:46:06 CEST 2019] ACME_NEW_ACCOUNT='https://acme-v02.api.letsencrypt.org/acme/new-acct' [Fri Oct 11 01:46:06 CEST 2019] ACME_REVOKE_CERT='https://acme-v02.api.letsencrypt.org/acme/revoke-cert' [Fri Oct 11 01:46:06 CEST 2019] ACME_AGREEMENT='https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf' [Fri Oct 11 01:46:06 CEST 2019] ACME_NEW_NONCE='https://acme-v02.api.letsencrypt.org/acme/new-nonce' [Fri Oct 11 01:46:06 CEST 2019] ACME_VERSION='2' [Fri Oct 11 01:46:06 CEST 2019] Le_NextRenewTime [Fri Oct 11 01:46:06 CEST 2019] _on_before_issue [Fri Oct 11 01:46:06 CEST 2019] _chk_main_domain='BenderNetwork.de' [Fri Oct 11 01:46:06 CEST 2019] _chk_alt_domains [Fri Oct 11 01:46:06 CEST 2019] Le_LocalAddress [Fri Oct 11 01:46:06 CEST 2019] d='BenderNetwork.de' [Fri Oct 11 01:46:06 CEST 2019] Check for domain='BenderNetwork.de' [Fri Oct 11 01:46:06 CEST 2019] _currentRoot='/var/customers/webs/ServerRISE/froxlor.ServerRISE.com' [Fri Oct 11 01:46:06 CEST 2019] d [Fri Oct 11 01:46:06 CEST 2019] _saved_account_key_hash is not changed, skip register account. [Fri Oct 11 01:46:06 CEST 2019] Read key length:4096 [Fri Oct 11 01:46:06 CEST 2019] Creating domain key [Fri Oct 11 01:46:06 CEST 2019] Using config home:/root/.acme.sh [Fri Oct 11 01:46:06 CEST 2019] ACME_DIRECTORY='https://acme-v02.api.letsencrypt.org/directory' [Fri Oct 11 01:46:07 CEST 2019] Use length 4096 [Fri Oct 11 01:46:07 CEST 2019] Using RSA: 4096 [Fri Oct 11 01:46:08 CEST 2019] The domain key is here: /root/.acme.sh/BenderNetwork.de/BenderNetwork.de.key [Fri Oct 11 01:46:08 CEST 2019] _createcsr [Fri Oct 11 01:46:08 CEST 2019] Single domain='BenderNetwork.de' [Fri Oct 11 01:46:08 CEST 2019] Getting domain auth token for each domain [Fri Oct 11 01:46:08 CEST 2019] d [Fri Oct 11 01:46:08 CEST 2019] url='https://acme-v02.api.letsencrypt.org/acme/new-order' [Fri Oct 11 01:46:08 CEST 2019] payload='{"identifiers": [{"type":"dns","value":"BenderNetwork.de"}]}' [Fri Oct 11 01:46:08 CEST 2019] RSA key [Fri Oct 11 01:46:08 CEST 2019] HEAD [Fri Oct 11 01:46:08 CEST 2019] _post_url='https://acme-v02.api.letsencrypt.org/acme/new-nonce' [Fri Oct 11 01:46:08 CEST 2019] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header -g -I ' [Fri Oct 11 01:46:09 CEST 2019] _ret='0' [Fri Oct 11 01:46:09 CEST 2019] POST [Fri Oct 11 01:46:09 CEST 2019] _post_url='https://acme-v02.api.letsencrypt.org/acme/new-order' [Fri Oct 11 01:46:09 CEST 2019] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header -g ' [Fri Oct 11 01:46:09 CEST 2019] _ret='0' [Fri Oct 11 01:46:09 CEST 2019] code='201' [Fri Oct 11 01:46:10 CEST 2019] Le_LinkOrder='https://acme-v02.api.letsencrypt.org/acme/order/69021419/1259842952' [Fri Oct 11 01:46:10 CEST 2019] Le_OrderFinalize='https://acme-v02.api.letsencrypt.org/acme/finalize/69021419/1259842952' [Fri Oct 11 01:46:10 CEST 2019] url='https://acme-v02.api.letsencrypt.org/acme/authz-v3/721527434' [Fri Oct 11 01:46:10 CEST 2019] payload [Fri Oct 11 01:46:10 CEST 2019] POST [Fri Oct 11 01:46:10 CEST 2019] _post_url='https://acme-v02.api.letsencrypt.org/acme/authz-v3/721527434' [Fri Oct 11 01:46:10 CEST 2019] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header -g ' [Fri Oct 11 01:46:10 CEST 2019] _ret='0' [Fri Oct 11 01:46:10 CEST 2019] code='200' [Fri Oct 11 01:46:10 CEST 2019] d='BenderNetwork.de' [Fri Oct 11 01:46:10 CEST 2019] Getting webroot for domain='BenderNetwork.de' [Fri Oct 11 01:46:10 CEST 2019] _w='/var/customers/webs/ServerRISE/froxlor.ServerRISE.com' [Fri Oct 11 01:46:10 CEST 2019] _currentRoot='/var/customers/webs/ServerRISE/froxlor.ServerRISE.com' [Fri Oct 11 01:46:10 CEST 2019] get to authz error. [Fri Oct 11 01:46:10 CEST 2019] _authorizations_map='bendernetwork.de,{"identifier":{"type":"dns","value":"bendernetwork.de"},"status":"pending","expires":"2019-10-17T23:15:18Z","challenges":[{"type":"http-01","status":"pending","url":"https://acme-v02.api.letsencrypt.org/acme/chall-v3/721527434/j3mWgQ","token":"CLXb6WjdlSGTb1xUy4YbO96BRevTF1-8lA_7IJYqj3I"},{"type":"dns-01","status":"pending","url":"https://acme-v02.api.letsencrypt.org/acme/chall-v3/721527434/FLNarw","token":"CLXb6WjdlSGTb1xUy4YbO96BRevTF1-8lA_7IJYqj3I"},{"type":"tls-alpn-01","status":"pending","url":"https://acme-v02.api.letsencrypt.org/acme/chall-v3/721527434/1HcXZg","token":"CLXb6WjdlSGTb1xUy4YbO96BRevTF1-8lA_7IJYqj3I"}]} ' Ich bin mal wieder ratlos und dankbar für jede Hilfe.
  6. FcgidProcessLifeTime 3600 FcgidIdleTimeout 3600 In der /etc/apache2/mods-enabled/fcgid.conf. Aktuell läuft wieder alles problemlos. Genauso plötzlich wie der Fehler aufgetreten ist, ist er nun auch wieder verschwunden.
  7. Moinsen, seit einigen Stunden habe ich das Problem, dass eine meiner Seiten ständig Fehler 500 spuckt. Genauer gesagt steht im Log des Kunden: "mod_fcgid: read data timeout" und im Apache Error Log: mod_fcgid: process 6054 graceful kill fail, sending SIGKILL in einigen Foren und auch hier in einem Thread fand ich die "Lösung" den Timeout von FCGID hoch zu schrauben. Leider ohne Erfolg. Seltsam ist auch, dass der Fehler sehr plötzlich auftritt. Die letzten Tage lief alles Problemlos und nun plötzlich das. Jemand eine Idee? Vielen Dank im Voraus!
  8. Vielen lieben Dank! Das war genau das was ich gesucht habe. Nun rennt alles.
  9. Welche sind die entsprechenden Settings? Konnte nichts entsprechendes finden.
  10. Froxlor ist nicht im Kundenverzeichnis eines anderen Panels. Froxlor liegt bei uns unter /var/customers/webs/User/froxlor.domain.de/. Das ganze dient nur der Subdomain für Froxlor. Funktionierte nun auch jahrelang ohne jegliche Probleme, nur in Kombination mit FCGID klappt es nicht mehr.
  11. Guten Tag, da in Wordpress Installationen bisher das bearbeiten von Datein nicht möglich war, entschied ich mich FCGID zu installieren. Dies scheint soweit auch geklappt zu haben. Das Problem ist folgendes: Ich hatte Froxlor und ein paar andere Panel in ein Kundenverzeichnis verschoben. Damit diese dort ordnungsgemäß arbeiten konnten, hatte ich diesen die Gruppe www-data zugewiesen. Leider wird diesen nun nicht die eigentliche Gruppe zugewisen bzw. sie erhalten nach den Cron die Gruppe www-data zurück. Kann mir da jemand weiterhelfen? Vielen Dank im Voraus und einen schönen Tag Pagefreak
  12. Achso. Naja nun funktioniert ja alles. Vielen Dank (auch für das beantworten meiner evtl. blöden Fragen)!
  13. In wie fern stimmt es denn nicht? Naja ist auch egal. Zuerst zeigte das Update kein Wirkung (ja ich habe den Cron abgewartet!) und dann anscheinend doch plötzlich. Keine Ahnung wie sowas geht aber nun ja, solange es funktioniert bin ich glücklich! Schönen Abend noch!
×
×
  • Create New...