Jump to content
Froxlor Forum

Pagefreak

Members
  • Content Count

    116
  • Joined

  • Last visited

Everything posted by Pagefreak

  1. Ich wusste nicht, dass dann der Cronjob nicht ausgeführt wird. Die Zertfikiate werden angelegt, aber in der DB/im Panel erscheinen trotzdem nur die neu angelegten.
  2. Ich bin jetzt wie folgt vorgegangen: Cron gestoppt Domain Ordner in /root/.acme.sh/ gelöscht Cron gestartet Der Cron für die Webserver-Konfiguration scheint nicht zu funktionieren, wenn ich ihn nicht manuell starte. Die Ordner/Zertifikaten wurde entsprechend auch nicht wieder in /.root/acme.sh/ angelegt. Die Crons passen meines Erachtens: */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/customers/webs/ServerRISE/froxlor.ServerRISE.com/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/customers
  3. Hilft leider alles nichts. Lediglich wenn ich die Domains neu anlege klappt es auch mit Let'sEncrypt. Bleibt mir wohl nichts anderes über. Kann ich die auch neu anlegen, ohne das die Mail Adressen und alles flöten gehen?
  4. Ich meine natürlich die Zertifikate. Ich werde es nochmal probieren, alles zu löschen und hoffe, dass sie dann eventuell auch von froxlor angelegt werden. Erkennt Froxlor selbstständig, dass keine Zertifikate vorhanden sind bzw. dass die vHosts aktualisiert werden müssen?
  5. [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Requesting/renewing Let's Encrypt certificates [information] Creating certificate for Webdesign-JH.de [information] Adding SAN entry: Webdesign-JH.de [information] Adding SAN entry: www.Webdesign-JH.de [information] Checking for LetsEncrypt client upgrades before renewing certificates: [Wed Apr 29 14:12:10 CEST 2020] Already uptodate! [Wed Apr 29 14:12:10 CEST 2020] Upgrade success! [Wed Apr 29 14:12:11 CEST 2020] Removing cron job [Wed Apr 2
  6. [information] Requesting/renewing Let's Encrypt certificates [information] Creating certificate for Webdesign-JH.de [information] Adding SAN entry: Webdesign-JH.de [information] Adding SAN entry: www.Webdesign-JH.de [information] Checking for LetsEncrypt client upgrades before renewing certificates: [Wed Apr 29 13:28:55 CEST 2020] Already uptodate! [Wed Apr 29 13:28:55 CEST 2020] Upgrade success! [Wed Apr 29 13:28:55 CEST 2020] Removing cron job [Wed Apr 29 13:28:55 CEST 2020] Lets find script dir. [Wed Apr 29 13:28:55 CEST 2020] _SCRIPT_='/root/.acme.sh/acme.sh' [Wed Apr 29 13:28:55 CEST 2020
  7. Moin, seit kurzem funktionierte LE nicht mehr. Aus den Logs entnahm ich, dass es ein Problem mit der acme.sh gab. ACME neu installiert und konfiguriert. Für eine neu angelegte Domain klappt alles problemlos, jedoch für die alten Domains nicht. Die Zertifikate werden erfolgreich in /root/.acme.sh/ angelegt jedoch nicht in die vHosts von Froxlor geschrieben und nicht in /etc/ssl/froxlor-custom/ kopiert. Bisher probiert: LE Zerts zwangs erneuern (wie von d00p erläutert) Cronjobs und Konfigs gecheckt LE für Domains deaktiviert+reaktiviert LE Cronjob manuell ausg
  8. Den Inhalt des acme.sh.log hatte ich oben schon gepostet. Das Hauptproblem scheint "get to authz error." zu sein. Die Challanges Typ "http-01" stehen auf Status "pending".
  9. Also liegt es daran, dass Froxlor nicht in der default directory liegt? Hat bisher ohne jegliche Probleme geklappt.
  10. Die Pfade für die Crons in /etc/cron.d/froxlor -> Cronjobs werden ja auch ausgeführt. Für die Let's Encrypt Challenges habe ich in den Einstellungen meinen Froxlor-Pfad angegeben (/var/customers/webs/ServerRISE/froxlor.ServerRISE.com). Ebenfalls in der acme.conf als Alias. Dennoch wird der Ordner .well-known nur unter /var/www/froxlor angelegt. Das ist was mir in /root/.acme.sh/acme.sh.log ausgegeben wird. Beim ausführen des Cronjobs kommt folgendes: https://pastebin.com/hbq49A9x
  11. Moin, leider wurden meine Zertifikate nicht mehr aktualisiert. Ich habe auf die 0.10.1 geupdatet und die Konfigurationen durchgeführt. ACME-Version in den SSL-Einstellungen auf v2. Da Froxlor nicht in /var/www/froxlor liegt habe ich die Pfade entsprechend angepasst. An folgenden Orten: in den Crons in den Einstellungen->SSL->Verzeichnis für Let's Encrypt challenges /etc/apache2/conf-enabled/acme.conf Die Zertifikaten werden zwar erstellt allerdings nicht in Froxlor angezeigt bzw. funktionieren nicht. In der acme.sh.log erscheint folgendes: [Fri Oct 11 0
  12. FcgidProcessLifeTime 3600 FcgidIdleTimeout 3600 In der /etc/apache2/mods-enabled/fcgid.conf. Aktuell läuft wieder alles problemlos. Genauso plötzlich wie der Fehler aufgetreten ist, ist er nun auch wieder verschwunden.
  13. Moinsen, seit einigen Stunden habe ich das Problem, dass eine meiner Seiten ständig Fehler 500 spuckt. Genauer gesagt steht im Log des Kunden: "mod_fcgid: read data timeout" und im Apache Error Log: mod_fcgid: process 6054 graceful kill fail, sending SIGKILL in einigen Foren und auch hier in einem Thread fand ich die "Lösung" den Timeout von FCGID hoch zu schrauben. Leider ohne Erfolg. Seltsam ist auch, dass der Fehler sehr plötzlich auftritt. Die letzten Tage lief alles Problemlos und nun plötzlich das. Jemand eine Idee? Vielen Dank im Voraus!
  14. Vielen lieben Dank! Das war genau das was ich gesucht habe. Nun rennt alles.
  15. Welche sind die entsprechenden Settings? Konnte nichts entsprechendes finden.
  16. Froxlor ist nicht im Kundenverzeichnis eines anderen Panels. Froxlor liegt bei uns unter /var/customers/webs/User/froxlor.domain.de/. Das ganze dient nur der Subdomain für Froxlor. Funktionierte nun auch jahrelang ohne jegliche Probleme, nur in Kombination mit FCGID klappt es nicht mehr.
  17. Guten Tag, da in Wordpress Installationen bisher das bearbeiten von Datein nicht möglich war, entschied ich mich FCGID zu installieren. Dies scheint soweit auch geklappt zu haben. Das Problem ist folgendes: Ich hatte Froxlor und ein paar andere Panel in ein Kundenverzeichnis verschoben. Damit diese dort ordnungsgemäß arbeiten konnten, hatte ich diesen die Gruppe www-data zugewiesen. Leider wird diesen nun nicht die eigentliche Gruppe zugewisen bzw. sie erhalten nach den Cron die Gruppe www-data zurück. Kann mir da jemand weiterhelfen? Vielen Dank im Voraus und einen schön
  18. Achso. Naja nun funktioniert ja alles. Vielen Dank (auch für das beantworten meiner evtl. blöden Fragen)!
  19. In wie fern stimmt es denn nicht? Naja ist auch egal. Zuerst zeigte das Update kein Wirkung (ja ich habe den Cron abgewartet!) und dann anscheinend doch plötzlich. Keine Ahnung wie sowas geht aber nun ja, solange es funktioniert bin ich glücklich! Schönen Abend noch!
  20. Es hat mich viele Stunden meines Lebens gekostet bis ich hierher gekommen bin. Ist halt etwas seltsam, wenn man regulär eine Stable von Froxlor installiert und plötzlich PHP für die Customer deaktiviert ist. Ich habe jetzt wie du geschrieben hast den aktuellen git Stand genommen, doch der Bug bleibt bestehen!
  21. Vielen Dank für den Tipp! Leider hatte unser Hoster einen Festplatten Crash und es ist eh alles futsch, womit ich Froxlor neu installieren muss. Vielleicht habe ich ja diesmal mehr "Glück".
  22. Ich sehe das auch. Aber bei Thunderbird ist alles eingetragen.
×
×
  • Create New...