Jump to content
Froxlor Forum

Pro-Webs

Members
  • Content count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Pro-Webs

  • Rank
    Newbie
  1. Schade ;( Wäre einfach übersichtlicher. Aber gut man kann mit leben. Dank Dir
  2. Gibt es eine Möglichkeit die Konfiguration die ich in Froxlor vHost eingebe so zu vereinfachen, dass ich dort nur eine Verweis ala "LINK ZU CONFIG DATEI" eingebe und in dieser Datei dann alle Änderungen vornehme? Diese sollte dann einfach nur über den LINK in den vHist eingebunden werden ... bei mir arteten die vHost Einstellungen gerade etwas aus, so das es langsam unübersichtlich wird diese in Froxlor direkt vorzunehmen. Danke
  3. Expires Header bei Ngnix und Froxlor

    Offenbar hatte ich einen völlig falschen Ansatz. Damit geht es nun mit Einschränkung, dass die "woff" immer noch kein expires hat ... woran das liegt ist mir noch unbekannt. location ~* \.(jpg|jpeg|png|gif|ico|css|js|svg|woff|mp4|ttf|otf|woff2|eot|swf|pdf))$ { expires 30d; add_header Pragma public; add_header Cache-Control "public"; } Vielleicht weiß einer woran das liegt mit der Font?
  4. Expires Header bei Ngnix und Froxlor

    Also ich habs jetzt mit dieser Konfig probiert. Klappt aber leider immer noch nicht # 35_froxlor_normal_vhost_hochzeitsfotografie-pajo.de.conf # Created 10.10.2017 10:25 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 91.250.82.51:80; server_name hochzeitsfotografie-pajo.de www.hochzeitsfotografie-pajo.de hochzeitsfotografen-pajo.de www.hochzeitsfotografen-pajo.de; include /etc/apache2/conf-enabled/acme.conf; access_log /var/customers/logs/klimek-hochzeitsfotografie-pajo.de-access.log combined; error_log /var/customers/logs/klimek-hochzeitsfotografie-pajo.de-error.log error; root /var/customers/webs/klimek/hochzeitsfotografie-pajo.de/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/klimek/webalizer/hochzeitsfotografie-pajo.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/htpasswd/1-c3d3ffdab2b8342809d19524c21b98c1.htpasswd; } location ~ \.php { try_files /b4c9e0f6dcf35af2c81a08071c782baf.htm @php; } location @php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_index index.php; fastcgi_pass unix:/run/php/php7.0-fpm.sock; } if ($scheme = http) { return 301 https://www.$server_name$request_uri; } map $sent_http_content_type $expires { default off; text/html epoch; text/css max; application/javascript max; ~image/ max; } expires $expires; add_header Cache-Control private; }
  5. Ein weiteres Problem, welches ich bei der Konfiguration von Nginx mit Froxlor habe wäre: Wie leite ich direkt bei Aufruf der domain bspw. www.hochzeitsfotografie-pajo.de auf https um? Soweit ich es ergoogelt habe müsste ich weitere "server" blöcke einbauen, dass geht über die vHost Einstellungen in Froxlor jedoch nicht. Eine Verschachtelung ist ebenfalls nicht möglich. Was wäre hier also der richtige Ansatz? Das gefundene Snippet wäre wie folgt: server { listen 80; listen [::]:80; server_name www.example.com; return 301 https://$server_name$request_uri; } server { listen 443 default_server ssl; server_name www.example.com; ssl_certificate /path/to/my/cert; ssl_certificate_key /path/to/my/key; } Ideen und Vorschläge sind sehr willkommen
  6. Expires Header bei Ngnix und Froxlor

    Nein, dass wusste ich nicht. Fand die Syntax aber schon verdächtig. Hatte das so nur eben auch gegoogelt. Wie würde es denn dann korrekt aussehen bzw. wo in Froxlor müsste ich dies dann einfügen, damit es wie gewünscht funktioniert? Danke im Voraus
  7. Expires Header bei Ngnix und Froxlor

    Danke für die schnelle Antwort Du meinst also so: user www-data; worker_processes auto; pid /run/nginx.pid; include /etc/nginx/modules-enabled/*.conf; events { worker_connections 768; # multi_accept on; } http { ## # Basic Settings ## sendfile on; tcp_nopush on; tcp_nodelay on; keepalive_timeout 65; types_hash_max_size 2048; # server_tokens off; # server_names_hash_bucket_size 64; # server_name_in_redirect off; include /etc/nginx/mime.types; default_type application/octet-stream; ## # SSL Settings ## ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE ssl_prefer_server_ciphers on; ## # Logging Settings ## access_log /var/log/nginx/access.log; error_log /var/log/nginx/error.log; ## # Gzip Settings ## gzip on; # Paul: Gzip Anpassung equivalent zu mod_deflate.c bei Apache gzip_disable "msie6"; gzip_vary on; gzip_proxied any; gzip_comp_level 6; gzip_buffers 16 8k; gzip_http_version 1.1; gzip_min_length 256; gzip_types text/plain text/css application/json application/javascript application/x-javascript text/xml application/xml application/xml+rss text/javascript application/vnd.ms-fontobject application/x-font-ttf font/opentype image/svg+xml image/x-icon; # Ende ## # Virtual Host Configs ## include /etc/nginx/conf.d/*.conf; include /etc/nginx/sites-enabled/*; } map $sent_http_content_type $expires { default off; text/html epoch; text/css max; application/javascript max; ~image/ max; } Bin was nginx angeht absoluter noop. Bisher war immer apache bei auf dem Server installiert.
  8. Ich habe Froxlor mit Ngnix laufen und wollte gerne die Expires Headers wie folgt setzen: # Expires map map $sent_http_content_type $expires { default off; text/html epoch; text/css max; application/javascript max; ~image/ max; } Soweit ich das jedoch sehe gibt es dabei kein "default" sondern von Froxlor generierte Dateien je Domain. Diese möchte ich natürlich nicht manuell ändern, da diese Froxlor jedes mal überschreiben dürfte, wenn ich dort eine Änderung vornehme. Insofern ist meine Frage, wie kann ich diese Ergänzung in Froxlor selbst vornehmen? Danke im Voraus
×