Jump to content
Froxlor Forum

AndrewL

Members
  • Content Count

    27
  • Joined

  • Last visited

Community Reputation

0 Neutral

About AndrewL

  • Rank
    Froxie
  1. @Shortie I agree with me not having a clue as I am definitely not comfortable with server administration yet which is why I am trying to set up a small vps myself with the help of communities and forums like this one so I can learn it. The server I'm trying to set basic stuff on is just for learning purposes. However, I don't agree with "shouldn't do it if you don't know the basics." since everyone doesn't just start off knowing everything they touch a-z. Just from this thread and another one that I started here itself, I have learnt from @d00p about a lot of "basic stuff" on server administration which would have taken me forever to wrap my head around if I just stick to theoretically learning it or as you said, not do it in the first place. Thanks for telling me that IMAP is port 143 and not 25 btw. That is yet another thing I just found out from this thread which made me google it and understand it further. Cheers
  2. When I change the smtp_server from localhost to the FQDN (ssl://vps1.shillongserver.com), the test for SMTP fails again and return the following error: Trying to send email... SMTP send: NOT OK(Connection failed: Failed to connect socket: fsockopen(): unable to connect to ssl://vps1.shillongserver.com:25 (Unknown error)) And the IMAP test returns the following: Connecting to ssl://vps1.shillongserver.com... IMAP connect: NOT OK(Login failed for test@customerdomain.com against vps1.shillongserver.com from 117.214.36.78. Could not connect to ssl://vps1.shillongserver.com:25: Unknown reason)
  3. I changed the default_host from `ssl://localhost` to `ssl://abc.domainname.com` (abc.domainname.com is the FQDN of the server) just now and rerun the test but the same error pops up. Do I need to change the smtp_server to the FQDN with ssl:// too or should the FQDN be specified just for the IMAP host? Also, I have ran `hostname -f` in the terminal to confirm the FQDN before updating the ssl:// with it.
  4. I have just extracted roundcube to /var/www/html/webmail as you said and then run the installer. In the Create Config section, I set the smtp port to 25 and set the smtp_server to localhost and the test for the SMTP config is working now. For IMAP, I set the default_host to ssl://localhost (added ssl:// for letsencrypt) and the default_port to 25 like in the SMTP section but the test for the IMAP config failed and return the following error: NOT OK(Login failed for test@abcxyz.com against localhost from 117.214.36.78. Could not connect to ssl://localhost:25: Unknown reason) What am I doing wrong now?
  5. @d00p I have tried adding the above code to the "Default vHost-settings for every domain container" in IP/ports for port 80 as well as adding it to the "Default vHost-settings" in Webserver settings as well as created a `roundcube.conf` file inside the `sites-available` folder and none of the above are working. By not working I mean, initializing the installer for roundcube and even though I get a green OK for everything, The send mail test keeps failing and returning a "Failed to connect socket" error. I have deleted the roundcube folder as well as remove the database for roundcube and it's user. I have also removed the above code from every place I added it too. I want to re-install it again but I'm not sure what to do first.
  6. So I should paste the Alias line and the Directory block into the default vhost-settings and default SSL vhost-settings and then run the installation?
  7. Following the step-by-step guide for integrating roundcube with froxlor (but for debian) shown here: https://myridia.com/dev_posts/view/1876, I have done everything till stage 8 but I'm not sure what I have to do in stage 9 which says: Which textbox should I add the above? Shouldn't it be in a `.conf` file inside the `sites-available` folder? Also, I left the default value for the port number in the config file.
  8. @d00p Oh, so I just download the client software like roundcube or phpmyadmin and link to it rather than integrating it with Froxlor? But how will roundcube integrate with the mailsettings I have set in the Froxlor settings?
  9. Hello, I have installed the latest version of Froxlor (0.10.12) on my Ubuntu 18.04 server and after tweaking the settings and running the configuration, everything is working beautifully. However, I noticed that there are options for specifying URLs for PHPMyAdmin, WebMail and WebFTP within the Panel Settings section but I can't seem to figure out how to integrate the three with Froxlor. Right now, I want to integrate Roundcube as my server's webmail client and any recommended client for webftp, but I'm not so sure how to go about it? What changes should I make to my server or to my Froxlor settings? I have already run the configuration for FTP-Server(Proftpd), Mailserver(SMTP) as well as Mailserver(IMAP/POP3) and have set the "FTP Server" to Proftpd in the FTP Server settings section and the "Type of the Mail Delivery Server" and "Type of the Mail Transfer Agent" to Dovecot and Postfix respectively in the Mailserver settings section. Regards.
  10. @d00p The reinstalled froxlor seems to work now. I most probably must have screwed up with the settings somewhere earlier. Thanks again for the help man!! I seem to have some problems with ftp now but I'll try to figure it out first and will post a new topic if I can't figure it out. Cheers.
  11. @d00p I think I might have messed up the settings somewhere when I installed froxlor. I'll try reinstalling it from scratch and follow the instructions you gave above. I think that should fix the issue if it really is a misconfigured setting that I did. I really appreciate your help man. Cheers!! I'll let you know if the new installation works or not in a while. Thanks again!
  12. Both "Enable Let's Encrypt for the froxlor vhost" and "Enable SSL-redirect for the froxlor vhost" are ticked in the Froxlor VirtualHost Settings section. I noticed an option "HTTP2 Support (enable HTTP2 support for ssl.)" in the Webserver settings section which is not checked however. Should I checked that too?
  13. I have removed the customer that I initially added as well as it's domain and then run the configuration for webserver and cron again. Then I ran the script you gave me earlier and got the following output: [information] TasksCron: Searching for tasks to do [information] TasksCron: Task10 started - setting filesystem quota repquota: Cannot stat() given mountpoint /dev/root: No such file or directory Skipping... repquota: No correct mountpoint specified. repquota: Cannot initialize mountpoint scan. [information] Task4 started - Rebuilding froxlor_bind.conf [information] Cleaning dns zone files from /etc/bind/domains/ [information] No domains found for nameserver-config, skipping... [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Requesting/renewing Let's Encrypt certificates [information] No new certificates or certificates due for renewal found [information] apache::createIpPort: creating ip/port settings for 193.36.237.207:80 [notice] 193.36.237.207:80 :: namevirtualhost-statement no longer needed for apache-2.4 [debug] 193.36.237.207:80 :: inserted vhostcontainer [information] apache::createIpPort: creating ip/port settings for 193.36.237.207:443 [debug] 193.36.237.207:443 :: inserted listen-statement [debug] System certificate file "" does not seem to exist. Disabling SSL-vhost for "vps1.shillongserver.com" [debug] 193.36.237.207:443 :: inserted vhostcontainer [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/ [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] Froxlor\Cron\Http\Apache::reload: reloading Froxlor\Cron\Http\Apache apache2.service is not active, cannot reload. [notice] Checking system's last guid And the inaccessible froxlor login problem occurs again. I deleted all the froxlor files from the sites-enabled folder, restarted apache and tried again to run configuration followed by the script that you gave and yet again, the inaccessible froxlor login problem occurs.
  14. I have removed the froxlor files and restarted apache. I'm in the froxlor dashboard again and since there are no ssl certificates generated yet, in the SSL settings, should I leave the "Path to the SSL certificate" and "Path to the SSL Keyfile" paths empty or leave the current default values "/etc/apache2/apache2.pem" and "/etc/apache2/apache2.key" there as it is? With regards to point 1, the option "Enable SSL usage" in the SSL Settings section and the options "Enable Let's Encrypt for the froxlor vhost" and "Enable SSL-redirect for the froxlor vhost" in the Froxlor VirtualHost settings section are all ticked. Should I go ahead and rerun the configuration now?
×
×
  • Create New...