Jump to content
Froxlor Forum
  • 0
Buckshot

[solved] Unknown Error (not in option): system_ipaddress

Question

Hallo,

 

ich habe Froxlor 0.9.34.2 auf Debian 8 mit nginx 1.9.12, PHP 7.0.4 (FPM) und MySQL 5.6.29 eingerichtet.

 

Läuft auch alles einwandrei, bis auf, wenn ich in Froxlor unter Server > Einstellungen auf die Systemeinstellungen gehe und versuche diese zu speichern (mit oder ohne Anpassungen) kommt die Fehlermeldung Unknown Error (not in option): system_ipaddress.

 

In den Logs konnte ich dazu leider keine weiteren Informationen finden.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Bitte mit der aktuellen git-version testen, es gab einige Änderungen. Auf der anderen Seite bist du der erste der dieses Problem meldet, daher würde ich mal davon ausgehen, dass es an dir liegen müsste. Der Fehler besagt (komischerweise) dass es den Wert den du in der Select-Box ausgewählt hast nicht in der Liste der auszuwählenden Sachen zu finden ist...

Share this post


Link to post
Share on other sites
  • 0

Die git-Version zu testen hatte ich jetzt leider keine Muße, daher hab ich mich entschlossen es noch mal neu mit meinen gesammelten Erfahrungen zu installieren. Diesmal jedoch mit Apache und PHP 5.6, also ganz simpel und das hat wunderbar geklappt. Ich werde dann lieber Stück für Stück updaten, aber hauptsache es läuft erst mal und das bis jetzt richtig gut  :D .

Share this post


Link to post
Share on other sites
  • 0

Hallo,

 

ich möchte diesen alten thread noch einmal hochholen, da das eigentliche Problem noch nicht gelöst ist (ist zumindest gerade bei mir aufgetreten)

Froxlor habe ich heute von git heruntergeladen (Version 0.9.37 (DB: 201608260))

Das Problem tritt auch auf, wenn ich an den Werten nichts ändere und auf speichern gehe (es sind von mir auch noch keine Änderungen vorgenommen worden, die gesamte Installation ist bisher "Standard")

 

Systemdetails:

Webserver:

  Apache/2.4.18 (Ubuntu) PHP-Version: 7.0.8-0ubuntu0.16.04.2 MySQL-Server-Version: 5.7.13-0ubuntu0.16.04.2 Webserver-Interface: APACHE2HANDLER System-Auslastung: 0.00 / 0.01 / 0.05 Kernel: 2.6.32-042stab116.2 (x86_64)

 

Abgesehen davon habe ich bis jetzt kein Problem mit meiner Installation feststellen können.

Share this post


Link to post
Share on other sites
  • 0

Wie lautet denn die ip Adresse die du als system-ip Adresse angegeben hast?

Share this post


Link to post
Share on other sites
  • 0

Bzw wurde denn innder Auswahl für die Default IPs eine Auswahl getroffen?

Share this post


Link to post
Share on other sites
  • 0
On 20.3.2016 at 11:40 AM, Buckshot said:

Läuft auch alles einwandrei, bis auf, wenn ich in Froxlor unter Server > Einstellungen auf die Systemeinstellungen gehe und versuche diese zu speichern (mit oder ohne Anpassungen) kommt die Fehlermeldung Unknown Error (not in option): system_ipaddress.

In den Logs konnte ich dazu leider keine weiteren Informationen finden.

Hallo, ich habe der gleiche Fehler wie oben.

Debian 9 , nginx, froxlor (heute von git heruntergeladen) system-ip Adresse angegeben , funktioniert aber nicht.

 

Debian 8 , apache 2.4, froxlor (apt-get), funktionierert 1a und ohne Fehler.

Share this post


Link to post
Share on other sites
  • 0

Nein, es gab keine IP. Ich habe server IP Adresse unter IPs/Ports hinzugefügt + Port "80" + vHost-Container auf "Ja" + service nginx restart gemacht , aber es funktioniert immer noch nicht.

Mehrmals von vorne installiert aber es klappt nicht (nur unter nginx)

 

Share this post


Link to post
Share on other sites
  • 0

naja, nur die IP einfügen reicht ja nicht...du musst die auch den domains zuweisen...oder was "funktioniert immer noch nicht"? Eine etwas genauere Beschreibung was du tust, wenn du schon einen uralten Thread wieder auspackst,....

Share this post


Link to post
Share on other sites
  • 0

Bei Apache oder apt-get installation braucht man keine Domains zuweisen damit Einstellungen funktionieren, ohne diese Fehlermeldung "Unknown Error (not in option): system_ipaddress." bei speichern.

Ich habe froxlor nach diese Tut: Stretch+nginx+php7welche hier jemand vor ein Paar Tagen veröffentlicht hat installiert aber ab dem Punkt 8.5 geht nicht weiter wegen diese Fehlermeldung. (habe mehrmals versucht)

Wo kann der Fehler liegen?

IP, hostname, Passwörter , usw habe ich bei Froxlor installation eingegeben

 

ja stimmt, das Thema ist uralt aber immer noch nicht "solved"

Share this post


Link to post
Share on other sites
  • 0

Und du sagst immer noch nicht was genau jetzt "nicht funktioniert", keine Logs, nix...wie soll ich dir bitte helfen? "geht nicht" ist nunmal keine Fehlermeldung mit der man was anfangen kann.

Share this post


Link to post
Share on other sites
  • 0

Moin, ich buddel den Thread auch nochmal aus.

Ich erhalte die Meldung "Unknown Error (not in option): system_phpfpm_defaultini_ownvhost"

Diese Meldung erscheint unter "Einstellungen -> Froxlor VirtualHost Einstellungen" auch wenn ich nichts ändere und nur auf "Speichern" klicke. Ich verwende die aktuelle git-version.

 

Vielen Dank!

Share this post


Link to post
Share on other sites
  • 0
44 minutes ago, DaSilva said:

Moin, ich buddel den Thread auch nochmal aus.

Ich erhalte die Meldung "Unknown Error (not in option): system_phpfpm_defaultini_ownvhost"

Diese Meldung erscheint unter "Einstellungen -> Froxlor VirtualHost Einstellungen" auch wenn ich nichts ändere und nur auf "Speichern" klicke. Ich verwende die aktuelle git-version.

K.A. was ihr da alle tut...ich installiere alle 3 Tage Froxlor und habe nie diese Probleme...sicher das du MySQL STRICT-MODE deaktiviert hast?

Share this post


Link to post
Share on other sites
  • 0

Jo, sql_mode = is drin.

Ich bin mir auch zu 100% sicher, dass eine neue Installation (sql und files) keine Probleme machen würde.

Allerdings ist das eine sehr alte Installation, welche womöglich nen paar macken hat. Jetzt ist die Frage, worauf diese Meldung deutet, kann es sein, dass mir da ne row in nem table fehlt oder einer zu viel da ist? Habe den Fehler auch nur auf dieser einen Kiste, sonst läuft das teil auch super.

Share this post


Link to post
Share on other sites
  • 0
SELECT `value` FROM `panel_settings` WHERE `settinggroup` = 'system' AND `varname` = 'phpfpm_defaultini_ownvhost'

 

Share this post


Link to post
Share on other sites
  • 0

mysql> use froxlor
Database changed
mysql> SELECT `value` FROM `panel_settings` WHERE `settinggroup` = 'system' AND `varname` = 'phpfpm_defaultini_ownvhost';
Empty set (0.00 sec)

Ist nicht anwesend, finde ich allerdings auch nicht in der master git  froxlor.sql

Share this post


Link to post
Share on other sites
  • 0

sry meine schuld, da hab ich mich nich an meine eigenen vorgaben der indizierung des settings-arrays gehalten. Das hier ist der korrekte Eintrag für die Einstellung:

SELECT `value` FROM `panel_settings` WHERE `settinggroup` = 'phpfpm' AND `varname` = 'vhost_defaultini'

 

Share this post


Link to post
Share on other sites
  • 0

Da sieht es bei mir so aus:

mysql> SELECT `value` FROM `panel_settings` WHERE `settinggroup` = 'phpfpm' AND `varname` = 'vhost_defaultini';
+-------+
| value |
+-------+
| 1     |
+-------+
1 row in set (0.00 sec)

Jup, ist da.

Share this post


Link to post
Share on other sites
  • 0

Und dann guckst jetzt Mal in der php_configs Tabelle ob's da ne config mit der ID 1 gibt ;)

Share this post


Link to post
Share on other sites
  • 0

Hat er :

mysql> select ID from panel_phpconfigs;
+----+
| ID |
+----+
|  1 |
|  3 |
|  6 |
|  7 |
+----+
4 rows in set (0.00 sec)

Was mich nur stutzig macht ist, dass auf dem Server fcgid verwendet wird und nicht fpm.fcgid.thumb.png.ebc65e822c19dfb332987874797ad007.png

Edited by DaSilva
add image

Share this post


Link to post
Share on other sites
  • 0

eh, ja dann stimmt doch da was nicht...dump mir doch bitte mal deine ganze panel_settings (gern auch als PM), da is doch irgendwas faul, default installation is das jedenfalls nicht

Share this post


Link to post
Share on other sites
  • 0

Hallo zusammen,

 

habe das gleiche Problem: 

"Unknown Error (not in option): system_phpfpm_defaultini_ownvhost"

wenn ich in Froxlor die Froxlor-VHOST Settings ändern will.

Zitat
Serversoftware: Apache
PHP-Version: 5.6.32-1~dotdeb+7.1
MySQL server version: 5.6.19-1~dotdeb.1
Webserver interface: CGI-FCGI
   
Kernel: 3.2.0-4-amd64 (x86_64)
   
Froxlor details
   
Installed version: 0.9.38.7-1+wheezy1 (DB: 201612110)
   

Server ist mit FCGI konfiguriert und läuft seit einigen Jahren.

Habe heute auf Let's Encrypt umgestellt und wollte den FROXLOR Vhost auf auf Let's Encrypt umstellen - leider geht es aufgrund des Fehlers nicht.

Wenn weitere Infos benötigt werden, einfach melden.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By tmuecksch
      Hallo liebe Community.
      Ich habe einen neuen Debian 9.4 Server aufgesetzt und Froxlor installiert (gemäß Wiki). Nach Durchführung aller notwendigen Konfigurationsschritte hat Froxlor wie gewohnt funktioniert. Anschließend habe ich ein SSL Zertifikat hochgeladen und in Froxlor, unter Einstellungen > SSL-Einstellungen  habe ich SSL aktiviert und die Pfade Zertifikatfiles angegeben. Anschließend habe ich eine einen neuen Eintrag unter IPs und Ports konfiguriert mit Port 443.
      Nach Generierung der neuen Config Files durch Froxlor ist folgender Fehler aufgetreten, der Apache nicht mehr starten lässt.
      May 17 09:50:14 X.de apachectl[1516]: (99)Cannot assign requested address: AH00072: make_sock: could not bind to address X:443 May 17 09:50:14 X.de apachectl[1516]: no listening sockets available, shutting down  
      Also würde ja nahe liegen, dass der Socket in Verwendung ist (was bei einem frischen Debian doch unwahrscheinlich ist)
      ➜ ~ netstat -tlpn | grep 443 ➜ ~ Der Port ist, wie wir sehen nicht in Verwendung. 
       
      ➜ ~ grep -r "Listen" /etc/apache2/ /etc/apache2/sites-enabled/10_froxlor_ipandport_X.443.conf:Listen X:443 /etc/apache2/ports.conf:Listen 80 /etc/apache2/ports.conf: Listen 443 /etc/apache2/ports.conf:# Listen 443 Man könnte nun vermuten, dass die beiden Listen 443 Einträge in der ports.conf den Fehler verursachen. Doch weit gefehlt. Wenn ich die beiden Einträge entferne ändert das nichts.
       
      Der Fehler lässt sich nur beheben wenn ich in der folgenden Datei die Zeile "Listen X:443" manuell lösche:
      # 10_froxlor_ipandport_X.443.conf # Created 17.05.2018 09:49 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Listen X:443 <VirtualHost X:443> DocumentRoot "/var/www/" ServerName Z.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/letsencrypt/live/Z.de/cert.pem SSLCertificateKeyFile /etc/letsencrypt/live/Z.de/privkey.pem SSLCertificateChainFile /etc/letsencrypt/live/Z.de/chain.pem </VirtualHost>  
      Wie kann das sein? Wieso generiert Froxlor eine nicht funktionierende VHost Config? Habe ich vielleicht was falsch gemacht? Ist der Fehler schon bekannt?
       
      P.S: Meine IP Adresse und Domain habe ich durch Großbuchstaben ersetzt.
       
    • By Randall Newman
      I have been in the process of installing Froxlor in a Google Cloud Instance. All the errors I have encountered I was able to fix them by searching on the web, but this one I couldn't find a solution for the past two hours. Simply I need help solving this error.😓

    • By Pierre
      Ich nutze eine kleine PHP-Datei als kontakt.php - sprich als kontaktformular.
      Dieses lief bis vor ca. 3 Wochen tadellos. Jedoch seit ca. 3 Wochen gibt es folgende Fehlermeldung aus, dass es die E-Mailadresse (Admin des Portals) an den die Nachrichten des Kontaktformulars gehen nicht findet, bzw. das diese nicht existieren würde, obwohl sie existiert und erreichbar ist und auf dem selben Server für die gleiche Domain liegt:
      SMTP Error: The following recipients failed: meine-emailadresse@meinedomain.de
      Innerhalb des Portals werden z.B. alle Newsletter, Paidmails etc. ohne Probleme über SMTP versendet.
      Wurde mit dem letzten Froxlor Update irgend etwas geändert was dies auslöst (from oder reply-to)?
    • By Patrick Walters
      Hallo,
      ich kenne seit einige Jahren Froxlor und verwende es auch sehr gern. 
       
      Ich habe 2 Probleme und 1 Fragen und hoffe mir kann geholfen werden.
       
      Zur Hintergrund-Information, ich verwende Debian 8 (64bit) und Postfix mit Dovecot.
       
      1. Der Mailversand via Webmailer (Auf gleichen Server) funktioniert, aber in den Mail-Header steht:
      Received: from pexmedia.de (unknown [185.101.92.201]) by pexmedia.de (Postfix) with ESMTPA id 0D8C43C0ECE Der Mailserver sollte eigentlich mail.pexmedia.de sein, der SMTP-Server smtp.pexmedia.de und der IMAP-Server imap.pexmedia.de mit den jeweiliegn Standartports.
      Warum steht vor der Server-IPAdresse unknown? Und wie behebt man es?
       
      2. Die Zugangsdaten für SMTP/IMAP stimmen, jedoch kann kein externes E-Mail Programm die Verbindung erfolgreich herstellen. Kurz gesagt seine Mailkonten kann man nicht mit Mailprogrammen wie Outlook etc. verwenden.
      In /var/log/mail.warn steht:
      Jan 31 04:44:24 mail postfix/smtpd[13385]: warning: unknown[46.44.171.19]: SASL LOGIN authentication failed: UGFzc3dvcmQ6 Jan 31 04:44:25 mail postfix/smtpd[13412]: warning: hostname rt171bb44-46-19.routit.net does not resolve to address 46.44.171.19: Name or service not known Jan 31 04:44:25 mail dovecot: auth: Warning: auth client 0 disconnected with 1 pending requests: Connection reset by peer Beim Versuch mit ein E-Mail Programm die Verbindung aufzubauen. Woran lliegt es?
      Im weiteren steht:
      Jan 31 06:46:17 mail postfix/smtpd[16068]: warning: hostname 201.92.101.185.in-addr.arpa does not resolve to address 185.101.92.201: Name or service not known Mein rDNS Eintrag ist: 201.92.101.185.in-addr.arpa 
      Wie sollte mein rDNS Eintrag denn lauten?
       
      In einer Version von Froxlor die ich mal hatte lief alles reibungslos.
       
      3. Mails von meinem Mailserver kommen bei Google in den Spam-Ordner. Liegt vilt. daran das Google die Mail als nicht verifiziert eingestuft hat. Wie mache ich das am dümmsten? 
       
      Die Configs sind die Standartkonfrigurationen von Froxlor.
       
      Hoffe mir wird geholfen. 
       
    • By luovis
      Hello,
      I would like to have my hostname domain to have a website and I found in the forum that in order to do that I would need to get panel to the subdomain.
      1) How do I change the hostname given in the format mydomain.com in the installation process to host.mydomain.com?
      I tried to change it straight in the Settings => System Settings but anything I try to edit there (or even without editing anything but trying to save) I get this:
      Error Unknown Error (not in option): system_ipaddress Back
      I have nothing in the menu IP's and Ports, but didn't want to start putting there anything by trial and error.
      2) If I get the hostname changed, can I make the webspace for the own site using the menu "Domains"? I have already made a "customer" for it.
      I've used this guidance for installing Froxlor:
      https://gridscale.io/en/community/tutorials/install-froxlor-ubuntu/
      I'm using Linode as a cloud server.
      Thank you for your advices.




×
×
  • Create New...