Jump to content
Froxlor Forum
  • 0

Question

I am installing Froxlor 10 on Debian 10 with MySQL and Apache2 on a home web server.

I get to the installation screen by going to localhost/froxlor and I get

"Welcome to Froxlor"

"It seems that Froxlor has not been installed yet."
"Click on the link below to start the installation."

I click "Start Install" and get to this page:

Checking system requirements...

All requirements are satisfied [green] and this is at the bottom:

All requirements are satisfied

 

Clicking the link to continue takes me to:

Database connection

MySQL-Hostname:

Database name:

Username for the unprivileged MySQL-account:

Password for the unprivileged MySQL-account:

Username for the MySQL-root-account:

Password for the MySQL-root-account:

 

Administrator Account

Administrator Username:

Administrator Password:

Administrator-Password (confirm):

Enable the official newsfeed
(https://inside.froxlor.org/news/):

 

Server settings

Server name (FQDN, no ip-address):

Server IP:

Webserver Apache 2.4:

HTTP username:

HTTP groupname:

 

[With all the correct fields and passwords filled in...]

Clicking the [continue] button takes me to the success screen...:

Froxlor install - setup

Checking MySQL-root access... OK
Creating backup of old database... OK 
Preparing database... OK
Creating database and username... OK
Testing if database and user have been created correctly... OK
Importing data... OK
Adjusting settings... OK
Inserting new values... OK
Creating admin-account... OK
Creating configfile... File was saved in /...

Froxlor was installed successfully.

 

Clicking the login button takes me to this:

"Welcome to Froxlor"

"It seems that Froxlor has not been installed yet."
"Click on the link below to start the installation."

And the process starts all over again...

It doesn't matter which browser I use - Chrome, Firefox - the result is the same.

I am a new Linux user, so some help would be appreciated.

Thank you.

 

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

So you're not reading correctly, section "Creating configfile" has clearly not a green result, you should pay attention to what's written there and follow instructions displayed

Link to post
Share on other sites
  • 0
6 hours ago, d00p said:

So you're not reading correctly, section "Creating configfile" has clearly not a green result, you should pay attention to what's written there and follow instructions displayed

Ok, I see my mistake.  I re-run the installer and see this in yellow (which I presume doesn't mean "failed" as that would be red, but "caution, do this", which in fact is what it is telling me to do):

File was saved in /tmp/fx7ROK0g, please move to /var/www/example/froxlor/lib/userdata.inc.php

A quick check of my system shows no file or directory named "fx7ROK0g' anywhere in the file manager.  So while it is telling me to move a file that was created, it was never created.  I have checked for hidden files and everything under '/var/*" and there is no file with that name.

Please advise...

Link to post
Share on other sites
  • 0

under /var/???? it CLEARLY says it's stored in /tmp/

Or just chown your /var/www/froxlor directory with user "www-data" (or which ever applies to your system's webserver user) and be gone with that problem

Link to post
Share on other sites
  • 0
1 hour ago, d00p said:

under /var/???? it CLEARLY says it's stored in /tmp/

Or just chown your /var/www/froxlor directory with user "www-data" (or which ever applies to your system's webserver user) and be gone with that problem

I looked under /tmp/ first, that is why I said nothing was there.  I then went and searched the entire file structure and the file is under /tmp/***apache2***/  <-- really long directory name here...  The directory under which you find the file in question is difficult to locate since it isn't identified as a Froxlor directory, but rather it is namespaced under apache2.

Also, every time you rerun the initialization script, it will generate a new file name under this pseudo-apache2 directory.

Moving it to the specified folder fixed the problem as /var/www/example/froxlor/userdata.inc.php

Thanks

Link to post
Share on other sites
  • 0
1 minute ago, Matteo said:

Also, every time you rerun the initialization script, it will generate a new file name under this pseudo-apache2 directory.

1) sure it generates a new file name, it uses tempnam() and sys_get_temp_dir()

2) even if the file is somehow generated in another temp_dir (as said, we're using php's sys_get_temp_dir() function) then it would TELL you where to find that file and in your case it said /tmp/ 

3) again: if the ownership of the froxlor files is correctly set to the webserver user you won't even be in that situation because then the installer is allowed to write its config file to /var/www/froxlor/lib/ itself

5 minutes ago, Matteo said:

Moving it to the specified folder fixed the problem as /var/www/example/froxlor/userdata.inc.php

of course it does...that's the whole point of the message that is being displayed

Link to post
Share on other sites
  • 0
On 5/1/2020 at 9:42 PM, Matteo said:

I looked under /tmp/ first, that is why I said nothing was there.  I then went and searched the entire file structure and the file is under /tmp/***apache2***/  <-- really long directory name here...  The directory under which you find the file in question is difficult to locate since it isn't identified as a Froxlor directory, but rather it is namespaced under apache2.

Also, every time you rerun the initialization script, it will generate a new file name under this pseudo-apache2 directory.

Moving it to the specified folder fixed the problem as /var/www/example/froxlor/userdata.inc.php

Thanks

I am facing the same issue. I did try to locate the file but in vain as you have mentioned. It is really difficult to locate. Can you help me with step by step process and commands used to find and move the file to  help me fix the problem at my end.

Link to post
Share on other sites
  • 0
6 hours ago, d00p said:

Well, the messages clearly state what you should do. What else do you need?

I am not able to locate the file or apache2 folder to enable it to be moved to var/www/html/froxlor....

Please help

Link to post
Share on other sites
  • 0

No idea what you guys do. Just chown /var/www/froxlor to www-data and the installation will be able to create the file right away at the correct destination. Anything else is just fallback. And if the Webserver is not able to create files in /tmp/ which should be world writable then i can't help it

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By Henrik
      Hi 
      I have not yet installed Froxlor, but before I do so I would like to know if it is possible to install Froxlor on a server where the Database MySql server is actually located on another server?
      So the webserver is separated from the database server?
      Henrik
    • By Marcel -//- AdSoleWare
      Hello.
      I manually installed Froxlor on Debian 8 and tried setting up. i installed php 7.3 in as it was the only missing point. i restarted apache2 and now it wont start. I need help
       
      Error Log:
       
    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
    • By tmuecksch
      Hallo liebe Community.
      Ich habe einen neuen Debian 9.4 Server aufgesetzt und Froxlor installiert (gemäß Wiki). Nach Durchführung aller notwendigen Konfigurationsschritte hat Froxlor wie gewohnt funktioniert. Anschließend habe ich ein SSL Zertifikat hochgeladen und in Froxlor, unter Einstellungen > SSL-Einstellungen  habe ich SSL aktiviert und die Pfade Zertifikatfiles angegeben. Anschließend habe ich eine einen neuen Eintrag unter IPs und Ports konfiguriert mit Port 443.
      Nach Generierung der neuen Config Files durch Froxlor ist folgender Fehler aufgetreten, der Apache nicht mehr starten lässt.
      May 17 09:50:14 X.de apachectl[1516]: (99)Cannot assign requested address: AH00072: make_sock: could not bind to address X:443 May 17 09:50:14 X.de apachectl[1516]: no listening sockets available, shutting down  
      Also würde ja nahe liegen, dass der Socket in Verwendung ist (was bei einem frischen Debian doch unwahrscheinlich ist)
      ➜ ~ netstat -tlpn | grep 443 ➜ ~ Der Port ist, wie wir sehen nicht in Verwendung. 
       
      ➜ ~ grep -r "Listen" /etc/apache2/ /etc/apache2/sites-enabled/10_froxlor_ipandport_X.443.conf:Listen X:443 /etc/apache2/ports.conf:Listen 80 /etc/apache2/ports.conf: Listen 443 /etc/apache2/ports.conf:# Listen 443 Man könnte nun vermuten, dass die beiden Listen 443 Einträge in der ports.conf den Fehler verursachen. Doch weit gefehlt. Wenn ich die beiden Einträge entferne ändert das nichts.
       
      Der Fehler lässt sich nur beheben wenn ich in der folgenden Datei die Zeile "Listen X:443" manuell lösche:
      # 10_froxlor_ipandport_X.443.conf # Created 17.05.2018 09:49 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Listen X:443 <VirtualHost X:443> DocumentRoot "/var/www/" ServerName Z.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/letsencrypt/live/Z.de/cert.pem SSLCertificateKeyFile /etc/letsencrypt/live/Z.de/privkey.pem SSLCertificateChainFile /etc/letsencrypt/live/Z.de/chain.pem </VirtualHost>  
      Wie kann das sein? Wieso generiert Froxlor eine nicht funktionierende VHost Config? Habe ich vielleicht was falsch gemacht? Ist der Fehler schon bekannt?
       
      P.S: Meine IP Adresse und Domain habe ich durch Großbuchstaben ersetzt.
       
    • By Randall Newman
      I have been in the process of installing Froxlor in a Google Cloud Instance. All the errors I have encountered I was able to fix them by searching on the web, but this one I couldn't find a solution for the past two hours. Simply I need help solving this error.?

×
×
  • Create New...