Jump to content
Froxlor Forum

tmuecksch

Members
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

0 Neutral

About tmuecksch

  • Rank
    Froxie
  1. Falls noch einmal jemand ein solches Problem mit Wordpress haben sollte hier meine Lösung: Unter https://gist.github.com/Adirael/3383404 gibt es ein script welches die Permissions für Wordpress Installationen fixt. Anschließend werden die Dateien wieder korrekt angelegt. Bitte unbedingt die Kommentare lesen, da sind wichtige Infos dabei.
  2. @Neutrino Danke für den Tipp. Auch das zeigt leider keine Wirkung. Mittlerweile bin ich auch noch mal einen Schritt weiter. Ich habe mit folgendem Script mal getestet wie von PHP Dateien angelegt werden: <?php if ($fp = fopen(time() . '.txt', 'w')) { fwrite($fp, 'This is a simple test.'); fclose($fp); echo "done"; } else { echo "error - cannot create file"; } Quelle: https://serverfault.com/questions/383734/how-do-i-set-default-umask-in-apache-on-debian Und mit diesem Script werden die Dateien korrekt angelegt. Das heißt, es muss ein Wordpress-Problem und kein Konfigurationsld00problem sein. @d00p Vielen dank für's in die Richtige Richtung schubsen.
  3. Danke für den Hinweis, das Stichwort umask hat mir gefehlt. sudo -u www-data touch foo erstellt Daten mit korrekten Rechten (-rw-r--r--). Laut diversen Google-Ergebnissen soll es helfen in "/etc/apache2/envvars" eine umask option "umask 002" einzufügen (+ apache2 Neustart versteht sich). Auch das hilft leider nicht. Ich google mal weiter...
  4. Trotz installation und Aktivierung in den Einstellungen bleibt das Permissions problem. Ich habe mal einen Screenshot einer hochgeladenen Datei beigefügt. Sie wird mit "--w--w--w- 1 www-data www-data" erstellt...
  5. Danke für Deine Antwort! Hier zunächst mal zu Einfachheit meine via apt-get installierten Pakete, sofern das für Dich interessant ist: https://pastebin.com/ExwSc9HY Hier noch meine aktivierten Apache mods: https://pastebin.com/fQagdrxG Weder bei libnss-mysql noch bei extrausers klingelt es bei mir. Der Server ist erst vor kurzem installiert worden, dazu habe ich ein reines Debian Image genutzt und dann Froxlor gemäß der Anleitung im Wiki und gemäß der Anweisungen in der Admin-UI unter Konfigurationen installiert. Das Einzige was ich darüber hinaus noch gemacht habe ist php-memcache zu installieren, da unser Wordpress ohne nicht funktioniert hat.
  6. Guten Tag, ich habe einen Debian 9 Server mit Froxlor und Apache2 am laufen. Wenn ich mit dem Kunden FTP Zugang Dateien hochlade haben diese Ordnungsgemäß das ownership 10000:10000. Wenn jedoch in der PHP-Weboberfläche eine Datei hochgeladen wird, wird diese mit dem ownership www-data:www-data hochgeladen. Liegt hier ein Konfigurationsfehler vor oder ist das Verhalten sogar so gewünscht? Ich kann den Fehler leider nicht entdecken. Das Problem ist nur, dass das PHP-Script dann eine Permission Denied Fehlermeldung wirft, wenn versucht wird die Datei zu lesen. Liebe Grüße tmuecksch
  7. Hallo. Ich habe leider genau das selbe Problem und google schon seit stunden. Hast Du eine Lösung gefunden?
  8. Hallo liebe Community. Ich habe einen neuen Debian 9.4 Server aufgesetzt und Froxlor installiert (gemäß Wiki). Nach Durchführung aller notwendigen Konfigurationsschritte hat Froxlor wie gewohnt funktioniert. Anschließend habe ich ein SSL Zertifikat hochgeladen und in Froxlor, unter Einstellungen > SSL-Einstellungen habe ich SSL aktiviert und die Pfade Zertifikatfiles angegeben. Anschließend habe ich eine einen neuen Eintrag unter IPs und Ports konfiguriert mit Port 443. Nach Generierung der neuen Config Files durch Froxlor ist folgender Fehler aufgetreten, der Apache nicht mehr starten lässt. May 17 09:50:14 X.de apachectl[1516]: (99)Cannot assign requested address: AH00072: make_sock: could not bind to address X:443 May 17 09:50:14 X.de apachectl[1516]: no listening sockets available, shutting down Also würde ja nahe liegen, dass der Socket in Verwendung ist (was bei einem frischen Debian doch unwahrscheinlich ist) ➜ ~ netstat -tlpn | grep 443 ➜ ~ Der Port ist, wie wir sehen nicht in Verwendung. ➜ ~ grep -r "Listen" /etc/apache2/ /etc/apache2/sites-enabled/10_froxlor_ipandport_X.443.conf:Listen X:443 /etc/apache2/ports.conf:Listen 80 /etc/apache2/ports.conf: Listen 443 /etc/apache2/ports.conf:# Listen 443 Man könnte nun vermuten, dass die beiden Listen 443 Einträge in der ports.conf den Fehler verursachen. Doch weit gefehlt. Wenn ich die beiden Einträge entferne ändert das nichts. Der Fehler lässt sich nur beheben wenn ich in der folgenden Datei die Zeile "Listen X:443" manuell lösche: # 10_froxlor_ipandport_X.443.conf # Created 17.05.2018 09:49 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Listen X:443 <VirtualHost X:443> DocumentRoot "/var/www/" ServerName Z.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder On SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/letsencrypt/live/Z.de/cert.pem SSLCertificateKeyFile /etc/letsencrypt/live/Z.de/privkey.pem SSLCertificateChainFile /etc/letsencrypt/live/Z.de/chain.pem </VirtualHost> Wie kann das sein? Wieso generiert Froxlor eine nicht funktionierende VHost Config? Habe ich vielleicht was falsch gemacht? Ist der Fehler schon bekannt? P.S: Meine IP Adresse und Domain habe ich durch Großbuchstaben ersetzt.
  9. Vielen Dank. Dann werde ich das mal ausprobieren!
  10. Hey, kurze Frage. Laut Debian-Wiki wird Debian 9 "Stretch" am 16.06.2017 offizielle released und damit stable (Link: https://wiki.debian.org/DebianStretch#Before_the_release). Ich möchte einen neuen Debian-Server mit Froxlor aufsetzen. Unterstützt Froxlor bereits Debian Stretch? Oder soll ich lieber Jessie nehmen? PS.: Über die Foren-Suche konnte ich leider keine Antwort darauf finden. Liebe Grüße tmuecksch
  11. Genau deswegen hab ich gefragt Danke für die Infos
  12. Wie man Debian upgraded weiß ich. Darum geht es nicht. Ich schreibe hier ins Forxlor Forum, da die eigentliche Frage ist, ob es notwendig ist zusätzliche Schritte vorzunehmen damit Froxlor nach dem Upgrade fehlerfrei funktioniert oder ob es einfach out-of-the-box funktioniert. Damals beim Upgrade auf Wheezy habe ich mir Froxlor mit einem simplen system upgrade zerschossen (obwohl es laut froxlor.org zu diesem Zeitpunkt bereits unterstützt wurde) und dachte ich frage mal bevor das Kind in den Brunnen gefallen ist.
  13. Danke für den freundlichen Hinweis. Dass Jessie unterstützt wird weiß ich. Die Frage zielte eigentlich eher darauf ab ob es eine Anleitung zur Migration/Update von Wheezy auf Jessie gibt, da ich den Eindruck hatte, dass das auch hier diskutiert wurde. Reicht einfach ein dist-upgrade?
×
×
  • Create New...