Jump to content
Froxlor Forum
  • 0
Marcel -//- AdSoleWare

Froxlor Update Error 500 And apache crash

Question

Hello.

I manually installed Froxlor on Debian 8 and tried setting up. i installed php 7.3 in as it was the only missing point. i restarted apache2 and now it wont start. I need help

 

Error Log:

Zitat

[Wed Feb 19 15:12:34.474085 2020] [:error] [pid 1941] [client 188.22.253.17:61745] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 66, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:12:34.474116 2020] [:error] [pid 1941] [client 188.22.253.17:61745] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 67, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:12:34.474137 2020] [:error] [pid 1941] [client 188.22.253.17:61745] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 64, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:12:34.474145 2020] [:error] [pid 1941] [client 188.22.253.17:61745] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 65, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:12:34.474150 2020] [:error] [pid 1941] [client 188.22.253.17:61745] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 66, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:12:34.474174 2020] [:error] [pid 1941] [client 188.22.253.17:61745] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 67, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:13:22.779392 2020] [:error] [pid 1951] [client 188.22.253.17:61839] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 64, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:13:22.779467 2020] [:error] [pid 1951] [client 188.22.253.17:61839] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 65, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:13:22.779478 2020] [:error] [pid 1951] [client 188.22.253.17:61839] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 66, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:13:22.779517 2020] [:error] [pid 1951] [client 188.22.253.17:61839] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 67, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:13:22.779546 2020] [:error] [pid 1951] [client 188.22.253.17:61839] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 64, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:13:22.779590 2020] [:error] [pid 1951] [client 188.22.253.17:61839] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 65, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:13:22.779599 2020] [:error] [pid 1951] [client 188.22.253.17:61839] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 66, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:13:22.779631 2020] [:error] [pid 1951] [client 188.22.253.17:61839] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 67, referer: http://cloud01.adsoleware.com/froxlor/admin_index$
[Wed Feb 19 15:20:01.387577 2020] [mpm_prefork:notice] [pid 1035] AH00171: Graceful restart requested, doing restart
[Wed Feb 19 15:20:01.474372 2020] [mpm_prefork:notice] [pid 1035] AH00163: Apache/2.4.10 (Debian) configured -- resuming normal operations
[Wed Feb 19 15:20:01.474389 2020] [core:notice] [pid 1035] AH00094: Command line: '/usr/sbin/apache2'
[Wed Feb 19 15:25:01.750438 2020] [mpm_prefork:notice] [pid 1035] AH00171: Graceful restart requested, doing restart
[Wed Feb 19 15:25:01.819378 2020] [mpm_prefork:notice] [pid 1035] AH00163: Apache/2.4.10 (Debian) configured -- resuming normal operations
[Wed Feb 19 15:25:01.819396 2020] [core:notice] [pid 1035] AH00094: Command line: '/usr/sbin/apache2'
[Wed Feb 19 15:30:02.126880 2020] [mpm_prefork:notice] [pid 1035] AH00171: Graceful restart requested, doing restart
[Wed Feb 19 15:30:02.213665 2020] [mpm_prefork:notice] [pid 1035] AH00163: Apache/2.4.10 (Debian) configured -- resuming normal operations
[Wed Feb 19 15:30:02.213681 2020] [core:notice] [pid 1035] AH00094: Command line: '/usr/sbin/apache2'
[Wed Feb 19 16:13:55.136504 2020] [:error] [pid 3160] [client 194.118.120.145:1455] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 64, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:13:55.136612 2020] [:error] [pid 3160] [client 194.118.120.145:1455] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 65, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:13:55.136625 2020] [:error] [pid 3160] [client 194.118.120.145:1455] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 66, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:13:55.136670 2020] [:error] [pid 3160] [client 194.118.120.145:1455] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 67, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:13:55.136706 2020] [:error] [pid 3160] [client 194.118.120.145:1455] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 64, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:13:55.136717 2020] [:error] [pid 3160] [client 194.118.120.145:1455] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 65, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:13:55.136725 2020] [:error] [pid 3160] [client 194.118.120.145:1455] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 66, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:13:55.136758 2020] [:error] [pid 3160] [client 194.118.120.145:1455] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 67, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:14:12.043752 2020] [:error] [pid 3166] [client 194.118.120.145:1499] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 64, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:14:12.043862 2020] [:error] [pid 3166] [client 194.118.120.145:1499] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 65, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:14:12.043881 2020] [:error] [pid 3166] [client 194.118.120.145:1499] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 66, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:14:12.043936 2020] [:error] [pid 3166] [client 194.118.120.145:1499] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 67, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:14:12.043973 2020] [:error] [pid 3166] [client 194.118.120.145:1499] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 64, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:14:12.043983 2020] [:error] [pid 3166] [client 194.118.120.145:1499] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 65, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:14:12.043990 2020] [:error] [pid 3166] [client 194.118.120.145:1499] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 66, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:14:12.044023 2020] [:error] [pid 3166] [client 194.118.120.145:1499] PHP Notice:  Trying to get property of non-object in /var/www/froxlor/lib/ajax.php on line 67, referer: http://cloud01.adsoleware.com/froxlor/admin_inde$
[Wed Feb 19 16:14:51.513646 2020] [:error] [pid 3159] [client 194.118.120.145:1592] PHP Parse error:  syntax error, unexpected '?' in /var/www/froxlor/lib/Froxlor/Api/Commands/Customers.php on line 291, referer: http://cloud01.adsolewar$
[Wed Feb 19 16:25:05.215909 2020] [:error] [pid 3234] [client 194.118.120.145:2919] PHP Parse error:  syntax error, unexpected '?' in /var/www/froxlor/lib/Froxlor/Api/Commands/Customers.php on line 291, referer: http://cloud01.adsolewar$
[Wed Feb 19 16:25:07.941168 2020] [:error] [pid 3231] [client 194.118.120.145:2936] PHP Parse error:  syntax error, unexpected '?' in /var/www/froxlor/lib/Froxlor/Api/Commands/Customers.php on line 291
[Wed Feb 19 16:25:08.693129 2020] [:error] [pid 3232] [client 194.118.120.145:2937] PHP Parse error:  syntax error, unexpected '?' in /var/www/froxlor/lib/Froxlor/Api/Commands/Customers.php on line 291
[Wed Feb 19 16:25:09.206550 2020] [:error] [pid 3158] [client 194.118.120.145:2940] PHP Parse error:  syntax error, unexpected '?' in /var/www/froxlor/lib/Froxlor/Api/Commands/Customers.php on line 291
[Wed Feb 19 16:40:35.880619 2020] [:error] [pid 3166] [client 194.118.120.145:4897] PHP Parse error:  syntax error, unexpected '?' in /var/www/froxlor/lib/Froxlor/Api/Commands/Customers.php on line 291, referer: http://cloud01.adsolewar$
[Wed Feb 19 16:40:48.705588 2020] [:error] [pid 3159] [client 194.118.120.145:4941] PHP Fatal error:  Class 'Froxlor\\Database\\Database' not found in /var/www/froxlor/lib/Froxlor/Settings.php on line 84
[Wed Feb 19 16:44:47.916920 2020] [mpm_prefork:notice] [pid 1035] AH00169: caught SIGTERM, shutting down
 

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Error Message indicates that you are not using php-7.0+

Share this post


Link to post
Share on other sites
  • 0

I guess you need to activate the correct php module for apache ;) a2enmod php7 / a2enmod php - depending on how you've installed php7 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Matteo
      I am installing Froxlor 10 on Debian 10 with MySQL and Apache2 on a home web server.
      I get to the installation screen by going to localhost/froxlor and I get
      "Welcome to Froxlor"
      "It seems that Froxlor has not been installed yet."
      "Click on the link below to start the installation."
      I click "Start Install" and get to this page:
      Checking system requirements...
      All requirements are satisfied [green] and this is at the bottom:
      All requirements are satisfied
        Clicking the link to continue takes me to:
      Database connection
      MySQL-Hostname:
      Database name:
      Username for the unprivileged MySQL-account:
      Password for the unprivileged MySQL-account:
      Username for the MySQL-root-account:
      Password for the MySQL-root-account:
       
      Administrator Account
      Administrator Username:
      Administrator Password:
      Administrator-Password (confirm):
      Enable the official newsfeed
      (https://inside.froxlor.org/news/):
       
      Server settings
      Server name (FQDN, no ip-address):
      Server IP:
      Webserver Apache 2.4:
      HTTP username:
      HTTP groupname:
       
      [With all the correct fields and passwords filled in...]
      Clicking the [continue] button takes me to the success screen...:
      Froxlor install - setup
      Checking MySQL-root access... OK Creating backup of old database... OK  Preparing database... OK Creating database and username... OK Testing if database and user have been created correctly... OK Importing data... OK Adjusting settings... OK Inserting new values... OK Creating admin-account... OK Creating configfile... File was saved in /... Froxlor was installed successfully.
        Clicking the login button takes me to this:
      "Welcome to Froxlor"
      "It seems that Froxlor has not been installed yet."
      "Click on the link below to start the installation."
      And the process starts all over again...
      It doesn't matter which browser I use - Chrome, Firefox - the result is the same.
      I am a new Linux user, so some help would be appreciated.
      Thank you.
       
    • By stolly82
      Hey together, 
       
      after almost 4 years using Froxlor on a Jessie system and really no issues I installed now 3 times a new Buster image, unfortunatley the server is crashing really random without any informations I can find. 
       
      Yesterday Hetzner changed my server, because they also told me this can be only a Hardware bug if the image is almost virgin, but today (and now we took that server live) the Server again crashed, so this can't be a hardware fail then. 
       
      We are using just the Hetzner Debian 10.3 LAMP with Froxlor. 
       
      Now Froxlor is the restored version from the old server, the crash is also with a plain image and a virgin Froxlor. 
       
      Strange is, all Logs I checked are clean, there is nothing happen except that the logs are stopping all at the same time (when it freezes) and they are starting again when I make a hard reset. 
       
      This is my journalctl from that time where the crash was. 19:59 I noticed that and restarted the server. 
       
      May be somebody from you has an idea how we can figure out how this can happen and may be a solution 🙂 

      For me it's total not understandable. 
      Thanks 
       
      Jan
       
      HARDWARE:
       

    • By Michael Groß
      Hallo,
      nachdem ich meinen Froxlor-Server neu aufgesetzt habe, habe ich nun ein anderes komisches Problem.
      Ich habe die Konfigurationsschritte vollständig durchgeführt - sicherheitshalber auch zuerst "automatisch" durchführen lassen und danach noch einmal verifiziert.
      Lege ich nun einen Kunden an (http://test.computer-stube.com), verweist dies auf den Root des Servers.
      Schaue ich in die vHost-Datei, steht dort folgendes:
      # 29_froxlor_normal_vhost_test.computer-stube.com.conf # Created 07.02.2020 16:55 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:80> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> # 29_froxlor_ssl_vhost_test.computer-stube.com.conf # Created 07.02.2020 17:26 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 (SSL) - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:443> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder off SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/certs/apache.crt SSLCertificateKeyFile /etc/ssl/private/apache.key <IfModule mod_headers.c> Header always set Strict-Transport-Security "max-age=0" </IfModule> DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> Also an sich ist die richtige Konfiguration hinterlegt.
      Im Cron ist folgendes konfiguriert:

      # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null 5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null 0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null 10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --backup 1> /dev/null Auch das manuelle Ausführen mittels "
      php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force bringt bei mir leider keinen Erfolg.
      Die Ausgabe vom debug ist wie folgt:
      root@lx001:/etc/apache2/sites-enabled# php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Requesting/renewing Let's Encrypt certificates [information] No new certificates or certificates due for renewal found [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:80 [notice] 178.63.105.174:80 :: namevirtualhost-statement no longer needed for apache-2.4 [debug] 178.63.105.174:80 :: inserted vhostcontainer [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:443 [debug] 178.63.105.174:443 :: inserted vhostcontainer [information] apache::createVirtualHosts: creating vhost container for domain 3, customer test [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/ [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi [notice] Creating passwd file [notice] Writing 1 entries to passwd file [notice] Succesfully wrote passwd file [notice] Creating group file [notice] Writing 1 entries to group file [notice] Succesfully wrote group file [notice] Creating shadow file [notice] Writing 1 entries to shadow file [notice] Succesfully wrote shadow file [notice] Checking system's last guid  
      Ich fühle mich gerade echt dämlich, kann ja eigentlich nicht so schwer sein, da es eigentlich ja alles nur "Copy+Paste" ist
      Das Endverzeichnis wurde jedoch korrekt angelegt:
      root@lx001:/var/customers/webs# ls test root@lx001:/var/customers/webs# cd test root@lx001:/var/customers/webs/test# ls index.html webalizer Ich habe zusätzlich zur "Standardkonfiguration" noch libnss-extrausers und FCGID  eingerichtet, da ich ältere PHP Versionen benötige.
      Grüße
      Michael
    • By Tom Spielvogel
      Hello community, i have updated my froxlor version from 0.8 or 0.9 i don't exactly remember to 0.10.12 to use the ACMEv2 challenges for Let's Encrypt.
      I have sql-dumped the old database.
      Any pointers on how I can restore the data into my new database? I don't want to manually type in all the customers with all their settings again 😮
      Please help!
    • By tmuecksch
      Guten Tag,
      ich habe einen Debian 9 Server mit Froxlor und Apache2 am laufen. Wenn ich mit dem Kunden FTP Zugang Dateien hochlade haben diese Ordnungsgemäß das ownership 10000:10000.
      Wenn jedoch in der PHP-Weboberfläche eine Datei hochgeladen wird, wird diese mit dem ownership www-data:www-data hochgeladen. Liegt hier ein Konfigurationsfehler vor oder ist das Verhalten sogar so gewünscht? Ich kann den Fehler leider nicht entdecken. Das Problem ist nur, dass das PHP-Script dann eine Permission Denied Fehlermeldung wirft, wenn versucht wird die Datei zu lesen.
       
      Liebe Grüße
      tmuecksch
×
×
  • Create New...