Jump to content
Froxlor Forum
  • 0
OliverRahner

overriding nginx try_files setting

Question

And the next issue on my way to nginx'iness.

I want to run Seafile on one vhost. I added all the settings Seafile told me to in their manual (https://manual.seafile.com/deploy/deploy_with_nginx.html).

Didn't work at first (got 404'ed after the initial redirect), but once I commented out either the "try_files" in "location /" or in "location @php" it started working.
It seems that the =404 which is default in "location @php" is the issue.

Even after reading through the source code's "mergeVhostCustom" magic I couldn't find a way to override the default try_files statement without patching my Froxlor installation...

Any hints?

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

There is currently no possibility to edit this, sorry

Share this post


Link to post
Share on other sites
  • 1
On 1/26/2018 at 10:46 AM, d00p said:

There is an issue on github for this already...

 

On 7/12/2017 at 5:35 AM, negrusti said:

Most of WordPress static caching plugins require try_files modification on Nginx, this is a very much needed feature.

 

On 6/6/2017 at 12:04 PM, OliverRahner said:

And the next issue on my way to nginx'iness.

I want to run Seafile on one vhost. I added all the settings Seafile told me to in their manual (https://manual.seafile.com/deploy/deploy_with_nginx.html).

Didn't work at first (got 404'ed after the initial redirect), but once I commented out either the "try_files" in "location /" or in "location @php" it started working.
It seems that the =404 which is default in "location @php" is the issue.

Even after reading through the source code's "mergeVhostCustom" magic I couldn't find a way to override the default try_files statement without patching my Froxlor installation...

Any hints?

 

On 1/26/2018 at 10:46 AM, d00p said:

There is an issue on github for this already...



Please how are current FROXLOR users able to Host websites like Wordpress and other websites since this issue is yet to be resolved.

Please I really need your response as most of my websites are either Pure PHP or WordPress and I use NGINX as web server and PHP-FPM on a CentOS 7 machine

 

Share this post


Link to post
Share on other sites
  • 0

My current quick-and-very-dirty workaround looks like this:

froxlor/scripts/jobs/cron_tasks.inc.http.30.nginx.php

if ($domain['phpenabled_customer'] == 1 && $domain['phpenabled_vhost'] == '1') {
    $webroot_text .= "\t" . 'index    index.php index.html index.htm;' . "\n";
    if (!preg_match("/^##NO_TRY_FILES$/m", $domain['specialsettings']))
    {
        $webroot_text .= "\t\t" . 'try_files $uri $uri/ @rewrites;' . "\n";
    } else {
        // NO_TRY_FILES statement found, don't put try_files into config
    }
} else {
    $webroot_text .= "\t" . 'index    index.html index.htm;' . "\n";
}

If I now put the statement "##NO_TRY_FILES" on a line by itself into the vhost special settings, no "try_files" will be generated in "location /".

Share this post


Link to post
Share on other sites
  • 0

Open Up a bugreport/Feature request on github then please.

Share this post


Link to post
Share on other sites
  • 0

I also require this Feature.

Most websites including WordPress require a config as simple as 

location / {
     try_files $uri $uri/ /index.php?$args ;
}

 

But this conflicts with what's Provided by Froxlor and NGINX would give error unable to start due to multiple  Location/      directives.
Once I digged into Froxlor, commented it out and mine worked But that equally affected my Froxlor installation forcing me to revert it back.

Please it's a much needed feature.
Thanks for the Good Work

Share this post


Link to post
Share on other sites
  • 0
On 7/12/2017 at 5:37 AM, d00p said:

Open Up a bugreport/Feature request on github then please.

I also require this Feature.

Most websites including WordPress require a config as simple as 

location / {
     try_files $uri $uri/ /index.php?$args ;
}

 

But this conflicts with what's Provided by Froxlor and NGINX would give error unable to start due to multiple  Location/      directives.
Once I digged into Froxlor, commented it out and mine worked But that equally affected my Froxlor installation  (giving either WHITE Screen or 500 internal Error) forcing me to revert it back.

Please it's a much needed feature.
Thanks for the Good Work

Share this post


Link to post
Share on other sites
  • 0
On 1.2.2018 at 7:55 PM, kingsley ezenwa said:

Please how are current FROXLOR users able to Host websites like Wordpress and other websites since this issue is yet to be resolved.

Don't know what you mean. Just installed a test wordpress on a server running nginx....no problem...again, like in other threads: READ CAREFULLY:

On 1.2.2018 at 7:55 PM, kingsley ezenwa said:

Most of WordPress static caching plugins require try_files modification on Nginx, this is a very much needed feature.

This doesn't mean wordpress itself does not work...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Schutzgeist
      Hallo, 
      vielleicht kann mir jemand hier ja einen kleinen Tipp geben.
      Es ist mehr eine nginx-Konfiguration. 
      PHP-404-Rückmeldungen sollen "sauber" an Joomla übergeben werden.
       
      Mein 'Froxlor-Standardvhost sieht wie folgt aus

      Allerdings kann ich über das Joomla eigene REDIRECT Modul keine .php - Erweiterungen intern umleiten. 
      Anstatt  die joomla-eigene 404 Seite zu erhalten, bekomme ich die von nginx, da  die Abfrage hier als erstes ausgeführt wird. 
      Also habe ich meine vhost stümperhaft umgeschrieben, s.d. ein Teil seinen Soll erfüllt. 

      Teilweise kann ich nun die Redirects über Joomla verwalten lassen, aber oft erhalte ich LOOPs, da ich ja immer auf die index.php verweise. 
      So, warum nutze ich nicht die nginx-Weiterleitungen ? 

      Ich nutze ein Multi-Sitemodul  sowie ein Modul, um eine php-Endung  zu simulieren. 
      Beide haben mit meiner und der Standardvhost-Konfiguration leichte Schwierigkeiten. 

       
      Welche Vhost-Anpassungen nutzt ihr bei Eurer Joomla-Webseite ? 
      Der Fehler sitzt vermutlich 30 cm vor meinem Bildschirm. 
      Innerhalb meiner letzten 30 Versuche habe ich wohl  oft alte Cache-Webseiten geladen und ggf. die richtige Konfig übersehen.
       

       
       
       
       
       
    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
    • By Evren
      Hi,
      I wonder if there is anyone who able to properly set up Let's Encrypt feature with nginx?
      I followed suggested steps but I couldn't make it happen.
      - activate Let's Encrypt in the settings - as admin, goto Configuration -> select your distro -> select Webserver -> select your software - copy'n'paste the acme.conf part of the configration template - restart/reload webserver Then I run the cron
      php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug
       
      [information] Updating Let's Encrypt certificates [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid  
      But, when I try to enable Let's Encrypt for a domain, the system automatically uncheck this option after I save.
      Any idea?
      Thanks
    • By seochemnitz
      Moin,
      ich habe da mal eine Frage zum Browser Caching.
      Man kann das Browser Caching in den conf Dateien unter /etc/nginx/sites-available/ mit folgenden Befehl aktivieren.
      location ~* \.(jpg|jpeg|png|gif|ico|css|js)$ { expires 365d; } Das funktioniert wunderbar. Leider werden die conf Dateien durch den Cronjob wieder überschrieben.
      Gibt es eine Möglichkeit das irgendwo fest zu hinterlegen, damit es automatisch in die neu generierten Dateien eingetragen wird?
       
      NGINX 1.3.1
      PHP5
      0.9.38.7-1+wheezy1
       
      Ich freue mich auf eure Antworten!
      Silvio
    • By hede
      Hallo,
      ich habe Debian Strecht und nginx mit MariaDB installiert und möchte gern PHP 7 mit FPM ans laufen bekommen.
      Das erste Problem, dass ich habe ist, dass die Ausgabe von ls /var/customers/webs nicht die User sondern nur die ID ausgibt.
      drwxr-xr-x 5 10000 10000 4096 Nov 10 15:26 web1 Habe alles wie in der Anleitung beschrieben installiert und erhalte auch hier die User:
      cat /var/lib/extrausers/passwd web1:x:10000:10000:Froxlor User:/var/customers/webs/web1/:/bin/false Nun läuft der Webserver auch trotzdem und ich kann per FTP Dateien hochladen. Allerdings wird der PHP Socket nicht erstellt.
      In der vHost steht z.B.
      fastcgi_pass unix:/var/run/php/web1-meinedomain.de-php-fpm.socket;
      Im Ordner /var/run/php existieren aber nur php7.0-fpm.pid und php7.0-fpm.sock. Im Froxlor Backend habe ich " Verwende libnss-extrausers anstatt libnss-mysql" aktiviert. Cronjobs sind auch eingerichtet.
       
      Ich hatte auch mal in der /etc/php/7.0/fpm/pool.d/www.conf folgende Zeile eingefügt "include=/etc/php-fpm.d/*.conf". Ob das richtig ist weiß ich leider nicht. Aber wenn ich dann fpm neustarte erhalte ich folgende Fehler:
      ERROR: [pool meinedomain.de] cannot get uid for user 'web1' Ich vermute es hat mit libnss zu tun. Habt Ihr vielleicht eine Idee?
×
×
  • Create New...