Jump to content
Froxlor Forum

seochemnitz

Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About seochemnitz

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Ich habe für mich eine Lösung gefunden. Wenn man weiß wo man anfassen muss ist es ganz einfach. Da ich an Froxlor nicht ran kam, habe ich mir per MySQLDump ein Backup der Froxlor Datenbank gezogen. Habe diese mit MySQL Workbench geöffnet und habe nach "extrausers" gesucht. War natürlich nicht aktiviert und habe den Wert von 0 auf 1 gesetzt. Das gleiche habe ich mit den Pfad zu den php-fpm.sockets gemacht. Nach /var/run/ gesucht und in /var/run/php/ geändert. Dann die Datenbank wieder eingespielt und den Server neu gestartet. Dat Ding läuft wie Hecke! Als wenn nichts gewesen wäre. Grüße aus Chemnitz Silvio
  2. So, ich bin wieder da. Neues System, gleiches Problem. Server neu aufsetzen, Mail einrichten usw. ist alles kein Problem. Bei php-fpm (jetzt php7.2-fpm) ist alles vorbei. Die Anleitung habe ich befolgt (wenn ich das English richtig verstanden habe) https://github.com/Froxlor/Froxlor/wiki/nginx-with-php-fpm Ich habe ein Error 502 auf allen Seiten. An Froxlor komme ich nicht ran. php7.2-fpm startet nicht. (cannot get uid for user ) journalctl -xe -- Unit php7.2-fpm.service has begun starting up. Mär 20 00:27:47 mail php-fpm7.2[1808]: [20-Mar-2018 00:27:47] ERROR: [pool AnjaFrox.mail.xt-host.de] cannot get uid for user 'AnjaFrox' Mär 20 00:27:47 mail php-fpm7.2[1808]: [20-Mar-2018 00:27:47] ERROR: FPM initialization failed Mär 20 00:27:47 mail systemd[1]: php7.2-fpm.service: Main process exited, code=exited, status=78/n/a Mär 20 00:27:47 mail systemd[1]: Failed to start The PHP 7.2 FastCGI Process Manager. -- Subject: Unit php7.2-fpm.service has failed -- Defined-By: systemd -- Support: https://www.debian.org/support -- -- Unit php7.2-fpm.service has failed. -- -- The result is failed. Mär 20 00:27:47 mail systemd[1]: php7.2-fpm.service: Unit entered failed state. Mär 20 00:27:47 mail systemd[1]: php7.2-fpm.service: Failed with result 'exit-code'. Die config Dateien werden nicht in /etc/php/7.2/fpm/pool.d sondern in /etc/php/7.0/fpm/pool.d geschrieben. Die vhost Dateien werden generiert und liegen in /etc/nginx/sites-enabled. System: Debian 9 nginx/1.12.2 php7.2 mysql 5.7.21 nscd libnss-extrausers sind installiert und angepasst Danke! Gruß Silvio
  3. Ja, das ist mir bewusst! Trotzdem Danke für den Hinweis.
  4. Das Hauptproblem ist ersteinmal gelöst. Ich habe mir Froxlor local installiert und bin dann nochmal Schritt für Schritt die Konfiguration durchgegangen. Die Configs von libnss und nsswitch waren das Problem. MySQL Zugangsdaten bewirken doch manchmal Wunder. Was mir noch noch nicht gefällt sind die Ladezeiten der Seiten. Seiten die vorher teilweise unter 500ms geladen wurden brauchen jetzt 1,5 Sekunden oder mehr. Aber das scheint nur ein bischen Feintuning zu sein. Wordpress braucht auch keine FTP Zugangsdaten mehr. GENIAL! Vielen Dank für deine Hilfe!
  5. Moin, dann fang ich mal an. Eigentlich wollte ich nur Plugins im Wordpress aktualisieren. Da mir das Eingeben der FTP Zugangsdaten in Wordpress aber auf dem Sack ging habe ich ein wenig gegoogelt. Dabei bin ich auf einen Beitrag gestoßen das php-fpm genutzt werden sollte. Dann habe ich hier im Forum nachgesehen und bin dabei auf folgenden Verweis gestoßen. https://github.com/Froxlor/Froxlor/wiki/nginx-with-php-fpm Da mein Englisch nicht das Beste ist, habe ich wohl etwas falsch verstanden und irgendwo etwas falsch eingetragen. Systeminformationen siehe unten! Wenn ich jetzt folgendes ausführe: /usr/bin/php5 /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug Bekomme ich folgende Ausgabe: [information] cron_tasks: Searching for tasks to do [information] nginx::createIpPort: creating ip/port settings for [2a01:4f8:190:62f4::12]:80 [information] nginx::createIpPort: creating ip/port settings for [2a01:4f8:190:62f4::12]:443 [information] nginx::createIpPort: creating ip/port settings for 78.47.59.168:80 [information] nginx::createIpPort: creating ip/port settings for 78.47.59.168:443 [information] nginx::createIpPort: creating ip/port settings for 78.47.59.172:80 [information] nginx::createIpPort: creating ip/port settings for 78.47.59.172:443 [information] nginx::createIpPort: creating ip/port settings for 78.47.59.190:80 [information] nginx::createIpPort: creating ip/port settings for 78.47.59.190:443 [information] nginx::writeConfigs: rebuilding /etc/nginx/sites-enabled/ [information] nginx::reload: reloading nginx [information] nginx::reload: running /etc/init.d/php-fpm restart sh: 1: /etc/init.d/php-fpm: not found [notice] Checking system's last guid Das er jetzt meckert und /etc/init.d/php-fpm nicht findet erscheint mir logisch. Das müsste doch php5-fpm heißen? Wo holt der sich das her, bzw. wo steht das drin? Schaue ich mir jetzt die configs in /etc/nginx/sites-enabled/ an, steht in diesen: listen = /var/lib/apache2/fastcgi/1-anjafrox-erotik-sexspielzeug.com-php-fpm.socket Dazu habe ich eine Frage. Was hat der Apache damit zu tun, da doch nginx läuft? Im Ordner /etc/php-fpm.d wurden für alle Domains die conf Dateien erstellt. Dort steht auch listen = /var/lib/apache2/fastcgi/1-anjafrox-erotik-sexspielzeug.com-php-fpm.socket drin. Ich habe auf allen Seiten ein 502 Bad Gateway. php5-fpm läuft und hat eine hohe CPU Auslastung zu verantworten. Auszug php5-fpm.log [27-Feb-2018 20:37:21] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful [27-Feb-2018 20:37:22] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful [27-Feb-2018 20:37:22] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful [27-Feb-2018 20:37:23] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful [27-Feb-2018 20:37:24] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful Auszug nginx error.log 2018/02/27 17:51:09 [crit] 16784#16784: *11209 connect() to unix:/var/lib/apache2/fastcgi/1-froxlor.panel-server1.xt-host.de-php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 77.22.254.223, server: server1.xt-host.de, request: "GET /froxlor/admin_settings.php?s=8657468a493298edeec0dc1633caa200&page=overview HTTP/1.1", upstream: "fastcgi://unix:/var/lib/apache2/fastcgi/1-froxlor.panel-server1.xt-host.de-php-fpm.socket:", host: "xt-host.de", referrer: "http://xt-host.de/froxlor/admin_settings.php" 2018/02/27 19:02:23 [alert] 23606#23606: *97 open socket #129 left in connection 12 2018/02/27 19:02:23 [alert] 23606#23606: aborting 2018/02/27 19:37:04 [alert] 2231#2231: *390 open socket #8 left in connection 9 2018/02/27 19:37:04 [alert] 2231#2231: *388 open socket #6 left in connection 11 2018/02/27 19:37:04 [alert] 2231#2231: *387 open socket #4 left in connection 12 2018/02/27 19:37:04 [alert] 2231#2231: aborting 2018/02/27 19:52:21 [crit] 14333#14333: *17 connect() to unix:/var/lib/apache2/fastcgi/1-froxlor.panel-server1.xt-host.de-php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 77.22.254.223, server: server1.xt-host.de, request: "GET /froxlor/customer_index.php?s=5acb3e02d14ff9b082fa9d2c716bea01 HTTP/1.1", upstream: "fastcgi://unix:/var/lib/apache2/fastcgi/1-froxlor.panel-server1.xt-host.de-php-fpm.socket:", host: "xt-host.de", referrer: "http://xt-host.de/froxlor/customer_domains.php?page=domains&s=5acb3e02d14ff9b082fa9d2c716bea01" 2018/02/27 19:52:27 [crit] 14333#14333: *17 connect() to unix:/var/lib/apache2/fastcgi/1-froxlor.panel-server1.xt-host.de-php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 77.22.254.223, server: server1.xt-host.de, request: "GET /froxlor/ HTTP/1.1", upstream: "fastcgi://unix:/var/lib/apache2/fastcgi/1-froxlor.panel-server1.xt-host.de-php-fpm.socket:", host: "xt-host.de" Systeminfo: Debian 7 PHP 5.6.33-1~dotdeb+7.1 (läuft) mysqld 5.5.59-0+deb7u1 (läuft) nginx 1.10.3 (läuft) Apache 2.2.22 (läuft nicht, soll er auch nicht) Installiert: libnss-mysql-bg nscd php5-fpm Dateien vorhanden: /etc/libnss-mysql.cfg /etc/libnss-mysql-root.cfg /etc/nsswitch.conf P.S. Ich bin nicht hier um mich blöde anmachen zu lassen. Ich bin hier um auf meine alten Tage noch etwas zu lernen.
  6. Moin, den Fehler habe ich auch gemacht. Wo kann ich das ändern? An Froxlor komme ich ja nicht mehr ran. (502 Bad Gateway) Vielen Dank!
  7. seochemnitz

    Nginx – Browser Caching aktivieren

    Vielen Dank für deine Antwort. Ich werde es heute Abend mal "testen". Einen schönen Tag noch. Silvio
  8. Moin, ich habe da mal eine Frage zum Browser Caching. Man kann das Browser Caching in den conf Dateien unter /etc/nginx/sites-available/ mit folgenden Befehl aktivieren. location ~* \.(jpg|jpeg|png|gif|ico|css|js)$ { expires 365d; } Das funktioniert wunderbar. Leider werden die conf Dateien durch den Cronjob wieder überschrieben. Gibt es eine Möglichkeit das irgendwo fest zu hinterlegen, damit es automatisch in die neu generierten Dateien eingetragen wird? NGINX 1.3.1 PHP5 0.9.38.7-1+wheezy1 Ich freue mich auf eure Antworten! Silvio
×