Jump to content
Froxlor Forum

OliverRahner

Members
  • Posts

    7
  • Joined

  • Last visited

Everything posted by OliverRahner

  1. My current quick-and-very-dirty workaround looks like this: froxlor/scripts/jobs/cron_tasks.inc.http.30.nginx.php if ($domain['phpenabled_customer'] == 1 && $domain['phpenabled_vhost'] == '1') { $webroot_text .= "\t" . 'index index.php index.html index.htm;' . "\n"; if (!preg_match("/^##NO_TRY_FILES$/m", $domain['specialsettings'])) { $webroot_text .= "\t\t" . 'try_files $uri $uri/ @rewrites;' . "\n"; } else { // NO_TRY_FILES statement found, don't put try_files into config } } else { $webroot_text .= "\t" . 'index index.html index.htm;' . "\n"; } If I now put the statement "##NO_TRY_FILES" on a line by itself into the vhost special settings, no "try_files" will be generated in "location /".
  2. And the next issue on my way to nginx'iness. I want to run Seafile on one vhost. I added all the settings Seafile told me to in their manual (https://manual.seafile.com/deploy/deploy_with_nginx.html). Didn't work at first (got 404'ed after the initial redirect), but once I commented out either the "try_files" in "location /" or in "location @php" it started working. It seems that the =404 which is default in "location @php" is the issue. Even after reading through the source code's "mergeVhostCustom" magic I couldn't find a way to override the default try_files statement without patching my Froxlor installation... Any hints?
×
×
  • Create New...