Jump to content
Froxlor Forum

kingsley ezenwa

Members
  • Content count

    48
  • Joined

  • Last visited

Community Reputation

0 Neutral

About kingsley ezenwa

  • Rank
    Advanced Froxie
  1. Quick Questions - Issues Configuring FROXLOR

    ???
  2. Quick Questions - Issues Configuring FROXLOR

    Hi Please am still waiting on how to send you Server login Thanks
  3. Quick Questions - Issues Configuring FROXLOR

    Hi Please how do I send you server access I have joined irc://irc.freenode.net/#froxlor using MIRC client but yet to get any response. If you drop your email, I will send you server access. Thanks
  4. Quick Questions - Issues Configuring FROXLOR

    Hi Am trying to figure out what am doing wrong both in CentOS 7 and Ubuntu and I have narrowed down to few points among which is this Failed to restart php-fcgi.service: Unit php-fcgi.service not found. Now despite the fact that FROXLOR seems to be php7.1 ready and I have been using php7.2 and php7.1 with corresponding php7.1-fpm But FROXLOR's vhosts are configured with a different php-fpm which seems to have it's configs (thanks to FROXLOR's configuration set-up) on my server but the service isn't able to start due to the fact it's not really installed. Am talking about php-fcgi.service which gives this error "Failed to restart php-fcgi.service: Unit php-fcgi.service not found." . Now am using php-fpm and not php-fcgi . I have narrowed much of this issue to php-fpm or php-fcgi which is part of the configuration being set-up at Ubuntu Trusty (14.04) » Webserver (HTTP) » nginx Configuration Set-up Page . .html pages seems to work perfectly but .php websites gives either 404 error or 502 Bad Gateway . So I know issue must be either php-fpm or php-fcgi And just so you know, i use NGINX with php7.1-fpm Please kindly help me so all the days, money and resources (left work, bought server 4 times, Sleepless nights & days) won't all go to waste. All my life, I have never faced this issue before But since it's same on Ubuntu and centOS 7, I know it's not FROXLOR's issue + there are people using FROXLOR. Am happy to say things seems to be much more better here on Ubuntu than on CentOS 7 . Here is the last part of the error log from one of the test domains 2018/02/08 10:48:14 [crit] 12080#12080: *1 connect() to unix:/var/run/1-zigdonor-zigdonor.com-php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 197.210.8.55, server: zigdonor.com, request: "GET /index.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/1-zigdonor-zigdonor.com-php-fpm.socket:", host: "zigdonor.com" 2018/02/08 10:48:14 [crit] 12080#12080: *1 connect() to unix:/var/run/1-zigdonor-zigdonor.com-php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 197.210.8.55, server: zigdonor.com, request: "GET /favicon.ico HTTP/1.1", upstream: "fastcgi://unix:/var/run/1-zigdonor-zigdonor.com-php-fpm.socket:", host: "zigdonor.com", referrer: "http://zigdonor.com/index.php" Websites works well if it's html but would give error if .php webpage
  5. Quick Questions - Issues Configuring FROXLOR

    Please be patient with me Sir I believe it's almost over. You don't know what I have gone through just to make this work Also can you drop the IRC channel. Saw one in froxlor's website but my browser was unable to open it Thanks
  6. Quick Questions - Issues Configuring FROXLOR

    .
  7. Quick Questions - Issues Configuring FROXLOR

    Yea I have just managed to do so But am hitting another issue though Below is a sample config for /etc/nginx//sites-enabled/10_froxlor_ipandport_178.79.170.161.80.conf if I comment out the LISTEN parameter, the website works but if i uncomment it, the whole server is unable to serve php files but would serve .html files. # 10_froxlor_ipandport_178.79.170. Please kindly help look into this. Would be waiting for your help161.80.conf # Created 07.02.2018 17:16 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { # listen 178.79.170.161:80 default_server; listen 178.79.170.161:80 default_server; # Froxlor default vhost server_name server5.baconsol.com; access_log /var/log/nginx/access.log; root /var/www/baconsol.com/cpanel/; index index.php index.html index.htm; location / { } location ~ \.php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_pass 127.0.0.1:8888; fastcgi_index index.php; } } NB: Initially, I had an issue which is related to this thread https://forum.froxlor.org/index.php?/topic/13329-solved-unknown-error-not-in-option-system_ipaddress/ But luckily, adding my IP address to FROXLOR IP & Ports section (which was surprisingly empty unlike when FROXLOR is installed in CentOS that it's auto filled. ) solved the issue. UPDATE 01 Changing the LISTEN Parameter to either listen *:80; OR listen localhost:80; solves the server-wide 404 error issue for .php files But Since whatever changes made to FROXLOR generated vhost files are lost on next domain edit or whatever, how do I permanently fix this. UPDATE 02 I can confirm that Unchecking Create vHost-Container: in IP & Ports solves the 404 error issue as the vhost file is now empty with just the following as it's content """"" # 10_froxlor_ipandport_178.79.170.161.80.conf # Created 07.02.2018 18:38 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. """"" My Observation Ubuntu seems more suited for FROXLOR than CentOS 7 as most configurations/defaults are correct .
  8. Quick Questions - Issues Configuring FROXLOR

    Hi Am once again giving Froxlor another trial But am now doing so on Ubuntu (even though it's my first time using Ubuntu since am coming from CentOS 7). I have installed everything but now am on FROXLOR Configuration page trying to generate a configuration for Ubuntu but all I can see for Ubuntu is Ubuntu Precise (12.04) and Ubuntu Trusty (14.04) But am on Ubuntu artful (17.10) and since am new to Ubuntu (using Ubuntu all because of FROXLOR) , I really don't know how to adapt the configuration. Any help would be appreciated. Server Machine is: Nginx Ubuntu artful (17.10) PHP 7.1 Mariadb Latest Froxlor from froxlor.org waiting for your kindful assistance Thanks
  9. Nice and Great work doop . Really wished FROXLOR worked for me. Also did the overriding nginx try_files setting implementation make it into this Release ? Thanks
  10. Quick Questions - Issues Configuring FROXLOR

    Okay now What do you use - FROXLOR with NGINX or FROXLOR with APACHE ? Maybe I would follow what you use if NGINX is too much on FROXLOR Am not so much a NOOB BUT FROXLOR is making me look worse like one
  11. Quick Questions - Issues Configuring FROXLOR

    NOPE You don't get me. After you help me configure it, I will backup the server image and transfer it to my other Server where all I have to do is change the domain and IP
  12. Quick Questions - Issues Configuring FROXLOR

    Or is it because am using CENTOS 7 ? Would have switched OS but am more comfortable with CentOS 7 but willing to play around with other OS if that's the issue. Can you please help me look into this ? Am willing to give server login details
  13. Quick Questions - Issues Configuring FROXLOR

    Care to help me look into it ? Don't mind sending you my server login details. It's a temporary server anyways I really would be glad Sir
  14. Quick Questions - Issues Configuring FROXLOR

    Am seriously lost
  15. Quick Questions - Issues Configuring FROXLOR

    I can see this Nginx PHP backendthis is where the PHP process is listening for requests from nginx, can be a unix socket of ip:port combination*NOT used with php-fpm but don't really know what it means. does *NOT used with php-fpm mean it's not applicable to php-fpm AND Can I delete it's current value 127.0.0.1:8888 and leave it blank as it's always added to all Vhosts created by FROXLOR location ~ \.php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_pass 127.0.0.1:8888; fastcgi_index index.php; }
×