Jump to content
Froxlor Forum
  • 0

Installationsschwierigkeiten von PHP-FPM mit Apache


mrmanuel
 Share

Question

Hallo,

ich bin gerade dabei einen neuen Froxlor (0.10.30-1) Webserver aufzusetzen und komme leider nicht weiter, da die Anleitung leider etwas in die Jahre gekommen ist. Als Betriebssystem verwende ich Debian Bullseye 11.1.0 amd64.

Ich habe Froxlor wie folgt konfiguriert:

Install froxlor on debian: Punkte 1 - 4

Symbolischen Link erstellt um Froxlor über HTTP/HTTPS erreichen zu können:

ln -s /var/www/froxlor/ /var/www/html/froxlor

Froxlor über die Web UI installiert und die Services über Shell automatisch konfiguriert:

php /var/www/froxlor//install/scripts/config-services.php --froxlor-dir=/var/www/froxlor/ --create

 

  • choose distribution [bullseye]: Enter
  • choose service [apache24]: Enter
  • choose service [bind]: x
  • choose service [postfix_dovecot]: x
  • choose service [dovecot_postfix2]: x
  • choose service [proftpd]: Enter
  • Select every service you need. Enter empty value when done
    choose service:
    cron
  • choose service: awstats
  • choose service: libnssextrausers
  • choose service: logrotate
  • choose service: php-fpm
  • choose service: Enter
  • choose output-filename [/tmp/froxlor-config-20211125.json]: Enter
  • Do you want to apply the config now? [y/N]: Y
  • --- Configuring: FTP ---
    Do you want to continue? [Y/n]
    Enter

Soweit so gut. Während der Konfiguration habe ich keine Fehler erhalten. Nun wollte ich anhang der Anleitung apache2 with php fpm PHP-FPM konfigurieren. Schritt 2 wurde vermutlich mit der Autokonfiguration über die Shell ausgeführt, jedoch fehlt z.B. das Modul fastcgi in Apache.

Bei Schritt 3 weiß ich leider nicht woher ich die Inhalte von /etc/libnss-mysql-root.cfg und /etc/libnss-mysql.cfg herbekommen soll. Die Datei /etc/nsswitch.conf ist bereits vorhanden. Wenn ich im Froxlor Panel unter "System -> Configuration -> Debian Bullseye (11.x) - Others (System) - libnss-extrausers (required for FCGID/php-fpm/mpm-itk)" auswähle erscheint mir nur die Konfiguration von /etc/nsswitch.conf.

Bei Schritt 4 gibt es die Datei /etc/apache2/mods-available/fastcgi.conf nicht, da in Schritt 2 das Modul nicht installiert/aktiviert wurde.

Wie kann ich nun PHP-FPM auf einem aktuellen System installieren? Gibt es eine aktuelle Anleitung die ich vielleicht nicht gefunden habe?

Vielen Dank im Voraus :)

 

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0
2 minutes ago, mrmanuel said:

Nun wollte ich anhang der Anleitung apache2 with php fpm PHP-FPM konfigurieren. Schritt 2 wurde vermutlich mit der Autokonfiguration über die Shell ausgeführt, jedoch fehlt z.B. das Modul fastcgi in Apache.

wenn du es über das config-services script gemacht hast brauchst du da eigentlich nix mehr installieren - voraussetzung ist natürlich das du vorher - so wie die anleitung es sagt - die Einstellungen alle entsprechend korrekt gesetzt hast!

3 minutes ago, mrmanuel said:

Bei Schritt 3 weiß ich leider nicht woher ich die Inhalte von /etc/libnss-mysql-root.cfg und /etc/libnss-mysql.cfg herbekommen soll. Die Datei /etc/nsswitch.conf ist bereits vorhanden. Wenn ich im Froxlor Panel unter "System -> Configuration -> Debian Bullseye (11.x) - Others (System) - libnss-extrausers (required for FCGID/php-fpm/mpm-itk)" auswähle erscheint mir nur die Konfiguration von /etc/nsswitch.conf.

libnss-extrausers ist was anderes als libnss-mysql !!! ich rate dringend libnss-extrausers zu nutzen, beachte das dafür die Option in den entsprechenden Einstellungen aktiviert sein muss.

Also:

1) Einstellungen komplett kontrollieren, alle gewünschten Dienste aktivieren (wie z.B. php-fpm, libnss-extrausers, etc.).

2) config-services ausführen oder ggfls manuell als admin -> Configuration -> distro wählen -> dienst wählen -> etc. -> befehle anschauen, kopieren und auf der shell ausführen

 

Link to comment
Share on other sites

  • 0

Vielen Dank für die schnelle Antwort.

Da dies meine erste Installation mit PHP-FPM ist, habe ich leider keine Ahnung welche Einstellungen ich vorher alles setzen muss und kann somit leider nur nach Anleitung vorgehen. Würde gerne Apache mit PHP-FPM nach den "best practice" Einstellungen installieren. Hast du vielleicht eine Liste welche das sind?

Würde sonst nur folgendes konfigurieren:

Settings --> System Settings --> Use libnss-extrausers instead of libnss-mysql --> tick checkbox

Settings --> PHP-FPM - Activated: Yes

Settings --> Froxlor VirtualHost settings --> Enable PHP-FPM for the Froxlor vHost --> tick checkbox

Link to comment
Share on other sites

  • 0

Ich habe nun mehrmals eine komplette Neuinstallation zum Testen durchgeführt. Ich habe Froxlor installiert, über Web konfiguriert und anschließend den Befehl

php /var/www/froxlor//install/scripts/config-services.php --froxlor-dir=/var/www/froxlor/ --create

ausgeführt um die restlichen Konfigurationen vorzunehmen. Hier scheint der Schritt zu fehlen, dass der froxlorlocal Benutzer und Gruppe angelegt wird, da die Berechtigungen auf den Ordner /var/custoers/tmp/froxlor.panel falsch gesetzt sind und der Benutzer/Gruppe froxlorlocal die "falsche"  ID hat:

Nov 25 18:47:45 srvweb01 php7.4-fpm[23596]: NOTICE: Not enabling PHP 7.4 FPM by default.
Nov 25 18:47:45 srvweb01 php7.4-fpm[23597]: NOTICE: To enable PHP 7.4 FPM in Apache2 do:
Nov 25 18:47:45 srvweb01 php7.4-fpm[23598]: NOTICE: a2enmod proxy_fcgi setenvif
Nov 25 18:47:45 srvweb01 php7.4-fpm[23599]: NOTICE: a2enconf php7.4-fpm
Nov 25 18:47:45 srvweb01 php7.4-fpm[23600]: NOTICE: You are seeing this message because you have apache2 package installed.
Nov 25 18:47:45 srvweb01 systemd[1]: Reloading.
Nov 25 18:47:45 srvweb01 systemd[1]: Reloading.
Nov 25 18:47:45 srvweb01 systemd[1]: Starting The PHP 7.4 FastCGI Process Manager...
░░ Subject: A start job for unit php7.4-fpm.service has begun execution
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░
░░ A start job for unit php7.4-fpm.service has begun execution.
░░
░░ The job identifier is 1284.
Nov 25 18:47:45 srvweb01 php-fpm7.4[23652]: [25-Nov-2021 18:47:45] ERROR: [pool srvweb01.hro.md0.eu] cannot get uid for user 'froxlorlocal'
Nov 25 18:47:45 srvweb01 php-fpm7.4[23652]: [25-Nov-2021 18:47:45] ERROR: FPM initialization failed
Nov 25 18:47:45 srvweb01 systemd[1]: php7.4-fpm.service: Main process exited, code=exited, status=78/CONFIG
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░
░░ An ExecStart= process belonging to unit php7.4-fpm.service has exited.
░░
░░ The process' exit code is 'exited' and its exit status is 78.
Nov 25 18:47:45 srvweb01 systemd[1]: php7.4-fpm.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░
░░ The unit php7.4-fpm.service has entered the 'failed' state with result 'exit-code'.
Nov 25 18:47:45 srvweb01 systemd[1]: Failed to start The PHP 7.4 FastCGI Process Manager.
░░ Subject: A start job for unit php7.4-fpm.service has failed
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support
░░
░░ A start job for unit php7.4-fpm.service has finished with a failure.
░░
░░ The job identifier is 1284 and the job result is failed.
Nov 25 18:47:45 srvweb01 groupadd[23685]: group added to /etc/group: name=froxlorlocal, GID=1000
Nov 25 18:47:45 srvweb01 groupadd[23685]: group added to /etc/gshadow: name=froxlorlocal
Nov 25 18:47:45 srvweb01 groupadd[23685]: new group: name=froxlorlocal, GID=1000
Nov 25 18:47:45 srvweb01 useradd[23692]: new user: name=froxlorlocal, UID=1000, GID=1000, home=/home/froxlorlocal, shell=/bin/false, from=/dev/pts/0
Nov 25 18:47:45 srvweb01 systemd[1]: Stopping The Apache HTTP Server...
░░ Subject: A stop job for unit apache2.service has begun execution
░░ Defined-By: systemd
░░ Support: https://www.debian.org/support

 

root@srvweb01:~# ls -l /var/customers/tmp/
total 4
drwxr-x--- 2 root root 4096 Nov 25 18:46 froxlor.panel

 

root@srvweb01:~# cat /etc/passwd | grep froxlorlocal
froxlorlocal:x:1000:1000::/home/froxlorlocal:/bin/false

 

Laut Anleitung sollte der Benutzer und Gruppe mit der ID 9999 angelegt werden:

addgroup --gid 9999 froxlorlocal

adduser --no-create-home --uid 9999 --ingroup froxlorlocal --shell /bin/false --disabled-password --gecos '' froxlorlocal

Vermutlich ein Bug?

Link to comment
Share on other sites

  • 0
16 minutes ago, mrmanuel said:

Laut Anleitung sollte der Benutzer und Gruppe mit der ID 9999 angelegt werden:

addgroup --gid 9999 froxlorlocal

adduser --no-create-home --uid 9999 --ingroup froxlorlocal --shell /bin/false --disabled-password --gecos '' froxlorlocal

Vermutlich ein Bug?

Nein, lediglich eine forcierte uid/gid - nicht relevant, der user ist mit uid/gid 1000 genausogut wie mit 9999

Das "Problem" in deinem Fall ist wohl eher das vor während der Konfiguration schon php-fpm pool-configs aus vorherigen Installation vorhanden sind und er deswegen nicht starten kann, wie du deiner eigenen Log entnehmen kannst, wurden die User ja anschließen erstellt.

Du solltest also lediglich nun apache2 und php-fpm neustarten müssen und alles ist ok; oder noch besser, einfach 1x den cronjob forcieren:

php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By schnudeldudel
      Hallo zusammen,
      ist es bekannt, dass man die "erst" PHP-FPM Version nicht löschen kann.
      Hintergrund: Über die Zeit sind neue PHP versionen erschienen und ich würde gern die php70 entfernen (bzw. die Versionen die ich nicht nutze).
      In der GUI kann man aber nicht alle löschen - auch wenn diese nicht benutzt werden - bei mir ist es die "php70" Konfig.
      Original-Screenshot aus meiner Konfig:

       
      Danke für Tipps dazu.
      Gruss.
      Meine Froxlor-Konfig:


    • By Marcel -//- AdSoleWare
      Hello.
      I manually installed Froxlor on Debian 8 and tried setting up. i installed php 7.3 in as it was the only missing point. i restarted apache2 and now it wont start. I need help
       
      Error Log:
       
    • By Michael Groß
      Hallo,
      nachdem ich meinen Froxlor-Server neu aufgesetzt habe, habe ich nun ein anderes komisches Problem.
      Ich habe die Konfigurationsschritte vollständig durchgeführt - sicherheitshalber auch zuerst "automatisch" durchführen lassen und danach noch einmal verifiziert.
      Lege ich nun einen Kunden an (http://test.computer-stube.com), verweist dies auf den Root des Servers.
      Schaue ich in die vHost-Datei, steht dort folgendes:
      # 29_froxlor_normal_vhost_test.computer-stube.com.conf # Created 07.02.2020 16:55 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:80> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> # 29_froxlor_ssl_vhost_test.computer-stube.com.conf # Created 07.02.2020 17:26 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. # Domain ID: 3 (SSL) - CustomerID: 2 - CustomerLogin: test <VirtualHost 178.63.105.174:443> ServerName test.computer-stube.com ServerAlias *.test.computer-stube.com ServerAdmin Michael.Gross@mgw94.de SSLEngine On SSLProtocol -ALL +TLSv1 +TLSv1.2 SSLCompression Off SSLHonorCipherOrder off SSLCipherSuite ECDH+AESGCM:ECDH+AES256:!aNULL:!MD5:!DSS:!DH:!AES128 SSLVerifyDepth 10 SSLCertificateFile /etc/ssl/certs/apache.crt SSLCertificateKeyFile /etc/ssl/private/apache.key <IfModule mod_headers.c> Header always set Strict-Transport-Security "max-age=0" </IfModule> DocumentRoot "/var/customers/webs/test/" FcgidIdleTimeout 30 SuexecUserGroup "test" "test" <Directory "/var/customers/webs/test/"> <FilesMatch "\.(php)$"> SetHandler fcgid-script FcgidWrapper /var/www/php-fcgi-scripts/test/test.computer-stube.com/php-fcgi-starter .php Options +ExecCGI </FilesMatch> Require all granted AllowOverride All </Directory> LogLevel warn ErrorLog "/var/customers/logs/test-error.log" CustomLog "/var/customers/logs/test-access.log" combined </VirtualHost> Also an sich ist die richtige Konfiguration hinterlegt.
      Im Cron ist folgendes konfiguriert:

      # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null 5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null 0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null 10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --backup 1> /dev/null Auch das manuelle Ausführen mittels "
      php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force bringt bei mir leider keinen Erfolg.
      Die Ausgabe vom debug ist wie folgt:
      root@lx001:/etc/apache2/sites-enabled# php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug [information] TasksCron: Searching for tasks to do [information] Running Let's Encrypt cronjob prior to regenerating webserver config files [information] Requesting/renewing Let's Encrypt certificates [information] No new certificates or certificates due for renewal found [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:80 [notice] 178.63.105.174:80 :: namevirtualhost-statement no longer needed for apache-2.4 [debug] 178.63.105.174:80 :: inserted vhostcontainer [information] apache::createIpPort: creating ip/port settings for 178.63.105.174:443 [debug] 178.63.105.174:443 :: inserted vhostcontainer [information] apache::createVirtualHosts: creating vhost container for domain 3, customer test [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/ [information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/ [information] Froxlor\Cron\Http\ApacheFcgi::reload: reloading Froxlor\Cron\Http\ApacheFcgi [notice] Creating passwd file [notice] Writing 1 entries to passwd file [notice] Succesfully wrote passwd file [notice] Creating group file [notice] Writing 1 entries to group file [notice] Succesfully wrote group file [notice] Creating shadow file [notice] Writing 1 entries to shadow file [notice] Succesfully wrote shadow file [notice] Checking system's last guid  
      Ich fühle mich gerade echt dämlich, kann ja eigentlich nicht so schwer sein, da es eigentlich ja alles nur "Copy+Paste" ist
      Das Endverzeichnis wurde jedoch korrekt angelegt:
      root@lx001:/var/customers/webs# ls test root@lx001:/var/customers/webs# cd test root@lx001:/var/customers/webs/test# ls index.html webalizer Ich habe zusätzlich zur "Standardkonfiguration" noch libnss-extrausers und FCGID  eingerichtet, da ich ältere PHP Versionen benötige.
      Grüße
      Michael
    • By j4mb4l4j4
      Hallo, ich habe eine Frage zum idle-timeout bei PHP-FPM.
      Ich habe gem. Froxlor howto-debian-9-ubuntu-cosmic-php-73  die Installation vorgenommen mit PHP-FPM mit Apache das FPM Basic.
      Wollte mal mit idle-timout in den Settings das Timeout hochschhrauben was ich auch getan habe (siehe Screen).
       
      Bei meinem alten Server wurde mir in den Apache Configs diese Option geschrieben (siehe Screen), das fehlt aber in den Configs beim neuen Server (siehe Screen).
      Wird das woanders hingeschrieben ?
      Überlege nur grade wie ich verifiziere, dass das was ich eingestellt habe auch so übernommen wurde oder ob mir noch ein Setting oder Modul fehlt.



    • By みゆき
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
×
×
  • Create New...