Jump to content
Froxlor Forum

Question

Hallo d00p mit dem restlichen Froxlor-Team,

 

ich arbeite schon seit über 6 Jahre mit Froxlor und weiß dieses Tool sehr zu schätzen.

Ich habe bislang meinen Server von extern Verwalten lassen sodass ich nur Zugriff auf das Panel hatte und alles Hintergrund nicht mitbekommen hab.

Aktuell befass ich mich, mit unter auch wegen meines Studiums zum Wirtschaftsinformatiker näher mit der Materie und habe auf einem Pi 3 Model B, Apache24, MariaDB 10 und PHP 7.4 installiert.

Danach bin ich dann der Installationsroutine von Froxlor gefolgt und hab noch zusätzlich einen Roundcube Webmailer installiert als auch eine Domain auf den Pi laufen lassen.

Soweit so gut. Die Hauptdomain vrultimate.net löst wie gewünscht auf das Froxlor Panel auf (/var/www/froxlor ... in /var/www/html) umbenannt, die Crons laufen durch und scheint sonst keine Probleme zu haben. Also habe ich einen "Testkunden" angelegt, mittels FTP ein paar Inhalte draufgezogen und eine Subdomain für diesen (myselfe.vrultimate.net) Der Pfad (/var/customers/webs/myselfe/) scheint richtig angelegt zu sein und laut Domain-Einstellungen sollte die Subdomain auch in das Verzeichnis verweisen. Leider löst die Subdomain aber auf die Standard Froxlor Seite und ich verstehe nicht warum. Ich habe die Einstellungen mit denen meines vormaligen Hosters verglichen und konnte bis auf die Versionsunterschiede und entsprechende Anpassungen von den Einstellungen her, keine Differenzen entdecken.  Vielleicht könnt Ihr mir helfen, neue Erkenntnisse zu bekommen 😃 

Viele Grüße 😃 

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

Was sagt der Apache Error log, wie sieht die vhost Datei von dieser Sub-Domain aus usw?
Ohne Logs, kann man nur raten...

 

Share this post


Link to post
Share on other sites
  • 0
vor 36 Minuten schrieb irisdina:

Was sagt der Apache Error log, wie sieht die vhost Datei von dieser Sub-Domain aus usw?
Ohne Logs, kann man nur raten...

 

[Thu Jul 09 16:18:17.798244 2020] [mpm_prefork:notice] [pid 604] AH00169: caught                     SIGTERM, shutting down
[Thu Jul 09 16:18:18.311723 2020] [mpm_prefork:notice] [pid 1317] AH00163: Apach                    e/2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 16:18:18.311980 2020] [core:notice] [pid 1317] AH00094: Command line                    : '/usr/sbin/apache2'
[Thu Jul 09 16:21:02.887522 2020] [mpm_prefork:notice] [pid 1317] AH00171: Grace                    ful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified doma                    in name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress th                    is message
[Thu Jul 09 16:21:03.064161 2020] [mpm_prefork:notice] [pid 1317] AH00163: Apach                    e/2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 16:21:03.064285 2020] [core:notice] [pid 1317] AH00094: Command line                    : '/usr/sbin/apache2'
[Thu Jul 09 16:21:31.651043 2020] [mpm_prefork:notice] [pid 1317] AH00169: caugh                    t SIGTERM, shutting down
[Thu Jul 09 16:21:50.727939 2020] [mpm_prefork:notice] [pid 711] AH00163: Apache                    /2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 16:21:50.744358 2020] [core:notice] [pid 711] AH00094: Command line:                     '/usr/sbin/apache2'
[Thu Jul 09 16:30:02.991584 2020] [mpm_prefork:notice] [pid 711] AH00171: Gracef                    ul restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified doma                    in name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress th                    is message
[Thu Jul 09 16:30:03.231425 2020] [mpm_prefork:notice] [pid 711] AH00163: Apache                    /2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 16:30:03.231527 2020] [core:notice] [pid 711] AH00094: Command line:                     '/usr/sbin/apache2'
[Thu Jul 09 16:31:39.107543 2020] [mpm_prefork:notice] [pid 711] AH00171: Gracef                    ul restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified doma                    in name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress th                    is message
[Thu Jul 09 16:31:39.347260 2020] [mpm_prefork:notice] [pid 711] AH00163: Apache                    /2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 16:31:39.347345 2020] [core:notice] [pid 711] AH00094: Command line:                     '/usr/sbin/apache2'
[Thu Jul 09 16:42:00.377955 2020] [mpm_prefork:notice] [pid 711] AH00171: Gracef                    ul restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified doma                    in name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress th                    is message
[Thu Jul 09 16:42:00.596198 2020] [mpm_prefork:notice] [pid 711] AH00163: Apache                    /2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 16:42:00.596280 2020] [core:notice] [pid 711] AH00094: Command line:                     '/usr/sbin/apache2'
[Thu Jul 09 16:42:08.322737 2020] [mpm_prefork:notice] [pid 711] AH00171: Gracef                    ul restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified doma                    in name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress th                    is message
[Thu Jul 09 16:42:08.525465 2020] [mpm_prefork:notice] [pid 711] AH00163: Apache                    /2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 16:42:08.525546 2020] [core:notice] [pid 711] AH00094: Command line:                     '/usr/sbin/apache2'
[Thu Jul 09 16:50:02.242527 2020] [mpm_prefork:notice] [pid 711] AH00171: Gracef                    ul restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified doma                    in name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress th                    is message
[Thu Jul 09 16:50:02.421698 2020] [mpm_prefork:notice] [pid 711] AH00163: Apache                    /2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 16:50:02.421796 2020] [core:notice] [pid 711] AH00094: Command line:                     '/usr/sbin/apache2'
[Thu Jul 09 20:15:02.195887 2020] [mpm_prefork:notice] [pid 711] AH00171: Gracef                    ul restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified doma                    in name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress th                    is message
[Thu Jul 09 20:15:02.521626 2020] [mpm_prefork:notice] [pid 711] AH00163: Apache                    /2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 20:15:02.521709 2020] [core:notice] [pid 711] AH00094: Command line:                     '/usr/sbin/apache2'
[Thu Jul 09 20:20:02.444980 2020] [mpm_prefork:notice] [pid 711] AH00171: Gracef                    ul restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified doma                    in name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress th                    is message
[Thu Jul 09 20:20:02.668644 2020] [mpm_prefork:notice] [pid 711] AH00163: Apache                    /2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 20:20:02.668744 2020] [core:notice] [pid 711] AH00094: Command line:                     '/usr/sbin/apache2'
[Thu Jul 09 20:58:00.499408 2020] [mpm_prefork:notice] [pid 711] AH00169: caught                     SIGTERM, shutting down
[Thu Jul 09 21:16:51.429940 2020] [mpm_prefork:notice] [pid 1148] AH00163: Apach                    e/2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 21:16:51.433880 2020] [core:notice] [pid 1148] AH00094: Command line                    : '/usr/sbin/apache2'
[Thu Jul 09 21:20:02.294256 2020] [mpm_prefork:notice] [pid 1148] AH00171: Grace                    ful restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified doma                    in name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress th                    is message
[Thu Jul 09 21:20:02.493190 2020] [mpm_prefork:notice] [pid 1148] AH00163: Apach                    e/2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 21:20:02.493292 2020] [core:notice] [pid 1148] AH00094: Command line                    : '/usr/sbin/apache2'
[Thu Jul 09 22:57:41.237121 2020] [mpm_prefork:notice] [pid 1148] AH00169: caugh                    t SIGTERM, shutting down
[Thu Jul 09 22:58:01.043512 2020] [mpm_prefork:notice] [pid 720] AH00163: Apache                    /2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 22:58:01.056775 2020] [core:notice] [pid 720] AH00094: Command line:                     '/usr/sbin/apache2'
[Thu Jul 09 23:40:03.304684 2020] [mpm_prefork:notice] [pid 720] AH00171: Gracef                    ul restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified doma                    in name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress th                    is message
[Thu Jul 09 23:40:03.505269 2020] [mpm_prefork:notice] [pid 720] AH00163: Apache                    /2.4.38 (Raspbian) configured -- resuming normal operations
[Thu Jul 09 23:40:03.505369 2020] [core:notice] [pid 720] AH00094: Command line:                     '/usr/sbin/apache2'
[Fri Jul 10 07:55:54.911479 2020] [php7:error] [pid 2796] [client 91.39.180.83:6                    0244] PHP Fatal error:  Uncaught Exception: Curl error: Connection timed out aft                    er 10000 milliseconds in /var/www/html/lib/Froxlor/Http/HttpClient.php:28\nStack                     trace:\n#0 /var/www/html/lib/ajax.php(51): Froxlor\\Http\\HttpClient::urlGet()\                    n#1 {main}\n  thrown in /var/www/html/lib/Froxlor/Http/HttpClient.php on line 28                    , referer: http://vrultimate.net/admin_index.php?s=b5fca9753ca24aa1290abe6bde0f6                    c81
[Fri Jul 10 08:22:10.730307 2020] [php7:error] [pid 8192] [client 91.39.180.83:6                    0682] PHP Fatal error:  Uncaught Exception: Curl error: Connection timed out aft                    er 10000 milliseconds in /var/www/html/lib/Froxlor/Http/HttpClient.php:28\nStack                     trace:\n#0 /var/www/html/lib/ajax.php(51): Froxlor\\Http\\HttpClient::urlGet()\                    n#1 {main}\n  thrown in /var/www/html/lib/Froxlor/Http/HttpClient.php on line 28                    , referer: http://vrultimate.net/admin_index.php?s=886bb216e438a66a91e01e1ab1ad3                    033
[Fri Jul 10 08:25:02.413393 2020] [mpm_prefork:notice] [pid 720] AH00171: Gracef                    ul restart requested, doing restart
AH00558: apache2: Could not reliably determine the server's fully qualified doma                    in name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress th                    is message
[Fri Jul 10 08:25:02.673847 2020] [mpm_prefork:notice] [pid 720] AH00163: Apache                    /2.4.38 (Raspbian) configured -- resuming normal operations
[Fri Jul 10 08:25:02.673928 2020] [core:notice] [pid 720] AH00094: Command line:                     '/usr/sbin/apache2'
[Fri Jul 10 08:35:46.400860 2020] [php7:error] [pid 8824] [client 91.39.180.83:6                    0758] PHP Fatal error:  Uncaught Exception: Curl error: Connection timed out aft                    er 10001 milliseconds in /var/www/html/lib/Froxlor/Http/HttpClient.php:28\nStack                     trace:\n#0 /var/www/html/lib/ajax.php(51): Froxlor\\Http\\HttpClient::urlGet()\                    n#1 {main}\n  thrown in /var/www/html/lib/Froxlor/Http/HttpClient.php on line 28                    , referer: http://vrultimate.net/admin_index.php?s=886bb216e438a66a91e01e1ab1ad3                    033

In dem Apache error.log schauts zwar wüst aus mit Fatal error, aber ich glaub das hat nix mit der Auflösung zu tun. 
Die myselfe-error.log ist leer.

Und die V-Host-Einstellung wird offensichtlich automatisch von Froxlor generiert, welche ich aber nicht finden kann. Bei IP / Ports sieht das ganze so aus:
image.thumb.png.abc0c8f863abdb145807d6038cb860f6.png

Und in den System-Einstellungen schaut das so aus:
image.thumb.png.60246305148d8e025be0888a9debc0d5.png

 

Und bei der Subdomain in den Einstellungen sieht es soweit auch normal aus, bzw. so wie ich es kenne:
image.thumb.png.46a188991808457138def53c22d001d5.png

 

Ich muss auch sagen, weil es mir gerade aufgefallen ist. Dass er das Verzeichnis scheinbar ansprechen kann aber meine Sachen nicht erkennt, weil er den webalizer wieder anlegt wenn ich diese lösche 😅

Share this post


Link to post
Share on other sites
  • 0

Deine Vhost Dateien findest du unter /etc/apache2/sites-available/
Deine Error Logs zu der Domain findest du unter /etc/customers/logs

Share this post


Link to post
Share on other sites
  • 0
vor 24 Minuten schrieb irisdina:

Deine Vhost Dateien findest du unter /etc/apache2/sites-available/
Deine Error Logs zu der Domain findest du unter /etc/customers/logs

In beiden fällen ist ist nichts da. Bei sites-available sind nur die Defaults drin und etc/customers gibts nicht, dafür gibts aber /var/customers/logs in dessen error.log aber nichts drin steht. In der enable steht eine vhost:


# 29_froxlor_normal_vhost_myselfe.vrultimate.net.conf
# Created 10.07.2020 08:25
# Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel.

# Domain ID: 1 - CustomerID: 1 - CustomerLogin: myselfe
<VirtualHost 91.39.180.83:80>
  ServerName myselfe.vrultimate.net
  ServerAlias *.myselfe.vrultimate.net
  ServerAdmin ***
  DocumentRoot "/var/customers/webs/myselfe"
  php_admin_value sendmail_path "/usr/sbin/sendmail -t -f ***"
  php_admin_value open_basedir "/var/customers/webs/myselfe:/tmp"
  LogLevel warn
  ErrorLog "/var/customers/logs/myselfe-error.log"
  CustomLog "/var/customers/logs/myselfe-access.log" combined
</VirtualHost>
 

Muss ich die conf händisch oder mittels cron in available kopieren? Oder sollte das Froxlor von sich aus machen? 🤔

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, Exsolium87 said:

In beiden fällen ist ist nichts da. Bei sites-available sind nur die Defaults drin und etc/customers gibts nicht, dafür gibts aber /var/customers/logs in dessen error.log aber nichts drin steht. 

Ups war mein Fehler mit dem Log Ordner. Muss mich hier an den Standard Pfad gewöhnen :P
Was sagt den der Cronjob, wenn du diesen Manuell ausführst mit php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug (ggf. Pfad zu deiner Froxlor installation anpassen!)
Ist Froxlor überhaupt auch Richtig eingerichtet oder einfach nur Installiert und drauf los gelegt?

Share this post


Link to post
Share on other sites
  • 0
vor 1 Minute schrieb irisdina:

Ups war mein Fehler mit dem Log Ordner. Muss mich hier an den Standard Pfad gewöhnen :P
Was sagt den der Cronjob, wenn du diesen Manuell ausführst mit php /var/www/froxlor/scripts/froxlor_master_cronjob.php --force --debug
Ist Froxlor überhaupt auch Richtig eingerichtet oder einfach nur Installiert und drauf los gelegt?

chown: der Eigentümer von '/var/www/html/php-fcgi-scripts/myselfe/myselfe.vrultimate.net/php-fcgi-starter' wird geändert: Die Operation ist nicht erlaubt
[information] TasksCron: Searching for tasks to do
[information] apache::createIpPort: creating ip/port settings for  91.39.180.83:80
[notice] 91.39.180.83:80 :: namevirtualhost-statement no longer needed for apache-2.4
[debug] 91.39.180.83:80 :: inserted vhostcontainer
[information] apache::createVirtualHosts: creating vhost container for domain 1, customer myselfe
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] apache::writeConfigs: rebuilding /etc/apache2/htpasswd/
[information] apache::writeConfigs: rebuilding /etc/apache2/sites-enabled/
[information] Froxlor\Cron\Http\Apache::reload: reloading Froxlor\Cron\Http\Apache
[notice] Checking system's last guid
 

Mir fehlen die availables oder?

Share this post


Link to post
Share on other sites
  • 0

Schau mal nach, was in /etc/apache2/sites-enabled/ drin ist ... gott ich habe schon seit Jahrzehnten nicht mehr mit Apache2 gearbeitet.
Hast du probiert den Eigentümer zu ändern oder kommt die Obere Meldung von Froxlor?

Share this post


Link to post
Share on other sites
  • 0
vor 1 Minute schrieb irisdina:

Schau mal nach, was in /etc/apache2/sites-enabled/ drin ist ... gott ich habe schon seit Jahrzehnten nicht mehr mit Apache2 gearbeitet.
Hast du probiert den Eigentümer zu ändern oder kommt die Obere Meldung von Froxlor?

Dann musst du ja schon richtig alt sein 😲🤣 Sorry 🙃

In der enabled sind:


000-default.conf
05_froxlor_dirfix_nofcgid.conf
10_froxlor_ipandport_91.39.180.83.80.conf
29_froxlor_normal_vhost_myselfe.vrultimate.net.conf
40_froxlor_diroption_f8d8ab484923a182e03a253dbf72866a.conf
 

Ich hatte fcgi kurzzeitig aktiviert und konnte danach nicht mehr auf Froxlor zugreifen, dann hab ichs wieder rausgeschmissen. Das könnte der Grund dafür gewesen sein, warum ich mich nicht mehr einloggen konnte 🤔 Das kommt glaub ich von Froxlor.

 

Share this post


Link to post
Share on other sites
  • 0
vor 23 Minuten schrieb Exsolium87:

Ist Froxlor überhaupt auch Richtig eingerichtet oder einfach nur Installiert und drauf los gelegt?

Ich glaub zunehmend, das ich einfach drauf los gelegt hab 😬

Muss aber auch  zu meiner Verteidigung dazu sagen, dass ich keine Dokumentation zu Froxlor gefunden hab.

Share this post


Link to post
Share on other sites
  • 0

steht alles da was zu beachten ist -> https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-from-tarball

Welche Einstellungen wo wie für dich relevant sind, dass musst du als server-admin natürlich wissen, froxlor kennt ja dein system nicht und was du da vllt noch so mit machst ( entsprechend aber bietet froxlor dir eben genau die freiheit und nimmt dir nicht alle freiheiten )

Share this post


Link to post
Share on other sites
  • 0
vor 12 Minuten schrieb d00p:

steht alles da was zu beachten ist -> https://github.com/Froxlor/Froxlor/wiki/Install-froxlor-from-tarball

Welche Einstellungen wo wie für dich relevant sind, dass musst du als server-admin natürlich wissen, froxlor kennt ja dein system nicht und was du da vllt noch so mit machst ( entsprechend aber bietet froxlor dir eben genau die freiheit und nimmt dir nicht alle freiheiten )

Ok. Danke 😃 

Muss ich dann jetzt konfigurationsmäßig noch was machen, damit die Domain den richtigen Inhalt zurück liefert? 🤔 Für mich als 2. Semestler sieht das alles plausibel aus 😅🙈

Share this post


Link to post
Share on other sites
  • 0

Die vhosts sehen eigentlich gut und korrekt aus. Kommt die dort hinterlegte Domain denn bei deinem Raspberry an?

Share this post


Link to post
Share on other sites
  • 0

Jap, wenn ich nen Ping mach bekomm ich die erwartete IP vom Pi zurück, sind spezielle Ports erforderlich außer 80, 21,20, 25,143 usw? 🤔

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, Exsolium87 said:

sind spezielle Ports erforderlich außer 80, 21,20, 25,143 usw? 🤔

Eigentlich nicht, ggfls noch 53 für DNS falls das ein probleml sein sollte. Zum Testen aber bitte immer jegliche Firewall ausmachen um die auszuschließen

Share this post


Link to post
Share on other sites
  • 0

Ja kann ja nich sein, die vhosts sehen korrekt aus, wenn du sonst nich irgendwas manuell noch gefrickelt hast sollte das problemlos gehen. Kann ich dir aber ohne mehr info oder zugriff auf die kiste nicht sagen. Logs gucken logs gucken logs gucken. Irgendwo findet sich immer was. Prüfe ob der apache die vhosts einliest (apache2 -t -D DUMP_VHOSTS) usw usw

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Jason Szymanski
      Hallo,
       
      ich habe leider ein Problem mit Froxlor.
      Zu meiner Situation: Froxlor läuft auf der Subdomain web01.meinedomain.net
      Jetzt möchte ich die Domain aber auch noch weiter Nutzen und habe mich daher als Kunde angelegt und die Domain meineDomain.net als Domain hinzugefügt.
      Dort kann ich auch weitere Subdomains hinzufügen. Das scheint soweit auch zu klappen ich sehe das er VHosts anlegt und auch die Verzeichnisse im FTP anlegt.
      Wenn ich jetzt allerdings versuche auf meinedomain.net oder eine andere Subdomain unter dieser Domain zuzugreifen leitet er mich auf web01.meinedomain.net
      Ich habe mich schon in den Einstellungen umgeschaut konnte aber keine entsprechende Einstellung finden an der das liegen könnte.
      Wie verhindere ich also das er mich auf Froxlor umleitet?
       
      Mit Freundlichen Grüßen
      Jason Szymanski
    • By Maxiffm
      Hallo,
      ich bin schon wieder am verzweifeln, vielleicht kann mir jemand helfen...
      Ich habe eine Domain mit Letsencrypt angelegt und die läuft auch wunderbar.
      Nun will ich dazu eine Wildcard Subdomain OHNE SSL (Letsencrypt) anlegen,
      es wird ein vhost für SSL angelegt und erzeugt beim Apache-Server einen Konfigurationsfehler...
      Läßt sich sowas realisieren oder ist das ein Fehler bei Froxlor ?
      Die Domain mit https://meine-domain.de und http://*.meine-domain.de angelegt, der Ordner
      wo  die -> http://*.meine-domain.de hinverweist wird angelegt, aber die Sub-Domains laufen in den
      Root des Servers, also 404 Not Found.
       
       
       
    • By Robert08020
      Hallo,
      Wenn ich einen neuen Kunden anlege, Doamin zuweise und FTP einrichte und gehe dann via WinSCP auf den Server, finde ich nichts. Der Ordner /var/customers wurde nicht erstellt.
      Kann mir jemand helfen?
      Mfg Robert08020
    • By H4nSolo
      Hallöchen zusammen,
      ich hätte mal eine Frage bezüglich Froxlor und Cloudflare.
       
      Da einige die Froxlor benutzen, bestimmt auch bei cloudflare ihre domain eingetragen haben, stellt sich mir die Frage ob man dies nicht gleich auch mit cloudflare verbinden kann um so seine subdomains / Domains miteinzurichten, ohne sich immer zusätzlich bei cloudflare anzumelden.

      Cloudflare bringt ja von Haus aus eine API mit womit man sich auch über Scripte und einen Authentifikations Key extern anmelden kann.
      Cloudflare API: https://api.cloudflare.com/
       
      Ich für meinen Teil würde es Prima finden wenn zum Beispiel Kunden ihren Login Key eintragen, und damit bequem auch bei erstellung von subdomains gleichzeitig (sofern sie ihre Domain beim Cloudflare registriert haben) alles in einem abwickeltn können.
       
       
      Was haltet ihr von der Idee und könnte man es überhaubt verwirklichen für Froxlor?
       
      lg H4nSolo
    • By Marc Zweier (KnowSlayes)
      Ich glaube ich brauche für heute noch mal einen kleinen Denkanstoß um den berühmten Hacken zu finden.
      Folgendes ist eingestellt:
      IPs und Ports (Meiner einziger IP) -> Benutzerdefinierter Docroot -> /var/www/
      Einstellungen -> Hostname -> v22018xxx.luckysrv.de
      Einstellungen -> Froxlor VirtualHost Einstellungen -> Froxlor direkt über den Hostnamen erreichbar machen [X]
      Ziel ist es das Froxlor Admin Panel über v22018xxx.luckysrv.de erreichbar zu machen, aber bei jeder anderen URL oder meiner IP das Standard Verzeichnis /var/www/ anzuzeigen
       
      Leider wird der Hostname nicht auf den richtigen Ordner /var/www/froxlor eingestellt. Nur wenn ich den IPs und Ports (Meiner einziger IP) -> Benutzerdefinierter Docroot rausnehme.
×
×
  • Create New...