Jump to content
Froxlor Forum
  • 0
Maxiffm

Wie legt man eine SSL Domain an, aber die Subdomains als Wildcard ohne SSL?

Question

Hallo,

ich bin schon wieder am verzweifeln, vielleicht kann mir jemand helfen...

Ich habe eine Domain mit Letsencrypt angelegt und die läuft auch wunderbar.

Nun will ich dazu eine Wildcard Subdomain OHNE SSL (Letsencrypt) anlegen,

es wird ein vhost für SSL angelegt und erzeugt beim Apache-Server einen Konfigurationsfehler...

Läßt sich sowas realisieren oder ist das ein Fehler bei Froxlor ?

Die Domain mit https://meine-domain.de und http://*.meine-domain.de angelegt, der Ordner

wo  die -> http://*.meine-domain.de hinverweist wird angelegt, aber die Sub-Domains laufen in den

Root des Servers, also 404 Not Found.

 

 

 

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

das liegt dann wohl daran, dass die hauptdomain der subdomain eine SSL fähige IP Adresse zugewiesen bekommen hat. Am besten legst du dann die Subdomain mit dem admin user als "Hauptdomain" an, gib dabei an das diese Domain eine Subdomain einer anderen Domain ist (Auswahlbox) da sonst die reihenfolge der vhosts nicht stimmt. Bei der kannst du dann die SSL fähige IP einfach weglassen und - tadaaa

Share this post


Link to post
Share on other sites
  • 0

Vielen Dank für den Hinweis, werde es nachher mal probieren...

==> Am besten legst du dann die Subdomain mit dem admin user als "Hauptdomain" an...

Hab ich noch nie gemacht, wußte auch nicht daß das überhaupt geht...mal sehen obs klappt...

 

 

Share this post


Link to post
Share on other sites
  • 0

also ich hab das so gemacht, wie du gesagt hast:  neue Domain angelegt 1 x als * und 1x als webcam als

subdomain mit Wildcard von einer SSL Dommain und DocumentRoot den Pfad zum Script, logischerweise die

die IP nicht auf SSL also Port 80.

Leider ohne Erfolg, die Sub-Domains werden immer noch zum Root des Servers, also auf 404 Not Found

geleitet.

 

Share this post


Link to post
Share on other sites
  • 0

Andere Möglichkeiten? Ich würde sagen du hast was falsch gemacht. Vllt kontrollierst du nach den einstellungen einfach mal die von froxlor erstellen vhosts, schaust ob das alles so passt wie es sein sollte; gerne auch hier rein posten; das ist im Grunde keine schwierige Einstellung, ich wüsste nicht wieso das nicht gehen sollte

Share this post


Link to post
Share on other sites
  • 0

So, ich habe das ganze die letzen 24 Stunden ausgiebig getestet.

Definitiv ein Froxlor Fehler, da müße auf alle Fälle noch nachgebessert werden.

Wenn ich als Admin eine neue Domain anlege -> *.meine-domain.de und bei Diese Domain ist eine Subdomain von der Domain" -> meine-domain.de auswähle und diese als Wildecard setze, dann wird diese auch angelegt, aber die -> blablabla.meine-domain.de Domains verweisen dann alle immer auf den Server Root und nicht in den vorgegebenen Ordner.

Ein ändern der vhost Datei und bind Konfigutation brachte keinen Erfolg.

Aber wenn ich als Admin eine neue Domain anlege -> go.meine-domain.de und bei Diese Domain ist eine Subdomain von der Domain" -> meine-domain.de auswähle und diese als Wildecard setze, dann geht das ganze

mit http://blablabla.go.meine-domain.de

Das Problem ist, daß die Haupt-Domain meine-domain.de als SSL läuft und da kein Wildcard gesetzt werden kann.

Ich habe noch eine uralte Froxlor-Version separat im Einsatz, da geht das tadelos, aber leider ohne Letsencypt ?

Scheint so, als kann man nicht alles haben...

Gruß Maxi

Share this post


Link to post
Share on other sites
  • 0
11 hours ago, Maxiffm said:

Wenn ich als Admin eine neue Domain anlege -> *.meine-domain.de

definitv ein anwenderfehler... "*.meine-domain.de" ist keine gültige Domain die angelegt werden können sollte.

Ich glaube deine Anforderungen habe ich falsch verstanden. So funktioniert das nicht, bzw. kann nicht funktionieren. WEnn "meine-domain.de" nunmal non-ssl und ssl IP's hat, dann je nach einstellung nunmall auch *.meine-domain.de.

Was hingegen funktioniert, wie ich es beschrieben habe, ist das Anlegen von z.B. "sub.meine-domain.de" als HAUPTDOMAIN, diese kann dann ohne ssl-IP angelegt werden und hier kannst du *.sub.domain.de nutzen.

11 hours ago, Maxiffm said:

Ich habe noch eine uralte Froxlor-Version separat im Einsatz, da geht das tadelos, aber leider ohne Letsencypt ?

eh what? glaub ich nicht...dieses konstrukt was du da beschreibst war in froxlor und nicht mal in syscp jemals enthalten. Da zeig mir mal bitte den von froxlor generierten Vhost dazu

 

Share this post


Link to post
Share on other sites
  • 0

Jetzt müssen wir auf SSL umstellen (Datenschutz), aber in der Wildcard-Domain werden Inhalte eines Frames nicht mit SSL  angezeigt und Wildcard Sub-Domains sowieso erstmal nicht mit SSL gehen, die Kunden-Urls sind von Homeservern zu 99% mit  http.

 

Share this post


Link to post
Share on other sites
  • 0

Da Anlegen der Subdoman *.domain.tld ist schlichtweg nicht möglich in froxlor (Error: Wrong Input in Field 'Domain') - entweder ist da in 0.9.29 und vorher was falsch oder du hast da manuell in der datenbank rumgespielt.

8 minutes ago, Maxiffm said:

PS: auf unserem Portal sind mittlerweile über 70.000 User weltweit, deshalb ist eine *.meine-domain.de ohne SSL so wichtig.

Dann mach es dir halt nicht so schwer und nimm entweder eine domain komplett dafür und ohne SSL oder mach halt "*.sub.meine-domain.de"

Share this post


Link to post
Share on other sites
  • 0

ne ne, nix in Froxlor-Datenbank gefuschelt...und auch nix am Froxlor-Script gemacht...ging einfach und ich dachte "oh wie nett"

 

 

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Maxiffm said:

Doch, das geht ja...das ist kein Problem Froxlor Version: 0.9.39.5 (DB: 201802130)  und Debian Jessie ?

dann zeig mir bitte was genau du da wo machst, denn bei mir geht es nicht (demo.froxlor.org) und ich behaupte mal ich weiss wie ich froxlor bedienen muss

Share this post


Link to post
Share on other sites
  • 0

es macht schlichtweg keinen sinn die subdomain "*" anlegen zu können denn dafür gibts die setting "wildcard alias"

Share this post


Link to post
Share on other sites
  • 0

Eh, das ist ganz normal eine subdomain mit Name "www"...du erzählst hier als du hast "*" angelegt...naja, mach wie du denkst, wenn's funktioniert ist ja toll.

Aber eins: dein "lieber" bin ich sicher nicht...

Share this post


Link to post
Share on other sites
  • 0

 

Damit du siehst, daß das bei mir geht, erzeugt allerdings ein Syntax-Error....ich habe gerade die demo.froxlor.org probiert, da geht das nicht.

Bei mir schon und ich hab nichts am Script oder Datenbank gemacht, einfach installiert und es geht.

 

 

froxlor

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Maxiffm said:

damit du siehst, daß das bei mir geht, erzeugt allerdings ein Syntax-Error....ich habe gerade die demo.froxlor.org probiert, da geht das nicht.

K.a. was du da tust, aber es sollte nicht gehen. Ende.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Jason Szymanski
      Hallo,
       
      ich habe leider ein Problem mit Froxlor.
      Zu meiner Situation: Froxlor läuft auf der Subdomain web01.meinedomain.net
      Jetzt möchte ich die Domain aber auch noch weiter Nutzen und habe mich daher als Kunde angelegt und die Domain meineDomain.net als Domain hinzugefügt.
      Dort kann ich auch weitere Subdomains hinzufügen. Das scheint soweit auch zu klappen ich sehe das er VHosts anlegt und auch die Verzeichnisse im FTP anlegt.
      Wenn ich jetzt allerdings versuche auf meinedomain.net oder eine andere Subdomain unter dieser Domain zuzugreifen leitet er mich auf web01.meinedomain.net
      Ich habe mich schon in den Einstellungen umgeschaut konnte aber keine entsprechende Einstellung finden an der das liegen könnte.
      Wie verhindere ich also das er mich auf Froxlor umleitet?
       
      Mit Freundlichen Grüßen
      Jason Szymanski
    • By H4nSolo
      Hallöchen zusammen,
      ich hätte mal eine Frage bezüglich Froxlor und Cloudflare.
       
      Da einige die Froxlor benutzen, bestimmt auch bei cloudflare ihre domain eingetragen haben, stellt sich mir die Frage ob man dies nicht gleich auch mit cloudflare verbinden kann um so seine subdomains / Domains miteinzurichten, ohne sich immer zusätzlich bei cloudflare anzumelden.

      Cloudflare bringt ja von Haus aus eine API mit womit man sich auch über Scripte und einen Authentifikations Key extern anmelden kann.
      Cloudflare API: https://api.cloudflare.com/
       
      Ich für meinen Teil würde es Prima finden wenn zum Beispiel Kunden ihren Login Key eintragen, und damit bequem auch bei erstellung von subdomains gleichzeitig (sofern sie ihre Domain beim Cloudflare registriert haben) alles in einem abwickeltn können.
       
       
      Was haltet ihr von der Idee und könnte man es überhaubt verwirklichen für Froxlor?
       
      lg H4nSolo
    • By Marc Zweier (KnowSlayes)
      Ich glaube ich brauche für heute noch mal einen kleinen Denkanstoß um den berühmten Hacken zu finden.
      Folgendes ist eingestellt:
      IPs und Ports (Meiner einziger IP) -> Benutzerdefinierter Docroot -> /var/www/
      Einstellungen -> Hostname -> v22018xxx.luckysrv.de
      Einstellungen -> Froxlor VirtualHost Einstellungen -> Froxlor direkt über den Hostnamen erreichbar machen [X]
      Ziel ist es das Froxlor Admin Panel über v22018xxx.luckysrv.de erreichbar zu machen, aber bei jeder anderen URL oder meiner IP das Standard Verzeichnis /var/www/ anzuzeigen
       
      Leider wird der Hostname nicht auf den richtigen Ordner /var/www/froxlor eingestellt. Nur wenn ich den IPs und Ports (Meiner einziger IP) -> Benutzerdefinierter Docroot rausnehme.
    • By FearTheDude
      Hey liebe Leute,
      bin nagelneu hier, benutze Froxlor aber schon etwas länger. Nachdem ich heute Golem kurz durchgeblättert habe, ist mir ein Artikel ins Auge gesprungen, den vermutlich auch Froxlor, deren Maintainer und natürlich am meisten die Nutzer dieser Software erfreuen sollte.
      Kurze Rede, langer Sinn: Ab 27. Februar 2018 möchte Let's Encrypt mit der produktiven Vergabe von Wildcard Zertifikaten beginnen.
      Eine Test-Api wird wohl ab dem 4. Januar 2018 verfügbar sein.
      Quelle: https://www.golem.de/news/https-let-s-encrypt-bringt-wildcard-zertifikate-1712-131621.html
    • By LukasH
      Einen wunderschönen guten Abend,
      Ich habe ein kleines Problem mit Subdomains auf meinem Webserver. Ich habe für diesen Froxlor mit LetsEncrypt eingestellt und bereits RainLoop als Webmailer eingerichtet. Das hat wunderbar funktioniert über 
      meinedomain.de/webmailordner.
      Nun wollte ich allerdings eine Subdomain anlegen (webmail.meinedomain.de) das will aber nicht funktionieren. Die Subdomain bekommt korrekt ein SSL Zertifikat zugewiesen, allerdings wird die in dem Verzeichnis liegende PHP Datei nicht ausgeführt sondern einfach nur der Inhalt angezeigt. Somit ist das Aufrufen des Webmailers nicht möglich. Rufe ich den Webmailer wieder über "meinedomain.de/webmailordner" auf funktioniert alles ganz normal.
      Ebenfalls wollte ich das Verzeichnis von meinedomain.de ändern, sobald ich das allerdings mache bekomme ich nur noch den Fehler 403 forbidden unter der Domain. Sobald ich den Pfad wieder in den Kundenroot ändere funktioniert es wieder. 
      Allerdings sollen auf den Server doch diverse Domains für verschiedene Dienste umgezogen werden und die aktuelle Domain ist nur für einen Dienst gedacht soll also auf einen Unterordner verweisen, wo ist hier das Problem?
      Vielen Dank für eure Hilfe! In den angehängten Screenshot ist die Konfiguration in Froxlor zu sehen, falls noch etwas benötigt wird reiche ich das natürlich sofort nach. 



×
×
  • Create New...