Jump to content
Froxlor Forum
  • 0
cronosdev

Verbinden mit Mailserver nicht möglich

Question

Hallo Froxlor Froum,

 

kämpfe seit Tagen damit einen VServer mit Froxlor erfolgreich zum laufen zu bringen, allerdings fallen mir immer wieder Steine in den Weg. Nach dem kürzlich gelösten ProFTP Fehler habe ich nun das Problem das ich mich nicht mit meinem Mailserver verbinden kann. Habe bereits viel Im Internet nach Lösungen gesucht aber nichts gefunden. Wie schon oft gelesen habe ich mich auch wirklich penibel an die Konfigurationsschritte des Webinterfaces gehalten. 

Um es nur kurz anzumerken, dies ist meine zweite Froxlor Installation auf einem VServer. Die erste liefe ohne nennenswerte Probleme ab und ist auch immer noch in Betrieb. 

 

Mein aktuelles System läuft auf Ubuntu 14.04, Froxlor per apt installiert und anschließend Konfiguration durchgeführt. Standardmäßig Postfix mit Dovecot.

 

Der Fehler sieht wie folgt aus: Ich versuche mich per Email-Client mit einer vom Dummy Kunden erstellten Email auf den Server einzuloggen. Ich erhalte lediglich die Meldung, das die Verbindung zum Server nicht hergestellt werden kann. Ping an besagten Server ist erfolgreich. Was mich stutzig macht ist das ein nmap auf auf port 143 auswirft das der Port 143 geschlossen ist. Die Logs sagen folgendes:

 

mail.log

 

postfix/master[811]: daemon started -- version 2.11.0, configuration /etc/postfix
postfix/qmgr[816]: 4D08D3EB60620: from=<admin@[MEIN_HOSTNAME]>, size=1344, nrcpt=1 (queue active)
dovecot: lda: Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: No such file or directory
dovecot: lda: Fatal: Internal error occurred. Refer to server log for more information.
postfix/pipe[1262]: 4D08D3EB60620: to=<[KUNDENMAIL]@[KUNDEN_DOMAIN]>, relay=dovecot, delay=6105, delays=6105/0.01/0/0.18, dsn=4.3.0, status=deferred (temporary failure)
 
mail.err
 
dovecot: lda: Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: No such file or directory
dovecot: lda: Fatal: Internal error occurred. Refer to server log for more information.
 
Kann nur nochmal betonen das ich alle Schritte genaustens nach Anweisung durch geführt habe. 
 
Kann mir jemand bei der Problemlösung helfen?
 
MFG
 
 

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0
/etc/dovecot/conf.d/10-ssl.conf sieht wie folgt aus:

 

##

## SSL settings

##

 

# SSL/TLS support: yes, no, required. <doc/wiki/SSL.txt>

#ssl = yes

 

# PEM encoded X.509 SSL/TLS certificate and private key. They're opened before

# dropping root privileges, so keep the key file unreadable by anyone but

# root. Included doc/mkcert.sh can be used to easily generate self-signed

# certificate, just make sure to update the domains in dovecot-openssl.cnf

ssl_cert = </etc/dovecot/dovecot.pem

ssl_key = </etc/dovecot/private/dovecot.pem

 

# If key file is password protected, give the password here. Alternatively

# give it when starting dovecot with -p parameter. Since this file is often

# world-readable, you may want to place this setting instead to a different

# root owned 0600 file by using ssl_key_password = <path.

#ssl_key_password =

 

# PEM encoded trusted certificate authority. Set this only if you intend to use

# ssl_verify_client_cert=yes. The file should contain the CA certificate(s)

# followed by the matching CRL(s). (e.g. ssl_ca = </etc/ssl/certs/ca.pem)

#ssl_ca = 

 

# Require that CRL check succeeds for client certificates.

#ssl_require_crl = yes

 

# Directory and/or file for trusted SSL CA certificates. These are used only

# when Dovecot needs to act as an SSL client (e.g. imapc backend). The

# directory is usually /etc/ssl/certs in Debian-based systems and the file is

# /etc/pki/tls/cert.pem in RedHat-based systems.

#ssl_client_ca_dir =

#ssl_client_ca_file =

 

# Request client to send a certificate. If you also want to require it, set

# auth_ssl_require_client_cert=yes in auth section.

#ssl_verify_client_cert = no

 

# Which field from certificate to use for username. commonName and

# x500UniqueIdentifier are the usual choices. You'll also need to set

# auth_ssl_username_from_cert=yes.

#ssl_cert_username_field = commonName

 

# DH parameters length to use.

#ssl_dh_parameters_length = 1024

 

# SSL protocols to use

#ssl_protocols = !SSLv2

 

# SSL ciphers to use

#ssl_cipher_list = ALL:!LOW:!SSLv2:!EXP:!aNULL

 

# Prefer the server's order of ciphers over client's.

#ssl_prefer_server_ciphers = no

 

# SSL crypto device to use, for valid values run "openssl engine"

#ssl_crypto_device =

Share this post


Link to post
Share on other sites
  • 0

Entweder "ssl = yes" oder ssl_cert und ssl_key auskommentieren, dann dovecot neustarten

Share this post


Link to post
Share on other sites
  • 0

Hab "ssl = yes" auskommentiert. Problem bleibst bestehen die Logs sagen immer noch das selbe. Login mit Email-Client immer noch: "Verbindung zum Server kann nicht hergestellt werden".

Share this post


Link to post
Share on other sites
  • 0
Ergibt:

 

/etc/dovecot/conf.d/10-mail.conf:#auth_socket_path = /var/run/dovecot/auth-userdb

/etc/dovecot/conf.d/10-master.conf:  unix_listener auth-userdb {

Share this post


Link to post
Share on other sites
  • 0

dann das zeug in der /etc/dovecot/conf.d/10-mail.conf als aktivieren....

Share this post


Link to post
Share on other sites
  • 0

Hab nun auth_socket_path = /var/run/dovecot/auth-userdb in der /etc/dovecot/conf.d/10-mail.conf aktiviert. Fehlermeldung taucht nicht mehr in den Logs auf. Trotzdem Verbindung nicht möglich. 

 

MFG

Share this post


Link to post
Share on other sites
  • 0

Gucksu logs...muss ja was drinstehen wieso es nicht geht. Bitte zur not auch mail_debug = yes aktivieren

Share this post


Link to post
Share on other sites
  • 0

Also nach erneuten schauen in die Logs immer noch selbes Problem:

 

dovecot: lda: Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: No such file or directory
dovecot: lda: Fatal: Internal error occurred. Refer to server log for more information.
postfix/pipe[1608]: 4D08D3EB60620: to=<[KUNDEN_EMAIL]@[KUNDEN_DOMAIN]>, relay=dovecot, delay=18523, delays=18522/0.25/0/0.34, dsn=4.3.0, status=deferred (temporary failure)

Share this post


Link to post
Share on other sites
  • 0

Habe nun folgendes herausgefunden. Habe für die Konfiguration von Froxlor übers Webinterface immer Ubuntu 14.04 ausgewählt, da dies ja auch mein Betriebssystem ist. Habe mir mal die Konfigurationsschritte für Debian 8 Jessie angeschaut. Dort wird der Dovecot Dienst viel intensiver behandelt und mehr Configs als bei Ubuntu bearbeitet. Wie kommt das zu Stande? Macht es Sinn einfach die Debian Konfiguration zu durchlaufen da Ubuntu ja auch nur ein Abkömmling von Debian ist? 

 

MFG

Share this post


Link to post
Share on other sites
  • 0

Habe nun die Configs für Debian auf Ubuntu 14.04 durchgeführt. Bis jetzt scheint der Server so zu laufen. Musste nur wie hier schon beschrieben wieder die ProFTP Config anpassen.

 

Nur als Verständnisfrage. Wieso sind die Configs für Ubuntu 14.04 im Webinterface, ich sage mal, unvollständig?

 

MFG

Share this post


Link to post
Share on other sites
  • 0

Weil wir das alle in unserer Freizeit und unentgeltlich machen... Und keine sau Ubuntu aufm Server hat xD

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By thunfischbaum
      Hi everyone,
      just a little problem here. I have severa domains registered on my froxlor installation and a different hostname of course. So let's say domain1.de is my hostname. The second domain, which is used by a customer is called domain2.de . When I view the mail.log I am not able to find my connection request. I do only see the bruteforce bots with example@domain1.de connecting. But any example@domain2.de request is not getting forwareded. I did configure the installation accordingdly with the provided templates.
      Best regards,
      thunfischbaum
    • By thunfischbaum
      Hi everyone,
      I'm running a Debian 10 Buster Server with PHP7.3 installed. The PHP7.3 update is the new component in the system. since then, I can't find any Mailboxes. There are no folders in the var/customers/mail/[customer] directory.
      If you take look at the Screenshot, you see, that the E-Mail adress is existent in Froxlor. 

      Mail Bounce
      Mail Log
       
      If I missed a log, please let me know, so I can attach it
      Best regards,
      thunfischbaum

    • By alex84
      Hallo,
      ich würde gerne Quotas für die Mailboxen nutzen. Dazu habe ich u.g. Funktion aktiviert und kann jetzt pro Mailbox Kontingente festlegen. 
      Allerdings werden die weder in Thunderbird noch Roundcube angezeigt. Die Option oben besagt ja auch, das eine "spezielle Konfiguration" vorausgesetzt wird. Also nun meine Frage(n) Was muss ich noch anpassen oder installieren? Haben sich mit der Aktivierung dieser Option auch die Konfigurationstemplates geändert? (Auf dem ersten Blick würde ich sagen: Nein)
      Ich nutze das aktuelle Froxlor 0.9.40.1 (allerdings auf Debian 10 - Ich habe mich dabei an diese Anleitung gehalten, so weit es rein um Froxlor geht. Also ohne die "Partitionieren"-etc Abschnitte: https://lichtmetzger.de/2019/05/31/debian-10-buster-und-froxlor-0-9-auf-einem-hetzner-ex52-server-installieren/) Die Config-Templates (Postfix/Dovecot) habe ich soweit 1:1 übernommen, lediglich die SSL-Zertifikate und das message_size_limit angepasst.
      Danke schonmal,
      Alex
×
×
  • Create New...