Jump to content
Froxlor Forum
  • 0
thunfischbaum

Only hostname E-Mail adresses are getting answered.

Question

Hi everyone,

just a little problem here. I have severa domains registered on my froxlor installation and a different hostname of course. So let's say domain1.de is my hostname. The second domain, which is used by a customer is called domain2.de . When I view the mail.log I am not able to find my connection request. I do only see the bruteforce bots with example@domain1.de connecting. But any example@domain2.de request is not getting forwareded. I did configure the installation accordingdly with the provided templates.

Best regards,

thunfischbaum

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Did you actually add an email address as customer? Try to increase the log-level - there should definetly be something in the mail.log

Share this post


Link to post
Share on other sites
  • 0

Well there should definetly be something in the logs...except If donain2.de does not Point to the Server 

Share this post


Link to post
Share on other sites
  • 0

So what do I need to enter in the imap and pop settings exactly?

Is it imap.domain1.de or imap.domain2.de or just the hostname without imap or pop prefix? Because maybe I'm just entering the wrong details... That would explain why there are no inbound connections visible from my end.

Share this post


Link to post
Share on other sites
  • 0

Test without SSL first, Just use the Servers IP, or the froxlor hostname you have entered when installing froxlor.

Share this post


Link to post
Share on other sites
  • 0

You should either way definetly See SOMETHING in the server logs. Try your Login and Post Output of:

tail /var/log/mail.log -n 100

Share this post


Link to post
Share on other sites
  • 0

Found me! I was searching for the E-Mail Adress in order to find the log entry.

 

Oct 26 16:53:39 fuwu-logistics dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip                                             =95.116.170.12, lip=194.55.15.31, session=<4KKRbtGVMORfdKoM>
Oct 26 16:53:39 fuwu-logistics dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip                                             =95.116.170.12, lip=194.55.15.31, session=<RseZbtGVMuRfdKoM>

 

Share this post


Link to post
Share on other sites
  • 0
23 minutes ago, thunfischbaum said:

user=<>

No username given as it seems. Loginname is the full email address

Share this post


Link to post
Share on other sites
  • 0

Hurray, I'm able to send mail! I forgot to give the iPad credentials for smtp *facepalm* My Mistake, sorry...

But, I'm still not able to receive Mail :(

 

 

EDIT:

Found some entries in the log,

Oct 26 18:12:44 fuwu-logistics dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=95.116.170.12, lip=194.55.15.31, session=<cZ1midKVcuRfdKoM>
Oct 26 18:12:44 fuwu-logistics dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=95.116.170.12, lip=194.55.15.31, session=<e09oidKVdORfdKoM>
Oct 26 18:12:47 fuwu-logistics dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=95.116.170.12, lip=194.55.15.31, session=<+2aVidKVduRfdKoM>
Oct 26 18:12:48 fuwu-logistics dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=95.116.170.12, lip=194.55.15.31, session=<SyOjidKVeORfdKoM>
Oct 26 18:12:50 fuwu-logistics dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=95.116.170.12, lip=194.55.15.31, session=<Tqu8idKVeeRfdKoM>
Oct 26 18:12:50 fuwu-logistics dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=95.116.170.12, lip=194.55.15.31, session=<zaS9idKVeuRfdKoM>
Oct 26 18:12:50 fuwu-logistics dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=95.116.170.12, lip=194.55.15.31, session=<jqLAidKVe+RfdKoM>
Oct 26 18:12:50 fuwu-logistics dovecot: imap-login: Aborted login (no auth attempts in 0 secs): user=<>, rip=95.116.170.12, lip=194.55.15.31, session=<T97BidKVfORfdKoM>

But I specified a user this time...

Share this post


Link to post
Share on other sites
  • 0

Well "can't receive" can be many things. Without any helpful log messages there is not much I can help you with. Can be one of 1000 of causes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By hoschi
      Ich hab noch gaaanz alte Systeme (+10 Jahre) am Start und wollte nicht auf dovecot umstellen.
      Falls jemand danach suchen sollte, die "alte" Kombination von Programmen ist weiter nutzbar, wenn angepasst (Debian 9+). Hintergrund: froxlor speichert in seiner DB die Passwörter nach konfiguration als password und password_enc ab, letzteres ist verschlüsselt. Der hash lässt erkennen, womit gearbeitet wurde - ein einfacher String ist ein Uralt-crypt-Passwort, aktuell sollte sowas wie $5$ am Anfang stehen, was auf SHA-256 verweisst.
      Werden die Klartextpasswörter gelöscht, ist die alte Konfiguration nicht mehr verwendbar. Wäre aber mal sinnvoll, die rauszuwerfen. Folgendes ist anzupassen:
      /etc/courier/authmysqlrc:
      MYSQL_USER_TABLE mail_users MYSQL_CRYPT_PWFIELD password_enc #MYSQL_CRYPT_PWFIELD crypt Damit wird courier angewiesen, für pop und imap verschlüsslte PW auszulesen. Die SHA-256 lib ist bei Debian inclusive. crypt fliegt raus. Fertig ist der Mailabruf.
      Tricky ist die Anpassung von postfix. Die dort benutzte Bibliothek für sasl hat Einschränkungen und ist der letztlich der Grund für Probleme. Lässt sich beheben mit folgender /etc/postfix/sasl/smtpd.conf:
      pwcheck_method: authdaemond authdaemond_path: /run/courier/authdaemon/socket mech_list: plain login In der Datei stand vorher pwcheck_method: auxprop mit sql plugin drin. Das Problem ist: auxprop kann nur Klartext. Aber dafür erlaubt auxprop die Verwendung von cram-md5 und digest-md5 zum hashen auf Clientseite, früher war daher die mech_list um diese beiden ergänzt. Bedeutet: der Client verbindet sich unverschlüsselt und ohne TLS, aber hasht noch auf dem Clientsystem das Passwort mit md5 und übermittelt dann nur den hash über den unverschlüsselten Kanal. Bei TLS kann man sich das sparen - erst wird der Kanal abgesichert, dann kann das PW unverschlüsselt geschickt werden und wird auf Serverseite gehasht und dann verglichen - das erledigt der authdaemond. auxprop kann das nicht.
      Die Mechlist wird dem Client übermittelt. Ganz alte Accounts haben evtl. noch Clienthashes und kein SSL eingeschaltet, die müssen dann umstellen auf STARTTLS mit Klartext - gilt aber nur für den Mailversand. Klartext bedeutet wie gesagt nur, das der Thunderbird/Outlook/etc. das Passwort ungehasht schickt, der authdaemond hasht das und vergleicht dann diesen hash mit dem in der froxlor Datenbank - da steht aber nix mehr im Klartext drin.
      Passwort-Wechsel ist für die User über Roundcube wie gewohnt möglich. In der DB könnt ihr sehen wie der Hash sich ändert.
    • By mrairstone
      Guten Morgen,
      mir ist in Froxlor ein kleiner Fehler in Bezug auf CatchAll Email aufgefallen.
      Zum System:
      Debian 10, 64-Bit Froxlor 0.10.11 Postfix, Dovecot, Spamc Zum Problem:
      Beim Anlegen einer neuen E-Mailadresse kann man je Domain nur eine CatchAll-Adresse definieren. Wenn man jedoch eine bestehende E-Mailadresse bearbeitet, kann man dort ganz einfach auf CatchAll umschalten.
      Dadurch kann es passieren, dass mehrere Emailadressen unterhalb einer Domain als CatchAll definiert sind. Das ist mir erst aufgefallen, als ich E-Mails in meinem Postfach hatte, welche nicht für meine E-Mailadresse bestimmt waren.
      Da auf dem Account in Froxlor mehrer Nutzer zugreifen (Feuerwehr) und E-Mailadressen hinzufügen, ändern und auch löschen - habe ich erst sehr spät gesehen das mehrere CatchAll vorhanden waren.
      Wenn man eine Mail an eine E-Mailadresse sendet, welche als CatchAll definiert wurde, wird die Mail auch an alle anderen E-Mailadressen weitergeleitet, die unterhalb der Domain als CatchAll definiert sind.(Jedenfalls bei postfix)
      Temporäre Lösung:
      Damit eingehende Mails an eine vorhandene E-Mailadresse, welche als CatchAll definiert ist, auch nur im Postfach dieser E-Mailadresse landen, habe ich die SQL-Anweisung in der "mysql-virtual_alias_maps.cf" wie folgt abgeändert:
      query = SELECT destination FROM mail_virtual AS v, panel_customers AS c WHERE c.customerid = v.customerid AND c.deactivated = 0 AND (v.email = '%s' OR v.email_full = '%s') AND trim(v.destination) <> '' Ich habe das eben auch noch einmal in der Demoversion ausprobiert, Screenshot im Anhang.
       
      Gruß

    • By thunfischbaum
      Hi everyone,
      I'm running a Debian 10 Buster Server with PHP7.3 installed. The PHP7.3 update is the new component in the system. since then, I can't find any Mailboxes. There are no folders in the var/customers/mail/[customer] directory.
      If you take look at the Screenshot, you see, that the E-Mail adress is existent in Froxlor. 

      Mail Bounce
      Mail Log
       
      If I missed a log, please let me know, so I can attach it
      Best regards,
      thunfischbaum

    • By nisamudeen97
      Hi,
      Wile doing migration of email accounts from one froxlor server to another I have noting some thing.   Expecting some clarification on this.  As we all know emails are normally stored in the location "/var/customers/mail/user/domain.com/user/Maildir/" .   I create email accounts via froxlor panel and copy the email files directly via scp or rsync from old server to new.  The strange thing I have noticed is it is not coping custom folders and its emails like we have in source.  
      The solution I have found for this is to use imapsync between old and new.  imapsync is preserving custom folders like as it is in source.    Does it mean custom folder settings are stored somewhere else?  How we can preserve it and copy emails manually?
×
×
  • Create New...