Jump to content
Froxlor Forum

cronosdev

Members
  • Content Count

    37
  • Joined

  • Last visited

Community Reputation

0 Neutral

About cronosdev

  • Rank
    Advanced Froxie
  1. Nur ne Frage da es Angeboten wird.
  2. Habe nun die Configs für Debian auf Ubuntu 14.04 durchgeführt. Bis jetzt scheint der Server so zu laufen. Musste nur wie hier schon beschrieben wieder die ProFTP Config anpassen. Nur als Verständnisfrage. Wieso sind die Configs für Ubuntu 14.04 im Webinterface, ich sage mal, unvollständig? MFG
  3. Habe nun folgendes herausgefunden. Habe für die Konfiguration von Froxlor übers Webinterface immer Ubuntu 14.04 ausgewählt, da dies ja auch mein Betriebssystem ist. Habe mir mal die Konfigurationsschritte für Debian 8 Jessie angeschaut. Dort wird der Dovecot Dienst viel intensiver behandelt und mehr Configs als bei Ubuntu bearbeitet. Wie kommt das zu Stande? Macht es Sinn einfach die Debian Konfiguration zu durchlaufen da Ubuntu ja auch nur ein Abkömmling von Debian ist? MFG
  4. Kann mich nur wiederholen. Hab die Konfiguration genaustens durchgeführt
  5. Also nach erneuten schauen in die Logs immer noch selbes Problem: dovecot: lda: Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: No such file or directory dovecot: lda: Fatal: Internal error occurred. Refer to server log for more information. postfix/pipe[1608]: 4D08D3EB60620: to=<[KUNDEN_EMAIL]@[KUNDEN_DOMAIN]>, relay=dovecot, delay=18523, delays=18522/0.25/0/0.34, dsn=4.3.0, status=deferred (temporary failure)
  6. Hab nun auth_socket_path = /var/run/dovecot/auth-userdb in der /etc/dovecot/conf.d/10-mail.conf aktiviert. Fehlermeldung taucht nicht mehr in den Logs auf. Trotzdem Verbindung nicht möglich. MFG
  7. Ergibt: /etc/dovecot/conf.d/10-mail.conf:#auth_socket_path = /var/run/dovecot/auth-userdb /etc/dovecot/conf.d/10-master.conf: unix_listener auth-userdb {
  8. Hab "ssl = yes" auskommentiert. Problem bleibst bestehen die Logs sagen immer noch das selbe. Login mit Email-Client immer noch: "Verbindung zum Server kann nicht hergestellt werden".
  9. /etc/dovecot/conf.d/10-ssl.conf sieht wie folgt aus: ## ## SSL settings ## # SSL/TLS support: yes, no, required. <doc/wiki/SSL.txt> #ssl = yes # PEM encoded X.509 SSL/TLS certificate and private key. They're opened before # dropping root privileges, so keep the key file unreadable by anyone but # root. Included doc/mkcert.sh can be used to easily generate self-signed # certificate, just make sure to update the domains in dovecot-openssl.cnf ssl_cert = </etc/dovecot/dovecot.pem ssl_key = </etc/dovecot/private/dovecot.pem # If key file is password protected, give the password here. Alternatively # give it when starting dovecot with -p parameter. Since this file is often # world-readable, you may want to place this setting instead to a different # root owned 0600 file by using ssl_key_password = <path. #ssl_key_password = # PEM encoded trusted certificate authority. Set this only if you intend to use # ssl_verify_client_cert=yes. The file should contain the CA certificate(s) # followed by the matching CRL(s). (e.g. ssl_ca = </etc/ssl/certs/ca.pem) #ssl_ca = # Require that CRL check succeeds for client certificates. #ssl_require_crl = yes # Directory and/or file for trusted SSL CA certificates. These are used only # when Dovecot needs to act as an SSL client (e.g. imapc backend). The # directory is usually /etc/ssl/certs in Debian-based systems and the file is # /etc/pki/tls/cert.pem in RedHat-based systems. #ssl_client_ca_dir = #ssl_client_ca_file = # Request client to send a certificate. If you also want to require it, set # auth_ssl_require_client_cert=yes in auth section. #ssl_verify_client_cert = no # Which field from certificate to use for username. commonName and # x500UniqueIdentifier are the usual choices. You'll also need to set # auth_ssl_username_from_cert=yes. #ssl_cert_username_field = commonName # DH parameters length to use. #ssl_dh_parameters_length = 1024 # SSL protocols to use #ssl_protocols = !SSLv2 # SSL ciphers to use #ssl_cipher_list = ALL:!LOW:!SSLv2:!EXP:!aNULL # Prefer the server's order of ciphers over client's. #ssl_prefer_server_ciphers = no # SSL crypto device to use, for valid values run "openssl engine" #ssl_crypto_device =
  10. Hallo Froxlor Froum, kämpfe seit Tagen damit einen VServer mit Froxlor erfolgreich zum laufen zu bringen, allerdings fallen mir immer wieder Steine in den Weg. Nach dem kürzlich gelösten ProFTP Fehler habe ich nun das Problem das ich mich nicht mit meinem Mailserver verbinden kann. Habe bereits viel Im Internet nach Lösungen gesucht aber nichts gefunden. Wie schon oft gelesen habe ich mich auch wirklich penibel an die Konfigurationsschritte des Webinterfaces gehalten. Um es nur kurz anzumerken, dies ist meine zweite Froxlor Installation auf einem VServer. Die erste liefe ohne nennenswerte Probleme ab und ist auch immer noch in Betrieb. Mein aktuelles System läuft auf Ubuntu 14.04, Froxlor per apt installiert und anschließend Konfiguration durchgeführt. Standardmäßig Postfix mit Dovecot. Der Fehler sieht wie folgt aus: Ich versuche mich per Email-Client mit einer vom Dummy Kunden erstellten Email auf den Server einzuloggen. Ich erhalte lediglich die Meldung, das die Verbindung zum Server nicht hergestellt werden kann. Ping an besagten Server ist erfolgreich. Was mich stutzig macht ist das ein nmap auf auf port 143 auswirft das der Port 143 geschlossen ist. Die Logs sagen folgendes: mail.log postfix/master[811]: daemon started -- version 2.11.0, configuration /etc/postfix postfix/qmgr[816]: 4D08D3EB60620: from=<admin@[MEIN_HOSTNAME]>, size=1344, nrcpt=1 (queue active) dovecot: lda: Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: No such file or directory dovecot: lda: Fatal: Internal error occurred. Refer to server log for more information. postfix/pipe[1262]: 4D08D3EB60620: to=<[KUNDENMAIL]@[KUNDEN_DOMAIN]>, relay=dovecot, delay=6105, delays=6105/0.01/0/0.18, dsn=4.3.0, status=deferred (temporary failure) mail.err dovecot: lda: Error: userdb lookup: connect(/var/run/dovecot/auth-userdb) failed: No such file or directory dovecot: lda: Fatal: Internal error occurred. Refer to server log for more information. Kann nur nochmal betonen das ich alle Schritte genaustens nach Anweisung durch geführt habe. Kann mir jemand bei der Problemlösung helfen? MFG
  11. Sehr guter Hinweis, beim Versuch den proftpd service zu starten habe ich folgende Fehlermeldung erhalten: proftpd[5604]: Fatal: unknown configuration directive 'TLSECCertificateFile' on line 7 of '/etc/proftpd/tls.conf' [fail] Bin dann in die tls.conf gegangen und habe folgende Zeilen auskommentiert: #TLSECCertificateFile /etc/ssl/certs/proftpd_ec.crt #TLSECCertificateKeyFile /etc/ssl/private/proftpd_ec.key Danach versucht den Service erneut zustarten und jetzt klappt es. Wieso machen die zwei Zeilen Probleme. Habe ich gar keine Möglichkeit die Kunden per SFTP zu verbinden? MFG
  12. Super vielen Dank Vielleicht auch eine Idee zu meinem Problem d00p? MFG
  13. Auch versucht. Bekomme dann folgende Fehlermeldung: Status: Verbinde mit [sERVER_IP]... Status: Verbindungsversuch fehlgeschlagen mit "ECONNREFUSED - Verbindung durch Server verweigert". Fehler: Herstellen der Verbindung zum Server fehlgeschlagen auth.log sagt diesmal gar nichts, genau so wie proftpd.log. PS: wie ich gesehen hab wurden wohl mehre Topics erstellt. Keine Ahnung wie das passiert ist aber es tut mir Leid. Andere können natürlich vom Admin gelöscht werden wenn möglich. MFG
  14. Hallo Froxlor Forum, kämpfe nun seit einigen Tagen mit einem Problem auf einem neu aufgesetzten Ubuntu 14.04 Server. Habe Froxlor zuerst per apt installiert und anschließend per Webinterface konfiguriert. Wenn ich nun einen neuen Kunden anlege und versuche mich mit diesem per FTP zu verbinden erhalte ich folgende Fehlermeldung: Status: Verbinde mit [sERVER_IP] Antwort: fzSftp started, protocol_version=5 Befehl: open "[KUNDEN_NAME]@[sERVER_IP]" 22 Befehl: Pass: ********* Fehler: Authentifizierung fehlgeschlagen. Fehler: Kritischer Fehler: Herstellen der Verbindung zum Server fehlgeschlagen auth.log sagt folgendes; h2568842 sshd[15198]: input_userauth_request: invalid user [KUNDEN_NAME][preauth] h2568842 sshd[15198]: pam_unix(sshd:auth): check pass; user unknown h2568842 sshd[15198]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=[MEINE_IP] h2568842 sshd[15198]: Failed password for invalid user [KUNDEN_NAME] from [MEINE_IP] port 39808 ssh2 h2568842 sshd[15198]: error: Received disconnect from [MEINE_IP]: 13: Unable to authenticate [preauth] Kunde wurde ordnungsgemäß in der Froxlor Database unter ftp_users angelegt. Jemand ne Idee wie das Problem gelöst werden kann. MFG
  15. At frist, very nice work oschn0r. But is there any Option that your theme ist also at the Login-Screen and when a new User login he has your theme as default?
×
×
  • Create New...