Jump to content
Froxlor Forum
  • 0

Let's Encrypt Fehlermeldung


lonesomewalker
 Share

Question

13 answers to this question

Recommended Posts

  • 0

Ja, lesen kann ich ja, nur wenn ich mit dig validieren kann, das die DNS-Einträge stimmen und auch auflösen?
Und in der Domaineinstellung selbst ist die IP sowohl für ohne als auch mit auf die gleiche IP gesetzt, die auch im DNS steht. 🤔
Edit: DNS macht auch froxlor, d.h. nix Externes.

Edited by lonesomewalker
Link to comment
Share on other sites

  • 0

Jupp, genau das macht mich ja verrückt 😶 bedeutet ja, DNS geht und froxlor hat auch die korrekte Zuordnung erstellt.
Traurig ist: ich habe NICHTS geändert, und jetzt hat er nach speichern nicht gemeckert -> geht.
An den Cronjobs kann es nicht liegen, die Configs schreibe ich mit einem sofortigen Rewrite von der Konsole aus gestartet neu.

Hmmm, mal debuggen, warum...

Link to comment
Share on other sites

  • 0

Moin allerseits,

der Eintrag ist noch nicht so alt, daher erlaube ich mir, mich dranzuhängen:

@Lonesomewalker: Was kam denn raus dabei? Ich habe aktuell dasselbe Problem wie beschrieben. Ich habe versucht, eine Domain einer anderen PHP-Konfiguration zuzuweisen (ist hier nicht relevant, war nur der Grund, warum ich die Domain neu speichern musste) und nun schimpft Froxlor genau dasselbe:

Fehlermeldung
Die DNS-Einträge der Domain enhalten keine der gewählten IP Adressen. Let's Encrypt Zertifikats-Erstellung ist nicht möglich.

Ich habe noch ein paar andere Domains probiert - überall dieselbe Meldung. Auch jeweils geprüft, ob die verwendete SSL-IP dem dig bzw. nslookup entspricht und ja, das ist immer der Fall.

Die DNS-Einträge der Domains und die Domains in Froxlor wurden ansonsten seit langer Zeit nicht mehr angefasst. Froxlor ist aktuell wie ich hoffe (0.10.33-1 (DB: 202112310)) ...

Unterschied bei mir ist, dass DNS extern definiert ist (bspw. ffmcity.de auf die 195.5.191.48).

Hilft eventuell meine Aussage, dass ich mehrere IPs auf dem Server definiert habe?

Vielen Dank im voraus!

Link to comment
Share on other sites

  • 0

Ich verstehe nicht so recht wo hier das Problem liegt. Die Fehlermeldung sagt eindeutig, dass ein dns check der domain keine IP Adresse ergeben hat, die beim Anlegen/Editieren der Domain ausgewählt wurde.

Stelle also sicher, dass ein "dig domain.tld A" eine IP ausspuckt die du auch in froxlor angelegt hast und der Domain zugewiesen ist.

Somit prüft froxlor, dass das Ausstellen von Let's Encrypt Zertifikaten via Cronjob nicht fehlschlägt weil die Domain nicht auf den Server zeigt.

Link to comment
Share on other sites

  • 0

Hallo d00p,

OK, ich denke, ich verstehe das Problem: Der Froxlor-Server ist ein virtuelles System hinter einer FW in einer DMZ. Die ganzen "Verbindungen" von außen nach innen werden geNATted.

Und irgendwann scheint da eine neue Prüfung dazugekommen zu sein, die dann - wie Du sagst - vorab prüft, ob das DNS passt. Das hat früher wie heute nicht in dem Sinne gepasst, aber Let's Encrypt selbst hatte nie Schwierigkeiten.

Ist das das Problem? Und wenn ja, wie kann ich das "umschiffen"?

Danke! 

Link to comment
Share on other sites

  • 0

Du kannst in den Einstellungen diese Prüfung einfach deaktivieren wenn du sicher bist, dass DNS in jedem Fall passt.

Settings -> SSL Settings -> Validate DNS of domains when using Let's Encrypt

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...