Jump to content
Froxlor Forum

froxlorforum@pilsgenuss.de

Members
  • Content Count

    18
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by froxlorforum@pilsgenuss.de

  1. Ja, Du hast nat├╝rlich recht: Wenn die IPs eingetragen (sind sie), konfiguriert und auch durch die Firewall gelassen werden, sollte das alles funktionieren. Hat es leider nicht. ­čÖé Ich habe die Domain nun auch auf die .71 umgestellt, sie hatte f├╝r sich ein Zertifikat gezogen. Das habe ich ihr nun "weggenommen" (war quatsch - habe es danach wieder gesetzt), sie wieder als Alias f├╝r die andere Domain konfiguriert. Dazwischen immer brav das Skript ablaufen lassen. Wo ich mir nun nicht mehr sicher bin: Muss die Domain ein "eigenes" H├Ąkchen bei "Let's Encrypt" haben (davon gehe ich aus) ode
  2. konnt' es doch nicht lassen: Ganz einfache Sache, denke ich: ich-bin-auch-verschnupft.de hat auf die IP .74 gezeigt, der Rest auf die .71. Ist zwar alles auf demselben Server, mag aber LE wohl nicht ... Na denn.
  3. Habe es hinbekommen: Eine der Alias-Domains ich-bin-auch-verschnupft.de hat vermutlich nicht mehr richtig aufgel├Âst (muss ich noch pr├╝fen). Jedenfalls stand etwas derart in der LE-Verification. Domain als Alias entfernt, neu gestartet und gl├╝cklicherweise war ich bei meinen Versuchen unter der Max-Anzahl Versuche, die man pro Stunde machen darf. Zertifikat erstellt f├╝r die verschnupft.de, die anderen Domains mit im Zert enthalten. Nur eben die eine Alias-Domain nicht. Schaue ich mir Morgen an, dann schreibe ich den Grund. Muss f├╝r heute Schluss machen. Hab M├Ąnnerschnupfen. Nacht
  4. OK, ich probier es so wie Du sagst! Ansonsten bestell ich ein Kauf-Jahreszertifikat und gut. ­čśĽ Danke f├╝r die schnelle Hilfe! ­čÖé
  5. Verflixt, habe im Debug-Modus des Cron-Jobs eine Fehlermeldung gefunden: [Mo 17. Feb 17:58:04 CET 2020] _post_url='https://acme-v02.api.letsencrypt.org/acme/new-nonce' [Mo 17. Feb 17:58:04 CET 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header -g -I ' [Mo 17. Feb 17:58:05 CET 2020] _ret='0' [Mo 17. Feb 17:58:05 CET 2020] POST [Mo 17. Feb 17:58:05 CET 2020] _post_url='https://acme-v02.api.letsencrypt.org/acme/new-order' [Mo 17. Feb 17:58:05 CET 2020] _CURL='curl -L --silent --dump-header /root/.acme.sh/http.header -g ' [Mo 17. Feb 17:58:06 CET 2020] _ret='0' [Mo 17.
  6. Hallo allerseits, ich habe einen Froxlor-Server (aktuelle Version), der auf einer IP .71 ein Wildcard-Zertifikat f├╝r eine Domain *.irgendwas.de laufen hat. Auf dieser IP gibt es au├čer Domains, die eben auf *.irgendwas.de lauten auch noch Domains, die bspw. auf wasanderes.com lauten. Daf├╝r habe ich jeweils Let's Encrypt Zertifikate aktiviert, was auch die letzte Zeit (Monate) soweit funktioniert hat und teilweise auch noch funktioniert. Bei einer Domain allerdings, als Bsp. ichbinverschnupft.de sieht man in Froxlor, dass Let's Encrypt aktiviert ist, Froxlor zieht sich auch brav ein Ze
  7. Moin, der OP hier. Sorry, dass ich mich die ganze Zeit nicht gemeldet habe - gab/ gibt leider schwerwiegende Gr├╝nde. Hat mit Krhs und Koma zu tun. Ist sonst nicht meine Art, mich nicht zu melden. Zur Sache: Ich hatte mir f├╝r's Erste mit dem viel weiter oben beschriebenen Workaround (www-data an Gruppen in /etc/groups) beholfen. Den von mir selbst reingesetzten Link auf einen ├Ąlteren Post hatte ich angesehen, gepr├╝ft, brachte mich aber nicht weiter. Inzwischen wurden 2 Froxlor-Updates reingedr├╝ckt und siehe da, beim heutigen Pr├╝fen stand auf einmal "www-data" mit hinter jedem Ein
  8. Kann es sein, dass mein Problem mit diesem hier identisch ist: Ich lese mir das in Ruhe durch und schaue, ob das passt. Da ging es auch um die ftp_groups
  9. ok. ? aber sonst gibt es definitiv kein "froxlorlocal". Bzw. schon, in ftp_groups: Suchergebnisse f├╝r "froxlorlocal" mindestens eines der W├Ârter: 0 Treffer in cronjobs_run 0 Treffer in domain_dns_entries 0 Treffer in domain_redirect_codes 0 Treffer in domain_ssl_settings 4 Treffer in ftp_groups Anzeigen L├Âschen 0 Treffer in ftp_quotalimits
  10. Anders rum: Kann ich ├╝ber die Datenbank die beiden Eintr├Ąge korrigieren - auf www-data? "system.mod_fcgid_httpuser": "froxlorlocal", "system.mod_fcgid_httpgroup": "froxlorlocal", Ich trau mich mal. Moment.
  11. OK, verstehe. Aber was doch schon bei mir falsch ist: Der "varname" ist nicht httpuser, sondern mod_fcgid_httpuser! Das bedeutet doch vermutlich, dass ich irgendwo eine Checkbox falsch gesetzt habe .. Grunds├Ątzlich habe ich ja genau den httpuser richtig: "system.httpuser": "www-data", "system.httpgroup": "www-data", Kann es sein, dass hier f├Ąlschlich "froxlorlocal" aus dem fcgid gezogen wird? Editieren kann ich das Feld ja nicht ...
  12. ok ... aber: Das hatte ich doch schon gemacht, oder? Das waren vorher genau die drei Zeilen, die ich aus dem Men├╝punkt "Einstellungen" "Import/Export" heruntergeladen habe. Da erzeugt Froxlor eine Datei Froxlor_settings-0.9.40.1-201809280_26.09.2019.json und in der habe ich nach "froxlorlocal" gesucht. Aktuell sind es diese Zeilen hier, nachdem ich das wieder zur├╝ck korrigiert habe: "phpfpm.vhost_httpuser": "froxlorlocal", "phpfpm.vhost_httpgroup": "froxlorlocal", "system.mod_fcgid_httpuser": "froxlorlocal", "system.mod_fcgid_httpgroup": "froxlorlocal", Das entspricht ex
  13. hmm. Verflixt. Ich verstehe - zumindest jetzt. Da stand zun├Ąchst in beiden Feldern "froxlorlocal" drin. Damit lief es nicht (klar). Also dachte ich, ich bin schlau und schreibe den www-data in die Gruppe. Aber: ich habe das alles unter dieser ├ťberschrift verstanden: Verwende PHP-FPM im Froxlor-Vhost Wenn verwendet, wird Froxlor selbst unter einem lokalen Benutzer ausgef├╝hrt Lokaler Benutzer f├╝r PHP-FPM (Froxlor-Vhost) Lokale Gruppe f├╝r PHP-FPM (Froxlor-Vhost)
  14. K├Ânnte es sein, dass "mein Froxlor" schon zu alt ist oder anders: H├Ątte ich die Einstellungen jedes Mal nach einem Upgrade neu machen m├╝ssen (habe schon grob kontrolliert, ob sich da was ge├Ąndert hat)? Sicher bin ich mir nicht, aber ich hatte Debian irgendwann hochgezogen von 8 auf 9 und dadurch (oder war es schon vorher von 7 auf 8 - m├╝sste ich nachsehen) wurde auch der Apache umgestellt. Die Einstellungen hatte ich mir angesehen. Die Umstellung auf php-fpm hatte ich erst vor kurzem vorgenommen, was bedingt gut geklappt hat. Und in diesem Zusammenhang kam auch erst libnss-extrausers dazu
  15. OK. Dann suche ich mal. ? Bei den Froxlor-VHost-Einstellungen steht es drin. Aber das sollte ja nicht zusammenh├Ąngen: "phpfpm.vhost_httpuser": "froxlorlocal", "phpfpm.vhost_httpgroup": "www-data", Das hier sollte nicht relevant sein: "system.mod_fcgid_httpuser": "froxlorlocal", "system.mod_fcgid_httpgroup": "froxlorlocal", Das sind alle Vorkommen von "froxlorlocal" im Download des JSON-Modells der Einstellungen.
  16. Erst einmal vielen Dank f├╝r die Antwort. Und ja, ich gebe zu, ich hatte dann ein paar Dinge als eigene Antwort reingeschrieben, die ich zum einen in der ersten Runde vergessen hatte, zum anderen der Nachvollziehbarkeit halber f├╝r wichtig hielt. Ja, ich nutze libnss-extrausers (sonst funktioniert php-fpm nicht wie gew├╝nscht, wenn ich das richtig verstanden habe). Und auch die Dateien existieren im Verzeichnis /var/lib/extrausers. Aber in der group-Datei steht bei keiner Gruppe "www-data" dabei. Hier die Gruppe "jens" aus dem Beispiel oben: jens:x:10002:jens,froxlorlocal,fro
  17. Als Erg├Ąnzung: Wenn ich das recht sehe, l├Ąuft php-fpm mit genau dem User, dem auch der Socket "geh├Ârt": jens 10844 0.0 0.0 359520 7476 ? S Sep24 0:00 php-fpm: pool bembel.city Und der zugeh├Ârige Logeintrag: [Wed Sep 25 02:13:57.561954 2019] [proxy:error] [pid 11018] (13)Permission denied: AH02454: FCGI: attempt to connect to Unix domain socket /var/lib/apache2/fastcgi/1-jens-bembel.city-php-fpm.socket (*) failed Habe nun versucht, wie hier beschrieben: https://serverfault.com/questions/897691/php-fpm-error-503-attempt-to-connect-to-unix-domain-socke
  18. Hallo allerseits, ich verstehe ein Problem auf meinem Froxlor-Server nicht: Das Grundsystem ist ein Debian 9.11 stable mit Apache 2.4.25, PHP 7.0.33, FPM-FCGI installiert bzw. aktiviert habe. Froxlor ist 0.9.40.1-1+jessie1 (DB: 201809280) laut Dashboard. Ich habe mod_proxy / mod_proxy_fcgi ebenso wie libnss-extrausers aktiviert und konfiguriert (nach Anleitung, hoffe ich). PHP-FPM ist aktiviert, PHP-FCGID ist NICHT aktiviert (l├Ąsst sich nicht aktivieren wegen aktiviertem PHP-FPM - sollte also passen). Das System hatte ich auf PHP-FPM umgestellt, um au├čer der "aktiven"
×
×
  • Create New...