Jump to content
Froxlor Forum
  • 0
schnudeldudel

Unknown Error (not in option): system_phpfpm_defaultini_ownvhost

Question

Hallo zusammen,

habe das Problem: 

"Unknown Error (not in option): system_phpfpm_defaultini_ownvhost"

wenn ich in Froxlor die Froxlor-VHOST Settings ändern will.

Zitat
Serversoftware: Apache
PHP-Version: 5.6.32-1~dotdeb+7.1
MySQL server version: 5.6.19-1~dotdeb.1
Webserver interface: CGI-FCGI
   
Kernel: 3.2.0-4-amd64 (x86_64)
   
Froxlor details
   
Installed version: 0.9.38.7-1+wheezy1 (DB: 201612110)
   

Server ist mit FCGI konfiguriert und läuft seit einigen Jahren.

Habe heute auf Let's Encrypt umgestellt und wollte den FROXLOR Vhost auf auf Let's Encrypt umstellen - leider geht es aufgrund des Fehlers nicht.

Wenn weitere Infos benötigt werden, einfach melden.

Nachtrag: habe in der mysql datenbank im backend die entsprechenden flags von hand gesetzt und den master cron aufgerufen -> dann ging zumindest die erstellung der zertis etc. Fazit: Hier scheint lediglich was im GUI nicht zu stimmen (merkwürdig: Fehlermeldung spricht von FPM - ich habe allerdings auf FCGI konfiguriert...".

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hallo,

leider bekomme ich genau dieselbe Fehlermeldung, ich bin allerdings schon bei 0.9.39.5.
Bei mir ist ebenfalls FCGID eingerichtet.

Eine manuelle Anpassung in der Tabelle hat bei mir ebenfalls geklappt, das LE-Zertifikat wurde erzeugt.
"le_froxlor_enabled" und "le_froxlor_redirect" in der Tabelle "panel_settings", falls jemand anderes auch das Problem haben sollte.

UPDATE: Ich habe das Problem mittlerweile gefunden. Wenn man öfters mal mit verschiedenen PHP-Configs experimentiert und dabei zufällig die PHP-Config mit der ID 2 gelöscht hat, dann will Froxlor beim Speichern den Standardwert 2 setzen für den jeweils nicht ausgewählten PHP-Modus (PCGI <> FPM) (auch wenn in beiden Dropboxen eine andere PHP-Config ausgewählt ist). Also einfach in der Datenbank (Tabelle "Panel_phpconfigs") eine neue Config mit ID 2 anlegen und alles ist gut.

Wäre vielleicht gut, das Löschen der ID 2 zu verhindern.

Viele Grüße
Marc

Edited by Marc
Update

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
    • By FearTheDude
      Folgende Situation:
      Ich betreibe einen vServer mit Froxlor als Hostingpanel
      Der docroot von meinedomain.tld liegt unter /var/customers/webs/meinAccount
      Eine SSL Weiterleitung wurde auf meinedomain.tld eingerichtet
      Kunden verwenden ein paar vorinstallierte tools (Webmailer, DB Frontend, Froxlor Panel) über toolname.meinedomain.tld
      Die Tools liegen nicht im docroot von meinedomain.tld sondern unter /var/www/toolname
      Folgendes Problem:
      Die SSL Weiterleitung von http auf https bei der Hauptdomain meinedomain.tld funktioniert nicht, es sei denn, man verwendet eine der Subdomains für die Tools
      Für meinedomain.tld wird anstatt /var/customers/webs/meinAccount der docroot /var/www verwendet
      Vorübergehende Lösung:
      Die Prüfung, ob mod_rewrite in der NN_froxlor_normal_vhost_meinedomain.tld.conf aktiv ist, entfernen
      <IfModule !mod_rewrite.c> Redirect 301 / https://meinedomain.tld/ </IfModule> Dann findet IMMER ein Redirect auf HTTPS statt, wobei hier auch der richtige docroot geladen wird.
      Nachteil:
      Sobald die Configs neu geschrieben werden, ist die Änderung weg.
      Fragen:
      Kann man die mod_rewrite prüfung für die SSL Weiterleitung irgendwo dauerhaft deaktivieren?
      Warum verwendet der vHost Container für http keinen bzw. den falschen docroot?
      Wie kann ich persistente Änderungen an den .conf Dateien für einen vHost vornehmen?
    • By H4nSolo
      Hallöchen zusammen,
      ich hätte mal eine Frage bezüglich Froxlor und Cloudflare.
       
      Da einige die Froxlor benutzen, bestimmt auch bei cloudflare ihre domain eingetragen haben, stellt sich mir die Frage ob man dies nicht gleich auch mit cloudflare verbinden kann um so seine subdomains / Domains miteinzurichten, ohne sich immer zusätzlich bei cloudflare anzumelden.

      Cloudflare bringt ja von Haus aus eine API mit womit man sich auch über Scripte und einen Authentifikations Key extern anmelden kann.
      Cloudflare API: https://api.cloudflare.com/
       
      Ich für meinen Teil würde es Prima finden wenn zum Beispiel Kunden ihren Login Key eintragen, und damit bequem auch bei erstellung von subdomains gleichzeitig (sofern sie ihre Domain beim Cloudflare registriert haben) alles in einem abwickeltn können.
       
       
      Was haltet ihr von der Idee und könnte man es überhaubt verwirklichen für Froxlor?
       
      lg H4nSolo
    • By UncleSnycs
      Hallo ich hoffe, mir kann jemand helfen. Ich habe eine Subdomain erstellt (phpmyadmin.example.ltd). Dort funktioniert PHP ohne probleme. Auf meiner anderen Subdomain (wi.example.ltd) funktioniert PHP überhaupt nicht und er zeigt mir bei der index.php nur den text an, der in der Datei drin steht. In Der vHost.conf steht, dass php disabled ist. Weiss jemand, wo man das aktivieren kann? Ich finde in der Konfiguration von der Subdomain den Eintrag nicht.
      Vielen Dank schonmal in vorraus.
      Mit freundlichen Grüßen
      UncleSnycs
    • By martinvh
      Hello folks,
      I'm experiencing the following issue: I have create a separate customer account for myself. When I add a subdomain, PHP is disabled in the resulting vHost config. I traced the way down: The customer is PHP enabled, the TLD domain is PHP enabled. I discovered, if I just open and re-save the TLD settings page for the specific domain from the admins account after creating the subdomain in the customer account, the "phpenabled" flag gets updated correctly in the database. Which setting am I missing to realise the behaviour without this workaround?
×
×
  • Create New...