Jump to content
Froxlor Forum
  • 0
martinvh

vHost with disabled PHP engine

Question

martinvh    0

Hello folks,

I'm experiencing the following issue: I have create a separate customer account for myself. When I add a subdomain, PHP is disabled in the resulting vHost config. I traced the way down: The customer is PHP enabled, the TLD domain is PHP enabled. I discovered, if I just open and re-save the TLD settings page for the specific domain from the admins account after creating the subdomain in the customer account, the "phpenabled" flag gets updated correctly in the database. Which setting am I missing to realise the behaviour without this workaround?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By j4mb4l4j4
      Hi, ich hätte mal eine simple Frage zum Thema Redirects.
      Wir möchten gerne folgende Redirects für eine Domain einrichten (siehe Screenshot für korrektest Beispiel aus dem Internet):
      http://www.domain.de   (301)   ->   https://domain.de https://www.domain.de (301)   ->   https://domain.de http://domain.de             (301)   ->   https://domain.de https://domain.de           (301)   ->   kein redirect Könnten wir dies im Froxlor Panel einstellen oder ist es hierzu erforderlich das wir die vHosts Configs der einzelnen Domains/Subdomains mit einer manuellen Config erweitern die die gewünschten Redirects aufweist ?
      Manuell würde ja bedeuten, dass Froxlor die Config nach 15min überschreibt.
      Können wir dies permanent hinzufügen oder gar im Panel ?
      Ich denke im worse Case dann über .htaccess oder ?
      Gerne würde ich natürlich im vHost anfangen statt in der unteren Ebene (.htaccess).
       
      Vielen Dank schon mal im Voraus.

    • By themrdomi
      Hallo liebes Froxlor Team,
      ich nutze Froxlor sehr gerne und finde es super, aber wieso gibt es 2017 noch nicht die Möglichkeit mehrere Domains mit einer IP Adresse zu nutzen?
      Das ist ja wirklich nicht so schwer.
      Ich habe jetzt halt provisorisch in jeder Domain einen Custom vhost eintrag hinzugefügt aber das ist eigentlich keine richtige Lösung.
      Es sollte wirklich nicht viel Aufwand sein, diese Option dem Panel hinzuzufügen...
       
      Gruß,
    • By Andreas
      Hallo zusammen,
      ich habe Probleme mit diversen SEO-/Webseiten-Anlayse-Tools, die beim Crawlen der Domain einen SSL Handshake Failure bekommen. Wir haben den Verdacht, dass diese Tools eventuell SNI nicht beherrschen und haben daher testweise eine Domain mit eigener IP auf einem vHost mit entsprechendem SSL-Zertifikat installiert. Die Domains laufen über den Browser fehlerfrei, die Tools machen allerdings Probleme. Ein SSL-Test via https://www.ssllabs.com/ssltest/ hat nun ergeben, dass auf dem vHost neben dem Domainzertifikat auch noch das Serverzertifikat ausgegeben wird.
      Wie kann ich die Domain bzw. den vHost in Froxlor so konfigurieren, so dass auf dem vHost nur das Zertifkat des entsprechenden vHosts ausgegeben wird?
      Danke schonmal für euere Hilfe.
    • By irisdina
      Hier mal ein kleines TUT wie man Froxlor mit NGINX (inkl. HTTP2), MARIADB und PHP7/1.0 betreibt.
      Ausgehend von Debian (9) Stretch
      Debian Stretch ist der neuste Stable rel. aber leider sind einige Sachen schon wieder veraltet bzw. alte Repos vorhanden, in den Debian Repos. Bsp. Nginx und MARIADB daher braucht man einige Sources wo man neuere Repos. Pakete bekommt.
      1. apt install curl wget apt-transport-https dirmngr subversion git
      2. Keys laden
      wget http://www.deb-multimedia.org/pool/main/d/deb-multimedia-keyring/deb-multimedia-keyring_2016.8.1_all.deb && dpkg -i deb-multimedia-keyring_2016.8.1_all.deb && wget https://nginx.org/keys/nginx_signing.key && apt-key add nginx_signing.key && apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0xF1656F24C74CD1D8
      3. Debian Stretch Source.list (/etc/apt/sources.list)
       
      4. apt-get update && apt-get dist-upgrade && apt-get autoclean
      Sollte Punkt 4 keine Fehler angezegt haben, fangen wir mit der Installation von MariaDB an.
      5. apt install mariadb-server mariadb-client

      Wärend der Installation werdet ihr nach dem Setzen den MySQL-Root PW's gefragt.


      nun sollte MariaDB installiert sein:
      mit mysql --version könnt ihr die version prüfen.

      und nun können wir NGINX installieren. In Debian Stretch wird version 11.9 von NGINX ausgeliefert, wir wollen aber mindestens vers. 1.12+ haben, weil da einige Fixes dabei sind.
      6. NGINX
      apt-get install nginx

      mit nginx -v können wir die version überprüfen.

      6.1 
      mkdir /etc/nginx/sites-available
      mkdir /etc/nginx/sites-enabled
      6.2
      Wenn man NGINX direkt von nginx.org per Repo bezieht, wird nur eine sehr minimale Struktur installiert, daher müssen wir da noch etwas Hand anlegen.
      Als erstes nehmen wir uns die nginx.conf (/etc/nginx/nginx.conf) vor mit nano /etc/nginx/nginx.conf wenn man den Editor nano nicht benutzen möchte kann man auch Vi oder dass Programm WinSCP benutzen

      wir löschen den ganzen inhalt und fügen dies ein
      und Speichern den inhalt und Prüfen kurz die nginx.conf mit nginx -t

      NGINX ist nun bereit und wir gehen über zu PHP.
       
      7. PHP 7.0 Installieren
      Ohne PHP geht gar nichts mit dem Webserver, daher müssen wir jetzt einige Pakete installieren.

      Prüfen wir hier auch die kurz die vers. von PHP mit php -v

      jetzt starten wir kurz mal NGINX und PHP7.0-FPM neu mit
      service nginx restart
      service php7.0-fpm restart
      Sollten die zwei services ohne Probleme neu gestartet sein, prüfen wir kurz per Browser ob unser Webserver richtig läuft.
      Dazu nehmen wir einen Browser und rufen per IP oder Domain unseren Server auf und bekommen eine schöne Meldung, wenn alles läuft wie es soll.

      8. Jetzt können wir Froxlor installieren.
      8.1 Als erstes sollten wir einen separaten vhost für Froxlor anlegen und nicht direkt per IP aufrufen.
      Dazu benutzen wir jetzt nano (oder einen anderen Editor deiner Wahl: siehe Punkt 6.2)
      nano /etc/nginx/sites-enabled/frox
      und fügen diesen inhalt ein
      Wie ihr seht, benutze ich php7.0-fpm.sock anstatt php-fcgi (127.0.0.1:8888) dazu aber gleich mehr
      und Speichere die Datei und überprüfen mit nginx -t ob alles OK ist, falls Ja starten wir den Server mit service nginx restart neu.
      8.3 Nun wechseln wir ein passenden Verzeichnis wo wir Froxlor hin haben wollen. als Bsp. habe ich jetzt /usr/share/nginx/ genommen.
      cd /usr/share/nginx/ und laden Froxlor per git (von GitHub) herunter. 
      dazu geben wir ein git clone https://github.com/Froxlor/Froxlor.git

      (Empfehlung den Froxlor Ordner immer umbennen bsp. per mv /usr/share/nginx/Froxlor /usr/share/nginx/dein wunsch name)
       
      8.4  Jetzt können wir Froxlor mit der http://www.SubDomain/dein frox verz./ (die wir dafür eingerichtet haben aufrufen)

       
      Sollte keine Fehler anzeigen gehen wir zum nächsten Schritt.
      Und geb deine Daten ein. (Ändert auch den Datenbank Name und den Benutzer für die Froxlor SQL)

      Und klicken auf Installation fortführen. (Meistens kommt jetzt die Meldung dass die userdata.inc.php nicht im /lib/ verzeichnis gespeichert werden konnte sondern im /tmp/ verzeichnis, daher müssen wir diese kurz verschieben.
      mv /tmp/userdata.inc.php /usr/share/nginx/euer froxlor verz./lib/
      solltet ihr die Datei verschoben haben, login wir uns nun in Froxlor ein und fangen an es einzurichten (ich zeige jetzt nur wenige dinge!)
      Wichtig:
      Jetzt sollten wir auch die Vhost Datei wieder löschen mit rm /etc/nginx/site-enable/frox aber nginx noch nicht neu Starten, dies macht Froxlor gleich von selbst. 
      (Hat den Hintergrund, das Froxlor gleich seine eigene Vhost conf erstellt und dies dann mit unseren Probleme macht und nginx nicht startet)
       
      8.5 Da wir php7.0-fpm benutzen müssen wir in den Einstellungen etwas ändern:
      Einstellungen => NGINX Einstellungen und gehen runter zu Nginx-PHP-Backend hier steht drin: 127.0.0.1:8888 dies ändern wir jetzt zu: unix:/run/php/php7.0-fpm.sock und klickt danach auf Speichern.

      Dies hat den Hintergrund da wir keine php-fcgi Datei brauchen/wollen.
       
      8.6 Jetzt erstellen wir kurz die cronjob Datei für Froxlor, dazu gehen wir
      Konfiguration » Debian Jessie (8.x) » Sonstige (System) » Cronjob for froxlor 
      und befolgt dort die Anweisungen. (in den jeweiligen Zeilen steht (/usr/bin/nano xxxxx es reicht wenn ihr nur nano xxxx) ein gebt bzw. dann geht dies auch nur mit dem Editor.
       
      Anmerkung:
      Falls ihr in Konfiguration » Debian Jessie (8.x) » Webserver (HTTP) » nginx reingeht braucht ihr 98% der Texte dort nicht zu beachten, weil diese nicht benötigt werden.
      Ihr braucht nur diesen Block (der letzte)
      und ggf. den für die acme.conf (Falls ihr SSL benutzt) zu beachten, den Rest braucht ihr nicht!
       
      Hoffe diese kleine Anleitung hilft euch weiter, bei fragen einfach melden


×