Jump to content
Froxlor Forum
  • 0
v3ng

AH00543: apache2: bad user name

Question

Hallo,

 

Ich wei?, dass dieses Thema hier schon 100x aufgeriffen wurde, jedoch habe ich bisher in keiner der Topics eine L?sung gefunden. 

Folgendes Problem, nach dem erstellen eines neuen Kunden und einem ausf?hren des Cronjobs bekomme ich folgende Meldung: AH00543: apache2: bad user name "Kunde"

Auf dem Server l?uft FCGID unter Debian 8. 
Libnss ist selbstverst?ndlich nach Konifgurationshinweisen aus dem Panel eingerichtet.

Sowohl Apache, MySQL als auch NSCD laufen und wurden auch in der richtigen Reihenfolge gestartet:

MySQL> NSCD > Apache

 

Der Log von sagt nichts.

 

Eine Idee? 

Danke und Gr??e

Share this post


Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 0


root@dev:/etc/apache2# grep -r Testa *

htpasswd/1-0c7f9614745a5e4ad1dcdc4a9879d8c1.htpasswd:Testa:c3DRU5qw1XoLY

sites-enabled/40_froxlor_diroption_0c7f9614745a5e4ad1dcdc4a9879d8c1.conf:<Directory "/var/customers/webs/Testa/webalizer/">

sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf:# 28_froxlor_normal_vhost_Testa.dev.firez.de.conf

sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf:# Domain ID: 1 - CustomerID: 1 - CustomerLogin: Testa

sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: ServerName Testa.dev.firez.de

sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: ServerAlias *.Testa.dev.firez.de

sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: DocumentRoot "/var/customers/webs/Testa/"

sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: SuexecUserGroup "Testa" "Testa"

sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: <Directory "/var/customers/webs/Testa/">

sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: FcgidWrapper /var/www/php-fcgi-scripts/Testa/Testa.dev.firez.de/php-fcgi-starter .php

sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: ErrorLog "/var/customers/logs/Testa-error.log"

sites-enabled/28_froxlor_normal_vhost_Testa.dev.firez.de.conf: CustomLog "/var/customers/logs/Testa-access.log" combined

 

Share this post


Link to post
Share on other sites
  • 0

Frohe Weihnachten!

 

root@dev:/etc/apache2# grep -r Testa *

 

Nein, du musst den Begriff/ die Zeichenfolge eingeben, die in der Fehlermeldung des Apache steht.

bad user name "Kunde"

In dem Fall also Kunde.
 
Dann findest du alle Dateien, in denen die Zeichenfolge vorkommt, und kannst so sehen, welche das Problem verursachen. Danach musst du gucken, wie oder wodurch das Problem entsteht/ entstanden ist, und es beseitigen/ korrigieren.

Share this post


Link to post
Share on other sites
  • 0

Hi, bei jedem neu erstellen Kunden tritt das Problem auf, "Testa" ist ein gerade neu erstellter. 

Gr??e und Frohes Fest

Share this post


Link to post
Share on other sites
  • 0

Ja, schon klar.

Es gibt da irgendwo in deinen Apache Configs irgendeine (oder mehrere), wo 'Kunde' drin steht. Und 'Kunde' ist kein g?ltiger User auf deinem System.

Du musst die Datei(en) finden, wo das drinsteht und dann analysieren, wieso weshalb warum das da steht und den/ die Fehler korrigieren.

 

Viel Erfolg!

Share this post


Link to post
Share on other sites
  • 0


root@dev:~# getent passwd Kunde

Kunde:x:10010:10010:Froxlor Customer:/var/customers/webs/Kunde/:/bin/false

 

Share this post


Link to post
Share on other sites
  • 0

Aha. Du hast den Kunden 'Kunde' genannt? Was hast du bei dem f?r Einstellungen in Froxlor? Insbesondere beim Heimatverzeichnis? Kontrolliere das mal und berichtige das gegebenenfalls.

Oder poste uns mal deine entsprechenden Einstellungen und guck' auch auf dem Server, ob die angegebenen Verzeichnisse auch existieren (und die korrekten Eigent?mer/ Gruppe und Berechtigungen haben).

Share this post


Link to post
Share on other sites
  • 0

Die L?sung war es, den "passwd" cache von NSCD zu deaktivieren.

Die nscd.conf habe ich demensprechend angepasst:

#
# /etc/nscd.conf
#
# An example Name Service Cache config file.  This file is needed by nscd.
#
# Legal entries are:
#
#	logfile			<file>
#	debug-level		<level>
#	threads			<initial #threads to use>
#	max-threads		<maximum #threads to use>
#	server-user             <user to run server as instead of root>
#		server-user is ignored if nscd is started with -S parameters
#       stat-user               <user who is allowed to request statistics>
#	reload-count		unlimited|<number>
#	paranoia		<yes|no>
#	restart-interval	<time in seconds>
#
#       enable-cache		<service> <yes|no>
#	positive-time-to-live	<service> <time in seconds>
#	negative-time-to-live   <service> <time in seconds>
#       suggested-size		<service> <prime number>
#	check-files		<service> <yes|no>
#	persistent		<service> <yes|no>
#	shared			<service> <yes|no>
#	max-db-size		<service> <number bytes>
#	auto-propagate		<service> <yes|no>
#
# Currently supported cache names (services): passwd, group, hosts, services
#


	logfile			/var/log/nscd.log
#	threads			4
#	max-threads		32
#	server-user		nobody
#	stat-user		somebody
	debug-level		1
#	reload-count		5
	paranoia		yes
#	restart-interval	3600

	enable-cache		passwd		no
	positive-time-to-live	passwd		100
	negative-time-to-live	passwd		20
	suggested-size		passwd		211
	check-files		passwd		yes
	persistent		passwd		yes
	shared			passwd		yes
	max-db-size		passwd		33554432
	auto-propagate		passwd		yes

	enable-cache		group		no
	positive-time-to-live	group		100
	negative-time-to-live	group		60
	suggested-size		group		211
	check-files		group		yes
	persistent		group		yes
	shared			group		yes
	max-db-size		group		33554432
	auto-propagate		group		yes

	enable-cache		hosts		yes
	positive-time-to-live	hosts		3600
	negative-time-to-live	hosts		20
	suggested-size		hosts		211
	check-files		hosts		yes
	persistent		hosts		yes
	shared			hosts		yes
	max-db-size		hosts		33554432

	enable-cache		services	yes
	positive-time-to-live	services	28800
	negative-time-to-live	services	20
	suggested-size		services	211
	check-files		services	yes
	persistent		services	yes
	shared			services	yes
	max-db-size		services	33554432

	enable-cache		netgroup	yes
	positive-time-to-live	netgroup	28800
	negative-time-to-live	netgroup	20
	suggested-size		netgroup	211
	check-files		netgroup	yes
	persistent		netgroup	yes
	shared			netgroup	yes
	max-db-size		netgroup	33554432

Hier der NSCD Log, der mich zu der L?sung brachte:

http://pastebin.com/bhGy0GS6

 

Eventuell k?nnte man das so in die config Templates einbauen, damit der Fehler in zukunft vermieden werden kann?

Share this post


Link to post
Share on other sites
  • 0

Nat?rlich, libnss-mysql-bg ist nach Template konfiguriert und installiert. 

Das Problem wurde durch den oben genannten Fix ja gel?st :)

Share this post


Link to post
Share on other sites
  • 0

Das Problem wurde durch den oben genannten Fix ja gel?st :)

Das mag ja sein, aber ich habe das Problem nicht (nie gehabt) und an den Standardeinstellungen in der nscd.conf nie etwas ge?ndert, also ist bei mir auch der Cache aktiviert.

Share this post


Link to post
Share on other sites
  • 0

Ja, und das legt doch die Vermutung nahe, dass auf dem betreffenden System irgendetwas "schief" gelaufen ist, was du jetzt mehr oder weniger "zuf?llig" durch das ?ndern der nscd.conf beseitigt hast. Ich hab' aber selber viel zu wenig Ahnung, um auch nur den Hauch einer Idee zu haben, was da schief gelaufen sein k?nnte.

Share this post


Link to post
Share on other sites
  • 0

Das ist ein komplett frisches Debian 8 minimal System. Es wurde 2 mal Neuinstalliert und jedes Mal trat der Fehler auf, welchen ich nun aber scheinbar beheben konnte. 

Das mir ein Fehler unterlaufen ist glaube ich eher nicht, da ich mich 1:1 an die Templates gehalten habe und es nicht das erste System ist, welches ich installiere. 

Dennoch habe auch ich zu wenig Ahnung um genaues sagen zu k?nnen, wieso das jetzt genau auf dem Server auftritt.

Share this post


Link to post
Share on other sites
  • 0

Dann warten wir mal ab, ob d00p eine Idee hat? ;)

Hast du auf den anderen Systemen, wo der Fehler nicht auftrat/ auftritt, auch schon Debian 8, oder ist das der erste mit Jessie?

Share this post


Link to post
Share on other sites
  • 0

Ja, es laufen auch 2 andere mit Debian jesse. 

d00p ist dieses Jahr wohl nichtmehr am Rechner, daher m?ssen wir uns wohl gedulden :) 

Share this post


Link to post
Share on other sites
  • 0

cache weglassen geht nat?rlich...ist zwar nicht sinn der nscd geschichte, aber wenns warum-auch-immer anders nicht geht ist das meiner meinung nach eine akzeptable l?sung

Share this post


Link to post
Share on other sites
  • 0

Jetzt tritt aber immer wieder folgendes Problem auf 

Dec 29 13:38:59 srv apache2: libnss-mysql: mysql_query failed: Lost connection to MySQL server during query, trying again (2)
Dec 29 13:38:59 srv apache2: libnss-mysql: Connection to server '127.0.0.1' failed: Can't connect to MySQL server on '127.0.0.1' (111)

Nach einem Restart der Dienste in der richtigen Reihenfolge (MySQL>NSCD>Apache) funktioniert es wieder f?r kurze Zeit, dann aber wieder das selbe Ergebnis

Share this post


Link to post
Share on other sites
  • 0

Ich habe den passwd cache nun wieder aktiviert. Auff?lig ist nun aber folgendes, ich restarte MySQL, NSCD und anschlie?end Apache (also in der korrekten Reihenfolge) aber dennoch m?chte sich libnss garnichtmehr mit MySQL verbinden:

libnss-mysql: Connection to server '127.0.0.1' failed: Can't connect to MySQL server on '127.0.0.1' (111)

Erscheint unteranderem bei der Abfrage des MySQL Status.

 

 

Wiederum merkw?rdig ist, dass ein gerade erstellter Kunde nach zweimaligem manuellen ausf?hrens des Crons scheinbar richtig angelegt wurde. Beim ersten Ausf?hren kam die erwartete Meldung "bad username" beim zweiten Ausf?hren ging es. ( libnss ist dennoch weiterhin ohne MySQL Verbindung)

root@srv:~# getent passwd Kunde
kle:x:10009:10009:Froxlor Customer:/var/customers/webs/kle/:/bin/false

?ber Hilfe bin ich sehr dankbar, ggfls lasse ich dem Helfer auch eine kleine Spende zukommen.

Guten Rutsch!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Keon
      Hallo alle miteinander,
       
      ich bin derweil dabei mir Froxlor auf einem CentOS7 System zum laufen zu bringen. Hier mal kurz ein kleiner Überblick wie ich aktuell stehe:
      SSH Port ändern, sudo User, NTP, EPEL Release, FirewallD für http, https, ssh mit neuem Port frei, fail2ban für SSH Apache, MariaDB, PHPMyAdmin, mod_ssl inkl. config und self signed cert, Froxlor Grundinstallation, Webserver und SSL Einstellungen Admin Menü, (Pfade, reload Script etc.) IP/Port 443 hinzugefügt, Konfiguration -> CentOS -> sonstiges -> cronjob for froxlor Ebenso habe ich - auch wenn unter "Konfiguration" für "CentOS" nicht vorhanden, die acme.conf angelegt  
      Kommen wir zur Frage:
      Wie bekomme ich hin, dass ich folgende Einstellung setzen kann:
       
      Habe ich noch etwas vergessen? Etwas grundlegendes? Bin normalerweise seit Debian Etch bis Jessie gewöhnt - sammle grad die ersten Erfahrungen mit Froxlor & CentOS nach 2 Jahren Pause aus der Informatik.
       
      Beste Grüße
    • By Kyle Willets
      I looked around and like my last question the directory on Centos 7 is different then the configuration in
      RHEL / CentOS (7) »  Webserver (HTTP) »  Apache 2.4
      I see that ofcourse my apache 2 is installed in httpd and I am searching, but no /etc/apache2/conf-enabled/acme.conf. I did see the first command created the var folders fine for customers, but the others all failed: 
      [root@s128426 ~]# nano /etc/httpd/conf/httpd.conf
      [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/
      chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/
      chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/
      chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/
      chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
       
      When I search httpd these directories do not exist within it. Is there a separate install  for apache for Froxlor or something I am missing? I am really thinking about going to debian, but my dedicated host does not offer debian stretch at the moment so went centos being I knew it was the most up to date right now in their list.
       

       
    • By wwl
      Hallo, ich hab heute noch eine 2. Frage:
      Ich hab vor einiger Zeit http/2 auf meinem Apachen eingerichtet. Jetzt habe die Beobachtung gemacht das seit dem aktivieren der http/2 Version auf meinem Apache nur sehr wehnige Anfrage auch in http2 abgearbeitet werden. Wenn ich am Firefox nachschaue (Addon http2 indicator) wird für eine webseite auf meinem Server http2 erkannt. Aber im Log steht das er trotzdem http/1.1 verwendet. Muss ich den Webseiten (TYPO3,WP,Joomla) noch sagen das sie auch über http/2 abgerufen werden können?
      Im apache2.conf File
      Protocols h2 h2c http/1.1
      H2Push          on
      H2PushPriority  *                       after
      H2PushPriority  text/css                before
      H2PushPriority  image/jpeg              after   32
      H2PushPriority  image/png               after   32
      H2PushPriority  application/javascript  interleaved

      Besten Dank für Tipps
      Christian
    • By Developer
      Hallo zusammen,
      ich habe ein Problem mit Froxlor, bzw. dessen Erreichbarkeit. Ich habe auf meinem Root-Server Debian 8.9 (Jessie) laufen und dort Froxlor installiert. Froxlor liegt in /var/www/froxlor/. Problem ist nun, dass diese Adresse von meinem Apache anscheinend nie abgerufen wird. Der Server-Name domain1.de und noch eine weitere Domain domain2.de die beide ihre eigenen Customers in /var/customers/webs/ haben funktionieren problemlos. Als Workaround habe ich versucht /var/www/froxlor in das webs Verzeichnis eines Customers zu symlinken, dann bekomme ich allerdings folgenden php-Error:
      [Wed Nov 29 10:47:43.392017 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Warning: Unknown: open_basedir restriction in effect. File(/var/www/froxlor/index.php) is not within the allowed path(s): (/var/customers/webs/johannes:/tmp) in Unknown on line 0 [Wed Nov 29 10:47:43.392110 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Warning: Unknown: failed to open stream: Operation not permitted in Unknown on line 0 [Wed Nov 29 10:47:43.392127 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Fatal error: Unknown: Failed opening required '/var/customers/webs/johannes/froxlor/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0 Ich habe außerdem festgestellt, dass die beiden vhosts 10_froxlor_ipandport_x.x.x.x.433.conf und 10_froxlor_ipandport_x.x.x.x.80.conf komplett leer von froxlor erzeugt werden. Nur der Header ist drin:
      # 10_froxlor_ipandport_x.x.x.x.443.conf # Created 28.11.2017 16:55 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Also kann mir jedemand hier helfen, wie ich froxlor wieder erreichbar machen kann?
      Viele Grüße und schonmal vielen Dank,
      Johannes
    • By NitroxydeX
      Hallo Community und Staff,
      bezüglich eines Serverwechsel stande nun auch eine Änderung des Control Panels an, da unser bisher genutztes einfach zu wenig geupdatet wurde und Fehler selbst gefixt werden mussten.
      Es blieb eigentlich nur Froxlor übrig. Allerdings haben wir nun feststellen müssen, dass man bei Froxlor nicht die Möglichkeit hat den Datenbanknamen und Nutzer frei zu wählen, was viele als hohes Sicherheitsrisiko werten. Warum ist dies so gewählt? Und gibt es bereits jetzt schon eine Möglichkeit das zu aktivieren?
      Zum anderen Problem: Froxlor scheint magisch alles abzufangen. Bislang hatte ich Apache so konfiguriert, dass alle nicht vorhanden Vhosts ins 403-Forbidden Nirvana gesendet werden. Gleiche Konfiguration habe ich nun auch mit Froxlor versucht und mein Abfangen als 01-beginnende Apache config hinterlegt. Dies fängt auch direkte Aufrufe der IP ab, allerdings funktioniert dies weder mit der IP noch mit nicht angelegten (Sub)-Domains. Es wird immer automatisch auf den FQDN des Panels umgeleitet, was eigentlich gar nicht möglich sein sollte. 
       
      Vielen Dank schon mal für die Antworten
×
×
  • Create New...