Jump to content
Froxlor Forum

Keon

Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Keon

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hallo Zusammen, ich habe gerade ein Debian Server aufgesetzt und bin dort wie folgt vorgegangen: https://docs.google.com/document/d/1bLq-HMzexNIqNpsq6PtAbodwBEaH6YhHTAKtWLhuTc4/edit?usp=sharing Anschließend habe ich meine Konfigurationen wie folgt eingestellt: https://imgur.com/a/b3TMLcM Könnte mir eventuell jemand verraten ob ich soweit erst einmal alles richtig konfiguriert habe und vorbereitet habe für den Cronjob sobald er drin ist bzw. ob sich irgendwo Fehler eingeschlichen haben? Ich hatte das Problem, dass sobald ich mit diesen Einstellungen und Vorgehensweise in der Shell einen 503 auf meine Hauptseite ohne Inhalt bekommen habe und einen 404 auf Froxlor - und ich verstehe nicht woran es liegt, da in den logs keinerlei Fehler, Warnungen oder sonstiges ersichtlich waren. Würde mich über eure Unterstützung freuen. Beste Grüße
  2. old topic - but i got the same issue.
  3. Nabend, gibt es hier zufällig die ein oder anderen die Interesse daran hätten. gemeinsam nach und nach. eine strukturierte Wiki über Konfigurationen und Installationen in Verbindung mit einem Froxlor CentOS7 System zu schaffen? Ich selbst arbeite mich aktuell erst einigermaßen in CentOS7 ein (Umstieg von Debian). Ich habe das Handbuch/die Wiki bisher einfach mit meiner eigenen Konfiguration mitgeschrieben. Würde mich über Ergänzungen freuen. https://docs.google.com/document/d/1Uk7qBRHk1876E3rK7FwoEQHnxv7PoLFIGeX8LpkaS78/edit?usp=sharing Beste Grüße
  4. Da setzt man schon alle Einstellungen und übersieht den Haken zu setzen...*schäm* Dann gehts direkt weiter...^^ Das ganze ist jetzt unter Einstellungen -> SSL -> Lets Encrypt aktiviert, ebenso wie oben genannt und den cronjob hab ich abgewartet. Jedoch wird immer noch das selbst signierte Zertifikat verwendet. Ich könnte mir vorstellen, da ich das Zertifikat unter /etc/httpd/conf.d/ssl.conf so konfiguriert habe? Aber wo hat LE dann jetzt das für den Host erstellte Zertifikat hingeschmissen, damit ich die Settings anpassen kann? (Habe auch noch unter Einstellungen -> SSL Einstellungen -> Pfad zum SSL Zertifikat/Private Key das self signed Zertifikat stehen.
  5. SSL ist in Froxlor durchaus aktiviert, mod_ssl läuft auch (inkl. Firewall Konfiguration) und das selbst signierte Zertifikat funktioniert auch. (Zwar wie erwartet mit Datenschutz-Warnung aber funktioniert) Jetzt wollte ich LetsEncrypt ein ordentliches Zertifikat erstellen lassen für den Host - Option lässt sich nur nicht anwählen.
  6. Hallo alle miteinander, ich bin derweil dabei mir Froxlor auf einem CentOS7 System zum laufen zu bringen. Hier mal kurz ein kleiner Überblick wie ich aktuell stehe: SSH Port ändern, sudo User, NTP, EPEL Release, FirewallD für http, https, ssh mit neuem Port frei, fail2ban für SSH Apache, MariaDB, PHPMyAdmin, mod_ssl inkl. config und self signed cert, Froxlor Grundinstallation, Webserver und SSL Einstellungen Admin Menü, (Pfade, reload Script etc.) IP/Port 443 hinzugefügt, Konfiguration -> CentOS -> sonstiges -> cronjob for froxlor Ebenso habe ich - auch wenn unter "Konfiguration" für "CentOS" nicht vorhanden, die acme.conf angelegt Kommen wir zur Frage: Wie bekomme ich hin, dass ich folgende Einstellung setzen kann: Habe ich noch etwas vergessen? Etwas grundlegendes? Bin normalerweise seit Debian Etch bis Jessie gewöhnt - sammle grad die ersten Erfahrungen mit Froxlor & CentOS nach 2 Jahren Pause aus der Informatik. Beste Grüße
  7. Vielen Dank für den Überblick. :)
  8. Schönen guten Abend, ich wollte einfach mal über den scheinbar kürzesten Weg in Erfahrung bringen wie die Kompatibilität von Froxlor zu CentOS (7) steht? Beispielsweise mit LetsEncrypt, den Konfigurationsvorlagen und vor allem die Zusammenarbeit mit Apache. Während der Konfiguration ist mir nur aufgefallen, dass z.B. gewisse Ordnerstrukturen oder Dateien nicht so sind, wie in den Konfigurationsbeispielen verwendet bzw. die Standard Werte der kompletten Einstellungen sind sehr auf Debian eingenordet. Auf den ersten Blick wäre es nicht schwer es irgendwie mit CentOS (7) in Einklang zu bringen doch mich würde da interessieren wie die Entwicklung in Richtung CentOS denkt? Beste Grüße
×
×
  • Create New...