Jump to content
Froxlor Forum

Kyle Willets

Members
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Kyle Willets

  • Rank
    Newbie
  1. Kyle Willets

    Apache on Centos 7 no Acme

    I looked around and like my last question the directory on Centos 7 is different then the configuration in RHEL / CentOS (7) » Webserver (HTTP) » Apache 2.4 I see that ofcourse my apache 2 is installed in httpd and I am searching, but no /etc/apache2/conf-enabled/acme.conf. I did see the first command created the var folders fine for customers, but the others all failed: [root@s128426 ~]# nano /etc/httpd/conf/httpd.conf [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/ chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/ chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/ chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/ chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory When I search httpd these directories do not exist within it. Is there a separate install for apache for Froxlor or something I am missing? I am really thinking about going to debian, but my dedicated host does not offer debian stretch at the moment so went centos being I knew it was the most up to date right now in their list.
  2. Kyle Willets

    Pro FTP no directory and Lets Encrypt SSL

    I fixed it 0.0 had to re update my hosts file with the IP and the domain LOL I need more coffee.
  3. Kyle Willets

    Pro FTP no directory and Lets Encrypt SSL

    Now I ran into this issue Job for proftpd.service failed because the control process exited with error code. See "systemctl status proftpd.service" and "journalctl -xe" for details. after these steps: [root@s128426 ~]# chmod 0600 "/etc/proftpd.conf" [root@s128426 ~]# chown root:0 "/etc/proftpd.conf" [root@s128426 ~]# systemctl enable proftpd.service [root@s128426 ~]# systemctl reload-or-restart proftpd.service Job for proftpd.service failed because the control process exited with error code. See "systemctl status proftpd.service" and "journalctl -xe" for details. [root@s128426 ~]#
  4. Kyle Willets

    Pro FTP no directory and Lets Encrypt SSL

    That is good to know Thank you! If you knew how long I have been searching over Google since last night. Now to figure thi SSl stuff out. I am so used to CPanel and everything being there so slowly learning
  5. ================================================================================================================= Package Arch Version Repository Size ================================================================================================================= Reinstalling: proftpd x86_64 1.3.5e-4.el7 epel 3.7 M proftpd-mysql x86_64 1.3.5e-4.el7 epel 50 k Transaction Summary ================================================================================================================= Reinstall 2 Packages Total download size: 3.7 M Installed size: 9.7 M Is this ok [y/d/N]: y Downloading packages: (1/2): proftpd-1.3.5e-4.el7.x86_64.rpm | 3.7 MB 00:00:00 (2/2): proftpd-mysql-1.3.5e-4.el7.x86_64.rpm | 50 kB 00:00:00 ----------------------------------------------------------------------------------------------------------------- Total 4.0 MB/s | 3.7 MB 00:00:00 Running transaction check Running transaction test Transaction test succeeded Running transaction Installing : proftpd-1.3.5e-4.el7.x86_64 1/2 Installing : proftpd-mysql-1.3.5e-4.el7.x86_64 2/2 Verifying : proftpd-mysql-1.3.5e-4.el7.x86_64 1/2 Verifying : proftpd-1.3.5e-4.el7.x86_64 2/2 Installed: proftpd.x86_64 0:1.3.5e-4.el7 proftpd-mysql.x86_64 0:1.3.5e-4.el7 Complete! [root@s128426 ~]# mv "/etc/proftpd/proftpd.conf" "/etc/proftpd/proftpd.conf.frx.bak" mv: cannot stat ‘/etc/proftpd/proftpd.conf’: No such file or directory [root@s128426 ~]# ^C [root@s128426 ~]# cd /etc/proftpd/ -bash: cd: /etc/proftpd/: No such file or directory I am unable to setup ProFTP. I am using the latest version of Centos 7 and PHP 7. It says it installed, but yeah as ya can see. With the SSL it says to config something but does nto say what. So was wondering if anyone had any tips on how to get Lets Encypt working properly. Thank You.
×