Jump to content
Froxlor Forum

Developer

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Developer

  • Rank
    Newbie
  1. Hier meine 000-default.conf: <VirtualHost *:80> # The ServerName directive sets the request scheme, hostname and port that # the server uses to identify itself. This is used when creating # redirection URLs. In the context of virtual hosts, the ServerName # specifies what hostname must appear in the request's Host: header to # match this virtual host. For the default virtual host (this file) this # value is not decisive as it is used as a last resort host regardless. # However, you must set it for any further virtual host explicitly. #ServerName www.example.com ServerAdmin webmaster@localhost DocumentRoot /var/www/ # Available loglevels: trace8, ..., trace1, debug, info, notice, warn, # error, crit, alert, emerg. # It is also possible to configure the loglevel for particular # modules, e.g. #LogLevel info ssl:warn ErrorLog ${APACHE_LOG_DIR}/error.log CustomLog ${APACHE_LOG_DIR}/access.log combined # For most configuration files from conf-available/, which are # enabled or disabled at a global level, it is possible to # include a line for only one particular virtual host. For example the # following line enables the CGI configuration for this host only # after it has been globally disabled with "a2disconf". #Include conf-available/serve-cgi-bin.conf </VirtualHost> Damit sollte die DocRoot doch eigentlich auf /var/www gesetzt sein oder irre ich mich da? Ist wie gesagt nur als Workaround gedacht gewesen damit ich vielleicht IRGENDWIE wieder froxlor benutzen kann. Das geht wiederum eben nur, wenn ich froxlor tatsächlich mal gestartet bekomme.
  2. Hallo zusammen, ich habe ein Problem mit Froxlor, bzw. dessen Erreichbarkeit. Ich habe auf meinem Root-Server Debian 8.9 (Jessie) laufen und dort Froxlor installiert. Froxlor liegt in /var/www/froxlor/. Problem ist nun, dass diese Adresse von meinem Apache anscheinend nie abgerufen wird. Der Server-Name domain1.de und noch eine weitere Domain domain2.de die beide ihre eigenen Customers in /var/customers/webs/ haben funktionieren problemlos. Als Workaround habe ich versucht /var/www/froxlor in das webs Verzeichnis eines Customers zu symlinken, dann bekomme ich allerdings folgenden php-Error: [Wed Nov 29 10:47:43.392017 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Warning: Unknown: open_basedir restriction in effect. File(/var/www/froxlor/index.php) is not within the allowed path(s): (/var/customers/webs/johannes:/tmp) in Unknown on line 0 [Wed Nov 29 10:47:43.392110 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Warning: Unknown: failed to open stream: Operation not permitted in Unknown on line 0 [Wed Nov 29 10:47:43.392127 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Fatal error: Unknown: Failed opening required '/var/customers/webs/johannes/froxlor/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0 Ich habe außerdem festgestellt, dass die beiden vhosts 10_froxlor_ipandport_x.x.x.x.433.conf und 10_froxlor_ipandport_x.x.x.x.80.conf komplett leer von froxlor erzeugt werden. Nur der Header ist drin: # 10_froxlor_ipandport_x.x.x.x.443.conf # Created 28.11.2017 16:55 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Also kann mir jedemand hier helfen, wie ich froxlor wieder erreichbar machen kann? Viele Grüße und schonmal vielen Dank, Johannes
×
×
  • Create New...