Jump to content
Froxlor Forum

Question

Hallo, ich hab heute noch eine 2. Frage:

Ich hab vor einiger Zeit http/2 auf meinem Apachen eingerichtet. Jetzt habe die Beobachtung gemacht das seit dem aktivieren der http/2 Version auf meinem Apache nur sehr wehnige Anfrage auch in http2 abgearbeitet werden. Wenn ich am Firefox nachschaue (Addon http2 indicator) wird für eine webseite auf meinem Server http2 erkannt. Aber im Log steht das er trotzdem http/1.1 verwendet. Muss ich den Webseiten (TYPO3,WP,Joomla) noch sagen das sie auch über http/2 abgerufen werden können?

Im apache2.conf File

Protocols h2 h2c http/1.1
H2Push          on
H2PushPriority  *                       after
H2PushPriority  text/css                before
H2PushPriority  image/jpeg              after   32
H2PushPriority  image/png               after   32
H2PushPriority  application/javascript  interleaved


Besten Dank für Tipps
Christian

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Ich hab genau die settings (froxlor generated) und mein http/2 indicator sagt: läuft (ist ein Contao-CMS)

Share this post


Link to post
Share on other sites
  • 0

Würd ich gern, aber mein browser sagt:

www.beyond-history.com hat eine ungültige Antwort gesendet.
ERR_SSL_PROTOCOL_ERROR

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Keon
      Hallo alle miteinander,
       
      ich bin derweil dabei mir Froxlor auf einem CentOS7 System zum laufen zu bringen. Hier mal kurz ein kleiner Überblick wie ich aktuell stehe:
      SSH Port ändern, sudo User, NTP, EPEL Release, FirewallD für http, https, ssh mit neuem Port frei, fail2ban für SSH Apache, MariaDB, PHPMyAdmin, mod_ssl inkl. config und self signed cert, Froxlor Grundinstallation, Webserver und SSL Einstellungen Admin Menü, (Pfade, reload Script etc.) IP/Port 443 hinzugefügt, Konfiguration -> CentOS -> sonstiges -> cronjob for froxlor Ebenso habe ich - auch wenn unter "Konfiguration" für "CentOS" nicht vorhanden, die acme.conf angelegt  
      Kommen wir zur Frage:
      Wie bekomme ich hin, dass ich folgende Einstellung setzen kann:
       
      Habe ich noch etwas vergessen? Etwas grundlegendes? Bin normalerweise seit Debian Etch bis Jessie gewöhnt - sammle grad die ersten Erfahrungen mit Froxlor & CentOS nach 2 Jahren Pause aus der Informatik.
       
      Beste Grüße
    • By Kyle Willets
      I looked around and like my last question the directory on Centos 7 is different then the configuration in
      RHEL / CentOS (7) »  Webserver (HTTP) »  Apache 2.4
      I see that ofcourse my apache 2 is installed in httpd and I am searching, but no /etc/apache2/conf-enabled/acme.conf. I did see the first command created the var folders fine for customers, but the others all failed: 
      [root@s128426 ~]# nano /etc/httpd/conf/httpd.conf
      [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/
      chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/
      chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chown root:0 /etc/apache2/sites-enabled/
      chown: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
      [root@s128426 ~]# chmod 0600 /etc/apache2/sites-enabled/
      chmod: cannot access ‘/etc/apache2/sites-enabled/’: No such file or directory
       
      When I search httpd these directories do not exist within it. Is there a separate install  for apache for Froxlor or something I am missing? I am really thinking about going to debian, but my dedicated host does not offer debian stretch at the moment so went centos being I knew it was the most up to date right now in their list.
       

       
    • By Developer
      Hallo zusammen,
      ich habe ein Problem mit Froxlor, bzw. dessen Erreichbarkeit. Ich habe auf meinem Root-Server Debian 8.9 (Jessie) laufen und dort Froxlor installiert. Froxlor liegt in /var/www/froxlor/. Problem ist nun, dass diese Adresse von meinem Apache anscheinend nie abgerufen wird. Der Server-Name domain1.de und noch eine weitere Domain domain2.de die beide ihre eigenen Customers in /var/customers/webs/ haben funktionieren problemlos. Als Workaround habe ich versucht /var/www/froxlor in das webs Verzeichnis eines Customers zu symlinken, dann bekomme ich allerdings folgenden php-Error:
      [Wed Nov 29 10:47:43.392017 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Warning: Unknown: open_basedir restriction in effect. File(/var/www/froxlor/index.php) is not within the allowed path(s): (/var/customers/webs/johannes:/tmp) in Unknown on line 0 [Wed Nov 29 10:47:43.392110 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Warning: Unknown: failed to open stream: Operation not permitted in Unknown on line 0 [Wed Nov 29 10:47:43.392127 2017] [:error] [pid 8404] [client xxxxx:44863] PHP Fatal error: Unknown: Failed opening required '/var/customers/webs/johannes/froxlor/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0 Ich habe außerdem festgestellt, dass die beiden vhosts 10_froxlor_ipandport_x.x.x.x.433.conf und 10_froxlor_ipandport_x.x.x.x.80.conf komplett leer von froxlor erzeugt werden. Nur der Header ist drin:
      # 10_froxlor_ipandport_x.x.x.x.443.conf # Created 28.11.2017 16:55 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. Also kann mir jedemand hier helfen, wie ich froxlor wieder erreichbar machen kann?
      Viele Grüße und schonmal vielen Dank,
      Johannes
    • By NitroxydeX
      Hallo Community und Staff,
      bezüglich eines Serverwechsel stande nun auch eine Änderung des Control Panels an, da unser bisher genutztes einfach zu wenig geupdatet wurde und Fehler selbst gefixt werden mussten.
      Es blieb eigentlich nur Froxlor übrig. Allerdings haben wir nun feststellen müssen, dass man bei Froxlor nicht die Möglichkeit hat den Datenbanknamen und Nutzer frei zu wählen, was viele als hohes Sicherheitsrisiko werten. Warum ist dies so gewählt? Und gibt es bereits jetzt schon eine Möglichkeit das zu aktivieren?
      Zum anderen Problem: Froxlor scheint magisch alles abzufangen. Bislang hatte ich Apache so konfiguriert, dass alle nicht vorhanden Vhosts ins 403-Forbidden Nirvana gesendet werden. Gleiche Konfiguration habe ich nun auch mit Froxlor versucht und mein Abfangen als 01-beginnende Apache config hinterlegt. Dies fängt auch direkte Aufrufe der IP ab, allerdings funktioniert dies weder mit der IP noch mit nicht angelegten (Sub)-Domains. Es wird immer automatisch auf den FQDN des Panels umgeleitet, was eigentlich gar nicht möglich sein sollte. 
       
      Vielen Dank schon mal für die Antworten
    • By nurtext
      Moin,
      anscheinend schlägt Let's Encrypt bei Subdomains fehl, weil es gerne auch eine weitere "www"-Subdomain an die bestehende hängen würde. Siehe Log:
      root@meine-tolle-domain:/root# /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug [information] Updating Let's Encrypt certificates [information] Updating hilfe.meine-tolle-domain.de [information] Adding SAN entry: hilfe.meine-tolle-domain.de [information] Adding SAN entry: www.hilfe.meine-tolle-domain.de [information] letsencrypt Using 'https://acme-v01.api.letsencrypt.org' to generate certificate [information] letsencrypt Creating new account key [information] letsencrypt Starting new account registration [information] letsencrypt Sending registration to letsencrypt server [information] letsencrypt Sending signed request to /acme/new-reg [information] letsencrypt New account registered. [information] letsencrypt Accepting lets encrypt Terms of Service [information] letsencrypt Accepting agreement at URL: https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf [information] letsencrypt Sending signed request to /acme/reg/18369331 [information] letsencrypt Lets encrypt Terms of Service accepted [information] letsencrypt Starting certificate generation process for domains [information] letsencrypt Requesting challenge for hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for hilfe.meine-tolle-domain.de [information] letsencrypt Token for hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY and should be available at http://hilfe.meine-tolle-domain.de/.well-known/acme-challenge/5lbwRluW103CyNPdbmq7p_kd7p3blY8WGNSV0N0RNBY [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/ZXmZ4SU2Oy0__ipk-ihaPtDq39OyNfBKAEHzfMvmO5U/1478709781 [information] letsencrypt Verification pending, sleeping 1s [information] letsencrypt Verification ended with status: valid [information] letsencrypt Requesting challenge for www.hilfe.meine-tolle-domain.de [information] letsencrypt Sending signed request to /acme/new-authz [information] letsencrypt Got challenge token for www.hilfe.meine-tolle-domain.de [information] letsencrypt Token for www.hilfe.meine-tolle-domain.de saved at /var/www/froxlor/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE and should be available at http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE [error] letsencrypt Please check http://www.hilfe.meine-tolle-domain.de/.well-known/acme-challenge/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE - token not available; PHP error: {"type":2,"message":"file_get_contents(http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE): failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known","file":"\/var\/www\/froxlor\/lib\/classes\/ssl\/class.lescript.php","line":232} [information] letsencrypt Sending request to challenge [information] letsencrypt Sending signed request to https://acme-v01.api.letsencrypt.org/acme/challenge/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA/1478709934 [information] letsencrypt Verification pending, sleeping 1s [error] Could not get Let's Encrypt certificate for hilfe.meine-tolle-domain.de: Verification ended with error: {"identifier":{"type":"dns","value":"www.hilfe.meine-tolle-domain.de"},"status":"invalid","expires":"2017-07-11T15:20:54Z","challenges":[{"type":"http-01","status":"invalid","error":{"type":"urn:acme:error:connection","detail":"DNS problem: NXDOMAIN looking up A for www.hilfe.meine-tolle-domain.de","status":400},"uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709934","token":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","keyAuthorization":"eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE.lzkNGm6yCkkELPqgqQ8h9v-MfPi-5gRkb9yf76fy86s","validationRecord":[{"url":"http:\/\/www.hilfe.meine-tolle-domain.de\/.well-known\/acme-challenge\/eJnDjhknVPim732szZ9rZt22T9DoKP2xkQI6-A1c4KE","hostname":"www.hilfe.meine-tolle-domain.de","port":"80","addressesResolved":[],"addressUsed":"","addressesTried":[]}]},{"type":"tls-sni-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709935","token":"S1kgT_jIG8reMxRvGEf9niDf4WIiPyr5XslKbIFQ6eY"},{"type":"dns-01","status":"pending","uri":"https:\/\/acme-v01.api.letsencrypt.org\/acme\/challenge\/4ZX-ZuA9abbaOpoUhAnqyhnLDUzWp7xm5YPUZns7orA\/1478709936","token":"mp8J-ChoyV2gMPQyuJQoZaRlH2ePfcBYcb0v-cZ1zmU"}],"combinations":[[1],[0],[2]]} [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid root@meine-tolle-domain:/root/ Irgendwie sieht das für mich nicht gewollt aus, oder? ?
×
×
  • Create New...