Jump to content
Froxlor Forum

Archived

This topic is now archived and is closed to further replies.

  • 0
JulesNet

[solved] Fehler bei Aktualisierung

Question

Erstmal vielen Dank f?r das Update.

W?hrend der Aktualisierung von froxlor via apt trat kein Fehler auf (Debian), ich wurde aufgefordert mich als Administrator anzumelden.

Allerdings ist eine Anmeldung unm?glich und ich bekomme folgende Benachrichtigungen von dem master cronjob "Version of file doesnt match version of database. Exiting...".

Darauf hin habe ich manuel in der Datenbank die Version von 0.9.27 auf 0.9.28 aktualisiert und konnte mich ohne Probleme anmelden.

Ist dieses Verfahren unumstritten m?glich oder wird bei der ersten Anmeldung als Administrator die Datenbank mit den Updates versehen, sodass die Software zwar nun aktualisiert ist, die Datenbank jedoch nicht?

 

Ich danke f?r eure Hilfe ;)

 

[EDIT] bei der Anmeldung erhalte ich folgende Meldung: "HTTP-Fehler 500 (Internal Server Error): Beim Versuch des Servers, die Anforderung zu verarbeiten, ist eine unerwartete Bedingung aufgetreten."

Share this post


Link to post
Share on other sites

Recommended Posts

Das ist kein gutes Verfahren, denn das bedeutet, das die Datenbank-Aktualisierungen wohl nicht durchgef?hrt wurden. Du h?ttest nach dem Aktualisieren des Paketes und Anmeldung als Admin eigentlich auf die Update-Seite kommen sollen

Share this post


Link to post
Share on other sites

Ja das bef?rchte ich auch :( 

Ich habe gerade noch was erg?nzt. Der URL auf den bei der Anmeldung weitergeleitet wird scheint auch zu passen: /admin_updates.php?s=b6cd842bd149f6243173586c4e39baad

Share this post


Link to post
Share on other sites

Das Problem wurde gel?st. Ich habe das Formular erneut abgeschickt, also mit der Fehlermeldung zusammen noch mal aktualisiert und die Datenbank wurde aktualisiert. 

Ich habe leider ?berhaupt keine Ahnung wieso es nur so funktionierte...

Danke f?r die Hilfe :)

Share this post


Link to post
Share on other sites

syslog 

 

 

Apr 12 15:38:13 vsxxx4 Froxlor: [Administrator Action (updater)] Updating from 0.9.28-svn1 to 0.9.28-svn2
Apr 12 15:38:13 vsxxx4 Froxlor: MySQL - Error: Invalid SQL: ALTER TABLE  `panel_languages` ADD  `iso` CHAR( 3 ) NOT NULL DEFAULT  'foo' AFTER  `language`; ErrNo: 1060; Desc: Duplicate column name 'iso'; Script: /admin_updates.php?s=f714aae7647d454d5e87c62cf30dae04; 

Share this post


Link to post
Share on other sites

das sollte ja eigentlich nicht vorkommen k?nnen, aber wir erleben immer wieder tolle wunder.

Das kann man aber manuell umgehen, das zu erkl?ren ist hier allerdings etwas zu umfangreich, am besten kommste grad mal in den IRC (irc.freenode.net/#froxlor) und dann schaun wir uns das mal an

Share this post


Link to post
Share on other sites

Hallo,

habe seit dem update heute auch ein problem mit dem update.

Beim Update gab es keine Fehler als ich Froxlor aufrufen wollte, bekamm ich eine leere wei?e Seite angezeigt!?

Share this post


Link to post
Share on other sites

Eine wei?e Seite deutet immer auf PHP Fehler hin, schau mal in die error log des Webservers

Share this post


Link to post
Share on other sites

Eine wei?e Seite deutet immer auf PHP Fehler hin, schau mal in die error log des Webservers

da steht folgendes drin:

[sat Apr 13 00:08:46 2013] [warn] [client 91.12.16.241] mod_fcgid: stderr: PHP Warning:  include_once(./install/updates/preconfig.php): failed to open stream: Permission denied in /var/www/froxlor/admin_updates.php on line 100, referer: http://94.101.38.163/
[sat Apr 13 00:08:46 2013] [warn] [client 91.12.16.241] mod_fcgid: stderr: PHP Warning:  include_once(): Failed opening './install/updates/preconfig.php' for inclusion (include_path='.:/usr/share/php/:/usr/share/php5/') in /var/www/froxlor/admin_updates.php on line 100, referer: http://94.101.38.163/
[sat Apr 13 00:08:46 2013] [warn] [client 91.12.16.241] mod_fcgid: stderr: PHP Fatal error:  Call to undefined function getPreConfig() in /var/www/froxlor/admin_updates.php on line 101, referer: http://94.101.38.163/

Share this post


Link to post
Share on other sites

Also, entweder nutzt du mod_PHP,dann sollte der Webserver user owner sein, nutzt du FCGID muss es dem entsprechenden lokalen user geh?ren

Share this post


Link to post
Share on other sites

du hast nicht etwa safe_mode f?r den Froxlor Vhost aktiviert? Mal davon abgesehen das es safe_mode nichtmehr gibt in aktuellen php versionen

 

Froxlor funktioniert nicht mit safe_mode = On, bitte auf Off stellen

Share this post


Link to post
Share on other sites

Hatte auch gerade den Fehler mit: "HTTP-Fehler 500 (Internal Server Error): Beim Versuch des Servers, die Anforderung zu verarbeiten, ist eine unerwartete Bedingung aufgetreten."

 

Dann einmal den Apache Restarten lassen und siehe da: [warn] VirtualHost xx.xx.xx.xx:80 overlaps with VirtualHost xx.xx.xx.xx:80, the first has precedence, perhaps you need a NameVirtualHost directive

 

L?sung:

 

Die Datei /etc/apache2/ports.conf ?ffnen und folgende Zeile ?ndern:

 

NameVirtualHost *:80

 

In

 

NameVirtualHost HostIP:80


 

Share this post


Link to post
Share on other sites

joa was in der distributions-default-config is k?nnen wir nicht wissen, auf anderen gibt es sowas wie eine "ports.conf" nicht. 

Share this post


Link to post
Share on other sites

Habe jetzt aber bei meinen Kunden ein Problem alle seiten haben ein HTTP 500 Fehler in den Logs steht Folgendes:

 

configuration error:  couldn't perform authentication. AuthType not set!

Share this post


Link to post
Share on other sites

du hast nicht etwa safe_mode f?r den Froxlor Vhost aktiviert? Mal davon abgesehen das es safe_mode nichtmehr gibt in aktuellen php versionen

 

Froxlor funktioniert nicht mit safe_mode = On, bitte auf Off stellen

safe_mode war von anfang an off bei mir

Share this post


Link to post
Share on other sites

Habe jetzt aber bei meinen Kunden ein Problem alle seiten haben ein HTTP 500 Fehler in den Logs steht Folgendes:

 

configuration error:  couldn't perform authentication. AuthType not set!

 

Schau mal ob in den Einstellungen nicht ausversehen "Apache-2.4" aktiviert ist

Share this post


Link to post
Share on other sites

safe_mode war von anfang an off bei mir

 

dann stimmt was mit deinen Berechtigungen nicht, geh?rt auch /var/www/froxlor komplett dem lokalen user (z.B. froxlorlocal) und gibt es den user auch?

Share this post


Link to post
Share on other sites

Wo finde ich die Einstellung ich sehe immer nur Apache2

Edit: gefunden teste es mal

Schau mal ob in den Einstellungen nicht ausversehen "Apache-2.4" aktiviert ist

Share this post


Link to post
Share on other sites

komisch, der default f?r apache-2.4 ist eingetlich 'Off' und bei meinem eigenen Update gerade war das auch so :)

Share this post


Link to post
Share on other sites

Habe heute ebenfalls ein Update durchgef?hrt meines Froxlor auf meiner Debian Squeeze B?chse.

Lief auch erstmal alles wunderbar .. allerdings wurde dann die Config geschrieben und seit dem bekomme ich keine Webseiten zur?ck.

 

Nach dem ich die ?nderung in der ports.conf ge?ndert habe, konnte ich auch den Apache2 Server neu starten.

 

Jedoch bekomm ich jetzt immer noch keine Pages und somit geht auch nicht mehr das Froxlor Menu.

 

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

 

Error Log

[sun Apr 14 13:03:11 2013] [crit] [client 88.73.99.110] configuration error:  couldn't perform authentication. AuthType not set!: /froxlor
 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Similar Content

    • By Marcel -//- AdSoleWare
      Hello.
      I manually installed Froxlor on Debian 8 and tried setting up. i installed php 7.3 in as it was the only missing point. i restarted apache2 and now it wont start. I need help
       
      Error Log:
       
    • By Tom Spielvogel
      Hello community, i have updated my froxlor version from 0.8 or 0.9 i don't exactly remember to 0.10.12 to use the ACMEv2 challenges for Let's Encrypt.
      I have sql-dumped the old database.
      Any pointers on how I can restore the data into my new database? I don't want to manually type in all the customers with all their settings again 😮
      Please help!
    • By tmuecksch
      Hi,
      seit gestern um 18:40h erhalte ich alle 5 Minuten folgende Mail. Da ich seit Längerem nichts am Server geändert habe (außer gelegentliche Update) würde ich mal ganz lapidar einen Fehler meinerseits ausschließen. Bisher hat ja alles problemlos geklappt.
      Nach etwas Recherche scheint der Fehler mit acme.sh zusammenzuhängen.
      Betreff: 
       
      Inhalt:
       
       
      Was kann ich tun um den Fehler zu Debugger und/oder zu beheben?
       
       
    • By Pro-Webs
      Hallo,
      ich bin gerade dabei einen Shopware Shop v.5 unter nginx mit froxlor einzurichten.
      Das ist jedoch relativ problematisch.
      Aktuell habe ich im Froxlor folgende vHost Einstellung zur Domain:
      location @php { fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location / { index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } location ~ \.php$ { try_files $uri =404; include /etc/nginx/fastcgi_params; fastcgi_pass 127.0.0.1:9000; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param HTTPS $fastcgi_https; fastcgi_param HTTP_AUTHORIZATION $http_authorization; } Diese Einstellung führt zu einem 500 error.
      Meine 35_froxlor_ssl_vhost_studio-ausruestung.de.conf sieht damit leider wie folgt aus:
      # 35_froxlor_ssl_vhost_studio-ausruestung.de.conf # Created 02.01.2020 14:30 # Do NOT manually edit this file, all changes will be deleted after the next domain change at the panel. server { listen 91.250.82.51:443 ssl; server_name studio-ausruestung.de www.studio-ausruestung.de xn--studio-ausrstung-tzb.de *.xn--studio-ausrstung-tzb.de studioausruestung.de *.studioausruestung.de priolite-shop.com www.priolite-shop.com sirui-shop.de www.sirui-shop.de shooting-gutschein.de *.shooting-gutschein.de shooting-gutscheine.de *.shooting-gutscheine.de; ssl_protocols TLSv1 TLSv1.2; ssl_ciphers ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH; ssl_ecdh_curve secp384r1; ssl_prefer_server_ciphers on; ssl_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; ssl_certificate_key /etc/ssl/froxlor-custom/studio-ausruestung.de.key; add_header Strict-Transport-Security "max-age=0"; ssl_stapling on; ssl_stapling_verify on; ssl_trusted_certificate /etc/ssl/froxlor-custom/studio-ausruestung.de.crt; include /etc/apache2/conf-enabled/acme.conf; access_log /var/customers/logs/klimek-studio-ausruestung.de-access.log combined; error_log /var/customers/logs/klimek-studio-ausruestung.de-error.log error; root /var/customers/webs/klimek/studio-ausruestung.de/shopware/; location / { index index.php index.html index.htm; try_files $uri $uri/ @rewrites; index index.html index.php shopware.php; rewrite shopware.dll /shopware.php; rewrite files/documents/.* /engine last; #rewrite images/ayww/(.*) /images/banner/$1 last; rewrite backend/media/(.*) /media/$1 last; if (!-e $request_filename){ rewrite . /shopware.php last; } location ~ \.(jpe?g|png|gif|css|js)$ { rewrite backend/media/(.*) /media/$1 last; expires 1M; } } location @rewrites { rewrite ^ /index.php last; } location /webalizer { alias /var/customers/webs/klimek/webalizer/studio-ausruestung.de/; auth_basic "Restricted Area"; auth_basic_user_file /etc/nginx/htpasswd/1-c3d3ffdab2b8342809d19524c21b98c1.htpasswd; } location ~ \.php { try_files /333c3697df6a41bcc37bccd05271f644.htm @php; } location @php { fastcgi_split_path_info ^(.+\.php)(/.+)$; include /etc/nginx/fastcgi_params; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; fastcgi_param PATH_INFO $fastcgi_path_info; try_files $fastcgi_script_name =404; fastcgi_index index.php; fastcgi_param HTTPS on; fastcgi_pass unix:/run/php/php7.2-fpm.sock; fastcgi_read_timeout 1500; } location ~ ^/(engine|files|templates|media/(archive|banner|image|music|pdf|unknown|video))/ { rewrite ^/files/documents/.* /engine last; location ~ \.(jpe?g|png|gif|css|js)$ { expires 1M; } } location ~ \.(tpl|yml|ini)$ { deny all; } location /install/ { location /install/assets { } if (!-e $request_filename){ rewrite . /install/index.php last; } } location /update/ { location /update/assets { } location /update/templates { } if (!-e $request_filename){ rewrite . /update/index.php last; } } location /recovery/install/ { location /recovery/install/assets { } if (!-e $request_filename){ rewrite . /recovery/install/index.php last; } } location /recovery/update/ { location /recovery/update/assets { } if (!-e $request_filename){ rewrite . /recovery/update/index.php last; } } location ~ ^/(logs|media/temp|bin|cache)/ { deny all; } } Man bemerkt u.a. das einige Konfigurationen doppelt vorhanden sind, da floxlor diese auch selbst generiert. Das könnte natürlich schon die Ursache des Fehler sein. Ich weiß nur leider nicht, wie ich es "besser" lösen kann.
      Die original .htaccess für den appache sieht folgende Konfiguration vor:
      php_value memory_limit 1024M php_value max_execution_time 600 php_value upload_max_filesize 20M php_value post_max_size 20M <IfModule mod_rewrite.c> RewriteEngine on #RewriteBase /shopware/ # Https config for the backend #RewriteCond %{HTTPS} !=on #RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301] RewriteRule shopware.dll shopware.php RewriteRule files/documents/.* engine [NC,L] RewriteRule backend/media/(.*) media/$1 [NC,L] RewriteRule custom/.*(config|menu|services|plugin)\.xml$ ./shopware.php?controller=Error&action=pageNotFoundError [NC,L] RewriteCond %{REQUEST_URI} !(\/(engine|files|templates|themes|web)\/) RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/) RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ shopware.php [PT,L,QSA] # Fix missing authorization-header on fast_cgi installations RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] </IfModule> <IfModule mod_alias.c> # Restrict access to VCS directories RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$) # Restrict access to root folder files RedirectMatch 404 /(autoload\.php|composer\.(json|lock|phar)|README\.md|UPGRADE-(.*)\.md|CONTRIBUTING\.md|eula.*\.txt|\.gitignore|.*\.dist|\.env.*)$ # Restrict access to shop configs files RedirectMatch 404 /(web\/cache\/(config_\d+\.json|all.less))$ # Restrict access to theme configurations RedirectMatch 404 /themes/(.*)(.*\.lock|package\.json|\.gitignore|Gruntfile\.js|all\.less|node_modules\/.*)$ </IfModule> # Staging environment #SetEnvIf Host "staging.test.shopware.in" SHOPWARE_ENV=staging # Development environment #SetEnvIf Host "dev.shopware.in" SHOPWARE_ENV=dev #SetEnv SHOPWARE_ENV dev DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration <Files ~ "\.(tpl|yml|ini)$"> # Deny all requests from Apache 2.4+. <IfModule mod_authz_core.c> Require all denied </IfModule> # Deny all requests from Apache 2.0-2.2. <IfModule !mod_authz_core.c> Deny from all </IfModule> </Files> # Enable gzip compression <IfModule mod_deflate.c> AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json application/font-woff application/font-woff2 image/svg+xml </IfModule> <Files ~ "\.(jpe?g|png|gif|css|js|woff|woff2|ttf|svg|webp|eot|ico)$"> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 month" </IfModule> <IfModule mod_headers.c> Header append Cache-Control "public" Header unset ETag </IfModule> FileETag None </Files> # Match generated files like: # 1429684458_t22_s1.css # 1429684458_t22_s1.js <FilesMatch "([0-9]{10})_(.+)\.(js|css)$"> <ifModule mod_headers.c> Header set Cache-Control "max-age=31536000, public" </ifModule> <IfModule mod_expires.c> ExpiresActive on ExpiresDefault "access plus 1 year" </IfModule> </FilesMatch> # Disables auto directory index <IfModule mod_autoindex.c> Options -Indexes </IfModule> <IfModule mod_negotiation.c> Options -MultiViews </IfModule> <IfModule mod_php5.c> # php_value memory_limit 256M # php_value max_execution_time 120 # php_value upload_max_filesize 20M php_flag phar.readonly off php_flag magic_quotes_gpc off php_flag session.auto_start off php_flag suhosin.session.cryptua off php_flag zend.ze1_compatibility_mode off php_value always_populate_raw_post_data -1 </IfModule> # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php <IfModule mod_headers.c> Header append X-Frame-Options SAMEORIGIN </IfModule>  
      Für Ideen und Vorschläge wäre ich wie immer sehr dankbar
×
×
  • Create New...