Jump to content
Froxlor Forum
  • 0

Datenbank nach Update


Go to solution Solved by d00p,

Question

Hello community, i have updated my froxlor version from 0.8 or 0.9 i don't exactly remember to 0.10.12 to use the ACMEv2 challenges for Let's Encrypt.

I have sql-dumped the old database.

Any pointers on how I can restore the data into my new database? I don't want to manually type in all the customers with all their settings again ūüėģ

Please help!

Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 1

If you have updated an existing installation, the database is also updated and no data is lost. If you have installed the current 0.10 with a new database, you can easily tell froxlor to use the old database in its lib/userdata.inc.php file

Link to post
Share on other sites
  • 0

Thanks for your reply. I have created a new db from the dump, named froxlor. When I log on, I now see, that froxlor wants to migrate the date into the new format:

Die Froxlor-Dateien wurden aktualisiert. Neue Version ist 0.10.12. Die bisher installierte Version ist 0.9.38.8

However: there is an error I don't know how to fix: (step: "Converting all MyISAM tables to InnoDB")

A database error occurred

SQLSTATE[42S01]: Base table or view already exists: 1050 Table './froxlor/api_keys' already exists

Thanks for your help

 

UPDATE: I have tried to manually update the tables to InnoDB and it works for most of them, except api_keys. I have also tried to change the update script to create api_keys with the InnoDB engine right away, but this also throws an error, so it may have something to do with the table layout? I don't see anything special about the table, but maybe you can provide some ideas.

Thanks again!

 

Here is the log from froxlor webinterface:

 

Adding field for fpm-daemon configs[OK]
Adding new fpm-daemons table[OK]
Converting php-fpm settings to new layout[OK]
Deleting unneeded settings[OK]
Adding field allowed_phpconfigs for customers[OK]
Adding new setting for Let's Encrypt ACME version[OK]
Adding field pass_authorizationheader for php-configs[OK]
Adding new setting for SSL protocols[OK]
Adding field for security.limit_extensions fpm-setting[OK]
Adding dynamic php-fpm php.ini settings[OK]
Adding php-fpm php PATH setting for envrironment[OK]
Updating from 0.9.38.8 to 0.9.39 final
Updating from 0.9.39 to 0.9.39.1
Updating from 0.9.39.1 to 0.9.39.2
Adding new plans table[OK]
Adding domain field for try_files flag[OK]
Updating from 0.9.39.2 to 0.9.39.3
Updating from 0.9.39.3 to 0.9.39.4
Updating from 0.9.39.4 to 0.9.39.5
Adding fullchain field to ssl certificates[OK]
Adding webserver logfile settings[OK]
Adding webserver logfile-script settings[OK]
Checking for required PHP json-extension[OK]
Checking for current cronjobs that need converting[OK]
Adding leaccount field to panel customers[OK]
Adding system setting for let's-encrypt account[OK]
Adding new fields for php configs[OK]
Synchronize fpm-daemon process manager settings with php-configs[OK]
Updating from 0.9.39.5 to 0.9.40
Updating from 0.9.40 to 0.9.40.1
Updating from 0.9.40.1 to 0.10.0-rc1
Adding new api keys table[OK]
Adding new api settings[OK]
Adding new default-ssl-ip setting[OK]
Altering admin ip's field to allow multiple ip addresses[OK]
Adding dhparams-file setting[OK]
Adding new settings for 2FA[OK]
Adding new fields to admin-table for 2FA[OK]
Adding new fields to customer-table for 2FA[OK]
Adding new logview-flag to customers[OK]
Adding new is_configured-flag[OK]
Adding fields writeaccesslog and writeerrorlog for domains[OK]
Updating cronjob table[OK]
Removing ticketsystem[OK]
Updating nameserver settings[OK]
Adding new webserver error-log-level setting[OK]
Adding new ECC / ECDSA setting for Let's Encrypt[OK]
Removing current Let's Encrypt certificates due to new implementation of acme.sh[OK]
Inserting job to regenerate configfiles[OK]
Adding new froxlor vhost domain alias setting[OK]
Converting all MyISAM tables to InnoDB

 
Edited by Tom Spielvogel
Link to post
Share on other sites
  • 0

That's a weird place for this exact error to occur because the table is added way earlier in the update process (Adding new api keys table) which was successful for you. The converting just runs an ALTER TABLE and does not create any new tables. With all the manual fixes you have tried now it is hard to now what happened and what not. If you like, I can take a look at the server and fix the update for you

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By Marcel -//- AdSoleWare
      Hello.
      I manually installed Froxlor on Debian 8 and tried setting up. i installed php 7.3 in as it was the only missing point. i restarted apache2 and now it wont start. I need help
       
      Error Log:
       
    • By shaaz
      Is that possible to install froxlor in c-panel using one database user password?
      Or how can we skip the values of mysql_unpriv_user and mysql_unpriv_pass while installing?
    • By NitroxydeX
      Hallo Community und Staff,
      bez√ľglich eines Serverwechsel¬†stande nun auch eine √Ąnderung des Control Panels an, da unser bisher genutztes einfach zu wenig geupdatet¬†wurde und Fehler selbst gefixt werden mussten.
      Es blieb eigentlich nur Froxlor √ľbrig. Allerdings haben wir nun feststellen m√ľssen, dass man bei Froxlor nicht die M√∂glichkeit hat den Datenbanknamen und Nutzer frei zu w√§hlen, was viele als hohes Sicherheitsrisiko werten. Warum ist dies so gew√§hlt? Und gibt es bereits jetzt schon eine M√∂glichkeit das zu aktivieren?
      Zum anderen Problem: Froxlor scheint magisch alles abzufangen. Bislang hatte ich Apache so konfiguriert, dass alle nicht vorhanden Vhosts ins 403-Forbidden Nirvana gesendet werden. Gleiche Konfiguration habe ich nun auch mit Froxlor versucht und mein Abfangen als 01-beginnende Apache config hinterlegt. Dies fängt auch direkte Aufrufe der IP ab, allerdings funktioniert dies weder mit der IP noch mit nicht angelegten (Sub)-Domains. Es wird immer automatisch auf den FQDN des Panels umgeleitet, was eigentlich gar nicht möglich sein sollte. 
       
      Vielen Dank schon mal f√ľr die Antworten
    • By Hadet
      Hi so i'm pretty new to this, I have a LAMP stack running on Ubuntu 16.04 Amazon's Lightsail EC2 style platform similar to DigitalOcean's droplet setups
      So far i got everything setup, php-7 is installed, mysql is installed and it's all working i installed Froxlor with no errors, i've even setup the Mail Server and FTP though i haven't been able to test those yet
      I'm currently taking classes for sysadminstration and web development but my experience is still at a beginer level. If anyone can tell me what i set up wrong or need to change, i'd really appreciate it. It took me a long time to get this running because all the documentation was very out of date, i ended up doloading the latest version and extracting it in my var/www/html/ directory, i can access the pannel and even login to the admin account i set up during the setup phase.
      When trying to add a new user to test thing i get the following message once i've filling everything out
      A database error occurred SQLSTATE[01000]: Warning: 1265 Data truncated for column 'add_date' at row 1
       
      EDIT: Also redtext sorry not familiar with this forum setup. SO it DID add the User, but i'm still getting Mysql errors on things like email.I followed the instructions to the letter through ssh everything should be good. I've gone through them twice step by step to make sure.
      Rebuilt the whole LAMP stack from the ground up, configured everything exactly how it said to in the config guides
      Here's the Rerror it gives.
      Dear froxlor-team,

      the following error has been reported by a user:

      -------------------------------------------------------------
      01000 SQLSTATE[01000]: Warning: 1265 Data truncated for column 'add_date' at row 1

      File: /lib/classes/database/class.Database.php:72

      Trace:
      #0 /lib/classes/database/class.Database.php(72): PDOStatement->execute(Array)
      #1 /admin_customers.php(935): Database::pexecute(Object(PDOStatement), Array)
      #2 {main}

      -------------------------------------------------------------

      Froxlor-version: 0.9.38.7
      DB-version: 201612110

      End of report
       
    • By DavidCK
      Hello!

      I can not update via "Auto-Update" option, froxlor identifies the new version but when I do click in the "Auto-Update"  I have this message:

      Froxlor update

      You already have the latest Froxlor version.
       
      Any Idea?
      Another way to safe update?? Thanks.

      Regards.
       
×
×
  • Create New...