Jump to content
Froxlor Forum
  • 0

SSH access with libnss-extrausers


Exploit
 Share

Question

Hello, I'm trying to provide an SSH shell access to customers on an Debian Bullseye.

So far the usernames are shown properly in the system but the loggin in with SSH is rejected. The path in "/var/lib/extrausers/passwd" is always set to "/bin/false" even if I set the "List of available shells" in Froxlor on "/bin/bash", while the cronjob does create the files.

Any Idea, why the path is not what I would expect to be set in the passwd file?

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

You have to explicitly enable shell usage in the settings as well as specify allowed binaries (e.g. /bin/bash or /bin/sh).

The customer can then edit the corresponding FTP user and select an available shell for it to be used for the user.

The Cronjob will then regenerate the extra users files accordingly.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...