Jump to content
Froxlor Forum

tt33tt

Members
  • Content Count

    80
  • Joined

  • Last visited

Community Reputation

0 Neutral

About tt33tt

  • Rank
    Advanced Froxie

Recent Profile Visitors

2964 profile views
  1. ok, alles klar. Habe es zum Laufen gebracht ­čÖé Composer kann ich einfach in Webverzeichnis reininstallieren und dann komme ich an https://github.com/weberhofer/jsonrpcphp
  2. OK, danke! Dazu muss ich entsprechend hier einfach die Befehle ausf├╝hren https://getcomposer.org/download/ php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');" php -r "if (hash_file('sha384', 'composer-setup.php') === '48e3236262b34d30969dca3c37281b3b4bbe3221bda826ac6a9a62d6444cdb0dcd0615698a5cbe587c3f0fe57a54d8f5') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;" php composer-setup.php php -r "unlink('composer-setup.php');" Aber in das root-Directory macht das kein Sinn. Muss ich das in der jeweiligen Dom├Ąne ausf├╝hren oder in irgendeiner PHP-Bibliothek, damit alle Dom├Ąnen darauf zugreifen k├Ânnen? Das kann ich dann sicherlich auch f├╝r die Froxlor-API benutzen.
  3. Hallo alle zusammen, ich w├╝rde gerne auf eine API von Limesurvey zur├╝ckgreifen. Daf├╝r muss ich installieren: https://github.com/weberhofer/jsonrpcphp Kann ich in die composer.json einfach so hinzuf├╝gen? Ist das mit Froxlor kompatibel? Das readme zeigt mir diese beiden M├Âglichkeiten: To install composer require weberhofer/jsonrpcphp or add this to your composer.json, and composer update { "require": { "weberhofer/jsonrpcphp": "~2" } }
  4. Hallo alle zusammen, meine Datei /bin/nano /etc/cron.d/froxlor enth├Ąlt # automatically generated cron-configuration by froxlor # do not manually edit this file as it will be re-generated periodically. PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --tasks 1> /dev/null 0 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --traffic 1> /dev/null 5 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --used_tickets_reset 1> /dev/null 7 0 1 * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --ticketarchive 1> /dev/null 10 0 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --usage_report 1> /dev/null 0 */6 * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --mailboxsize 1> /dev/null */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt 1> /dev/null * * * * * root /usr/bin/nice -n 5 /usr/bin/php5 -q /var/www/froxlor/scripts/froxlor_master_cronjob.php --backup 1> /dev/null Leider steht dort /usr/bin/php5 Es sollte hei├čen /usr/bin/php weil das immer auf die aktuellste PHP-Version bei mir verlinkt. Wenn ich das dort ├Ąndere, wird das automatisch ├╝berschrieben. Ich habe herausgefunden, dass ich in den Froxlor-Einstellungen das ├Ąndern kann. Mein Vorschlag: Standardm├Ą├čig auf /usr/bin/php beim n├Ąchsten Froxlor-Update setzen oder zumindest auf die aktuellste php-Version setzen, die von Froxlor unterst├╝tzt wird.
  5. Hi, do I understand this right, that 16.04 is supported by Froxlor? Some software does not work on 14.04 I did not upgraded because I think Froxlor does not support 16.04
  6. OK, openbasedir brauche ich nicht zu ber├╝cksichtigen. Echt super, dass es Letsencrypt gibt. Dadurch ist HTTPS so schnell umsetzbar
  7. Ich habe eine open_basedir-Einschr├Ąnkung: jede Dom├Ąne darf nur innerhalb des Dom├Ąnenverzeichnisses zugreifen. Alles au├čerhalb muss ich zulassen. Das hing mal mit einer Querinfektion zwischen mehreren Domains zusammen. Ich habe diesen Ordner mit den Schl├╝sseln freigegeben in open_basedir. Und ja, ich habe ja geschrieben, dass es conf.d ist :-)
  8. Nach langem Probieren... Aus irgendeinem Grund ist das Verzeichnis conf-enabled nicht in der apache.conf included und ich habe den Pfad bei open_basedir als Ausnahme hinzuf├╝gt. Mir ist noch eingefallen open_basedir zu deaktivieren. Und im php-info steht nun erkennbar: open_basedir -> /var/www/froxlor/.well-known/acme-challenge Versuch absoluter Pfadzugriff: include ("/var/www/froxlor/.well-known/acme-challenge/index.html"); -> OK Versuch ├╝ber alias Pfadzugriff: echo file_get_contents("http://medienkompetenz.jetzt/.well-known/acme-challenge/index.html"); -> Warning: file_get_contents(http://medienkompetenz.jetzt/.well-known/acme-challenge/index.html): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /var/kunden/webs/rainer/medienkompetenz.jetzt/test.php on line 10 => Geht nicht Versuch ├╝ber alias selbe Domain: acme.conf -> Alias "/essen" "/var/kunden/webs/rainer/medienkompetenz.jetzt/Test" Ergebnis im acces.log -> 95.91.217.236 - - [07/Jun/2018:15:40:33 +0200] "GET /essen/index.html HTTP/1.1" 404 31909 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0" Einf├╝gen in vHost klappt: Alias "/.well-known/acme-challenge" "/var/www/froxlor/.well-known/acme-challenge" (Warum muss ich service apache2 restart machen und warum geht reload nicht?) Einf├╝gen in apache2.conf klappt und in conf.d/ auch => Aus irgendeinem Grund ist das Verzeichnis conf-enabled nicht in der apache.conf included... Das musste ich nachholen bzw. alternativ eine Verkn├╝pfung in conf.d ablegen. Jetzt klappt alles
  9. Keine Fehler in den Logfiles erkennbar in diesem Zusammenhang. Speichern m├╝sste er den Schl├╝ssel unter /var/www/froxlor/.well-known/acme-challenge/1234 unabh├Ąngig davon ob die acme.conf stimmt oder nicht? Meine wichtigste Frage: Muss ich apache2.pem manuell erstellen oder nicht? Und wie wird sie normalerweise erstellt?
  10. OK, ich habe jetzt damit angefangen einfach letsencrypt f├╝r Froxlor zu aktivieren und f├╝r alle anderen zu deaktiveren. Apache kann nun die Config laden. Es kommt der selbe Fehler wie oben. Was ich sehr seltsam finde: [information] letsencrypt Token for cloud.rainerwiederstein.de saved at /var/www/froxlor/.well-known/acme-challenge/1234 and should be available at http://cloud.rainerwiederstein.de/.well-known/acme-challenge/1234 Aber dort ist kein Token zu finden... Wenigstens sollte er dort gespeichert sein oder? Zus├Ątzlich zieht denke ich die Umleitung nicht aus der acme.conf, weil ich im Original Webserververzeichnis http://cloud.rainerwiederstein.de/froxlor/.well-known/acme-challenge/index.html auf die index.html zugreifen kann. Aus http://cloud.rainerwiederstein.de/.well-known/acme-challenge/index.html geht es aber nicht und genauso verh├Ąlt es sich mit allen anderen Dom├Ąnen. Au├čerdem ist apache2.pem weiterhin nicht erstellt.
  11. OK, habe das mal auf 128M gesetzt. Der Webserver hat insgesamt nur 4 GB. Damit komme ich bis auf solche Einzelf├Ąlle gut zurecht.
  12. Ja, bin auf ACME-v1 Muss ich dann den Pfad auch unter "IPs und Ports" eintragen? Habe das mit und ohne versucht. Beides hilft nicht. Beim Apache kommt der Config-Fehler, dass die apache2.pem fehlt. Muss ich manuell ein apache2.pem erzeugen?´╗┐ //edit: Er kann die Config glaube ich nicht laden, wegen dem Fehler, dass die apache2.pem fehlt.
  13. Ah, die IP vom AXFR Server von INWX hat sich ge├Ąndert: https://kb.inwx.com/index.php?action=artikel&cat=3&id=146&artlang=de&highlight=axfr Ich musste in Froxlor im Nameserver unter AXFR die neue IP eintragen.
  14. Danke f├╝r den Hinweis! Ich habe das jetzt auf 32MB erh├Âht nur f├╝r den Froxlor-Host. Jetzt geht es :-) Das erscheint mir allerdings als recht viel.
×
×
  • Create New...