Jump to content
Froxlor Forum
  • 0
hede

Debian Stretch und libnss-extrausers

Question

Hallo,

ich habe Debian Strecht und nginx mit MariaDB installiert und möchte gern PHP 7 mit FPM ans laufen bekommen.

Das erste Problem, dass ich habe ist, dass die Ausgabe von ls /var/customers/webs nicht die User sondern nur die ID ausgibt.

drwxr-xr-x 5 10000 10000 4096 Nov 10 15:26 web1

Habe alles wie in der Anleitung beschrieben installiert und erhalte auch hier die User:

cat /var/lib/extrausers/passwd
web1:x:10000:10000:Froxlor User:/var/customers/webs/web1/:/bin/false

Nun läuft der Webserver auch trotzdem und ich kann per FTP Dateien hochladen. Allerdings wird der PHP Socket nicht erstellt.

In der vHost steht z.B.

fastcgi_pass unix:/var/run/php/web1-meinedomain.de-php-fpm.socket;

Im Ordner /var/run/php existieren aber nur php7.0-fpm.pid und php7.0-fpm.sock. Im Froxlor Backend habe ich " Verwende libnss-extrausers anstatt libnss-mysql" aktiviert. Cronjobs sind auch eingerichtet.

 

Ich hatte auch mal in der /etc/php/7.0/fpm/pool.d/www.conf folgende Zeile eingefügt "include=/etc/php-fpm.d/*.conf". Ob das richtig ist weiß ich leider nicht. Aber wenn ich dann fpm neustarte erhalte ich folgende Fehler:

ERROR: [pool meinedomain.de] cannot get uid for user 'web1'

Ich vermute es hat mit libnss zu tun. Habt Ihr vielleicht eine Idee?

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

/etc/nsswitch.conf vergessen anzupassen? Und die PHP-Sockets stimmen schon so, hast du vllt den pfad zu den fpm-pool-configs nicht korrekt gesetzt in den Einstellungen? Bitte nicht davon ausgehen, dass die Defaults 100% passen!!!

Share this post


Link to post
Share on other sites
  • 0

In /etc/nsswitch.conf  steht:

# Make sure that `passwd`, `group` and `shadow` have mysql in their lines
# You should place mysql at the end, so that it is queried after the other mechanisams
#
passwd:         compat mysql
group:          compat mysql
shadow:         compat mysql

hosts:       files dns
networks:    files dns

services:    db files
protocols:   db files
rpc:         db files
ethers:      db files
netmasks:    files
netgroup:    files
bootparams:  files

automount:   files
aliases:     files

Und in den Einstellungen habe ich soweit auch alles angepast:

FastCGI IPC Verzeichnis: /var/run/php/

Pfad zu php-fpm-Konfigurationen: /etc/php-fpm.d/

 

id web1 bringt folgende Ausgabe:
id: ‘web1’: no such user

Share this post


Link to post
Share on other sites
  • 0

joa, nsswitch ist falsch, nach Änderungen in den Einstellungen musst du die Konfigurationsschritte dafür auch noch mal durchgehen, für libnss-extrausers gibt es welche :) die nsswitch.conf muss doch wissen das sie extrausers nutzen soll und nicht mehr mysql

8 minutes ago, hede said:

Pfad zu php-fpm-Konfigurationen: /etc/php-fpm.d/

joa das wird nich passen, wirf mal nen blick in deine php-fpm.conf welcher ordner da inkludiert wird, bei debian meist eher sowas wie /etc/php/7.0/fpm/pool.d/

Share this post


Link to post
Share on other sites
  • 0

Vielen Dank. Habe mir ein paar mal den Konfigurationsschritt angesehen und immer gedacht da hat sich nichts geändert.:unsure:.

Der Pfad der PHP-Config muss auch "/etc/php/7.0/fpm/pool.d/" heißen. Damit werden jetzt die sockets angelegt und die Ordner Berechtigungen werden richtig gesetzt.

Share this post


Link to post
Share on other sites
  • 0

Jetzt habe ich allerdings ein neues Problem und ich kann das Froxlor Backend nicht öffnen, da die "run/php/php7.0-fpm.sock" fehlt.

In "/etc/php/7.0/fpm/pool.d" sind jetzt nur noch die configs von Froxlor drin und die vorherige www.conf wurde gelöscht. Wenn ich diese per Hand anlege wird wieder eine php7.0-fpm.sock angelegt aber das ist ja nicht sinn der Sache und wird nach jedem Cronjob gelöscht. Im Backend unter einstellungen habe ich beim Webserver den Pfad zu run/php/php7.0-fpm.sock angegeben.

Share this post


Link to post
Share on other sites
  • 0

Dann solltest du für das Froxlor panel selbst auch fpm aktivieren, ein mischmasch mit fpm und anderer integration ist nich zu empfehlen. Einstellungen -> Froxlor Vhost Einstellungen

Share this post


Link to post
Share on other sites
  • 0

Hier meine eruierung zu meinem Fehler 502 Bad Gateway

* Alle pfade mehrmals gecheckt

1. Aktiveren von libnss-extrausers anstatt libnss-mysql unter Systemeinstellungen

2. aktiviere unter einstellungen > Froxlor VirtualHost > Verwende PHP-FPM im Froxlor-Vhost 

3. Gehe zu PHP > PHP-FPM Versionen:
ändere den befehl von "service php7.0-fpm restart" zu "service php7.2-fpm restart"

und den pfad:

"/etc/php/7.0/fpm/pool.d/" zu "/etc/php/7.2/fpm/pool.d/"

4. schreibe zusätzlich noch die configs neu

5. führe den cron aus

danach ist aus die maus mit dem froxlor panel 502 bad gateway > nginx/1.14.0

cron meldet hier schon:
Job for php7.2-fpm.service failed because the control process exited with error code.

 

● php7.2-fpm.service - The PHP 7.2 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.2-fpm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2018-09-26 17:54:38 CEST; 2min 22s ago
     Docs: man:php-fpm7.2(8)
  Process: 6982 ExecStart=/usr/sbin/php-fpm7.2 --nodaemonize --fpm-config /etc/php/7.2/fpm/php-fpm.conf (code=exited, status=78)
 Main PID: 6982 (code=exited, status=78)

Sep 26 17:54:37 srv.dom.example systemd[1]: Starting The PHP 7.2 FastCGI Process Manager...
Sep 26 17:54:38 srv.dom.example php-fpm7.2[6982]: [26-Sep-2018 17:54:38] ERROR: [pool customerdomain.example] cannot get uid for user 'customer'
Sep 26 17:54:38 srv.dom.example php-fpm7.2[6982]: [26-Sep-2018 17:54:38] ERROR: FPM initialization failed
Sep 26 17:54:38 srv.dom.example systemd[1]: php7.2-fpm.service: Main process exited, code=exited, status=78/n/a
Sep 26 17:54:38 srv.dom.example systemd[1]: Failed to start The PHP 7.2 FastCGI Process Manager.
Sep 26 17:54:38 srv.dom.example systemd[1]: php7.2-fpm.service: Unit entered failed state.
Sep 26 17:54:38 srv.dom.example systemd[1]: php7.2-fpm.service: Failed with result 'exit-code'.

Die Hautdomain mit einer html datei "srv.dom.example" und die kundendomain "customerdomain.example" laufen noch.
Jedoch alles was hinten agehängt wird wie z.b. das froxlor panel wo ich zusätzlich durch einen tcp/ip port schlaufe nicht.

Nginx status sieht wie folgt aus:
● nginx.service - nginx - high performance web server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2018-09-26 15:38:09 CEST; 2h 26min ago
     Docs: http://nginx.org/en/docs/
  Process: 6967 ExecReload=/bin/kill -s HUP $MAINPID (code=exited, status=0/SUCCESS)
 Main PID: 706 (nginx)
    Tasks: 5 (limit: 4915)
   CGroup: /system.slice/nginx.service
           ├─ 706 nginx: master process /usr/sbin/nginx -c /etc/nginx/nginx.conf
           ├─6969 nginx: worker process
           ├─6970 nginx: worker process
           ├─6971 nginx: worker process
           └─6972 nginx: worker process

Sep 26 16:20:01 srv.dom.example systemd[1]: Reloading nginx - high performance web server.
Sep 26 16:20:01 srv.dom.example systemd[1]: Reloaded nginx - high performance web server.
Sep 26 16:50:58 srv.dom.example systemd[1]: Reloading nginx - high performance web server.
Sep 26 16:50:58 srv.dom.example systemd[1]: Reloaded nginx - high performance web server.
Sep 26 16:58:32 srv.dom.example systemd[1]: Reloading nginx - high performance web server.
Sep 26 16:58:32 srv.dom.example systemd[1]: Reloaded nginx - high performance web server.
Sep 26 17:26:22 srv.dom.example systemd[1]: Reloading nginx - high performance web server.
Sep 26 17:26:22 srv.dom.example systemd[1]: Reloaded nginx - high performance web server.
Sep 26 17:54:37 srv.dom.example systemd[1]: Reloading nginx - high performance web server.
Sep 26 17:54:37 srv.dom.example systemd[1]: Reloaded nginx - high performance web server.

hatte am anfange der installation schon ein kleines problem mit den fast cgi params

musste die oberen 3 lines entfernen, da ansonst nginx meldete die seien doppelt:
/bin/nano /etc/nginx/fastcgi_params

fastcgi_connect_timeout 65;
fastcgi_send_timeout    180;
fastcgi_read_timeout    180;

unter /etc/php/7.2/fpm/pool.d sind die konfig dateien der Hautdomain "srv.dom.example.conf" und der Kundendomain customerdomain.example.conf

diese enthalten:
Hauptdomain:

listen.owner = froxlorlocal
listen.group = froxlorlocal
listen.mode = 0660
user = froxlorlocal
group = froxlorlocal

Kundendomain

listen.owner = customer
listen.group = customer
listen.mode = 0660
user = customer
group = customer

Warum nimmt er da den user "customer" ? 
müsste da nicht "www-data" oder "froxlorlocal" sein ?

alias config in froxlor verweist auf /var/www/php-fpm 
dieser enthält aber keine dateien. (wurde von mir erstellt mit chmod 0755 "/var/www/php-fpm")

unter run/php sind nur "php7.1-fpm.sock" & "php7.1-fpm.pid" drin (da stimmt auf jedenfall mal was nicht)
unter konfiguration PHP-FPM (alternative to mod_php) installieren danach sind php7.2-fpm.sock und pid vorhanden.
Das war mein fehler, habe vergessen den fpm in der froxlor konfig zu intallieren. Dachte ich hätte dies schon gemacht bei der php installation, aber dem war nicht so 😉 

punkt 1-5 wiederholt resp den cron manuell ausgeführt ergabt zuerst:

root@server:~# php /usr/share/AdminPanel/scripts/froxlor_master_cronjob.php --force
sh: 1: /usr/sbin/repquota: not found
Job for php7.2-fpm.service failed because the control process exited with error code.
See "systemctl status php7.2-fpm.service" and "journalctl -xe" for details.
root@server:~# systemctl status php7.2-fpm.service
● php7.2-fpm.service - The PHP 7.2 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.2-fpm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2018-09-26 20:28:00 CEST; 46s ago
     Docs: man:php-fpm7.2(8)
  Process: 7807 ExecStart=/usr/sbin/php-fpm7.2 --nodaemonize --fpm-config /etc/php/7.2/fpm/php-fpm.conf (code=exited, status=78)
 Main PID: 7807 (code=exited, status=78)

Sep 26 20:27:59 srv.dom.example systemd[1]: Starting The PHP 7.2 FastCGI Process Manager...
Sep 26 20:28:00 srv.dom.example php-fpm7.2[7807]: [26-Sep-2018 20:28:00] ERROR: [pool customerdomain.example] cannot get uid for user 'customer'
Sep 26 20:28:00 srv.dom.example php-fpm7.2[7807]: [26-Sep-2018 20:28:00] ERROR: FPM initialization failed
Sep 26 20:28:00 srv.dom.example systemd[1]: php7.2-fpm.service: Main process exited, code=exited, status=78/n/a
Sep 26 20:28:00 srv.dom.example systemd[1]: Failed to start The PHP 7.2 FastCGI Process Manager.
Sep 26 20:28:00 srv.dom.example systemd[1]: php7.2-fpm.service: Unit entered failed state.
Sep 26 20:28:00 srv.dom.example systemd[1]: php7.2-fpm.service: Failed with result 'exit-code'.
root@server:~# systemctl status nginx
● nginx.service - nginx - high performance web server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2018-09-26 15:38:09 CEST; 4h 51min ago
     Docs: http://nginx.org/en/docs/
  Process: 7792 ExecReload=/bin/kill -s HUP $MAINPID (code=exited, status=0/SUCCESS)
 Main PID: 706 (nginx)
    Tasks: 5 (limit: 4915)
   CGroup: /system.slice/nginx.service
           ├─ 706 nginx: master process /usr/sbin/nginx -c /etc/nginx/nginx.conf
           ├─7796 nginx: worker process
           ├─7797 nginx: worker process
           ├─7798 nginx: worker process
           └─7799 nginx: worker process

Ich dachte mir verdammt und hab dann aus jux den cron nochmals gestartet...

und siehe da:

root@server:~# php /usr/share/AdminPanel/scripts/froxlor_master_cronjob.php --force
root@server:~# systemctl status php7.2-fpm.service
● php7.2-fpm.service - The PHP 7.2 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.2-fpm.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2018-09-26 20:29:55 CEST; 1min 41s ago
     Docs: man:php-fpm7.2(8)
 Main PID: 7891 (php-fpm7.2)
   Status: "Processes active: 0, idle: 2, Requests: 7, slow: 0, Traffic: 0req/sec"
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/php7.2-fpm.service
           ├─7891 php-fpm: master process (/etc/php/7.2/fpm/php-fpm.conf)
           ├─7892 php-fpm: pool customerdomain.example
           └─7893 php-fpm: pool srv.dom.example

scheint nun zu funktionieren, hatte da meine schwierigkeiten und dachte ich poste das mal hier als hint.

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, noise said:

Warum nimmt er da den user "customer" ? 
müsste da nicht "www-data" oder "froxlorlocal" sein ?

Nein, Kunden-PHP-Prozesse laufen natürlich auch unter Kunden-User...das ist ja Sinn der Sache

 

Share this post


Link to post
Share on other sites
  • 0

ok das hat mich irritiert  

cannot get uid for user 'customer'

da dies als fehler angezeigt wurde, deshalb dachte ich zuerst es könnte an dem

froxlor localuser oder an der nsswitch.conf liegen.

jedoch waren es die sock und pid datei... man lernt immer wieder was dazu, war meine erste installation mit nginx und fpm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Schutzgeist
      Hallo, 
      vielleicht kann mir jemand hier ja einen kleinen Tipp geben.
      Es ist mehr eine nginx-Konfiguration. 
      PHP-404-Rückmeldungen sollen "sauber" an Joomla übergeben werden.
       
      Mein 'Froxlor-Standardvhost sieht wie folgt aus

      Allerdings kann ich über das Joomla eigene REDIRECT Modul keine .php - Erweiterungen intern umleiten. 
      Anstatt  die joomla-eigene 404 Seite zu erhalten, bekomme ich die von nginx, da  die Abfrage hier als erstes ausgeführt wird. 
      Also habe ich meine vhost stümperhaft umgeschrieben, s.d. ein Teil seinen Soll erfüllt. 

      Teilweise kann ich nun die Redirects über Joomla verwalten lassen, aber oft erhalte ich LOOPs, da ich ja immer auf die index.php verweise. 
      So, warum nutze ich nicht die nginx-Weiterleitungen ? 

      Ich nutze ein Multi-Sitemodul  sowie ein Modul, um eine php-Endung  zu simulieren. 
      Beide haben mit meiner und der Standardvhost-Konfiguration leichte Schwierigkeiten. 

       
      Welche Vhost-Anpassungen nutzt ihr bei Eurer Joomla-Webseite ? 
      Der Fehler sitzt vermutlich 30 cm vor meinem Bildschirm. 
      Innerhalb meiner letzten 30 Versuche habe ich wohl  oft alte Cache-Webseiten geladen und ggf. die richtige Konfig übersehen.
       

       
       
       
       
       
    • By irisdina
      Warning, this is not an official guide!!!
      1.
      sudo mv /etc/apt/source.list /etc/apt/source.list.bak 1a. Create new Source.list
      sudo nano /etc/apt/source.list 1b.  insert (for Debian Stretch)
      1.2B (for Ubuntu Cosmic)
       
      1c. 
      sudo apt update && sudo apt dist-upgrade && sudo apt autoclean && sudo apt autoremove 1d. 
      sudo apt install curl wget apt-transport-https dirmngr git software-properties-common Now you can start setting up your server
      2. MariaDB install
      Warning use sudo command für this install!
      sudo apt install mariadb-server mariadb-client 2a. MariaDB 10.3 Workround (Optional)
      3. nginx install
      sudo apt install nginx 3a. 
      mkdir /etc/nginx/sites-available mkdir /etc/nginx/sites-enabled 3b. nano /etc/nginx/nginx.conf
      4. PHP install
      sudo apt-get -y install php7.3-fpm php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-mysql php7.3-curl php7.3-gd php7.3-intl php-pear php-imagick php7.3-imap php-memcache php7.3-memcached php7.3-pspell php7.3-recode php7.3-sqlite3 php7.3-tidy php7.3-xmlrpc php7.3-xsl php7.3-mbstring php-gettext php7.3-fpm php7.3-cli php7.3-cgi php-bcmath php-zip php7.3-fpm php7.3-curl php7.3-gd php7.3-mysql php7.3-mbstring php7.3-zip php7.3-bcmath zip unzip 4a. 
      sudo service nginx restart sudo service php7.3-fpm restart Froxlor install
      There are two ways to get Froxlor. Stable (wget) and Beta Build (git / Master)
      Stable Version
      1. 
      cd /var/www/html/ 1a. 
      sudo https://files.froxlor.org/releases/froxlor-latest.tar.gz && sudo tar xzfv froxlor-latest.tar.gz or
      Git Version (Beta Version)
      sudo git clone https://github.com/Froxlor/Froxlor.git && sudo chown -HR www-data:www-data Froxlor/ sudo apt install composer  su - www-data -s /bin/bash cd /var/www/html/Froxlor/ 1a(2). Composer install in your Froxlor directory
      composer install --no-dev 1b. 
      sudo chown -R www-data:www-data Froxlor/ Set up Froxlor
      2. Open Your Browser
      2a.
      http://your IP or Hostname/Froxlor
       

      Install Froxlor finish
       3d. Move userdata (Optional) 
      sudo mv /tmp/userdata.inc.php /var/www/html/Froxlor/lib/ 2c. 
      sudo rm /etc/nginx/site-enable/default don't restart nginx!
      Froxlor Settings
      1. Cronjob
      sudo nano /etc/cron.d/froxlor insert 
      # # Set PATH, otherwise restart-scripts won't find start-stop-daemon # PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin # # Regular cron jobs for the froxlor package # # Please check that all following paths are correct # */5 * * * * root /usr/bin/nice -n 5 /usr/bin/php -q /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php sudo chmod 0640 "/etc/cron.d/froxlor" sudo chown root:0 "/etc/cron.d/froxlor" sudo service cron restart 2. Nginx PHP Backend
      Settings > Webserver settings > Nginx PHP backend
      from 127.0.0.1:8888 to unix:/run/php/php7.3-fpm.sock
      3. 
      sudo mkdir -p /var/customers/webs/ sudo mkdir -p /var/customers/logs/ sudo mkdir -p /var/customers/tmp sudo chmod 1777 /var/customers/tmp sudo service nginx restart 4. IPs and Ports > Add IP/Port

      2a(1), SSL Port



      Wait 5min for Autimatic Start Froxlor's cronjob or start the cronjob manually
      sudo php /var/www/html/Froxlor/scripts/froxlor_master_cronjob.php --force --debug Optional
      PHP-FPM activate
      1. User/Group add
      sudo adduser froxlorlocal --disabled-password --no-create-home && sudo usermod -a -G www-data froxlorlocal 2. libnss-extrausers install 
      sudo apt install nscd libnss-extrausers sudo mkdir -p /var/lib/extrausers sudo touch /var/lib/extrausers/{passwd,group,shadow} sudo mv "/etc/nsswitch.conf" "/etc/nsswitch.conf.frx.bak" sudo nano /etc/nsswitch.conf # Make sure that `passwd`, `group` and `shadow` have mysql in their lines # You should place mysql at the end, so that it is queried after the other mechanisams # passwd: compat extrausers group: compat extrausers shadow: compat extrausers hosts: files dns networks: files dns services: db files protocols: db files rpc: db files ethers: db files netmasks: files netgroup: files bootparams: files automount: files aliases: files sudo service nscd restart sudo nscd --invalidate=group 2a. Settings > System settings > Activate > Use libnss-extrausers instead of libnss-mysql

      3. Settings > PHP-FPM > Activated:
      Change from NO to YES
      3a. PHP-FPM versions
      Change > php-fpm restart command:
      service php7.3-fpm restart and
      Configuration directory of php-fpm: > to 
      /etc/php/7.3/fpm/pool.d/ 3b. Settings > Froxlor VirtualHost settings > Activate > Enable PHP-FPM for the Froxlor vHost

      3c. 
      sudo chown -HR froxlorlocal:froxlorlocal /var/www/html/Froxlor SSL / Let's Encrypt activate
      1.
      sudo apt install certbot 1a. 
      sudo mkdir /etc/nginx/ssl && cd /etc/nginx/ssl 1b. Create SSL File
      sudo openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/ssl/nginx.key -out /etc/nginx/ssl/nginx.crt 1c. 
      sudo nano /etc/nginx/acme.conf insert
      location /.well-known/acme-challenge { alias /var/www/html/Froxlor/.well-known/acme-challenge; location ~ /.well-known/acme-challenge/(.*) { default_type text/plain; } }  
      2. Open your  Froxlor Panel
      Settings> SSL > Activated:
      Change from NO to YES
      2a. Settings > SSL > Settings
      Change your path from your certificate / Keyfile
      Path to the SSL certificate
      insert
      /etc/nginx/ssl/nginx.crt Path to the SSL Keyfile
      insert
      /etc/nginx/ssl/nginx.key 2b. Settings > SSL > Settings
      Activate > Enable Let's Encrypt

      Change Path to the acme.conf snippet to > 
      /etc/nginx/acme.conf 2c. Activate on Settings > Froxlor VirtualHost settings
      - Enable Let's Encrypt for the froxlor vhost
      - Enable SSL-redirect for the froxlor vhost
      - HTTP Strict Transport Security (HSTS)
      - Include HSTS for any subdomain






      2d. Activated HTTP2 Support on > Settings > Nginx
       
    • By Evren
      Hi,
      I wonder if there is anyone who able to properly set up Let's Encrypt feature with nginx?
      I followed suggested steps but I couldn't make it happen.
      - activate Let's Encrypt in the settings - as admin, goto Configuration -> select your distro -> select Webserver -> select your software - copy'n'paste the acme.conf part of the configration template - restart/reload webserver Then I run the cron
      php /var/www/froxlor/scripts/froxlor_master_cronjob.php --letsencrypt --debug
       
      [information] Updating Let's Encrypt certificates [information] Let's Encrypt certificates have been updated [notice] Checking system's last guid  
      But, when I try to enable Let's Encrypt for a domain, the system automatically uncheck this option after I save.
      Any idea?
      Thanks
    • By seochemnitz
      Moin,
      ich habe da mal eine Frage zum Browser Caching.
      Man kann das Browser Caching in den conf Dateien unter /etc/nginx/sites-available/ mit folgenden Befehl aktivieren.
      location ~* \.(jpg|jpeg|png|gif|ico|css|js)$ { expires 365d; } Das funktioniert wunderbar. Leider werden die conf Dateien durch den Cronjob wieder überschrieben.
      Gibt es eine Möglichkeit das irgendwo fest zu hinterlegen, damit es automatisch in die neu generierten Dateien eingetragen wird?
       
      NGINX 1.3.1
      PHP5
      0.9.38.7-1+wheezy1
       
      Ich freue mich auf eure Antworten!
      Silvio
    • By tt33tt
      Hi all,
      there is a new feature libnss-extrausers
      What does that do?




×
×
  • Create New...