Jump to content
Froxlor Forum
  • 0

Eigene Nameserver in Froxlor einrichten


CubE135
 Share

Question

Hallo, ich möchte mir gern eigene Nameserver einreichen, worauf ich dann diverse Domains leiten kann.

Ich habe bei meinem Domain Provider bereits die nötigen Hostnames eingetragen(ns1.meinedomain.tld und ns2.meinedomain.tld).

Einen Name-/DNS-Server habe ich über die Froxlor Konfiguration bereits installiert(bind9 nameserver).

Nun weiß ich nicht genau, wie ich im Froxlor Panel weiter machen soll.

 

Kann mir da jemand helfen? :)

MfG CubE135

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

eh du aktivierst in den Einstellungen "Nameserver"? Passt entsprechend deines Systems ggfls. noch die ein oder andere Einstellung an...sonst nix, froxlor generiert dann die bind confings...oder was genau meinst du?

Link to comment
Share on other sites

  • 0

Hallo, ich habe in Froxlor, wie im anhängenden Screenshot zu sehen ist, Nameserver aktiviert und meine Nameserver eingetragen.

Wenn ich aber nun bei einer anderen Domain meine Nameserver angebe, verweist die Domain nicht auf meinen Server.

IMG_20180705_113325.png

Link to comment
Share on other sites

  • 0

Wenn du in froxlor nameserver funktionalität aktivierst, heisst das du betreibst LOKAL auf dem Server einen DNS Server (config-vorgaben von froxlor) - denn froxlor erstellt dann dort die Zonen etc. mit allen Angaben aus dem Panel

Link to comment
Share on other sites

  • 0

Hallo,

wohin bzw auf welche IP zeigen den die NS*. Subdomains?
Zeigen diese den auf deinen Server, auf dem der Bind läuft?

Hab gerade mal geschaut und sowohl die Haupt- als auch die Subdomains angepingt und die zeigen auf verschieden IP-Adresse, das könnte eventuell schon das Problem sein.

Edited by cardman
Link to comment
Share on other sites

  • 0
vor 1 Stunde schrieb cardman:

Hallo,

wohin bzw auf welche IP zeigen den die NS*. Subdomains?
Zeigen diese den auf deinen Server, auf dem der Bind läuft?

Hab gerade mal geschaut und sowohl die Haupt- als auch die Subdomains angepingt und die zeigen auf verschieden IP-Adresse, das könnte eventuell schon das Problem sein.

Hey, die NS*. Subdomains zeigen auf den Server, auf dem Froxlor und somit auch Bind läuft.

Die Hauptdomain läuft über cloudflare, daher vermutlich die unterschiedlichen IP's.

Link to comment
Share on other sites

  • 0
4 hours ago, CubE135 said:

Hey, die NS*. Subdomains zeigen auf den Server, auf dem Froxlor und somit auch Bind läuft.

Die Hauptdomain läuft über cloudflare, daher vermutlich die unterschiedlichen IP's.

Dir ist aber schon klar, dass du damit bei manchen Registries Probleme bekommst?
ns1 und ns2 müssen unterschiedliche IP-Adressen haben und bei .de-Domains dürfen diese nicht mal aus demselben /24-Netz sein. Es wäre wirklich besser du überlässt die Nameserver Cloudflare oder einem anderen Domainprovider der entsprechend Infrastruktur dafür hat.

Link to comment
Share on other sites

  • 0
vor 44 Minuten schrieb Shortie:

Dir ist aber schon klar, dass du damit bei manchen Registries Probleme bekommst?
ns1 und ns2 müssen unterschiedliche IP-Adressen haben und bei .de-Domains dürfen diese nicht mal aus demselben /24-Netz sein. Es wäre wirklich besser du überlässt die Nameserver Cloudflare oder einem anderen Domainprovider der entsprechend Infrastruktur dafür hat.

Ok, das wusste ich nicht.

Dann lass ich das lieber mit den Nameservern.

Trotzdem vielen lieben Dank :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...